Adobe

XD CC

2019 release S

CLASSROOM IN A BOOK'

The official training workbook from Adobe
Brian Wood



Contents

Cover Page

Title Page

Copyright Page

Where are the Lesson Files?
Contents

Getting Started

About Classroom in a Book
Prerequisites

Installing the program

Online Content

Recommended lesson order
Jumpstart

Additional resources

Adobe Authorized Training Centers

1 An Introduction to Adobe XD CC

Introducing Adobe XD CC

A typical UX design workflow
Starting Adobe XD and opening a file
Exploring the workspace (macOS)
Exploring the workspace (Windows)
Working in Design mode

Prototype mode

Changing the view of artwork
Previewing your designs

Sharing your designs

Finding resources for using Adobe XD

2 Setting Up a Project

Starting the lesson

Creating and saving a new document
Creating and editing artboards
Adding grids to artboards



Managing artboards with the Layers panel
3 Creating and Importing Graphics

Starting the lesson

Graphics and Adobe XD

Creating and editing shapes

Bringing in content from Adobe Illustrator
Drawing with the Pen tool

Working with UI Kits

4 Adding Images and Text

Starting the lesson

Assets and Adobe XD

Bringing in content from Photoshop
Masking content

Working with text

5 Organizing Content

Starting the lesson
Arranging objects
Working with the Layers panel
Working with groups
Aligning content
Positioning objects
Fixed positioning
6 Working with Assets and CC Libraries

Starting the lesson
Managing assets with the Assets panel
Working with Creative Cloud Libraries

7 Using Effects, Repeat Grids, and Responsive Resize
Starting the lesson
Applying and editing gradients
Understanding effects
Using repeat grids
Responsive resize

8 Creating A Prototype

Starting the lesson
Starting with prototypes
Taking prototypes further

9 Previewing a Prototype



Starting the lesson
Recording a prototype
Previewing on a device

10 Sharing Documents, Prototypes, and Design Specs

Starting the lesson
Methods of sharing

11 Exporting and Integration

Starting the lesson
Exporting assets
Using plugins

Index

i

ii

iii

iv

\%

vi

vii

viii

EDOO\]CSCH-BWNHN;Q“

[ S S = Y S =S W S T
N OO UG A N =o



18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57



58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97



98

99

100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137



138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
172
173
174
175
176
177



178
179
180
181
182
183
184
185
186
187
188
189
190
191
192
193
194
195
196
197
198
199
200
201
202
203
204
205
206
207
208
209
210
211
212
213
214
215
216
217



218
219
220
221
222
223
224
225
226
227
228
229
230
231
232
233
234
235
236
237
238
239
240
241
242
243
244
245
246
247
248
249
250
251
252
253
254
255
256
257



258
259
260
261
262
263
264
265
266
267
268
269
270
271
272
273
274
275
276
277
278
279
280
281
282
283
284
285
286
287
288
289
290
291
292
293
294
295
296
297



298
299
300
301
302
303
304
305
306
307
308
308
309
310
311
312
313
314
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336



337
338
339
340
341
342
343
344
345
346
347
348
349
350
351
352
353
354



‘ Adlob

Xd [ XD cc

____.;,;-:.--! 2019 release

CLASSROOM IN A BOOK'
The official training workbook from Adobe

Brian Wood




Adobe XD CC Classroom in a Book®, 2019
release

The official training workbook from Adobe

Brian Wood



Adobe® XD CC Classroom in a Book® (2019 release)
© 2019 Adobe. All rights reserved.

If this guide is distributed with software that includes an end user license agreement, this guide,
as well as the software described in it, is furnished under license and may be used or copied only
in accordance with the terms of such license. Except as permitted by any such license, no part of
this guide may be reproduced, stored in a retrieval system, or transmitted, in any form or by any
means, electronic, mechanical, recording, or otherwise, without the prior written permission of
Adobe Systems Incorporated. Please note that the content in this guide is protected under
copyright law even if it is not distributed with software that includes an end user license
agreement.

The content of this guide is furnished for informational use only, is subject to change without
notice, and should not be construed as a commitment by Adobe Systems Incorporated. Adobe
Systems Incorporated assumes no responsibility or liability for any errors or inaccuracies that
may appear in the informational content contained in this guide.

Please remember that existing artwork or images that you may want to include in your project
may be protected under copyright law. The unauthorized incorporation of such material into your
new work could be a violation of the rights of the copyright owner. Please be sure to obtain any
permission required from the copyright owner.

Any references to company names in sample files are for demonstration purposes only and are
not intended to refer to any actual organization.

Adobe, the Adobe logo, Acrobat, Classroom in a Book, Illustrator, InDesign, Dreamweaver,
After Effects, Photoshop, Bridge, Muse, XD, PostScript, and PostScript 3 are either registered
trademarks or trademarks of Adobe Systems Incorporated in the United States and/or other
countries.

Apple, Safari, Mac, Mac OS, macOS, and Macintosh are trademarks of Apple Inc., registered in
the U.S. and other countries. Microsoft, Windows, Windows XP, Windows 7, Windows 8, and
Windows 10 are either registered trademarks or trademarks of Microsoft Corporation in the U.S.
and/or other countries. Wacom and Intuos are trademarks of Wacom Company Ltd.
PANTONE®, myPANTONE™ and other Pantone LL.C properties are trademarks or registered
trademarks of Pantone LLC in the United States and other countries. All rights reserved.
NVIDIA is a trademark and/or registered trademark of NVIDIA Corporation in the U.S. and/or
other countries. Sketch is property of 2018 Bohemian B.V. All other trademarks are the property
of their respective owners.

Adobe Systems Incorporated, 345 Park Avenue, San Jose, California 95110-2704, USA

Notice to U.S. Government End Users. The Software and Documentation are “Commercial
Items,” as that term is defined at 48 C.F.R. §2.101, consisting of “Commercial Computer
Software” and “Commercial Computer Software Documentation,” as such terms are used in 48
C.F.R. 812.212 or 48 C.F.R. §227.7202, as applicable. Consistent with 48 C.F.R. §12.212 or 48
C.F.R. §8227.7202-1 through 227.7202-4, as applicable, the Commercial Computer Software



and Commercial Computer Software Documentation are being licensed to U.S. Government end
users (a) only as Commercial Items and (b) with only those rights as are granted to all other end
users pursuant to the terms and conditions herein. Unpublished rights reserved under the
copyright laws of the United States. Adobe Systems Incorporated, 345 Park Avenue, San Jose,
CA 95110-2704, USA. For U.S. Government End Users, Adobe agrees to comply with all
applicable equal opportunity laws including, if appropriate, the provisions of Executive Order
11246, as amended, Section 402 of the Vietnam Era Veterans Readjustment Assistance Act of
1974 (38 USC 4212), and Section 503 of the Rehabilitation Act of 1973, as amended, and the
regulations at 41 CFR Parts 60-1 through 60-60, 60-250, and 60-741. The affirmative action
clause and regulations contained in the preceding sentence shall be incorporated by reference.

Adobe Press is an imprint of Pearson Education, Inc. For the latest on Adobe Press books, go to
www.adobepress.com. To report errors, please send a note to errata@peachpit.com. For
information regarding permissions, request forms and the appropriate contacts within the Pearson
Education Global Rights & Permissions department, please visit
www.pearsoned.com/permissions/.

ISBN-13: 978-0-13-561964-3
ISBN-10: 0-13-561964-5
119


http://www.adobepress.com
mailto:errata@peachpit.com
http://www.pearsoned.com/permissions

Where are the Lesson Files?

Purchase of this Classroom in a Book in any format gives you access to the lesson files you’ll
need to complete the exercises in the book.

You’ll find the files you need on your Account page at peachpit.com on the Registered
Products tab.

1. Go to www.peachpit.com/register.

2. Sign in or create a new account.

3. Enter the ISBN: 9780135619643.
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4. Answer the questions as proof of purchase.

5. The lesson files can be accessed through the Registered Products tab on your Account
page.

6. Click the Access Bonus Content link below the title of your product to proceed to the
download page. Click the lesson file links to download them to your computer.
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Getting Started

Adobe® XD® CC is an all-in-one cross-platform tool for designing and prototyping websites
and mobile apps. Whether you are a general designer, web designer, User Experience (UX)
designer, or User Interface (UI) designer, Adobe XD® offers you the tools you need to get
professional-quality results.

About Classroom in a Book

Adobe XD CC Classroom in a Book® (2019 release) is part of the official training series for
Adobe graphics and publishing software developed with the support of Adobe product experts.
The features and exercises in this book are based on XD CC (February 2019 release).

The lessons are designed so that you can learn at your own pace. If you’re new to Adobe XD,
you’ll learn the fundamentals you need to master to put the application to work. If you are an
experienced user, you’ll find that Classroom in a Book teaches many advanced features,
including tips and techniques for using Adobe XD.

Although each lesson provides step-by-step instructions for creating a specific project, there’s
room for exploration and experimentation. You can follow the book from start to finish or do
only the lessons that correspond to your interests and needs. Each lesson concludes with a review
section summarizing what you’ve covered.

Prerequisites

Before beginning to use Adobe XD CC Classroom in a Book (2019 release), you should have
working knowledge of your computer and its operating system. Make sure that you know how to
use the mouse and standard menus and commands and also how to open, save, and close files. If
you need to review these techniques, see the printed or online documentation for macOS or
Windows.

Note

When instructions differ by platform, macOS commands appear first and then
the Windows commands, with the platform noted in parentheses. For example,
“press Option (macOS) or Alt (Windows) and click away from the artwork.”

Installing the program



Before you begin using Adobe XD CC Classroom in a Book (2019 release), make sure that your
system is set up correctly and that you’ve installed the required software and hardware.

You must purchase the Adobe XD CC software separately. For complete instructions on
installing the software, visit https://helpx.adobe.com/support/xd.html. You must install XD CC
from Adobe Creative Cloud onto your hard disk. Follow the onscreen instructions.

Note

In order to see the system requirements for Adobe XD, you can visit:
https://helpx.adobe.com/xd/system-requirements.html.

Minimum system requirements

macOS—macOS X v10.12 or later with the following minimum configuration:

Multicore Intel processor with 64-bit support with 1.4 GHz
Memory: 4GB of RAM
Non-retina display (Retina recommended)

Internet connection and registration are necessary for required software activation,
validation of subscriptions, and access to online services.

Windows—Windows 10 Creators Update (64-bit) — Version 1703 (build 10.0.15063) or later
with the following minimum configuration:

e Multicore Intel processor with 64-bit support with 1.4 GHz

e 4 GB of RAM of which 2 GB of available hard-disk space for installation; more free
space required during installation

e Display: 1280 x 800

e Graphics: Minimum Direct 3D DDI Feature Set: 10. For Intel GPU, drivers released in
2014 or later are necessary. To find this information, launch “dxdiag” from the Runmenu
and select the “Display” tab.

e XD on Windows 10 supports Windows’ native pen and touch features.

You can use touch input to interact with XD tools, create artwork on canvas, navigate
through layers, interact with symbols, wire prototypes, change shape properties in the
Property Inspector, scroll through preview window, drag images to the canvas, create
repeat grids and so on.

Online Content

Your purchase of this Classroom in a Book includes online materials provided by way of your
Account page on peachpit.com. These include:

Lesson Files
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To work through the projects in this book, you will need to download the lesson files from
peachpit.com. You can download the files for individual lessons or it may be possible to
download them all in a single file.

Web Edition

The Web Edition is an online interactive version of the book providing an enhanced learning
experience. Your Web Edition can be accessed from any device with a connection to the Internet
and it contains:

e The complete text of the book

e Hours of instructional video keyed to the text

e Interactive quizzes
In addition, the Web Edition may be updated when Adobe adds significant feature updates

between major Creative Cloud releases. To accommodate the changes, sections of the online
book may be updated or new sections may be added.

Note

Adobe XD CC is evolving quickly, with frequent updates. We will evaluate the
changes against the book and, if needed, supply a PDF of those changes where
you access your lesson files.

Accessing the Lesson Files and Web Edition

If you purchased an eBook from peachpit.com or adobepress.com, your Web Edition will
automatically appear under the Digital Purchases tab on your Account page. Click the Launch
link to access the product. Continue reading to learn how to register your product to get access to
the lesson files.

If you purchased an eBook from a different vendor or you bought a print book, you must register
your purchase on peachpit.com in order to access the online content:
1. Go to www.peachpit.com/register.
Sign in or create a new account.
Enter ISBN: 9780135619643.
Answer the questions as proof of purchase.

ANl o

The Web Edition will appear under the Digital Purchases tab on your Account page.
Click the Launch link to access the product.

The Lesson Files can be accessed through the Registered Products tab on your Account page.
Click the Access Bonus Content link below the title of your product to proceed to the download
page. Click the lesson file links to download them to your computer.


http://peachpit.com
http://peachpit.com
http://adobepress.com
http://peachpit.com
http://www.peachpit.com/register

Recommended lesson order

Adobe XD CC Classroom in a Book is designed to take you from A to Z in basic to intermediate
app and website design. Each new lesson builds on previous exercises, using the files and assets
you create to design and prototype an app. To achieve a successful result and the most complete
understanding of all aspects of design in Adobe XD, the ideal training scenario is to start in
Lesson 1 and perform each lesson in sequential order through the entire book to Lesson 11.
Because each lesson builds essential files and content for the next, you shouldn’t skip any
lessons or even individual exercises. While ideal, this method may not be a practicable scenario
for everyone.

Jumpstart

If you don’t have the time or inclination to perform each lesson in the book in order, or if you’re
having difficulty with a particular lesson, you can work through individual lessons using the
jumpstart method. Each lesson folder (when necessary) includes finished files and staged files
(files that are completed to that point in the Lessons).

To jumpstart a lesson, follow these steps:

1. The lesson files can be accessed through the Registered Products tab on your Account
page. Click the Access Bonus Content link below the title of your product to proceed to
the download page. Click the lesson file links to download them to your computer.

2. Open Adobe XD CC.

3. With no files open in Adobe XD, choose File > Open From Your Computer (macOS) or
press Ctrl+O (Windows) and navigate to the Lessons folder on your hard drive, then to
the specific lesson folder you are starting from. For instance, if you are jumpstarting
Lesson 7, navigate to the Lessons > Lesson07 folder and open the file named
L7_start.xd.

All of the jumpstart lesson files include “_start” in their names. These simple steps will
have to be repeated for each lesson you wish to jumpstart. If you choose the jumpstart
method once, however, you do not have to continue using it for all subsequent lessons.
For example, if you want to jumpstart Lesson 6, you can simply continue on to Lesson 7,
and so on.

After the file opens in XD, if fonts used in the document aren’t available on your system,
a listing of missing fonts will appear in the Assets panel on the left. If any of the missing
fonts are Adobe fonts in the Adobe Fonts Library, they are automatically activated and
available on your machine. If the Assets panel opens, you can click the Assets panel
button ([Z]), in the lower-left corner of the application window, to hide it.

Note

The lesson files were set up using the default font on macOS (Helvetica Neue).
Windows users will see a list of the missing fonts in the Assets panel. The
default font on Windows (Segoe UI) will be used in place of Helvetica Neue.



For most of the lessons, the Apple San Francisco font that comes with the
Apple UI Design Resources kit is also used.

Additional resources

Adobe XD CC Classroom in a Book (2019 release) is not meant to replace documentation that
comes with the program or to be a comprehensive reference for every feature. Only the
commands and options used in the lessons are explained in this book. For comprehensive
information about program features and tutorials, please refer to these resources:

Adobe XD Learn & Support: /helpx.adobe.com/support/xd.html (accessible in Adobe XD by
choosing Help > Learn & Support) is where you can find and browse tutorials, help, and support
on Adobe.com.

Adobe Forums: forums.adobe.com lets you tap into peer-to-peer discussions, questions, and
answers on Adobe products.

Adobe Create Magazine: create.adobe.com offers thoughtful articles on design and design
issues, a gallery showcasing the work of top-notch designers, tutorials, and more.

Resources for educators: www.adobe.com/education and edex.adobe.com offer valuable
information for instructors who teach classes on Adobe software. Find solutions for education at
all levels, including free curricula that can be used to prepare for the Adobe Certified Associate
exams.

Also check out these useful links:

Adobe XD CC product home page: See adobe.com/products/xd.html.

Adobe Authorized Training Centers

Adobe Authorized Training Centers offer instructor-led courses and training on Adobe products.
A directory of AATCs is available at training.adobe.com/training/partner-finder.html.
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1 An Introduction to Adobe XD CC

Lesson overview

In this lesson, you’ll explore the workspace and learn the following:

What Adobe XD CC is.

A typical Adobe XD workflow.

How to open an Adobe XD CC file.

How to work with the tools and panels.

How to zoom, pan, and navigate multiple artboards.
How to preview your projects.

How to share your projects.

This lesson takes approximately 30 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the
lesson files and Web Edition.”

Your Account page is also where you’ll find any updates to the lessons or to the lesson
files. Look on the Lesson & Update Files tab to access the most current content.
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In this first lesson, you’ll be introduced to a typical Adobe XD design workflow and explore
the workspace.

Introducing Adobe XD CC

Adobe XD CC is a complete end-to-end solution for designing user experiences for mobile apps,
websites, and more. You can design, prototype, preview, and share using the same tool.

Prototype

Share //' . Preview

In Adobe XD, you can create prototypes for websites or apps by designing all the screens or
pages in a single Adobe XD file. You can add artboards of the required screen size and then



define interactivity between them to visualize how users navigate through the screens or pages.
You can then test the prototype you create locally or on a device and easily share prototypes with
others to gather feedback via commenting and annotations. That feedback can then be
incorporated into the design. Finally, you can send design specs and exported production-ready
assets to a developer to create the app or website outside of Adobe XD.

Adobe XD CC is a powerful tool for working quickly and efficiently during the design and
prototype phase of the web or app development process.

A typical UX design workflow

In the early days of the web, designers created the user experience (UX) for websites on
desktops, making sure to optimize that experience across different browsers, browser versions,
and operating systems.

Since the rise of touchscreen devices, such as the Apple iPhone, designers have had to consider
the overall user experience of apps and websites on different devices. These days, with the
multitude of screen sizes and devices, operating systems, screen pixel densities (think Retina or
hiDPI), and other factors, creating a consistent and pleasurable user experience is an integral part
of the web or app design process. To get our products to market on time and on budget, and to
gain and retain users, we need to work quickly and efficiently.

In a typical web or app design workflow today, we follow the general process shown in the
following figure:

User Wireframe, Prototype, Dev,
Research Design Testing Launch

=

e Bullding %

Your design process may be different, depending on the project scope, budget, size, and type, but
this is generally how the process works.

First, we gather information through research. This can be accomplished by simply asking
questions of clients and your potential target audience, working with focus groups, checking
existing analytics, and more.

Note

A low-fidelity wireframe is one way to determine the functional elements of a
page or screen without diving into design specifics like colors and fonts. It is a
quick way to explore the basic structure and the relationships between the



content, or information, contained within an app or website.

We then start a design, which can be a low-fidelity, hand-drawn sketch—also called a low-
fidelity (low-fi) wireframe—or a high-fidelity (hi-fi) design. Early in the days of the mobile web,
we would sketch, wireframe, and design. Today we typically design, prototype, and collaborate
(share).

Croate Account

A low-fidelity wireframe A hi-fidelity design

To test the user experience, we will create an interactive prototype at some point in the design
process. The prototype is a tool for gathering feedback on the feasibility and usability of our
designs. In the following figure, you’ll see an example of prototyping interactivity in a high-
fidelity design.

@ Note

The smaller blue area at the bottom of the artboard on the left (covering the
Continue button) represents a hotspot, or interactive area that users will tap or
click. The larger blue area on the right represents the resulting screen that
shows. The blue connector (also called a wire) indicates the connection
between the hotspot and the resulting screen.
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In the past, several tools were needed to complete this process. Adobe XD CC was born out of
the need for a single all-in-one cross-platform tool for designing and prototyping websites and
mobile apps.

Starting Adobe XD and opening a file

To start working in Adobe XD, you’ll open a document and explore the XD workspace. You’ll
create and manipulate your design content using various elements such as panels, bars, and
windows, all of which make up the workspace.

» Note

If you have not already downloaded the project files for this lesson to your
computer from your Account page at peachpit.com, make sure to do so now.
See the “Getting Started” section at the beginning of the book.

The Home screen

When you first launch Adobe XD, the Home screen will appear. The Home screen gives you
easy access to presets, a list of recent files (if available), a list of add-ons, resources, a jumpstart
tutorial, and more. The Home screen appears when you create a new file, regardless of whether a
file is already open, or when you click the Home button (#) in the upper-left corner of the
application window with a document open.

1. Start Adobe XD CC.

» Note
The Home screen you see may look different. If you’ve opened files previously,


http://peachpit.com

it will look a bit different.

2. Click Your Computer on the left side of the Home screen. Navigate to the Lessons >
Lesson01 folder and open the L1_start.xd file.
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After the file opens in XD, if fonts used in the document aren’t available on your system,
a listing of missing fonts will appear in the Assets panel on the left. If any of the missing
fonts are Adobe fonts in the Adobe Fonts Library, they are automatically activated and
available on your machine. You’ll learn about missing fonts in Lesson 3, “Creating and
Importing Graphics.” If the Assets panel opens, you can click the Assets panel button (
[Z]), in the lower-left corner of the application window, to hide it.

You will use the L1_start.xd file to practice navigating, zooming, and investigating an
Adobe XD document and the workspace.

Note

To maximize the Adobe XD application and give yourself more room to work,
you may want to Option-click the green maximize button in the upper-left
corner of the application window (macOS) or click Maximize in the upper-right
corner (Windows).

Exploring the workspace (macOS)

With the L1_start.xd project file open on macOS, you’ll see the default XD workspace. If you
are on Windows, proceed to the next section.

e Choose View > Zoom To Fit All to see everything.
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B. Application modes Q

C. Toolbar —

D. Property Inspector

E. Artboards

F. Pasteboard

G. Panel icons —3

Note

The Adobe XD for Windows interface includes a menu icon (=) that you can
click to show menu items. See the next section, “Exploring the workspace
(Windows).”

A. The menu bar at the top of the application window provides access to commands
available in Adobe XD (macOS).

B. The application modes (Design and Prototype) provide a way to switch between
Design mode and Prototype mode.

C. The toolbar contains tools for selecting, drawing, and editing shapes, paths, and
artboards.

D. The Property Inspector is docked on the right side of the application window.
Adobe XD consolidates many of the most frequently accessed options in the Property
Inspector. The properties shown in the Property Inspector are contextual, which
means that they are based on the content selected in the document.

!

Adobe XD uses artboards to represent the screens in your app or website.

F. The pasteboard is the gray area around the artboards; it’s where you can place
content that you don’t want to associate with an existing artboard. The pasteboard and
artboards are contained within the document window.

G. Access to the Layers panel and Assets panel are located in the lower-left corner of
the application window.

macOS users can skip the next section, “Exploring the workspace (Windows),” and proceed to
the section “Working in Design mode.”

Exploring the workspace (Windows)



With the L1_start.xd project file open on Windows, you’ll see the default XD workspace.

e Press Ctrl+0 (zero) to see everything.

A.Menu bar B. Application modes C. Artboards D. Property Inspector
(") ~— e —

[

B

E.Panelicons F.Toolbar G. Pasteboard

A.

On Windows, there is no top-level menu bar. Right-click an object and use the
context menu instead. XD on Windows has a “hamburger” menu (=) in the upper-
left corner that allows you to create or open files, save, export assets, and more.

The application modes (Design and Prototype) provide a way to switch between
Design mode and Prototype mode.

Adobe XD uses artboards to represent the screens in your app or website.

The Property Inspector is docked on the right side of the application window.
Adobe XD consolidates many of the most frequently accessed options in the Property
Inspector. The properties shown in the Property Inspector are contextual, which
means they are based on the content selected in the document.

Access to the Layers panel and Assets panel are located in the lower-left corner of
the application window.

The toolbar contains tools for selecting, drawing, and editing shapes, paths, and
artboards.

The pasteboard is the gray area around the artboards; it’s where you can place
content that you don’t want to associate with an existing artboard. The pasteboard and
artboards are contained within the document window.

Working in Design mode

On both macOS and Windows, when working on your project in Adobe XD, there are two
modes you will be using: Design and Prototype. When you select a mode, certain features and
tools specific to that mode become available in the application window. Each mode represents a
stage in the design process.



When you open a file in Adobe XD, the program starts out in Design mode. In Design mode, you
create and edit artboards and add your design content to them.

Getting to know the tools

In Design mode, the toolbar on the left side of the workspace contains selection and editing tools,
drawing tools, a text tool, an artboard tool, and a zoom tool. As you progress through the lessons,
you’ll work with all of these tools.

@9 ® & Design

Select tool (V) ——

Rectangle tool (R) ——0)

Ellipse tool (E) ——O
Line tool (L) —l/
Pen tool (P) —|f?
Text tool (T) —-T

Artboard tool (A) — D

Zoom tool () ——Q

e Move the pointer over the Select tool () in the toolbar. Notice that the name (Select) and
keyboard shortcut (V) are displayed in a tooltip.
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Adobe XD was built for speed. To work faster, you can switch between tools using the
keyboard command associated with each of the tools. For instance, pressing the letter Z
will switch to the Zoom tool, and pressing the letter V will switch back to the Select tool.

Working with the Property Inspector

The Property Inspector is the docked panel on the right side of the workspace. It offers quick
access to options and commands relevant to the currently selected content. It’s also where you’ll
set appearance properties for most of your content.

1. Select the Select tool (M) in the toolbar, and click the image at the top of the artboard
named Hike Detail.
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The options for the selected content appear in the Property Inspector on the right,
including color options, border, effects, and more.

. In the Property Inspector, click the checkmark to the left of the Fill option to deselect
that option for the selected content (turn the fill off). The image disappears. Select the
same Fill option to show the image again.
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Most of the content in the Property Inspector changes depending on what is selected. If
there is nothing selected, the Property Inspector is dimmed.

. Click in the gray pasteboard area, away from the artboards, or choose Edit > Deselect
All (macOS) so that the content on the artboard is no longer selected.

Tip
You can also press Command+Shift+A (macOS) or Ctrl+Shift+A (Windows).




Working with panels

The two main panels in Adobe XD, aside from the Property Inspector, are Layers and Assets.
They are each opened by clicking a button in the lower-left corner of the workspace. By default,
these panels are docked on the left, and they give you quick access to assets and layers. Next,
you’ll experiment with closing and opening these panels.

Tip
You can also press Command+Y (macOS) or Ctrl+Y (Windows) to toggle the
Layers panel open and closed, or choose View > Layers (macOS).

1. Click the Layers panel button (¥ ) in the lower-left corner of the application window to
open the Layers panel, if it isn’t already open.

L ] & 1% Design totype L1 _start
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The Layers panel lists all of the artboards in the document when nothing in the document
window is selected. You can think of an artboard as a page in a web design or a screen in
an app design. Later in this lesson, you’ll learn more about artboards and how to
navigate them.

2. With the Select tool () selected in the toolbar, click the same image on the Hike Detail
artboard you selected earlier.
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When you select content on an artboard, all of the content of that artboard is listed in the
Layers panel. The Layers panel is contextual, which means it shows different content
depending on what is (or isn’t) selected.

Tip
You can also press Command+Shift+Y (macOS) or Ctrl+Shift+Y (Windows) to
toggle the Assets panel open and closed, or choose View > Assets (macOS).

3. Click the Assets panel button ([Z]) in the lower-left corner of the workspace to show the
Assets panel.

EEEN

The Assets panel is where you will find content you save in the current document, like
colors, text styles, and symbols. In Lesson 6, “Working with Assets and CC Libraries,”
you’ll learn about assets in the Assets panel.



4. Click the Assets panel button ([Z]) in the lower-left corner of the workspace to hide the
Assets panel.

Panel tip

When either the Layers or Assets panel is showing, you can drag the right edge of the panel
to the right to expand the panel area. You can drag the panel edge only so far to the left to
make it narrower, before it stops.
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Prototype mode

As a step in the design process, you may wish to connect artboards (screens) to each other to
visualize how users navigate your app or website. With Adobe XD, you can create interactive
prototypes to visualize the interactions between screens or wireframes in Prototype mode. You
can preview the interaction to validate the user experience and iterate on your design to save time
on development. You can also record the interactions and share them with stakeholders to get
their feedback.

Next, you’ll briefly explore Prototype mode. You’ll learn more about Prototype mode in Lesson
8, “Creating a Prototype.”

1. Press Command+0 (macOS) or Ctrl+0 (Windows) to make sure you can see all of the
design content.

2. Choose Edit > Deselect All (macOS) or click in a blank part of the gray pasteboard area
to deselect all.

3. Click Prototype in the upper-left corner of the application window to enter Prototype
mode.
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In Prototype mode, notice that the only tools available in the toolbar are the Select tool
and Zoom tool, and the Property Inspector on the right is now hidden. The main purpose
of Prototype mode is to add interactivity to your designs. So for the purpose of
visualizing how a transition from one screen to another might look, for instance, you can
add the interactivity between those screens here.

Tip

In Design mode on macOS, you can choose View > Switch Workspace to
switch between modes. You can also press Control+Tab (macOS) or Ctrl+Tab
(Windows) to toggle between Design and Prototype modes.

4. To select all of the content in the document, press Command+A (macOS) or Ctrl+A

(Windows).
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In the lesson file you currently have open, L 1_start.xd, the artboards have interactivity
added. The interaction between content appears as blue connector lines (also called
“wires”). There will be no interactivity by default when you create a design. You can
select an artboard or object and create a connection between it and another artboard. In
Lesson 8, you’ll learn all about how to create an interactive prototype.

As you add interactivity to your designs, you can test that interactivity either within the
desktop version of Adobe XD or on a mobile device using the Adobe XD mobile app.

5. To deselect the artwork, choose Edit > Deselect All (macOS) or press
Command+Shift+A (macOS) or Ctrl+Shift+A (Windows).

Changing the view of artwork

When you’re working in files, it’s likely that you’ll need to change the zoom level and navigate
among artboards. The magnification level, which can range from 2.5% to 6400%, is displayed
near the upper-right corner of the application window.

There are a lot of ways to change the zoom level in Adobe XD, and in this section you’ll explore
several of the most common methods.

Using macOS or Windows native zooming

On macOS, you can zoom using a scroll wheel, Magic Mouse, or trackpad. On Windows 10
(and later), you can zoom using a scroll wheel or trackpad. This utilizes the operating
system zooming and is one of the easier ways to zoom in XD. To zoom this way, try one of
the following:

e To zoom in: Option-scroll wheel (macOS) or Ctrl-scroll wheel (Windows), Option-
swipe (Magic Mouse), or pinch out (trackpad)

e To zoom out: Option-scroll wheel (macOS) or Ctrl-scroll wheel (Windows), Option-
swipe (Magic Mouse), or pinch in (trackpad)

e To pan: Two-finger swipe (trackpad)

Using view commands
To enlarge or reduce the view of artwork using the View menu, do the following:

1. Click Design in the upper-left corner of the application window to enter Design mode.

2. Choose View > Zoom In (macQOS), or open the Zoom menu in the upper-right corner of
the application window and choose Zoom In (Windows), to enlarge the display of the
artwork.



Tip
You can zoom in using the keyboard shortcut Command and + (macOS) or Ctrl
and + (Windows). You can also zoom out using the keyboard shortcut

Command and — (macOS) or Ctrl and — (Windows).

3. Choose View > Zoom Out (macOS), or click the Zoom menu in the upper-right corner
of the application window and choose Zoom Out (Windows), to reduce the view of the

artwork.

The zoom level appears in a menu in the upper-right corner of the application window,
identified by a down arrow next to a percentage.

Note
Using any of the viewing tools and commands affects only the display of the

artwork, not the actual size of the artwork.

4. Choose 150% from the Zoom menu in the upper-right corner of the application window.
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On Windows in the Zoom menu, you’ll see more options, like Zoom In and Zoom Out.



On either platform, you can also type a value into the Zoom field and press Return or
Enter to view your document content at different sizes.

. Choose View > Zoom To Fit All (macOS), or choose Zoom To Fit All from the Zoom

menu (Windows).

Because the gray pasteboard (the area outside the artboards) extends to 50,000 pixels in
both directions, you can easily lose sight of your design content. By choosing Zoom To
Fit All, you make sure that all content is fit (and centered) in the document window.

Tip
You can also press Command+0 (macOS) or Ctrl+0 (Windows) to fit all.

Tip
You can also press Command+3 (macOS) or Ctrl+3 (Windows) to zoom in to
the selected content.

6.

7.

With the Select tool (M) selected in the toolbar on the left, click the image you selected
earlier on the Hike Detail artboard.

Choose View > Zoom To Selection (macOS), or choose Zoom To Selection from the
Zoom menu in the upper-right corner of the application window (Windows), to zoom in
to the selected content, centering it in the document window.
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This zoom command is very useful, and one you will most likely use a lot. Learning the
keyboard shortcut for this command, Command+3 (macOS) or Ctrl+3 (Windows), will
allow you to work even faster.

8. Press Command+0 (macOS) or Ctrl+0 (Windows) to fit all of the artboards in the



window before continuing.

Using the Zoom tool

In addition to the Zoom menu options, you can use the Zoom tool ( Q) to magnify and reduce the
view of artwork to predefined magnification levels. If you’re familiar with the Zoom tool in
other Adobe applications, you’ll be familiar with the Zoom tool in XD.

1. Select the Zoom tool (Q) in the toolbar on the left, and then move the pointer into the
document window.

Notice that a plus sign (+) appears at the center of the Zoom tool pointer.

2. Move the Zoom tool over the large white number 3, and click a few times to zoom in.

Li_start — Edited
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The Zoom tool performs an animated zoom, and the artwork is displayed at a higher
magnification.

3. Move the pointer over another part of the document and click a few more times. Notice
that the area where you clicked is magnified.

4. With the Zoom tool still selected, move the pointer over another part of the document
and press the Option (macOS) or Alt (Windows) key. A minus sign (—) appears at the
center of the Zoom tool pointer. With the Option or Alt key pressed, click twice in the
document window to reduce the view of the artwork.
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You’ll use the Zoom tool frequently during the editing process to enlarge and reduce the
view of artwork. Because of this, Adobe XD allows you to select it using the keyboard at
any time without first deselecting any other tool you may be using. With any other tool
selected, try the following:

e To access the Zoom tool using your keyboard, press spacebar and then

Command (macOS), or press Ctrl+spacebar (Windows), and either click or drag
to zoom in.

¢ To zoom out, press spacebar+Option+Command (macOS) or Ctrl+Alt+spacebar
(Windows) and click.

5. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the design content again.

Note

Dragging with the Zoom tool selected while pressing the Option (macOS) or
Alt (Windows) key will zoom out. The effect is the same as Option-clicking
(macOS) or Alt-clicking (Windows) with the Zoom tool selected.

6. With the Zoom tool selected, drag from left to right across the content to zoom in.
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This creates a marquee that indicates the area to be zoomed in to. You can drag in any
direction to create a zoom box to zoom in to.

Tip
This is the same keyboard command for the Hand tool as is found in other
Adobe applications, like Illustrator, InDesign, and others.

Scrolling through a document

In Adobe XD, you can use the Hand tool () to pan to different areas of a document. Using the
Hand tool allows you to push the document around much like you would a piece of paper on
your desk. In this section, you’ll access the Hand tool and see how it works.

Note

The spacebar shortcut for the Hand tool (¥¥) does not work when the Text tool (
T') is active and the cursor is in text. If the cursor is in text, you can press the
Esc key (possibly a few times) to select the text object, not the text. You can
then press the spacebar to access the Hand tool.

1. Click to select any tool in the toolbar, and move the pointer into the document window.

2. Press and hold the spacebar to temporarily select the Hand tool, and then drag in any
direction in the document window. When finished, release the spacebar.
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Instead of panning with the Hand tool, you can also drag on a trackpad with two fingers
to pan in the document window.

Note

To use the Hand tool, Windows users may need to press and hold the spacebar
and, while pressing, press and let go of another key (like the Alt key). Then,
while still pressing the spacebar, pan in the document window.

Navigating artboards

Artboards represent the screens in your app design or the pages in your web design (they’re
similar to artboards in Adobe Illustrator or Adobe Photoshop) and are found in the gray
pasteboard area. You can have as many artboards in a single Adobe XD document as you like,
and most documents you create in Adobe XD start with a single artboard. You can easily add,
remove, and edit artboards after the document is created.

In Lesson 2, “Setting Up a Project,” you’ll learn how to work with artboards. In this section,
you’ll learn how to efficiently navigate a currently open document that contains multiple
artboards.

1. Choose View > Zoom To Fit All (macOS), or choose Zoom To Fit All from the Zoom
menu (Windows), to see all of the design content again.

The artboards in a document can be arranged in any order or orientation and can be
different sizes—they can even overlap. Suppose that you want to create a simple app
with four screens or design a website showing the screen sizes that represent different
devices. You can create different artboards for every screen, all with the same (or a
different) size and orientation.

2. With the Select tool (M) selected, click in the gray pasteboard area around the artboards
to ensure that all artwork is deselected.

3. Click the Layers panel button (¥) in the lower-left corner of the application window to
show the Layers panel.



)
The content you see in the Layers panel is contextual, which means it changes depending
on what is selected in the document. If nothing is selected, you’ll see a listing of all of
the artboards in the open document. When you select artwork, the artboard that the
artwork is on becomes the active artboard. The active artboard is listed at the top of the
Layers panel. It’s also indicated on the pasteboard by a subtle outline around the

artboard. In the Layers panel, you can navigate between artboards, rename artboards,
duplicate or delete artboards, and more.

Tip
You can also click an artboard name in the document window to select an
artboard. You’ll learn all about selecting artboards in Lesson 2.

4. Click each of the artboards in the Layers panel list, and notice that doing so selects that
artboard in the document window.
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You can tell which artboard is selected because the name above the artboard is
highlighted in blue and there is a blue highlight around the artboard.

Note

Double-clicking the artboard name (not the artboard icon [ [J]) in the Layers
panel or above the artboard in the document allows you to change the name of
the artboard.

5. Double-click the artboard icon ( [J) that appears to the left of the artboard name
“Explore” in the Layers panel.
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The artboard named Explore is now centered in the document window, and the content
of the Layers panel changes. It no longer lists all of the artboards and instead shows the
content on the Explore artboard.
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Note

Simply clicking content on an artboard also shows the content for that artboard
in the Layers panel.




6. Press Command+Y (macOS) or Ctrl+Y (Windows) to collapse the Layers panel.

Previewing your designs

You can test your prototype within Adobe XD using the desktop preview or the Adobe XD app
on your iOS or Android device. Next, you’ll take a look at previewing your designs within XD.

1. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the design content again.
2. Click in the gray pasteboard area outside of the artboards to deselect all.

Tip
You can also choose Window > Preview (macOS) to open the Preview
window, or press Command+Return (macOS) or Ctrl+Enter (Windows).

3. With nothing selected, click Desktop Preview (®») in the upper-right corner of the
application window to open the Preview window.

S

In the Preview window, you should see the home artboard (named Homescreen), since
nothing is selected. Normally, the artboard that is in focus (selected) shows in the
Preview window. The Preview window opens at the size of either the selected artboard
or the first artboard (with nothing selected).

Note

On a Windows touch device such as a Microsoft Surface Pro, the Preview
window may appear as a split screen. You can drag the divider between the
screens to hide the Preview window.




4. Click the Sign Up button in the Preview window.
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Clicking interactive elements allows you to easily test the navigation between screens as
you build your prototype.

5. Click the red button (macOS) or the X in the corner (Windows) of the Preview window
to close it.

Note

You’ll learn about sharing an entire project or a subset of artboards in Lesson
10.

Sharing your designs

At any point in the design process you may want to share your saved documents with others for
collaboration to gather feedback, pass design specifications like font size and color to
developers, and more. You can share the entire project, or a subset of artboards, with reviewers
by providing them a web link they can use to view your prototype or look at design specs in a
web browser.

Next, you’ll take a quick look at how you can share your design and what that means. In Lesson
10, “Sharing Documents, Prototypes, and Design Specs,” you’ll learn about sharing your
prototypes and design specs with others.

1. Click the Share button in the upper-right corner of the application.



Share Document
Share for Review
Share for Developmaent
Manage Links...

Record Video

You can share a cloud-based version of your project file (Share Document), share a link
to a working prototype (Share For Review), or share design specs (Share For
Development). After choosing how to share, you can choose from several sharing
options. If you make design changes later, you can always update the shared document,
prototype, or design specs or create a new version from the current design.

2. Press the Esc key or click away from the Share menu to hide it.

Switching between documents

When working in Adobe XD, you can have multiple documents open at one time. To switch
between open documents, you’ll first open another file to have another document open to
work with.

e Choose File > Open or Open From Your Computer (macOS) or, on Windows, click the
menu icon (=) and choose Open or Open From Your Computer. Navigate to a second
file and open it in Adobe XD.

The document opens in a separate application window.

e To switch to another open document, on macOS choose Window > [name of file], or,
on Windows, press Alt+Tab to switch between the open documents.

Finding resources for using Adobe XD

For complete and up-to-date information about using Adobe XD, choose Help > Learn &
Support (macOS) or, with a document open on Windows, click the menu icon (=) and choose
Help > Learn & Support from within Adobe XD. The https://helpx.adobe.com/support/xd.html
page will open in a web browser. From that web page you can explore the library of tutorials,
projects, and articles to learn more about Adobe XD.

Note
The web page you see will most likely look different, and that’s okay.
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e Choose File > Close (macOS), or click the X in the upper-right corner of the open
window (Windows), to close the L.1_start.xd file without saving.

Review questions

1 Briefly, what is Adobe XD?

2 What is meant by a low-fidelity (low-fi) wireframe?

3 What are two ways to change the view of a document?
4 What is a prototype used for?

5 What are the two methods for previewing a prototype?
6 What purpose does sharing serve?

Review answers

1 Adobe XD CC is a complete end-to-end solution for designing user experiences for both
websites and mobile apps. You can design, prototype, preview, and share in the same
tool.

2 A low-fidelity wireframe is a way to determine the functional elements of a page or
screen without diving into design specifics like colors and fonts. It is a quick method of
exploring the basic structure and relationships between content in an app or website using
rough representations of graphics and layout.

3 To change the zoom level of a document, you can choose commands from the View
menu (macOS) or the Zoom menu (macOS and Windows). You can also use the Zoom
tool (Q) in the toolbar and click in or drag over a document to enlarge or reduce the
view. In addition, you can use keyboard shortcuts to magnify or reduce the display of
artboards.



4 Interactive prototypes allow us to test our designs and to gather feedback on the
feasibility and usability of our designs.

5 Currently, the two main methods for previewing (testing) a prototype are by using
Desktop Preview with Adobe XD or by using the Adobe XD app on your iOS or Android
device.

6 Sharing a document saved to Creative Cloud, a prototype, or design specs is useful for
collaboration, testing a prototype, gathering feedback on your design, sharing design
specs, and more.



2 Setting up a Project

Lesson overview
In this lesson, you’ll learn how to do the following:

e Create and save a new document.

e Understand cloud documents.

e Create and edit artboards.

e Add grids to artboards.

e Work with multiple artboards.

e Manage artboards with the Layers panel.

This lesson takes approximately 45 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the
lesson files and Web Edition.”

Your Account page is also where you’ll find any updates to the lessons or to the lesson
files. Look on the Lesson & Update Files tab to access the most current content.
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In this lesson, you’ll start a new project and create and manage the artboards that will
become the screens in your app or web design project.

Starting the lesson

In this lesson, you’ll create your first project in Adobe XD CC and begin to set up design screens
for a hiking app you will design, prototype, and share. To start, you’ll open a final lesson file to
get an idea of what you will create in this lesson.

Note

If you have not already downloaded the project files for this lesson to your
computer from your Account page, make sure to do so now. See the “Getting
Started” section at the beginning of the book.

1. Start Adobe XD CC, if it’s not already open.

2. On macOS, choose File > Open From Your Computer. On Windows, click the menu
icon (=) in the upper-left corner of the application window and choose Open From
Your Computer.

For either macOS or Windows, if the Home screen is showing with no files open, click



Your Computer in the Home screen. Open the file named L2_end.xd, which is in the
Lessons > Lesson02 folder that you copied onto your hard disk.

3. Choose View > Zoom To Fit All (macOS), or choose Zoom To Fit All from the Zoom
menu (Windows) in the upper right, and leave the file open for reference. This file
shows you what you will create by the end of the lesson.
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Note

The screen shots for this lesson were taken on Windows. On macOS, you’ll see
the menus above the application window.

Creating and saving a new document

You’ll now begin your app design by creating a new document. In Adobe XD, you can have a
number of project files open at one time and easily move between them.

Tip
To show the Home screen, with a document open, you could also click the
Home button (#%) in the upper-left corner of the application window.

1. If the Home screen isn’t showing (if you have the L.2_end.xd file open), choose File >
New (macOS), or, on Windows, click the menu icon (=) and choose New.

With Adobe XD, you can start your document using a range of screen sizes. In the Home
screen that opens, you’ll find a row of icons representing the generic device sizes used in



app design, web design, and more. From left to right, the icons represent phones, tablets,
general web pages, and custom screen sizes. Within Adobe XD, screens are represented
by artboards. Know that no matter what screen size you start with, you can always edit
that size in your document later.

Tip
In the Home screen, you can click the Custom Size icon (not the W and H
fields) to create a new document without any artboards.

Tip
In the Home screen, the device size you choose becomes the default for that
device (phone, tablet, web page, or custom).

2. In the Home screen, click the iPhone X/XS name to reveal a menu of sizes. Click iPhone
X/XS (375 x 812), and a new document opens with a single artboard showing.

b Design. Prototype. Share, 8 Design. Prototype. Share
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The file that opens is your working file and will include all of the screens (artboards),
images, colors, and more that make up your project.



Note

You may see different screen sizes in the Home screen, and that’s okay. The
Home screen reflects the most widely used screen sizes and will change over
time.

Adobe XD and Retina (HiDPI)

By default, artboards in Adobe XD are considered 1x, or non-Retina (non-HiDPI) in size. If
you want to design at 2x, or Retina sizing (HiDPI), you will need to create custom size
artboards that are twice the size (scale) of the default artboards.

For instance, by default the iPhone 6/7/8 artboard size in Adobe XD is 375 x 667. To design
at Retina (HiDPI) size, you need to change the artboard dimensions to 750 x 1334.

Raster content you import will need to be of sufficient pixel density, which you’ll learn
about in Lesson 4, “Adding Images and Text.” When you export content, which you’ll do in
Lesson 11, “Exporting and Integration,” you can change the Designed At option to get the
correct export sizes, whether you designed at 1x or 2x (Retina).

Note
You will learn more about cloud documents in Lessons 9 and 10.

When you create a new document in Adobe XD, by default it is saved as a cloud document. If
you look above the document at the title, you’ll see a cloud icon (#), “Untitled-1” (or
something similar, like “Untitled-2"), and “Saved.”
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Cloud documents are stored and managed in Creative Cloud and are counted toward your
Creative Cloud storage quota. If you work on a cloud document offline, changes will be synced
back to the cloud when you reconnect.

Cloud documents and local XD documents are both fully compatible with XD. With cloud
documents, you have the advantage of autosave, sharing, and accessibility across devices in
online and offline mode.

Adobe XD’s cloud-native document type has a number of unique benefits that a locally saved
XD file does not, including the following:

e Autosave: When you save your document to Creative Cloud, the autosave feature
ensures that your document is updated and you don’t lose your work.

e Faster sharing: You can share XD documents with others right from within XD for a
faster and more robust experience.

e Access all of your work: You can use the Cloud Document Organizer to quickly find all
your documents, and the documents shared with you, right from within XD. You can see
any cloud documents you save by visiting assets.adobe.com/cloud-documents.

e Access documents across devices: You can save your documents as cloud documents
and access them across devices, including mobile preview using the XD mobile app.

While working through the lessons, you will work on a document saved to your hard drive
(local), rather than in the cloud.

3. Choose File > Save As (macOS), or on Windows click the menu icon (=) in the upper-
left corner of the application window and choose Save As, to reveal a menu of options.

In the menu of options that appears, you can change the name of the document and click
Save to save the document to Creative Cloud as a cloud document. If you want to save
the document locally, you can click Your Computer and navigate to a location on your
computer.

Tip
Another way to save a file is to click the arrow to the right of the filename
above the document, revealing the menu of options.

4. Change the name to Travel_Design. Click Your Computer to open an operating system
dialog box.
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5. In the dialog box that opens, navigate to the Lessons folder on your computer, and click
Save. The XD document is now saved locally.

In Lesson 9, “Previewing a Prototype,” and Lesson 10, “Sharing Documents, Prototypes,
and Design Specs,” you’ll learn about saving as cloud documents in Adobe XD, which
will allow you to share cloud documents.

Working with cloud documents Hila

To learn about how to save and work with cloud documents in Adobe XD, check out the video
“Working with cloud documents,” which is part of the Web Edition of this book. For more
information, see the “Web Edition” section of “Getting Started” at the beginning of the book.

Creating and editing artboards

When you first set up a document in Adobe XD, you typically start with a single artboard at a
size you choose. You can then add as many artboards as you need of similar or different sizes
and orientations. Each artboard represents a screen in your app design, web design, presentation,
and so on. For example, to create a web design, you might create different artboards for the
mobile, tablet, and desktop versions of that web page. Alternatively, if you’re creating an app,
you may want to create a single file with a separate artboard for each screen in your app.

Artboards in XD lay the groundwork for your design and are a feature you will spend a fair
amount of time working with. In this part of the lesson, you’ll use different methods to create
and edit artboards in the hiking app you’re designing.

Creating artboards with the Artboard tool



In this section, you’ll learn about the different ways to create artboards with the Artboard tool (
‘D). Later, you’ll use faster ways to create artboards, including duplicating existing artboards.

1. With the Travel_Design document open, press Command+0 (macOS) or Ctrl+0
(Windows) to center the single artboard in the document window.

2. Select the Select tool () and double-click the artboard name (iPhone X/XS — 1).
Change the name to Home and press Return or Enter to accept the name.
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Naming artboards helps you keep track of your screens when you’re editing your design
content, for targeting specific artboards for interactivity during prototyping, and more.

Tip
To access the Artboard tool, you can press the A key.

Note
Be careful if you double-click the artboard name with the Artboard tool
selected. If you miss, you may wind up creating an artboard instead.

3. Select the Artboard tool (‘D) in the toolbar on the left.

Notice the preset screen sizes, grouped by device platform—Apple, Google, and so on—
that appear in the Property Inspector on the right side of the workspace. You may need
to scroll in the Property Inspector to see them.

4. Click the iPhone X/XS size in the Property Inspector to add a new artboard to the
document at that size.



Because of the ever-changing nature of technology, the preset screen sizes you see may
be different, and that’s okay. By default, the new artboard is added to the right of the
currently selected artboard. If there are other artboards to the right of the selected
artboard, the new artboard is added to the far right of the other artboards.

Note

With nothing in the document selected and the Artboard tool selected, you will
see only the default artboard sizes listed in the Property Inspector. Currently,
the Home artboard is selected.

5. Choose View > Zoom Out (macOS), or press Command and — (macOS) or Ctrl and —
(Windows), a few times to zoom out.

6. Double-click the artboard name (iPhone X/XS — 1) above the new artboard and change
it to Explore. Press Return or Enter to accept the name change.

To select an artboard with the Artboard tool selected, you need to click the artboard
name. With the Select tool selected, there are other methods for selecting artboards,
which you will learn about later.




Tip
To delete an artboard, simply click its name to select it, and then press Delete or

Backspace. Deleting an artboard also deletes any content associated with that
artboard.

7. With the Artboard tool selected, click to the left of the artboard named Home to add

another. Double-click the name of the new artboard and change it to Countdown. Press
Return or Enter to accept the name change.

8. With the Artboard tool still selected, press Command and — (macOS) or Ctrl and —

(Windows) a few times to zoom out.

9. Click in the Explore artboard to add another artboard to the right.

10.

11.

In this step, you can see that if there are other artboards to the right of the selected
artboard (Countdown). The new artboard is added to the far right of the other artboards.

Change the new artboard name to Hike Detail. This artboard will eventually contain
detailed information about a hike.

There are many ways to add artboards, including drawing a custom-size artboard, which
is what you’ll do next.

Move the pointer to the right of the Hike Detail artboard, in line with its top edge. An
aqua guide appears, telling you when the pointer is aligned with the top edge. Drag



down and to the right to draw an artboard. As you drag, you’ll see the width and height
values changing in the Property Inspector. Release the mouse button when the artboard
roughly matches the size you see in the second part of the figure.

Note

You may need to scroll up in the Property Inspector to see the width and height
values.

You can draw an artboard of almost any size or orientation, and artboards you create can also
overlap.

Tip

As you draw an artboard, you can press the Option (macOS) or Alt (Windows)
key to draw from the center, or press the Shift key to constrain the proportions.
When you are finished drawing, make sure to release the mouse button and then
the key(s).

12. Change the name of the new artboard to Icons. Press Return or Enter to accept the
name.

You can work a lot of different ways, including creating the artboards you need at the
start of the project or duplicating artboards with existing content and resizing the design
content and artboards to match different screen sizes.

13. Choose File > Save (macOS), or on Windows, click the menu icon (=) in the upper-left
corner of the application window and choose Save.
Editing artboards

While creating your design, you will most likely need to change the position of artboards, resize



them, and more. Next, you’ll see how to reposition, resize, and duplicate artboards as well as set
a few other properties for them.

1. With the new Icons artboard still selected, in the Property Inspector on the right side of
the workspace you can now see options specific to that selected artboard. Change Width
to 700 and Height to 1000 in the Property Inspector. Press Return or Enter after the last
value entered.

Tip
You can select the Lock Aspect icon ( &) before resizing so that width and
height change together proportionally.

2. Make sure that the Portrait option ([)) is selected. It should be, since the dimensions you
enter will change the orientation of the selected artboard.

O

You can change properties such as width and height for a single artboard or multiple
selected artboards at one time. Changing the size or orientation of an artboard does not
affect the artwork on that artboard.

3. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the artboards and center
them in the document window.

4. Select the Select tool () in the toolbar. Click in the Hike Detail artboard to select it.
Drag the bottom-middle point down to make the artboard taller.

You can resize any of the existing artboards using the Select tool or the Artboard tool.
You will notice that a dashed line and widget appear on the artboard when the height of
the artboard is taller than the original size. This indicates the original height of the
artboard and the start of scrollable content, which you’ll learn about in Lesson 5,
“Organizing Content.”
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5. With the Select tool still selected, drag the Icons artboard below the row of smaller
artboards. Don’t worry about its exact position right now.

With the Select tool, you can select an artboard by clicking its name, by clicking in the
artboard area if the artboard is empty, or by dragging across the artboard. You can
arrange your artboards in a configuration that makes sense for your project and process.

Next, you’ll arrange the artboards in an order that makes sense for the flow of screens in
the app, and make copies to create new artboards. This can be done with either the
Artboard tool or the Select tool selected.

6. Drag the Countdown artboard to the right. Drag until purple spacing guides show a
value of 70 and you see aqua horizontal guides (indicating it is aligned with the others).
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The purple spacing between the objects (artboards in this case) appears when the space
between them is the same.

Note
If the Artboard tool is selected, in order to drag-duplicate an artboard you need
to drag it by the artboard name, not from within the artboard.

7. Option-drag (macOS) or Alt-drag (Windows) from within the Countdown artboard to
the right. Drag until the purple spacing guides show a value of 70 and you see aqua
horizontal guides (indicating it is aligned with the others). Release the mouse button and

then the key.

8. Change the name of the new artboard to Recording. Press Return or Enter to accept the
name.

Option/Alt-dragging an artboard is a great way to make a copy of an artboard and all of
its content, placing it where you want. In Adobe XD, you’ll find that there are a lot of
ways to create artboards. If you just want to add artboard copies in the same row, you

can use a keyboard command to duplicate them.

Tip
You can also simply copy and paste artboards.




Note
If you zoom out far enough, the artboard names may become truncated.

9. With the Recording artboard still selected, press Command+D (macOS) or Ctrl+D
(Windows) to create a duplicate that is placed to the right.

10. Change the name of the new artboard (Recording - 1) to Memory. Press Return or Enter
to accept the name.

11. With the artboard named Memory selected, press Command+D (macOS) or Ctrl+D
(Windows) to create a duplicate to the right. Leave the name as is for now.

12. Choose File > Save (macOS), or on Windows, click the menu icon (=) in the upper-left
corner of the application window and choose Save.

Tip
You can select multiple artboards and change the background color for all at
once.

Changing artboard appearance

You can change several properties for each artboard in your document, including the background
color, size, grids, and more. Changing the background color could be useful for showing white
icons on a dark background or previewing a screen designed with a dark background, for
instance. Next, you’ll change the appearance of an existing artboard.

1. Press Command+0 (macOS) or Ctrl+0 (Windows) to fit all artboards in the Document
window.

2. With the Select tool (M) selected, click in the Countdown artboard to select it.

3. In the Property Inspector on the right, deselect the Fill option.
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You can turn off the default fill of an artboard, but notice that the artboard outline is still
visible.

Note
You don’t have to type # when entering a color value in Hex format.

Tip

When editing the Hex value, you can enter Hex values using shorthand. You
can type any Hex value to have it repeated for all six values. For instance,
typing a single character, such as “f,” and pressing Return or Enter repeats that
character for all values (#ffffff). Typing two characters, such as “ab,” repeats in
order (#ababab). Typing three characters, such as “123,” repeats each character
in order (#112233).

4. Select the Fill option in the Property Inspector to turn the default white fill back on.
Click the Fill color box, to the right of that same option, to show the Color Picker.
Ensure that Hex is chosen from the color menu, and change the Hex value to FF491E.
Press Return or Enter after typing the value.
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Adobe XD offers a lot of ways to edit color, including visually.

5. Press the Esc key or click somewhere to hide the Color Picker.

Working with multiple artboards

You can change properties like background color and size for multiple artboards at one time.
This can greatly speed up your design process. Next, you’ll apply a background color to multiple
artboards.

1. With the Select tool (M) selected, click in the Recording artboard to select it. To also
select the Memory — 1 artboard, Shift-click in the Memory — 1 artboard.

You need to apply a background color to the Recording and Memory — 1 artboards so
those app screens will have a blue background. Next, you’ll apply a color you were
given as HSB values.

2. Click the Fill color box in the Property Inspector to show the Color Picker. Choose HSB
from the color menu, and change the values to H=205, S=88, B=35. Press Return or
Enter after typing the last value.
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3. Press the Esc key to hide the Color Picker.

4. Choose File > Save (macOS), or on Windows, click the menu icon (=) in the upper-left
corner of the application window and choose Save.




Aligning artboards

You can easily select and align or distribute the spacing between artboards to keep them more
visually organized. As you drag artboards, alignment guides and spacing guides make it
relatively easy to align them, but you can also align and distribute artboards using the alignment
methods at the top of the Property Inspector. Next, you’ll align the Icons artboard to the Memory
— 1 artboard so the Icon artboard is closer to that group of artboards.

1. Click in the Icons artboard and Shift-click the Memory — 1 artboard.

2. Click the Align Right option (=!) at the top of the Property Inspector to align the right
edge of the Icons artboard to the right edge of the Memory — 1 artboard.

T

The Align options are pinned at the top of the Property Inspector, which means they are
always showing. They are also contextual, which means they are dimmed when they’re
not available. You’ll learn all about aligning content and artboards in Lesson 5.

3. Click in the gray pasteboard area to deselect the artboards.

4. Choose File > Save (macOS), or on Windows, click the menu icon (=) in the upper-left
corner of the application window and choose Save.

Note

You’ll learn all about responsive resize in Lesson 7, “Using Effects, Repeat
Grids, and Responsive Resize.”

Artboards and responsive layouts

When designing for a multi-device landscape today, it’s important to consider the wide
variety of screen sizes available across mobile, tablet, and desktop resolutions. Since not all

designers use similar devices, designers need to consider how content works across multiple
screen sizes.

To solve this user problem, Adobe XD has developed a feature called responsive resize that
allows you to resize objects while maintaining spatial relationships at different sizes to best



adapt to multiple screen sizes.

—From XD Help

Adding grids to artboards

In Adobe XD, there is a universal pixel grid that you can snap content to. In addition, there are
two types of grid options for artboards: square grids and layout grids.

Square grids provide horizontal and vertical guides that you can align content to. When you draw
or transform content, objects snap to the grid automatically when the edges of the object are
within the grid’s snap-to zone. Square grids can be useful for aligning objects and also for giving
an idea of measurement when designing, and they are most often used when designing apps.

Note

Adobe XD uses a virtual pixel for most of its measurements and font sizes,
which is the same unit of measurement as a CSS pixel, the basic unit of
measurement in iOS. The virtual pixel is roughly equal to one physical pixel on
a 72 dpi monitor (and, incidentally, a point). You cannot change the unit of
measurement in Adobe XD.

Layout grids can be used to define columns on each artboard. A layout grid helps you define the
underlying structure of your design and how each component in it responds to different
breakpoints for responsive designs (web design). In Lesson 7, you’ll learn about responsive
resize, which allows you to resize artboards while maintaining spatial relationships at different
sizes to best adapt to multiple screen sizes.

In the following figure, a layout grid is applied to the artboard on the left, and a square grid is
applied to the artboard on the right.




Working with square grids

In this section, you’ll explore turning on square grids for artboards and changing the appearance
of grids. As I said earlier, square grids provide horizontal and vertical guides that you can align
content to and can be useful for determining the measurements of objects.

Note

The default grid you see may look different. That’s okay, since you’ll change
the grid type shortly.

1. With the Select tool () selected, click in the Home artboard to select it. Press
Command+3 (macOS) or Ctrl+3 (Windows) to zoom in to that artboard.

2. Choose Square from the Grid menu in the Property Inspector. Make sure that the option
is selected to turn the default square grid on for the selected artboard (an arrow is
pointing to it in the following figure).
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When you enable a square grid, you have some options you can set, like color and grid
size.

Tip

You can also choose View > Show Square Grid (macOS) or press Command+’
(macOS) or Ctrl+’ (Windows) to toggle the square grid on and off for the
selected artboard(s).

3. In the Property Inspector, click the color box to the left of Square Size to open the Color
Picker, and change the appearance of the grid. Drag the Alpha slider (on the far right in
the Color Picker) down to make the grid less visible. You can adjust the color to
whatever makes sense to you.
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Layout grids and square grids overlay the design content of the artboard. Later, when
you add content to these artboards, making the layout grid more transparent can make it
easier to focus on the content rather than the grid.

You can also toggle the visibility of a grid, which is what you will do at times in later
lessons.

4. Select the Square Size value, and change it to 20. Press Return or Enter to accept the
value.

You’ll notice that the smaller the grid size number, the denser the grid is, and the larger
the grid size number, the looser the grid is. An 8 pt grid system is relatively standard—or
at least a grid system whose lines are divisible by 8.

5. Change the Square Size value back to 8.

Units in Adobe XD

Adobe XD is unit-less and focuses on the relationships between elements. So, for example,
if you design an iPhone 6/7/8 artboard at 375x667 units, and it uses type with a 10 unit font
size, that relationship remains the same, no matter what physical size your design is scaled

to.

—From XD Help




6. Click the Make Default button to ensure that these square grid settings are the default for
square grids you apply going forward.

Now you’ll select a series of artboards and apply the new default square grid to them all
at once.

7. Press Command+0 (macOS) or Ctrl+0 (Windows) to fit all artboards in the document
window.

Tip
When dragging to select multiple artboards, only one of them needs to be fully
encompassed in the selection area.

8. Move the pointer off the upper-left corner of the Explore artboard. Drag down and
across the artboard. Keep dragging until the blue marquee box surrounds the entire
artboard. When the artboard is highlighted (selected), continue dragging across all of the
artboards in the same row, and release the mouse button to select them all. See the
figure. Make sure not to select the Icons artboard.

A >

9. Choose Square from the Grid menu in the Property Inspector.
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With a series of artboards selected, you could also change other values that appear in the
Property Inspector, like fill or width and height. Selecting a series of artboards and
applying properties like Width and Height can be a great way to ensure uniformity.

10. Click the Use Default button in the Property Inspector to apply the default square grid to
the selected artboards.
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The square grid on each of the selected artboards should now match the default square
grid you set on the Home artboard.

Applying a layout grid

Now you’ll apply a layout grid to an iPad-sized artboard you create. In Lesson 7, you’ll learn
about responsive resize that allows you to resize artboards while maintaining spatial relationships
at different sizes to best adapt to multiple screen sizes.

1. Press Command and — (macOS) or Ctrl and — (Windows) a few times to zoom out.

2. With the Select tool selected, click away from the artboards to deselect them.

3. Select the Artboard tool (') in the toolbar and click the iPad Pro 12.9in size in the
Property Inspector on the right. If you don’t see that size, select another.



4. Press the V key to select the Select tool, and drag the new iPad artboard to the right a
bit. Press Command+3 (macOS) or Ctrl+3 (Windows) to zoom in to that artboard.

Tip

You can also choose View > Show Layout Grid (macOS) or press
Shift+Command+’ (macOS) or Shift+Ctrl+’ (Windows) to toggle the Layout
grid on and off for the selected artboard(s).

5. Select the Layout option in the Grid section of the Property Inspector on the right to turn
on the default grid for the iPad artboard.

R
N

XD shows columns depending on the size of the artboard. For example, a phone-sized
artboard has fewer and narrower columns than does the default layout grid for a desktop
artboard. If you resize an artboard, the column widths in the layout grid change to fit the
new artboard size. You can change grid properties depending on your design needs.
You’ll do that next.

Note



You may need to adjust the Gutter Width and Column Width values to achieve
those margin values.

Note

Lots of designers will create a grid based on their design. You can do a quick
drawing of your layout on paper to get an idea for the number of columns.
Many popular frameworks also use a grid system of 12 columns, which is
easily divided, giving designers flexibility with their layout.

6. Click the Different Margin For Each Side ( @ ) button and ensure that the values for the
margins are 0, 28, 0, and 28, as shown in the figure. After entering the last value, press
Return or Enter. You may need to scroll in the Property Inspector to see the values.
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Gutter Width and Column Width are automatically calculated based on the size of the
artboard, the number of columns, and the margins set. The Gutter Width is the distance
between the columns, and the Column Width is the width of each column. You can
change either the Gutter Width or the Column Width values at this point, depending on
your design needs. Values you see in the Grid section of the Property Inspector are
values automatically calculated by XD. Leave the columns set to 12.

There are two options for setting margins: Linked Left/Right Margins (' @ ) (default) or
Different Margin For Each Side ( @ ). If you need to set different margins on any of the
sides of the artboard, you can select Different Margin For Each Side and change the
value(s).

7. Choose File > Save (macOS), or click the menu icon (=) in the upper-left corner of the
application window and choose Save (Windows).

Layout grid tip

Prefer an outline style of layout grid? Set the alpha in your layout grid to 0, and you’ll see only



the lines.

—Flaine Chao (@elainecchao)
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Managing artboards with the Layers panel

In Lesson 1, “An Introduction to Adobe XD CC,” you were introduced to the Layers panel and
saw how you could use it to navigate artboards in your documents. In this section, you’ll see how
you can also create and manage your artboards from the Layers panel. As you proceed through

the lessons, you’ll use what you learn here.

1. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all the design content in the
document.

2. With the Select tool (M) selected, click in the gray pasteboard area to deselect. It’s
important that nothing be selected for the next step.

3. Click the Layers panel button (¥ ) in the lower-left corner of the application window to
open the Layers panel.
In the Layers panel, with nothing selected, you’ll see a list of all the artboards in the
document. Notice that the artboards are listed in the order in which they were created,
with the last artboard you created at the top of the list.

Tip
You can also press Command+Y (macOS) or Ctrl+Y (Windows) to toggle the
visibility of the Layers panel.

4. Click Home in the Layers panel list.



14

[Ty, S
®

When you select an artboard in the list, the artboard is selected in the document, as you
saw in Lesson 1. Selecting artboards using the Layers panel can sometimes be easier.

. Drag the Home artboard up in the Layers panel list to the top. When you see a line
appear above the first item in the list (mine is “iPad Pro 12.9in — 1), release the mouse

button.

I tend to drag the artboards in an order that matches the path the user takes from one
screen to another in the document. In other words, in an app you may have a login
screen. After the user enters their login information, the next screen they may see in the
app is their home screen. The home screen artboard would follow the login screen
artboard in the flow (usually from left to right). This can also make the artboards easier
to find later. You can organize them however you want.

. Drag the artboards into the order you see in the following figure. It will follow the
general flow of the screens.
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7. Double-click the Memory — 1 artboard name in the Layers panel to select the name.
Change the name to Journal and press Return or Enter.
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8. Right-click the Journal artboard name in the Layers panel and choose Copy.

In the context menu that appears when you right-click, you will see a series of
commands, such as Copy, Delete, Duplicate, and more. These commands can be applied
to selected artboards. Performing these kinds of operations in the Layers panel can
sometimes be faster, especially when dealing with a lot of artboards at once.

9. Right-click the Icons artboard name in the Layers panel and choose Paste Appearance to
paste the blue fill.
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In this case, the square grid applied to the Journal artboard is not part of the appearance,
so it is not copied to the Icons artboard.

10. Click in the gray pasteboard area in the document to deselect all content.
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11. Choose File > Save (macOS), or click the menu icon (=) in the upper-left corner of the
application window and choose Save (Windows).

12. If you plan on jumping to the next lesson, you can leave the Travel _Design.xd file open.
Otherwise, for each open document, choose File > Close (macOS) or click the X in the
upper-right corner (Windows).

Review questions

1 What does an artboard represent in Adobe XD?

2 By default, when you resize an artboard to be taller, a dashed line appears on the
artboard. What does that dashed line indicate?

3 Which tool must be selected in order to see the preset artboard sizes that come with
Adobe XD with a document open?

4 What purpose does an artboard grid serve?
5 What are at least two things you can do with artboards in the Layers panel?

Review answers

1 In Adobe XD, artboards represent a screen (app) or page (website) in your design. Each
Adobe XD file can contain many artboards of similar or differing sizes and orientations.

2 The dashed line that appears on an artboard after making the artboard taller indicates the
original height of the artboard and the start of scrollable content. It’s useful for
determining what’s initially visible on the device.

3 To see the preset artboard sizes that come with Adobe XD when a document is open, you
must have the Artboard tool ('D) selected.

4 In Adobe XD, each artboard can contain either a layout grid or a square grid that provides
guides that you can align content to. Grids can be useful for aligning objects and can also



help you get a quick idea of measurement when designing.

5 In the Layers panel you can change artboard names, reorder the artboards, copy an
artboard, delete an artboard (and its contents), select and zoom in to an artboard, and
much more.



3 Creating and Importing Graphics

Lesson overview
In this lesson, you’ll learn how to do the following:

e Create and edit shapes.

e Change the fill and border of content.

e Combine shapes using Boolean operations.
e Draw with the Pen tool.

e Edit paths and shapes with the Pen tool.

e Work with UI Kkits.

This lesson takes approximately 60 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the
lesson files and Web Edition.”

Your Account page is also where you’ll find any updates to the lessons or to the lesson
files. Look on the Lesson & Update Files tab to access the most current content.
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Aside from creating artwork using the shape tools in Adobe XD, you can also create
artwork using the Pen tool. With these tools, you can precisely draw straight lines, curves,
and more complex shapes.

Starting the lesson

In this lesson, you’ll create vector shapes in the form of buttons, icons, and other graphic
elements. To start, you’ll open a final lesson file to get an idea of what you will create in this
lesson.

Note

If you have not already downloaded the project files for this lesson to your
computer from your Account page, make sure to do so now. See the “Getting
Started” section at the beginning of the book.

Note
The screen shots for this lesson were taken on macOS. On Windows, the menus



can be accessed by clicking the hamburger menu.

1. Start Adobe XD CC, if it’s not already open.

2. On macOS, choose File > Open From Your Computer. On Windows, click the menu
icon (=) in the upper-left corner of the application window and choose Open From
Your Computer.

For either macOS or Windows, if the Home screen is showing with no files open, click
Your Computer in the Home screen. Open the file named L3_end.xd, which is in the
Lessons > Lesson03 folder that you copied onto your hard disk.

For either macOS or Windows, if the Home screen is showing with no files open, click
Your Computer in the Home screen. Open the file named L3_end.xd, which is in the
Lessons > Lesson03 folder that you copied onto your hard disk.

After the file opens in XD, if fonts used in the document aren’t available on your system,
a listing of missing fonts will appear in the Assets panel on the left. You can right-click
any missing font to either replace it with a font on your system or highlight in the
document where it’s being used.
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If any of the missing fonts are Adobe fonts in the Adobe Fonts Library, they are
automatically activated and available on your machine.

Note

A new feature was added as the book was going to press. If you open an XD
document and font(s) used in the document aren’t available on your system, the
missing fonts will appear in the Assets panel. If any of the missing fonts are
Adobe fonts in the Adobe Fonts Library, they are automatically activated and
available on your machine. You can right-click the font in the Assets panel list
and either highlight where they are used or replace them.

3. If the Assets panel opens, you can click the Assets panel button ([Z]), in the lower-left
corner of the application window, to hide it.

4. Choose View > Zoom To Fit All (macOS) or Zoom To Fit All from the Zoom menu



(Windows) in the upper right and leave the file open for reference.

This file shows you what you will create by the end of the lesson.
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Graphics and Adobe XD

In Adobe XD, you’ll create and work with vector graphics (sometimes called vector shapes or
vector elements). Vector graphics are made up of lines and curves defined by mathematical
objects called vectors. Vector graphics can be created in Adobe XD or a program like Adobe
[lustrator. Using a variety of methods and tools in Adobe XD, you can freely move or modify
shapes or paths you create. These can be in the form of icons, buttons, and other design elements.

Adobe XD also allows you to incorporate bitmap images—technically called raster images—that
use a rectangular grid of picture elements (pixels) to represent the picture. Each pixel is assigned
a specific location and color value. Raster images can be created in a program like Adobe
Photoshop. In Lesson 4, “Adding Images and Text,” you’ll learn about the different types of
images you can bring into Adobe XD and how to work with them.

Creating and editing shapes

Creating vector artwork in Adobe XD is easy thanks to the array of drawing tools available. If
you’re coming from other Adobe applications, you’ll find the drawing tools in Adobe XD to be
streamlined and efficient, with a few differences. For more complex vector content, you can use
[lustrator and easily bring the vector artwork into XD.

Note

If you are starting from scratch using the jumpstart method described in the
section “Getting Started,” open L3_start.xd from the Lessons > Lesson03
folder.

1. Choose File > Open From Your Computer (macOS), or click the menu icon (=) in the
upper-left corner of the application window and choose Open From Y our Computer
(Windows). Open the Travel_Design.xd document in the Lessons folder (or where you
saved it).

2. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.



3. Click the artboard name “Home” in the document window to select that artboard. Press
Command+3 (macOS) or Ctrl+3 (Windows) to zoom in.

4. Select the Select tool (M) and click away from the artboards to deselect all.

Y

Creating shapes with shape tools

In this section, you’ll create a series of shapes using the shape tools. These shapes will become a
button and other graphic elements.

Tip

When drawing shapes, you can hold down Option (macOS) or Alt (Windows)
to draw from the center, or press Shift to constrain the proportions of the shape.
In the case of the Rectangle tool, pressing the Shift key constrains the shape to
a square as you draw.

1. Select the Rectangle tool (LJ) in the toolbar. Near the bottom of the Home artboard,
move the pointer over the left edge of the artboard until the border of the artboard turns
aqua. This change in color indicates that the shape will snap or align to the edge of the
artboard. Drag down and to the right to draw a rectangle, stopping on the right edge of
the artboard. When alignment guides appear on the right, release the mouse. Don’t
worry about the height for now.

Alignment guides are always on and can be very helpful for aligning, snapping, and
spacing content you create or transform.



Tip

You can also press the R key to select the Rectangle tool.

2. With the rectangle selected, drag the top-middle point of the shape up or down until you

see a Height value of approximately 80 in the Property Inspector.
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Drag to resize the rectangle

As with editing artboards, as you draw or edit shapes the Width and Height values in the
Property Inspector change to reflect the current sizing of the selected content.

The result in the Property Inspector

Note

After drawing a shape, the shape tool you used is still selected. For certain
transformations, like sizing and rounding corners, you won’t need to switch

tools.

3. Press Command+Shift+A (macOS) or Ctrl+Shift+A (Windows) to deselect all so that

you can see all of the artboards in the Layers panel.

4. Click the Layers panel button (¥) in the lower-left corner (or press Command+Y
[macOS] or Ctrl+Y [Windows]) to open the Layers panel, if it isn’t already open.
Double-click the artboard icon ([J) to the left of the artboard name “Icons” in the Layers

panel to fit the artboard in the document window.
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As you make your way through the lessons, you’ll see that there are a lot of ways to




navigate between artboards. The Layers panel is yet another method that you learned
about in Lesson 1, “An Introduction to Adobe XD CC.”

Note

If you started with the L.3_start.xd file, the default grid you see may not be the
same. Ensure that the Square Size is 8 and click the Square Size color to ensure
that the Alpha value in the Color Picker is 30%.

5. Choose Square from the Grid menu in the Property Inspector to turn it on. Click the Use
Default button to apply the default square grid you set up previously.
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Next you’ll create a record button that will be used on the Recording artboard.

Tip
You can press Command+’ (macOS) or Ctrl+’ (Windows) to show or hide the
square grid for a selected artboard or artboards.

Note

You may notice that as you drag, the width and height values are changing by
multiples of 8. That’s due to the square grid setting of 8.

6. Select the Ellipse tool () in the toolbar (or press the E key to select the Ellipse tool).
Hold down the Shift key and drag to create a circle on the artboard. As you drag, pay



attention to Width and Height in the Property Inspector. When you see an approximate
width of 150 and height of 150, release the mouse button and then the key.
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7. Right-click the circle and choose Copy. Then right-click and choose Paste to paste a
copy directly on top of the original.

8. To make the new circle half its size, drag a corner toward the center. As you drag, hold
down Option+Shift (macOS) or Alt+Shift (Windows) to resize it from the center and
maintain its proportions. Release the mouse button and then the keys.

oons,

9. Press Command+Shift+A (macOS) or Ctrl+Shift+A (Windows) to deselect all.
10. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.

Changing fill and border

Now that you have a few shapes in your design, you’ll start to change appearance properties for
them.

1. Select the Select tool () in the toolbar. Click to select the rectangle you drew toward
the bottom of the Home artboard.

2. Press the I key to select the fill Eyedropper so you can sample a color and apply it to the
fill of selected content. Move the pointer over the orange-red color in the Countdown
artboard and click to sample the color.




Note

Make sure you don’t sample the grid color! When zoomed out far enough, you
won’t have to worry about it.

Tip
You can also click the Eyedropper to the right of the Fill box in the Property
Inspector (circled in the figure) to be able to sample a color.

3. To save the orange-red color, click the Fill color in the Property Inspector and click the
plus (+) at the bottom of the Color Picker. Press the Esc key to hide the panel.
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4. Deselect the Border option to turn the border off for the selected rectangle.

5. Click the larger circle you drew on the Icons artboard to select it. Press Command+3
(macOS) or Ctrl+3 (Windows) to zoom in to it.
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6. Deselect the Fill option in the Property Inspector to remove the fill.

7. Click the Border color to show the Color Picker. Change the border color to white by
dragging in the Saturation/Brightness field.
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8. Click the plus (+) at the bottom of the Color Picker to save the white color.

Fill and border colors you create can be saved in this way. The colors you save using this
method only appear in the Color Picker for this document. You can’t give names to these

saved colors.

Tip
To delete a color swatch, drag the swatch away from the Color Picker window.

9. Click to select the smaller circle and deselect the Border option to turn it off.
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10. Drag across both circles to select them, and choose Object > Group (macOS) or right-
click and choose Group to keep them together as a group.

11. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Creating dashed lines



In addition to changing the color and size of a border for content, you also have options like
dashes, border alignment, and more. In this section, you’ll explore adding a dashed line to the
design, which may be used as part of a slideshow you create in a later lesson.

Tip
Don’t forget that you can also pinch using a trackpad, or Option-scroll/Alt-
scroll using a mouse, to zoom in or out.

1. Zoom out by pressing Command and — (macOS) or Ctrl and — (Windows) several times.

2. Select the Line tool (/") in the toolbar. Shift-drag to create a straight horizontal line.
Stop dragging when you see a width of approximately 140 in the Property Inspector.
Release the mouse button and then the key.
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In this case, since you’re drawing a straight horizontal line, the width translates to line
length. You should see that the width will jump by increments of 8. That’s because the
line is snapping to the square grid on the artboard.

Tip
To prevent the line from snapping, you could have turned off the square grid in
the Property Inspector after selecting the artboard.

3. Click the Border color box to show the Color Picker. Click the white color you saved
previously to apply it to the border of the line. Press the Esc key to hide the panel.



Lines you draw with the Line tool can’t have a fill color but can have a border color.

4. Change Size to 3. Press Return or Enter.

Now you’ll add a dash to the line by changing the Dash and Gap values.

5. Press Command+3 (macOS) or Ctrl+3 (Windows) to zoom in to the line.

Note

If you find that this zoom command won’t work, you can pinch-zoom on a
trackpad or select the Zoom tool and zoom in.

6. Change the Dash value in the Property Inspector to 16. Click in the Gap field and
change the value to 8. Press Return or Enter.

The Dash value is the length of each dash segment on the line, and the Gap value is the
distance between those dash segments.

If you find that one of the dashes on the line is not the same size as the others, you can



drag the end of the line to make it longer or shorter to show the full dash or hide one (or
more) of the dashes.
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7. To round the ends of the dashes, click the Round Cap button ( ) below the dash

options in the Property Inspector.

8. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Working with border options

Now, you’ll create a simple magnifying glass search icon and work with border alignment and
changing the line cap.

1.
2.

Press Command and — (macOS) or Ctrl and — (Windows) to zoom out.

Press the spacebar and drag to the left to see more of the Icons artboard to the right of
the line. You can also drag on a trackpad with two fingers to pan in the document
window.

Tip
Press Command+’ (macOS) or Ctrl+’ (Windows) to show or hide the square
grid for a selected artboard or artboards.

. Choose View > Hide Square Grid (macOS), or right-click the artboard and choose Hide

Square Grid (Windows).
This allows you to draw without snapping to the square grid.

Select the Ellipse tool () in the toolbar. Shift-drag to create a circle on the artboard to
the right of the line. As you drag, pay attention to Width and Height in the Property
Inspector. When you see an approximate width of 20 and height of 20, release the mouse



button and then the key.

5. Deselect the Fill option in the Property Inspector to remove the fill.

6. Click the Border color to show the Color Picker. Click the white color you saved
previously to apply it to the border. Press the Esc key to hide the panel.
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7. Change Border Size to 4 and press Return or Enter.
8. Click the Outer Stroke button ( =) to align the border to the outside of the shape.

By default, borders are aligned to the inside of paths in Adobe XD. Next you’ll draw the
handle of the search icon.
9. Press Command+Shift+A (macOS) or Ctrl+Shift+A (Windows) to deselect.

10. Select the Line tool and Shift-drag to make a small angled line, as you see in the figure.
This will be the handle of the magnifying glass.
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11. Change the border color to white, change the border size to 4, and press Return or Enter.
Click the Round Cap button ( € ) to round the ends of the line.
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12. With the Select tool selected, drag across both objects and press Command+G (macQOS)
or Ctrl+G (Windows) to group them together.

Note
You may want to reposition the handle before you group the objects together.

Rounding corners

When it comes to rectangles, you can easily round all of the corners of a rectangle at once or
each individually. In this next section, you’ll create a rounded-corner rectangle that will become
part of an icon.

1. With the Select tool (M) selected, zoom out by pressing Command and — (macOS) or
Ctrl and — (Windows).

To zoom in or out you can also pinch using a trackpad or Option-scroll/Alt-scroll using a
mouse.

2. Select the Rectangle tool (L]) in the toolbar and Shift-drag to create a square next to the
search icon you just created. Release the mouse button and then the key when it shows
an approximate width of 30 and height of 30 in the Property Inspector.



3. Deselect the Border option in the Property Inspector to remove the border.

For the next step, you may need to zoom in to see the corner radius widgets.

Tip
You can drag any of the corner widgets on the shape away from the center of
the shape to remove the corner radius.

4. Drag any one of the corner radius widgets ((®) toward the center of the shape to round
all of the corners at once. Drag as far as you can to make a circle.

Next, you’ll round corners independently on a shape.

5. To duplicate the circle, press Command+D (macOS) or Ctrl+D (Windows). A copy is
placed on top of the original.

6. Press the letter V to select the Select tool and drag the new circle straight down, away
from the original.
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7. Option-drag (macOS) or Alt-drag (Windows) the right-middle point around the shape to
the right to make it wider from both sides.

8. Change the Corner Radius value in the Property Inspector to 0 to remove the rounded
corners from the copy.

Note

If you find that you can’t change the radius value to 30—maybe you can only
change it to 26 or something—it may be that the rectangle is smaller than it is
in the figure. That’s okay.

9. Option-drag (macOS) or Alt-drag (Windows) the upper-left corner radius widget ()
toward the center of the shape. Drag until you see a Top Left Corner Radius value of
approximately 30 in the Property Inspector.
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Dragging with the Option/Alt key held down allows you to change one of the corner
radii. When you change a single corner radius by dragging with the Option/Alt key, the
Different Radius For Each Corner option ( © ) becomes selected in the Property
Inspector, allowing you to change each corner radius independently.

Tip



If you want to ensure that all of the radius values are the same again, you can
click the Same Radius For All Corners button ( ©).

Note

By default, when you transform a shape, the corner radius values do not scale
(change).

10. Change the Corner Radius values in the Property Inspector to 50, 50, 30, and 30 (or
similar values) and press Return or Enter to accept the values. Leave the shape selected.

11. With the Select tool selected, drag across both objects and press Command+G (macOS)
or Ctrl+G (Windows) to group them together.

Editing shapes

If you’ve ever edited shapes in other Adobe programs, like Illustrator, you’re likely used to
switching tools to accomplish shape editing tasks. In Adobe XD, shape editing is easily
accomplished with a single tool, the Select tool. In this section, you’ll create and edit shapes for a
map icon.

1. Choose View > Show Square Grid (macOS), or right-click the artboard and choose
Show Square Grid (Windows).

2. Select the Rectangle tool (LJ) in the toolbar and, starting on the square grid, drag to
create a rectangle that is wider than it is taller. Make sure to snap the right edge of the

rectangle to the square grid. See the figure. The rectangle in the figure has a height of 40
and a width of 72.
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In this case, the square grid can be a useful way to create shapes because it ensures
whole number values for width and height. Every shape you create has a bounding box
around it when selected. This is used for transforming the shape in different ways.

. Select the Select tool (M) and double-click the selected rectangle.

Double-clicking an object enters Path Edit mode, which allows you to edit the anchor
points of the object. At this point, you could select existing anchor points and edit or
delete them and add new anchor points, but you can’t move or transform the entire
shape.

. Drag across the top two anchor points to select them both. You could have also pressed
the Shift key and clicked both anchor points to select them.

. Drag one of the anchor points to the left, keeping them in line with the original position
of the anchor points. Snap the anchor point you are dragging to the square grid.
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. Press the Esc key to exit Path Edit mode. The bounding box is now showing again, and
the anchor points are hidden.

. With the shape still selected, move the pointer just off one of the corners. When the
pointer changes ("), Shift-drag clockwise to rotate the shape. When you see 90 in the
Rotation field of the Property Inspector, release the mouse button and then the Shift key.
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. With the Select tool () and the shape still selected, press Command+D (macOS) or
Ctrl+D (Windows) to paste a copy right on top of the original.

Next, you’ll flip the shape copy.

. Click the Flip Horizontally button (P4) in the Property Inspector to flip the shape.



10. Drag the shape you just flipped to the right. When there is a gap between the shapes,
stop dragging and release the mouse button. Aqua alignment guides appear, indicating it
is still aligned horizontally with the original shape.

Note

In the following figure, it shows a gap of 3. If you find that the shape is
snapping to the square grid and the gap value you see is 8, try zooming in
further. By zooming in, the shape will snap to the pixel grid and the square grid.

11. Option-drag (macOS) or Alt-drag (Windows) the shape on the left to the right to make a
copy. When it looks like the figure, release the mouse button and then the key.

. Drag across all three shapes and press Command+G (macOS) or Ctrl+G (Windows) to
group them together and make a map icon.

13. Deselect the Border option in the Property Inspector to remove the border.




Combining shapes

Like many other drawing applications, Adobe XD offers several Boolean operations for
combining shapes in different ways. There are four Boolean operations you can choose from:
Add, Subtract, Intersect, and Exclude Overlap. Using Boolean operations can be very useful for
creating more complex artwork from simpler shapes. To me, the best part of combining shapes
using Boolean operations in Adobe XD is the ability to edit each individual shape, even after
multiple shapes have been combined. Next, you’ll combine shapes to create a map pin icon.

1. Zoom out a bit by pressing Command and — (macOS) or Ctrl and — (Windows).

2. Select the Ellipse tool () in the toolbar. In a blank area of the artboard, Shift-drag to
create a circle. Don’t worry about the size for now. Just make it large enough to work
with. Release the mouse button and then the key.

3. With the Select tool (M) and the shape still selected, press Command+D (macOS) or
Ctrl+D (Windows) to paste a copy right on top of the original.

4. Option+Shift-drag (macOS) or Alt+Shift-drag (Windows) a corner to make the circle
smaller.
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5. Click the larger circle to select it. Double-click the shape to enter Path Edit mode and
see the anchor points. See the first part of the following figure.

Note

You may need to deselect the smaller circle first, before attempting to select the
larger circle.




6. Click the anchor point on the bottom of the circle to select it. You should see little
direction handles appear on either side of the point. These control the curve of the path
on either side of the anchor point.

Note
You will learn more about editing anchor points later in this lesson.

Tip
You can double-click the same point again to convert it back to a corner point.

7. Drag the bottom anchor point down to reshape the circle. As you drag, a vertical aqua
alignment guide should appear when the point is aligned with the anchor point at the top
of the shape. Drag down until it looks good to you.

Note
If you don’t see the aqua alignment guide, you may need to zoom in.

8. Double-click the same point to convert it to a corner point (not a curve).




10.

11.

In Adobe XD, you can easily edit existing shapes without having to switch tools from
the Select tool. Later in this lesson, in the section “Drawing with the Pen tool,” you’ll
learn about creating and editing paths with the Pen tool and the Select tool.

Press the Esc key to exit Path Edit mode. You should see the bounding box around the
shape, not the anchor points on the shape. Drag across both shapes to select them.

Click the Subtract button (T) in the Property Inspector to subtract the smaller circle
from the shape under it.
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Look in the Property Inspector and notice that the Subtract option is on. The Boolean
operations, such as Subtract, can be toggled off later, returning the shapes to two
separate shapes.

Deselect the Border option in the Property Inspector to remove the border.

Tip
In Lesson 6, “Working with Assets and CC Libraries,” you’ll learn about
saving colors and working smarter.

12.

Click the Fill color box in the Property Inspector to show the Color Picker. Select the
orange-red color you saved, at the bottom of the panel, to apply it.
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Editing combined shapes



No matter which of the operations you use for combining shapes, you can always edit the
underlying shapes you started with. Next, you’ll edit shapes from the map pin icon you just

created.

1.
2.

6.

Double-click the newly combined pin icon to enter editing mode for the selected shapes.
Click in the smaller circle in the center to select it, if it’s not already selected.
Notice the blue outline around the entire pin icon. When you double-click combined

shapes, the outline appears, indicating the combined shapes that you are editing. See the
second part of the following figure.

Option+Shift-drag (macOS) or Alt+Shift-drag (Windows) a corner to make the circle
even smaller. Release the mouse button and then the keys.

Press the Esc key to stop editing the individual shapes, and select the entire combined
pin icon.

Choose Object > Path > Convert To Path (macOS) or right-click and choose Path >
Convert To Path (Windows).

The Convert To Path command is useful if you want to make the path combination
permanent (you can no longer edit the individual paths) and also to be able to edit the
anchor points of the combined path.

Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Aligning content to the pixel grid

When you’re creating vector content in Adobe XD or bringing in vector content from other
sources, it’s important that the images you export later look sharp. To create pixel-accurate
designs, you can align artwork to the pixel grid using the Align To Pixel Grid option. The pixel
grid is an invisible grid of 72 squares per inch. Align To Pixel Grid is an object-level property
that enables an object to have its vertical and horizontal paths aligned to the pixel grid. Next
you’ll draw an arrow icon and align it to the pixel grid.

1.

2.

Choose View > Hide Square Grid (macOS) or right-click the artboard and choose Hide
Square Grid (Windows).

With the square grid off, content you create will now no longer be aligned to the grid.

Select the Line tool (/) in the toolbar and Shift-drag to make a horizontal line, as you
see in the figure. Release the mouse button and then the key.



Note

If you find that this zoom command won’t work, you can pinch-zoom on a
trackpad or select the Zoom tool to zoom in.

. Press Command+3 (macOS) or Ctrl+3 (Windows) to zoom in to the line.
. To deselect the line, press the Esc key.

Now you’ll draw the arrowhead.

. With the Line tool selected, starting on the right end of the path you drew, Shift-drag up
and to the left to make a line that is angled at 45 degrees.

. Press Command+D (macOS) or Ctrl+D (Windows) to duplicate the line in place. Click
the Flip Horizontally button ( *:4) in the Property Inspector.

. Select the Select tool and drag the flipped line straight down. Aqua alignment guides
will appear to help you align it.

. Drag across all of the paths and then right-click them and choose Group.

. In the Property Inspector, change the border color to white, change the border size to 4,
and press Return or Enter. Click the Round Cap button ( € ) to round the ends of the
line.



10. Shift-drag a corner to make it smaller. Drag until you see a width of around 24 in the
Property Inspector. Release the mouse button and then the key.
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Looking in the Property Inspector, you may see that the width and height values are not
whole numbers. Next, you’ll align the artwork in the group to the pixel grid, and those
values will become whole numbers.

Note
To see the change to the Height and Width values in the Property Inspector, you
may want to click away from the arrow artwork, then click to select it again.

11. Choose Object > Align To Pixel Grid (macOS) or right-click the selected artwork and
choose Align to Pixel Grid.

You probably noticed the subtle shift in the shapes as the paths were aligned to the pixel
grid. To give you an idea of what just happened, take a look at the following figure. On
the left is artwork that I didn’t align to the pixel grid before I exported it as a PNG; on
the right is artwork that is aligned to the pixel grid. You can clearly see the difference on

the horizontal and vertical paths.

Not aligned before exporting as PNG Aligned before exporting as PNG

12. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the artboards.
13. Click in a blank area of the gray pasteboard to deselect all.

Bringing in content from Adobe Illustrator



There are several ways to bring content from Illustrator into Adobe XD: open the Illustrator file
directly in Adobe XD, copy and paste from Illustrator to XD, export assets from Illustrator, add
the Illustrator artwork to a Creative Cloud library, and import into XD. In this section, you’ll
open an Illustrator document (.ai) in XD.

Note

For a list of supported and non-supported features when opening Illustrator files
in XD, visit https://helpx.adobe.com/xd/kb/open-illustrator-files-in-xd.html.

1. In Adobe XD, choose File > Open From Your Computer (macOS), or click the menu
icon (=) in the upper-left corner of the application window and choose Open From
Your Computer (Windows). In the Lessons > Lesson03 > links folder on your hard disk,
select the artwork.ai file, and click Open.

The Illustrator file contains artwork that you will incorporate into your design in Adobe
XD. There were two artboards in the Illustrator document that remain in the document
opened in XD, and the vector graphics and text are still editable. You can now copy and
paste or drag and drop this content into your other projects.

2. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.

The content on the left artboard contains a banner icon and other content, and the
artboard on the right contains a topographical map illustration. You’ll copy the content
into your Travel_Design.xd document.

3. Press Command+A (macOS) or Ctrl+A (Windows) to select all of the content.

4. Right-click directly on the content and choose Copy to copy it.
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5. Choose File > Close (macOS), or click the menu icon (=) in the upper-left corner of the
application window and choose Close (Windows). Don’t save the file. XD converted it
to a new XD file that you don’t need to keep.

6. In the Travel_Design.xd document, click in the gray pasteboard to deselect. Press
Command+V (macOS) or Ctrl+V (Windows) to paste the content. Drag the selected


https://helpx.adobe.com/xd/kb/open-illustrator-files-in-xd.html

artwork away from the artboards so it doesn’t touch any of them.
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Note

If some of the artwork disappears even when it’s not touching an artboard, you
may want to restart XD and reopen the files and try again.

Click away from the artwork to deselect it. Drag across the topography illustration to
select it, and then drag it onto the Recording artboard.
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8. Drag the artwork you pasted with the Location, Weather, Elevation, and Steps text (not
the orange-red banner icon) onto the top of the Memory artboard.

9. Drag the remaining orange-red banner icon onto the Icons artboard.
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10. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.
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Exporting artwork from Illustrator for Adobe XD



Sometimes, you may not be happy with the fidelity of the artwork opened in XD or copied from
[Mlustrator and pasted into XD. In this case, you can choose to export as SVG from Illustrator and
import or drag that asset into Adobe XD. To learn about how to easily export artwork from
[Mlustrator to be used in Adobe XD, check out the video “Exporting artwork from Illustrator for
Adobe XD,” which is a part of the Web Edition of this book. For more information, see the
“Web Edition” section of “Getting Started” at the beginning of the book.

Drawing with the Pen tool

Another way to create artwork is to use the Pen tool in Adobe XD. With the Pen tool, you can
create both freeform and more precise artwork and edit existing shapes. In this section, you’ll
explore the Pen tool by drawing artwork using straight and curved lines, and then you’ll learn
how to edit shapes with both the Pen and Select tools.

First, you’ll open an existing file and begin drawing some icons using the Pen tool.

1. Choose File > Open From Your Computer (macOS), or click the menu icon (=) in the
upper-left corner of the application window and choose Open From Y our Computer
(Windows). Locate the file named Drawing.xd, which is in the Lessons > Lesson03
folder that you copied onto your hard disk. Select the file and click Open.

This document has three icons you’ll create. You’ll use templates provided for tracing
paths, and then you can practice on your own.
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2. Double-click the artboard icon () to the left of the artboard name “Icon 1” in the
Layers panel to fit the artboard in the document window.

Drawing straight lines

You may have some experience with the Pen tool in an application like Illustrator or Photoshop.
The Pen tool in Adobe XD is similar, but in XD creating paths with the Pen tool may seem easier
and more intuitive. To start drawing with the Pen tool in Adobe XD, you’ll create an icon in the
shape of a house.



Tip
You can press the P key to select the Pen tool.

1. Select the Pen tool (£”) in the toolbar. Move the pointer over point 1 and click to create
an anchor point; then release the mouse button. Make sure you have released the mouse
button and move the pointer away from the point you just created, and you’ll see a line
connecting the first point and the pointer, no matter where you move the pointer. That
line gives you a preview of the next line segment you will draw.
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Later, as you create curved paths, it will make drawing them easier because you can
preview what the path will look like.

Note

If the path looks curved, you have accidentally dragged with the Pen tool. Press
Command+Z (macOS) or Ctrl+Z (Windows) to undo, and then click again
without dragging.

2. Move the pointer above the first anchor point, over point 2. When the pointer is
vertically aligned with the first point, the preview line will turn aqua to show that it’s
aligned. Click point 2 to create another anchor point.

You just created a path. A simple path is composed of two anchor points and a line
segment connecting those anchor points. You use the anchor points to control the
direction, length, and curve of the line segment.

3. Continue clicking points 3, 4, and 5 to create a house shape, releasing the mouse button
every time you click to create another anchor point.



The aqua snap guides are very useful for aligning anchor points you create to existing
anchor points. Notice that only the last anchor point is filled (not hollow like the rest of
the anchor points), indicating that it is selected.

4. Click the first anchor point you created to close the path and stop drawing.

After closing a path, the Select tool (M) is automatically selected. Next, you’ll create a
path that will be the roof of the house. This will be an open path, not closed.
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Tip

Instead of relying on alignment guides to align points as you create them, you
can also press the Shift key and click to create an anchor point. The Shift key
constrains the angle of the segment to a multiple of 45 degrees.

5. Select the Pen tool and move the pointer over point 6. Move the pointer around and you
most likely will see aqua snap guides. Press and hold Command (macOS) or Ctrl
(Windows) and move the pointer around. You will no longer see the aqua alignment
guides since dragging with the Command (macOS) or Ctrl (Windows) key down
temporarily disables the alignment guides. With the key still held down, click point 6.

Icon: &5 lcon: B lcon: T

6. With the key held down, click to add points at 7 and 8 to create a roof.
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7. Press the Esc key to stop drawing the path, which also automatically switches to the
Select tool.




Drawing with a square artboard grid turned on

Drawing on an artboard with the grid turned on means that what you draw will snap to the
grid lines. This can make creating icons or other vector objects easier and more precise. To
avoid snapping to the grid, you can press the Command (macOS) or Ctrl (Windows) key
while dragging the mouse and drawing an object.
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Drawing curves

Along with creating straight paths with the Pen tool, you can also draw curves. As you draw, you
create a line called a path. A path is made up of one or more straight or curved segments. The
beginning and end of each segment are marked by anchor points, which work like pins holding a
wire in place. A path can be closed (for example, a circle) or open, with distinct endpoints (for
example, a wavy line). You change the shape of a path by dragging its anchor points or the
direction points at the end of direction lines (together, direction points and direction lines are
called direction handles) that appear at anchor points.

Curved Path
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Line segment
Anchor point
Direction line
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Direction point

Creating curves with the Pen tool can be tricky, but with some practice you’ll soon be on your
way. Next, you’ll create a curved path. To do this, you’ll drag away from a point you create.

Tip
You can press the spacebar to access the Hand tool and then drag in the
document window to move to a blank area of the artboard.

1. Press Command+Shift+A (macOS) or Ctrl+Shift+A (Windows) to deselect all.



2. Double-click the artboard icon (J) to the left of the artboard name “Icon 2” in the
Layers panel to fit the artboard in the document window.

3. Select the Pen tool (£*) in the toolbar. Move the pointer over the gray point labeled 1.
Press and drag to the right, to the blue dot, to create a direction line.

(@

Notice that direction handles appear as you press and drag away from a point. Direction
handles consist of direction lines that end in round direction points. The angle and length
of the direction lines determine the shape and size of the curve. As you drag away from a
point, there are two direction handles, one before the point and one after it. Direction
lines move together by default and only show when you’re editing paths.

4. Move the pointer over point 2; then press and drag to the right. After you begin
dragging, press the Shift key to constrain the movement to a multiple of 15 degrees.
When you reach the blue dot, release the mouse button and then the key to create
direction lines.
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Next, you’ll create a corner point with no direction lines, and then go back and change it
to a smooth point.

5. Move the pointer over point 3. Click and release without dragging to create a corner
point with no direction lines.
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6. Move the pointer over point 4, and press and drag to the right. After you start dragging,
press the Shift key. When you reach the blue dot, release the mouse button and then the
key to create a direction line.



10.

11.

12.
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Move the pointer over the anchor point at 3. When the point turns blue and the pointer
changes (*), double-click to convert the point to a smooth point with direction handles
you can edit.

While drawing with the Pen tool in Adobe XD, you can always edit the path you are
currently drawing without switching tools.

Move the pointer over point 6 (skip point 5 for the moment). Press and drag to the right.
As you drag, press the Shift key. When you reach the blue dot, release the mouse button
and then the key to create a direction line.
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You skipped point 5 so you could see how to edit a path as you draw. Typically, you
would create point 5 before point 6.

Click the anchor point at point 6 to ensure that it’s selected. You can tell it’s selected
because it is blue. Press Delete or Backspace to remove it.

You can select anchor points in the path you are currently drawing with the Pen tool still
selected. If you delete an anchor point in the middle of a path, for instance, the
remaining anchor points will be connected.

Move the mouse pointer over point 5 and drag to the right. As you drag, press the Shift
key. When you reach the blue dot, release the mouse button and then the key to create a
direction line.

Move the mouse pointer over point 6 and drag to the right. As you drag, press the Shift
key. When you reach the blue dot, release the mouse button and then the key to create a
direction line.

Press the Esc key to stop drawing and automatically switch to the Select tool.



13.
14.

Change Border Size to 3 in the Property Inspector. Press Return or Enter.
With the Select tool selected, click in a blank area of the gray pasteboard to deselect the
last path.

If you want to practice without the template, try tracing the same shape below the
template in the area labeled Practice.

Changing path direction

The last icon you will create is a cloud. The path will contain an anchor point whose direction
lines are “split.” This means that a curve can be followed by a straight path, for instance.

1.

Double-click the artboard icon ([J) to the left of the artboard named Icon 3 in the Layers
panel to fit the artboard in the document window. To zoom in a bit further, press
Command and + (macOS) or Ctrl and + (Windows).

Select the Pen tool (£”) in the toolbar. Press and drag from point 1 to the left, to the blue
dot, to create a direction line. Release the mouse button.

Move the mouse pointer over point 2 and drag up to the blue dot to create a direction
line.
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Now you need the next part of the path to switch directions at the anchor point and
create another curve. You will split the direction lines to convert a smooth point to a
corner point. This involves a keyboard modifier.

Move the pointer over point 3 and drag to the gold dot to create a direction line. Release
the mouse button.

Press the Option (macOS) or Alt (Windows) key and drag the end of the direction line to
the blue dot. Release the mouse button and then the key.

The direction lines are now split, which means you can move them independently of
each other. The trailing direction line controls the curve of the path leading up to the
anchor point, and the leading direction line controls the curve of the path after the anchor
point.




Tip
To make the handles move together again, you can double-click the corner
anchor point twice.

10.

11.

. Move the mouse pointer over point 4 and drag to the right, to the blue dot, to continue

drawing the path.

When it comes to smooth points (curved), you’ll find that you spend a lot of time
focusing on the path segment behind (before) the anchor point you are creating.
Remember, by default there are two direction lines for a point. The previous direction
line controls the shape of the previous segment.

. Move the pointer over point 5 and drag to the gold dot to create a direction line. When

the path between points 4 and 5 look good, release the mouse button.

. Press the Option (macOS) or Alt (Windows) key and drag the end of the direction line to

the blue dot. Release the mouse button and then the key.
4 4 4
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. Move the mouse pointer over point 6 and drag down, to the blue dot, to continue

drawing the path.

Move the mouse pointer over point 7 and drag to the left, to the blue dot, to continue
drawing the path.

Move the mouse pointer over point 1 and click to close the cloud path.

If you want to practice without the template, try tracing the same shape below the
template in the area labeled Practice.



12. Deselect the Border option in the Property Inspector. Click the Fill color and in the
Color Picker, change the Hex value to an orange-red (#FF491E). You may need to make
sure that Hex is chosen in the Color Picker first.
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Editing artwork with the Pen tool

In Adobe XD, you can edit shapes and paths as you are drawing vector artwork or after the
artwork is created. In the next few exercises, you’ll focus on editing shapes using Path Edit
mode.

1. Press Command+Shift+A (macOS) or Ctrl+Shift+A (Windows) to deselect all.

2. Double-click the artboard icon ( ) to the left of the House artboard in the Layers panel
to fit the artboard in the document window.

3. With the Select tool () selected, double-click the top rectangle shape to enter Path Edit

mode.

4. Move the pointer over the top border of the path as you see in the first part of the
following figure. When the Pen tool icon (%) appears, click to create a new anchor point
and release the mouse button.

When in Path Editing mode, you don’t have to switch tools from the Select tool to add,
delete, and edit points.

5. Drag the anchor point up.



10.
11.
12.

13.

J

Double-click the line above the house shape to enter Path Editing mode. Move the
pointer over the path, and when you see the Pen tool icon, click to add a new anchor
point. See the first part of the following figure.

Drag that same anchor point up a bit. See the second part of the following figure.
Press the Esc key to exit Path Edit mode.

At this point, the anchor points aren’t visible, and you cannot edit them; only the
bounding box of the shape is visible.

Drag the path down, above the house icon. See the last part of the following figure.
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To finish the house artwork, you’ll edit the rectangle below the path to look like a
curving sidewalk.

Double-click the rectangle below the house shape to enter Path Editing mode.
Drag the top two anchor points on the selected shapes closer together.

Move the pointer over the lower-left anchor point and double-click to convert it to a
smooth point. The path at that anchor should now be a curve.

Click the end of the direction handle pointing down. Press Delete or Backspace to
remove it. The path on that side of the anchor point is now straight.

I




14. Drag the remaining direction handle up and to the right to curve the path.

)

15. Repeat steps 12—14 on the anchor point in the lower-right corner of the same shape.
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Copying the cloud icon

Next, you’ll copy the cloud icon you created to the Travel_Design.xd document.
1. Press Command+0 (macOS) or Ctrl+0 (Windows) to zoom out.
2. With the Select tool selected, right-click the cloud icon and choose Copy.

3. To close and save the Drawing document, choose File > Close (macOS) or click the X
in the upper-right corner (Windows).

You should be back in the Travel _Design.xd document.

Note
If you started with the L.3_start.xd jumpstart file, then return to that file.

4. Right-click the Icons artboard and choose Paste to paste the cloud icon.
5. Drag the icons around on the artboard so they are more evenly spaced. Later, it’ll make
it a little easier to select them.

kcons

Working with UI Kits



In Adobe XD you have access to a series of Ul (user interface) kits for Apple iOS, Microsoft
Windows, Google Material (Android), and wireframes. UI kits and wireframes can save time
when you’re designing for different device interfaces and platforms. They are XD files that
include common design elements such as icons, keyboard layouts, navigation bars, inputs,
buttons, and more. You can use a Ul kit as a starting point or copy and paste elements into your
own design. These resources can help you create a design that matches a specific design
language (like iOS).

Downloading the UI kit

In this section, you’ll download and unzip a UI kit from the developer.apple.com website. You’ll
then open an XD file from the downloaded files and copy a few elements into your design.

Note

If you are on Windows or cannot access the Adobe XD file on the Apple
website, you can open the UI_kit_content.xd document in XD, located in the
Lessons > Lesson03 folder. You can then press Command+A (macOS) or
Ctrl+A (Windows) to select all of the content in the document, copy it, and
paste it into the Travel_Design.xd file that is still open.

1. Choose File > Get UI Kits > Apple iOS (macQOS) or, on Windows, click the menu icon (
=) in the upper-left corner of the application window and choose Get UI Kits > Apple
iOS.

The UI kits listed in the menu you see are links to the websites that they can be
downloaded from. By choosing Apple iOS, the developer.apple.com website is opened
in your default browser to a page where you can download a UI kit specifically for
Adobe XD.

2. On the web page that opens in your default browser, click Download For Adobe XD.
After you accept an agreement, a DMG file is downloaded to your computer.
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3. Find the DMG file that was downloaded and double-click to view the contents.

4. Save the UI Elements + Design Templates + Guides folder to the Lessons folder on your
hard drive so that you can easily find the contents.


http://developer.apple.com
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5. Go back to your browser and visit https://developer.apple.com/fonts/. On that page, click
the button to download the San Francisco fonts.

6. On macOS, after the DMG for the fonts is downloaded, locate it and double-click to
view the contents. Open each folder and install each font.

San Francisco Font

Thee swstem font for i05, mecOS, w05, and watch0S

Note

For more information on how to install fonts on macOS, visit
https://support.apple.com/en-us/HT201749.

Opening and copying from the UI Kit

With the UI kit downloaded and unzipped and the San Francisco fonts installed (macOS only),

now you’ll open one of the downloaded files and copy content into your Travel_Design.xd
document.

1. Back in Adobe XD, choose File > Open From Your Computer (macOS), or click the
menu icon (=) in the upper-left corner of the application window and choose Open
From Your Computer (Windows). Navigate to the Lessons > UI Elements + Design

Templates + Guides folder. Open the UlElements+Design Templates+Guides-
iPhoneX.xd file in that folder.

Note

If you are on Windows or you don’t install the San Francisco fonts, you may
still proceed. You will most likely continue to see a missing fonts warning
every time you open a file that uses the content from these UI Kkits.

2. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.

3. In the Layers panel (Command+Y [macOS] or Ctrl+Y [Windows]), type bars into the
search field ( Q) at the top of the Layers panel to filter the list of content that appears in
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the panel (circled in the figure). Click Status Bars in the Ul ELEMENTS - BARS
section to select the content in the document.
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Note

After opening the file, if you see a message at the bottom of the application
window about missing fonts, you can click the X on the right side of the
message to close it.

. Press Command+3 (macOS) or Ctrl+3 (Windows) to zoom in.

. Click the X to the right of the search field ( Q) at the top of the Layers panel to clear the
filtering (circled in the following figure). You should now see all of the content for the
UI ELEMENTS - BARS artboard listed in the Layers panel.

. Click the folder icon ( B3) to the left of the Status Bars object in the Layers panel to see
the contents of the group.
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. Click the top status bar, press the Command key (macOS) or Ctrl key (Windows), and
click the white status bar to select both. Right-click either of them and choose Copy to
copy them.
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Note
If you started with the L.3_start.xd jumpstart file, then return to that file.

8.

9.

10.

11.

12.
13.

Choose Window > Travel_Design (macOS) or press Alt+Tab (Windows) to switch to
the Travel_Design.xd document.

Back in the Travel_Design.xd document, click in the artboard named Memory and press
Command+3 (macOS) or Ctrl+3 (Windows) to fit the artboard in the document window.
Press Command+V (macOS) or Ctrl+V (Windows) to paste the status bars on the
artboard. Drag them into the position you see in the figure.

Choose Window > UlElements+Design Templates+Guides-iPhoneX (macOS) or press
Alt+Tab (Windows) to switch to the UIElements+DesignTemplates+Guides-
iPhoneX.xd document.
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Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.

Double-click the keyboard on the artboard named “UI Elements — System.” It’s far to
the right of the artboard that contains the status bars you just selected and copied. Press
Command+C (macOS) or Ctrl+C (Windows) to copy it.




14.

15.

Choose File > Close (macOS) or click the X in the upper-right corner of the application
window (Windows) to close the file and return to the Travel_Design.xd document.

Back in the Travel_Design.xd document, in the Memory artboard press Command+V

(macOS) or Ctrl+V (Windows) to paste the keyboard on the artboard. Drag it into the
position you see in the figure.
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Note
If you started with the L.3_start.xd jumpstart file, then return to that file.

Note

The small link icon in the upper-left corner of each element you’ve pasted will
be discussed in Lesson 6.

16.
17.

Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

If you plan on jumping to the next lesson, you can leave the Travel_Design.xd file open.
Otherwise, for each open document, choose File > Close (macOS) or click the X in the
upper-right corner (Windows).



Note
If you started with the L.3_start.xd jumpstart file, then keep that file open.

Review questions

1 What is Path Edit mode?

2 How do you combine several shapes into one?

3 How do you draw straight vertical, horizontal, or diagonal lines using the Pen tool ( £*)?
4 How do you draw a curved path using the Pen tool?

5 How do you convert a smooth point on a curve to a corner point?

6 What is a UI kit?

Review answers

1 Path Edit mode is when shape anchor points are visible but moving the mouse does not
draw anything. In Path Edit mode, you can edit or delete existing anchor points or add
new anchor points.

2 To combine several shapes into one, you can select the shapes and then apply one of the
combine options in the Property Inspector to create new shapes out of the overlapping
objects.

3 To draw a straight line, click with the Pen tool (£”) and then move the pointer and click
again. The first click sets the starting anchor point, and the second click sets the ending
anchor point of the line. To constrain the straight line vertically, horizontally, or along a
45° diagonal, press the Shift key as you click to create the second anchor point with the
Pen tool.

4 To draw a curved path with the Pen tool, click to create the starting anchor point and
release the mouse button. Move the mouse pointer to another part of the artboard, drag to
set the direction of the curve, and then release the mouse button to end the curve.

5 To convert a smooth point on a curve to a corner point (or vice versa), double-click the
shape or path with the Select tool () to enter Path Edit mode. With the anchor points
showing on the selected artwork, double-click an anchor point to convert it to the
opposite. If it’s currently smooth, it will become a corner point and vice versa.

6 A UI kit is a file or set of files that contains resources, such as user-interface elements
(buttons, icons, and more), that are specific to an operating system. It can help you design
apps (or websites) that match a design language like iOS.



4 Adding Images and Text

Lesson overview
In this lesson, you’ll learn how to do the following:

e Import images.

e Transform images.

¢ Bring in content from Adobe Illustrator CC.
¢ Bring in content from Adobe Photoshop CC.
e Mask content.

e Add text.

e Format text.

This lesson takes approximately 45 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the
lesson files and Web Edition.”

Your Account page is also where you’ll find any updates to the lessons or to the lesson
files. Look on the Lesson & Update Files tab to access the most current content.
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In Adobe XD, images and text play an important part in any design. This lesson focuses on
importing and transforming images, as well as adding and formatting text.

Starting the lesson

In this lesson, you’ll bring raster images into, and add text to, your app design. To start, you’ll
open a final lesson file to get an idea for what you will create in this lesson.

Note

If you have not already downloaded the project files for this lesson to your
computer from your Account page, make sure to do so now. See the “Getting
Started” section at the beginning of the book.

1. Start Adobe XD CC, if it’s not already open.

2. On macOS, choose File > Open From Your Computer. On Windows, click the menu
icon (=) in the upper-left corner of the application window and choose Open From
Your Computer.

For either macOS or Windows, if the Home screen is showing with no files open, click
Your Computer in the Home screen. Open the file named L4_end.xd, which is in the
Lessons > Lesson04 folder that you copied onto your hard disk.



Note

The figures in the lesson were taken on macOS, so on Windows the XD
interface will be a little different.

3. If you see a message at the bottom of the application window about missing fonts, you
can click the X on the right side of the message to close it.

4. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the design content. This
file shows you what you will create by the end of the lesson.
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5. Leave the file open for reference, or choose File > Close (macOS) or click the X in the
upper-right corner of the open window (Windows) to close the file.

Assets and Adobe XD

In the previous lesson, you explored creating, importing, and editing vector graphics. In this
lesson, you’ll learn about the different types of image assets you can import into Adobe XD, the
different methods for bringing them in from programs like Photoshop and Sketch, and how to
work with them to fit your design.

Tip
In Lesson 6, “Working with Assets and CC Libraries,” we discuss CC
Libraries, which allow for an image-linking workflow.

When it comes to images, Adobe XD supports PSD, Al, PNG, GIF, SVG, JPEG, and TIFF
images. In Adobe XD, images (both raster and vector) that you import are embedded in the XD
file, since there is no image-linking workflow, by default, as you would find in Adobe InDesign.

Sizing raster images for Adobe XD



If you’re designing using the default artboard sizes (1x), you need to pay attention to the
sizing of any raster images (JPEG, GIF, PNG) that you import into your design. The sizing
is especially important if you will later need to export production-ready assets for a website
or app.

It’s best to edit your raster images in a program like Photoshop to be the maximum size you
need before you import them into XD. In the case of an image for a website, if your image
spans the entire width of a 1920 x 1080 artboard, you’ll want to ensure that your image is
3840 pixels across (twice the width of the intended use in XD). Be careful about simply
importing overly large images each time you need an image, since large file sizes can slow
down load time.

If you’re designing for iOS, and designing at 1x, you’ll want to make sure that any raster
images you import are scaled at 3x (three times the size they are in your Adobe XD design),
and for Android, 400% (or 4x).

Importing an image

In Adobe XD, there are several methods for adding assets to your projects. In this section, you’ll
import a few assets into your design using the Import command.

Note

If you are starting from scratch using the jumpstart method described in the
section “Getting Started,” open L4_start.xd from the Lessons > Lesson04
folder.

1. Choose File > Open From Your Computer (macOS) or click the menu icon (=) in the
upper-left corner of the application window and choose Open From Your Computer
(Windows). Open the Travel_Design.xd document in the Lessons folder (or where you
saved it).

2. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.
3. With the Select tool (M) selected, click the Home artboard in the document window.

Note

To learn more about image sizing and Adobe XD, see the sidebar “Sizing raster
images for Adobe XD.”

4. Choose File > Import (macOS) or click the menu icon (=) in the upper-left corner of
the application window and choose Import (Windows). Navigate to the Lessons >
Lesson04 > images folder. Click to select the image named home_1.jpg. Click Import.
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JPEG images you import into Adobe XD are placed at half size. That means a JPEG that
is 400 pixels x 400 pixels will be placed at 200 pixels x 200 pixels. The image is placed
in the center of the selected artboard and is larger than the artboard. Any image content
that is outside the bounds of the artboard is hidden. With the image selected, XD shows
the masked content as semi-transparent to give you a preview of what is hidden.

5. With the Select tool (M) selected, drag the image until the bottom edge snaps to the
bottom edge of the artboard, and ensure that it’s still centered on the artboard (a vertical
aqua guide will appear when it’s centered).

Tip

You can also scale an image non-proportionally if you need. Before dragging to
resize, with the image selected, you can turn off the Lock Aspect option (&) in
the Property Inspector on the right.

6. Drag the top-middle handle of the image down until the image is as tall as the artboard.
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The proportions of raster images are maintained when resizing by dragging.

7. Right-click the image and choose Send To Back (macOS) or Arrange > Send To Back
(Windows) to arrange the image behind the other content on the Home artboard.
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Note

If you were to export the home_1.jpg image (not the entire artboard), the final
asset would not be cropped as you see it when you deselect the image on the
artboard. You’ll learn about exporting in Lesson 11, “Exporting and

Integration.”

8. Click away from the image, in a blank area of the document window, to deselect it. You
should now see that the image content that is outside the bounds of the artboard is

hidden.
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Importing multiple assets

In Adobe XD, you can import multiple assets using a variety of methods. In this section, you’ll
import an SVG file and a PNG using the Import command.




Note

In the images folder, you’ll see an Illustrator document named red_map.ai. You
can import native Illustrator documents (.ai) into Adobe XD as well.

1. Choose File > Import (macOS) or click the menu icon (=) in the upper-left corner of
the application window and choose Import (Windows). Navigate to the Lessons >
Lesson04 > images folder. Click to select the image named journal_header.png and
Command-click (macOS) or Ctrl-click (Windows) the image named red_map.svg. Click

Import.
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Both assets are placed next to each other, in a row, in the center of the document
window. Any imported assets that touch an artboard are placed on that artboard. If a
placed image doesn’t overlap the first artboard, it will be placed on the next artboard to

the right, and so on. Images that don’t overlap an artboard will be placed on the empty
pasteboard.

2. Drag one of the assets down to drag them both away from the artboards.
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3. With the Select tool selected, click in a blank area away from the selected assets to
deselect them. Click the red map artwork to select it.




Note

If the image seems to disappear, it may have been placed on the iPad sized
artboard, and most of it may be hidden. You can drag the image to the left a bit
to get it on the Journal artboard.

4. Right-click the selected map artwork and choose Cut. Right-click in the Countdown
artboard and choose Paste.
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5. Drag the other image you placed, journal_header.png, from its center, into the middle of
the Journal artboard. Make sure the pointer is within the bounds of the Journal artboard
and release the mouse button.
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The image is placed on the Journal artboard and is cropped by the bounds of the
artboard.

Importing assets via drag and drop



Another method for bringing assets into Adobe XD is to drag and drop from the Finder (macOS)
or File Explorer (Windows). This is a great way to insert images into existing frames (as you’ll
see in a later section, “Masking with an image fill”’) or as a more precise placement option.

1.

2.

With the Select tool (M) selected, click in a blank area away from the artboards to
deselect all.

Go to the Finder (macOS) or File Explorer (Windows), open the Lessons > Lesson04 >
images folder, and leave the folder open. Go back to XD. With XD and the folder
showing, click the image named scene_1.png.

Command-click (macOS) or Ctrl-click (Windows) the image named scene_2.png to
select both images. Release the key and drag either of the selected images into XD, just
below the Home artboard.
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Both images are placed next to each other on the pasteboard as a row of images. If you
were to release the mouse button over an artboard, any images that touch the artboard
would be placed on that artboard. Images that don’t overlap an artboard will be placed
on the empty pasteboard.
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Note
If an image seems to disappear, it’s because it was placed on one of the



artboards, and most of it may be hidden. You can drag the image away from the
artboard.

4,

Click in Adobe XD to make it the focus again, if necessary.

Replacing an image

If you need to replace an image in your design, you can do so by dragging an image from your
desktop onto an existing image to replace it. Next, you’ll replace a copy of an image in your

design.

1.

Go to the Finder (macOS) or Windows Explorer (Windows), open the Lessons >
Lesson04 > images folder, and leave the folder open in the Finder window (macOS) or
Windows Explorer (Windows). Go back to XD.

With XD and the folder showing, click the image named home_2.jpg. Drag the image on
top of the home_1.jpg image on the Home artboard. When it shows a blue highlight,
release the mouse button to replace the image.
3

o0 ® images
¢ T o N BT
| Farorines B home_1.pg

#1 home_2.jpg

A | Devices o T o
o Enplore | == journal_header.png
& Y e — = journal.psd
a3, 3 Rl meng.png
ne_2.ip

* red_map.ai
' red_map.svg
& scene_1.png home_2.jpg
B scene_2png

®= screen_header.png

12110018, 748 A0
fified YLIOMB, T:48 AM

‘ ¥ s 163422435
A Tags

The image will fill the shape proportionally and will most likely be masked by the shape
(parts of the new image may be hidden). This may mean that the new image is scaled if
the image you are replacing is larger or smaller than the image you are dragging in.

Tip

You can also Option-drag (macOS) or Alt-drag (Windows) content between
artboards, but you will need to work harder to get it in exactly the same position
as the copy.

3. With the image on the Home artboard selected, press Command+C (macOS) or Ctrl+C

(Windows) to copy it. With the Select tool selected, click in a blank area of the Hike
Detail artboard to make it the active artboard. Press Command+V (macOS) or Ctrl+V

(Windows) to paste it.



Content copied from one artboard to another is pasted in the same position, relative to
the upper-left corner. In Lesson 5, “Organizing Content,” you’ll see how to arrange
content and work with layering to get the new image behind the content you pasted from
the iOS UI kit in Lesson 3, “Creating and Importing Graphics.”

Tip

If you copy and paste using keyboard commands or menu items (macOS) and
you want to paste on a particular artboard, click in a blank area of an artboard
or select it to make it the active artboard before pasting.

Transforming images

Images you import into Adobe XD can be transformed in a variety of ways—from scaling and
rounding corners to rotating and positioning. In this section, you’ll apply a few transformations
to the images you’ve imported so far.

1.
2.
3.

Click the image on the Journal artboard.
Press Command+3 (macOS) or Ctrl+3 (Windows) to zoom in to the selection.
Press Command and — (macOS) or Ctrl and — (Windows) once to zoom out.

Notice the corner widgets (®) in the corners of the image. As with vector shapes you
draw, you can also round the corners on an image or in the Property Inspector. For more
information on rounding corners, refer to the Lesson 3 section “Rounding corners.”

Drag the image to reposition it. Notice that as you drag, if an edge of the image comes
close to an artboard edge, it snaps. As you drag, press the Command (macOS) or Ctrl
(Windows) key to temporarily turn off snapping. Position the image as you see in the
following figure. Release the mouse button and then the key.



Note

If the image doesn’t scale in proportion, make sure the Lock Aspect ( &) option
is selected in the Property Inspector and try scaling it again.

5. Drag the lower-left bounding point of the box around the image up and to the right to
make it smaller. Make sure it’s still a little wider than the artboard.

With the image in place, next you’ll transform another by scaling and rotating.

6. Zoom out, using any method, far enough to see the Recording artboard.

Tip

Pressing the Shift key as you drag to rotate will constrain the rotation to 15
degree increments.

7. Drag across the topographic map artwork on the Recording artboard to select all of it.
Move the pointer just off any corner of the selected artwork. When the rotate arrow (%)
appears, drag counterclockwise to rotate the artwork. When you see approximately —10°
in the rotation angle of the Property Inspector, release the mouse button.



10.

As you rotate, the Rotation value will change in the Property Inspector. You can also
edit the Rotation value in the Property Inspector to rotate an object.

. Shift-drag the lower-right corner away from the center to make it larger, ensuring that

the artwork covers the bottom part of the artboard. Release the mouse button and then
the key.

Press Command+0 (macOS) or Ctrl+0 (Windows) to see everything.

Click the image at the top of the Journal artboard to select it. Change the X value to 0
and press Return or Enter. Leave the Y value (vertical position) as is in the Property
Inspector. Leave the image selected.
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The X (horizontal) value and Y (vertical) value each start at zero (0) in the upper-left
corner of each artboard. Content such as the image, in this case, is positioned from its
upper-left corner relative to the upper-left corner of the artboard. Positioning content

using the X and Y values can help you work more precisely.



Resizing an image in its frame

Images you bring into XD are contained within a frame. When you transform an image frame,
the image is transformed as well. You can also select the image within the frame and transform it
separately. Next, you’ll resize an image within its frame. This can be an easy way to hide parts of
an image you don’t want showing.

1. With the image at the top of the Journal artboard still selected, zoom in to the selected
image by pressing Command+3 (macOS) or Ctrl+3 (Windows) or by using any other
method you’ve learned up to this point.

2. Double-click the image to reveal bounding points around it.

The points you see around the perimeter of the image are used to resize the image within
the frame. Currently you can’t edit the individual anchor points for the shape of the
image frame. The corner radius widgets that you saw previously in the image corners are
now gone. When you edit the image within the frame, you can no longer edit the corner
radius of the corners.

Later in this lesson, you’ll learn about masking an image with a shape. In that case, you
will be able to edit the frame or the image within the frame.

3. Drag the bottom-middle point of the image down to make it larger within the frame.

The bottom part of the image will be hidden when you drag beyond the edge of the
frame it’s in.

4. Press the Esc key to stop resizing the image and show the bounding box of the image
again.



5. Drag the lower-right point of the bounding box toward the center of the image to make it
a bit smaller. Make sure it still covers the width of the artboard.
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6. Press Command+0 (macOS) or Ctrl+0 (Windows) to see everything.

7. Choose File > Save (macOS) or click the menu icon (=) in the upper-left corner of the
application window and choose Save (Windows).

Bringing in content from Photoshop

There are a lot of ways to bring content from Photoshop into XD: copy and paste, export from
Photoshop and import into XD, import a Photoshop file (.psd) (which places the PSD content
into the XD file), open a Photoshop file (.psd) directly in XD (which opens the PSD as a separate
XD file), or place the content in a Creative Cloud Library and drag it into your design from the
Creative Cloud Library panel in XD.

In this section, you’ll use a few different methods to bring content from Photoshop into your
design in Adobe XD.

Note

If you don’t have the latest version of Adobe Photoshop CC installed on your
machine, in Adobe XD you can choose File > Import (macOS) or click the
menu icon (=) in the upper-left corner of the application window and choose
Import (Windows). Navigate to the Lessons > Lesson04 > images folder and
import the screen_header.png image file.

Copying and pasting from Photoshop to XD

To start, you’ll open a Photoshop document in Photoshop and copy content that you will then
paste into your Adobe XD project.

1. Open the latest version of Adobe Photoshop CC.

2. Choose File > Open. Navigate to the Lessons > Lesson04 > images folder, select the file
named journal.psd, and click Open. If the New Library From Document dialog box
appears, click Cancel.



The Photoshop file contains a design with multiple artboards that contains layers of
imagery, text, vector content, and more. Next, you’ll copy image content and paste it
into Adobe XD as a flattened raster image.

3. Choose View > Fit On Screen.

The image at the top of the Journal artboard needs to be copied into your XD project,
without the time and other status bar information currently on top of it. You can make a
selection, select specific layers, and copy what you need or simply copy a selected area
and paste a flattened raster image of that content.

4. Make sure the Layers panel is open. You can choose Window > Layers to see it.

In Photoshop, the Layers panel lists artboards along with layers. They’re marked by
disclosure triangles, as groups are, but they lack the folder icons that groups display.

5. Click the disclosure triangle next to the Journal artboard name (it should be at the top of
the list) to reveal the contents of the artboard. Scroll down in the Layers panel, if
necessary, to see the layer named Journal Header Image. Click to select it.

6. Command-click (macOS) or Ctrl-click (Windows) the layer thumbnail to the left of the
layer name in the panel to make a selection from the layer content.
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7. Choose Edit > Copy to copy the image within the selection marquee.

8. Close Photoshop, without saving if asked. Back in Adobe XD, in the Travel_Design
document, press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the artboards,
if you don’t already.

9. With the Select tool selected, click in the gray pasteboard away from the artboards to
deselect all.

10. With nothing selected, press Command+V (macOS) or Ctrl+V (Windows) to paste the
content into the center of the document window.

Note
Content you paste from Photoshop is a single flattened image in Adobe XD.

11. Drag the image below the Icons artboard.

qQ

12. Choose File > Save (macOS) or click the menu icon (=) in the upper-left corner of the
application window and choose Save (Windows).

Opening a Photoshop file in Adobe XD

You can open Photoshop (.psd) files in Adobe XD, and they will be converted into XD files.
When a Photoshop file is opened in XD, Photoshop elements and effects that can be mapped to
XD’s functionality are available. The rest of the elements either are rasterized or don’t appear in
the XD file. Next, in Adobe XD you’ll open a design started in Photoshop.



1. In Adobe XD, choose File > Open From Your Computer (macOS) or click the menu
icon (=) in the upper-left corner of the application window and choose Open From
Your Computer (Windows). Open the journal.psd document in the Lessons > Lesson04
> images folder.
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The Photoshop document is now an XD document called Journal, that is open in Adobe
XD.

2. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.

Most of the content on the two artboards is still editable in XD, but there are a few
exceptions. For a listing of the supported features when you open Photoshop files in
Adobe XD, see https://helpx.adobe.com/xd/kb/open-photoshop-files-in-xd.html.

3. With the Select tool (M) selected, click the text “Meng” in the Journal artboard.

4. Open the Layers panel by clicking the Layers panel button (#¥) in the lower-left corner
of the application window, if it isn’t already open. In the Layers panel, you’ll see a
folder icon (®a) to the left of the selected content named “Hike info,” which indicates a
group of content. Click the folder icon to reveal everything in it. All of the text is still
editable.

Vara

5. Click the white status bar content at the top of the Journal artboard on the left.

The status bar content has been rasterized and is now a single image. You can tell


https://helpx.adobe.com/xd/kb/open-photoshop-files-in-xd.html

because of the image icon (& ) in the Layers panel to the left of the name. Next, you’ll

copy one of the artboards into your project.

Click in a blank area, away from the artboards, to deselect all. Then click the Journal

ver2 artboard name above the artboard on the right. Press Command+C (macOS) or

Ctrl+C (Windows) to copy the artboard and all of its content.
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7. Choose File > Close (macOS) or click the X in the upper-right corner (Windows) to

close the Journal document, without saving it.

8. Back in the Travel_Design.xd document, press Command+V (macOS) or Ctrl+V

(Windows) to paste the artboard and content to the right of the iPad artboard.

9. Drag the group with the “Meng” text to the Journal artboard and drop it below the

image.



10. To center the content on the Journal artboard, click the Align Center (Horizontally)
button (%) at the top of the Property Inspector. The group is aligned to the horizontal
center of the artboard.
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Note

You can only open Sketch files created using Sketch version 43 or newer. If
you have an older file, save the file using the latest version of Sketch, and then
open the file in XD.

Tip
You can drag images directly from all modern web browsers onto your

artboards. You can also drag the images into an object on an artboard; when
you do so, the image size is automatically adjusted to fit the object.

Bringing in assets from Sketch

You can open a .sketch file directly in XD. You can then edit the file in XD just like any other
XD file, wire interactions, and share as prototypes or design specs.

e You can also select an asset in Sketch, make it exportable as SVG, and drag the content
from the Layers panel into XD.



e You can also copy a Sketch file to the OS clipboard, and use the Paste Appearance
option to paste the image directly as an image fill.

—From XD Help

Masking content

You can easily hide portions of images or shapes (paths) using two different methods of masking
in Adobe XD: mask with shape or image fill. Masks are nondestructive, which means that
nothing that is hidden by the mask is deleted. In either case, you can adjust the mask, if required,
to highlight another portion of the masked content.

Masking with a shape or path

The first method for masking you will learn is masking with a shape. This method of masking
(hiding) portions of artwork or images is similar to masking in a program like Illustrator. The
mask is either a closed path (shape) or an open path (like a path in the shape of an “s,” for

instance). To mask content, the masking object is on top of the object to be masked. Next, you’ll

mask a portion of artwork.

1. Click in the gray pasteboard area to deselect all.

2. In the Layers panel on the left, double-click the artboard icon () to the left of the
Recording artboard to select it and zoom in to it.

3. Click to select the map illustration artwork so you can see all of it.

Tip
Pressing the R key will select the Rectangle tool.

4. Select the Rectangle tool (LJ) in the toolbar. Starting at the top edge of the artwork on
the left edge of the artboard, drag down and to the right corner of the artboard.

5. Press the V key to select the Select tool.
6. With the shape still selected, in the Layers panel, Shift-click the Path and Group objects



to select the map artwork behind the shape.
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7. Choose Object > Mask With Shape (macOS) or right-click and choose Mask With
Shape from the menu that appears (Windows).
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With the Layers panel open and the image still selected on the artboard, you’ll see Mask
Group 1 in the Layers panel list. The mask shape and the object that is masked are now
part of a group.
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Editing a mask

When you mask content, you may later want to crop it in a different way, revealing more or less



of that content. When you mask with a shape, as you did in the previous section, you can easily
edit both the mask and the object masked. Next, you’ll change how the content from the previous
section is masked.

1. With the Select tool (M) selected and the image still selected, double-click the map
artwork to enter mask editing mode. The mask (rectangle) will be selected.

]

Double-clicking a masked object will temporarily show the mask and the masked object
(the map artwork, in this instance) in the window. That way, you can edit either the mask
or the object that is masked.

Note

Any appearance property changes you make to the rectangle shape that is the
mask, like fill or border, will not show when you exit the editing mode.

Tip
In Path Edit mode, you can add, delete, and move anchor points as well as
convert them between smooth and corner (and back) by double-clicking.

2. Click the Different Radius For Each Corner button ( ¢ ) in the Property Inspector on the
right. Change the first two values to 15, pressing Return or Enter after typing in the
second value. Leave the last two values at 0.
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The top two corners of the mask are now slightly rounded. If you wanted to edit the

mask shape further, you could double-click the edge of the mask and enter Path Editing
mode to edit the anchor points.

. In the Layers panel, click the Mask Group 1 icon ( ﬂ) to reveal the content of the mask
group, if you don’t already see it. Click the “path” object and then Shift-click the
“group” object to select both. To keep them together, you will now group them. Right-

click one of the selected objects in the Layers panel list and choose Group to group
them.
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» Note

The numbers you see in the names of objects in the Layers panel (“Path 154,”
for example) may be different, and that’s okay.

. Option+Shift-drag (macOS) or Alt+Shift-drag (Windows) the lower-right handle of the
map artwork down a little to make it larger.

You could transform the masked content in different ways, or you could select the shape
that is the mask (the rectangle, in this case) and reposition or resize it. You can also copy
and paste other content into the mask.



5. Drag the selected artwork into the center of the artboard. Make sure that it fills the mask
shape and covers the lower corners of the artboard.

6. Press the Esc key to exit the mask editing mode. The map artwork is once again masked.

Tip
You can also stop editing the parts of a mask by clicking other artwork in the
document.

Tip

To remove a mask, you could select the mask group and choose Object >
Ungroup Mask (macOS) or right-click the group and choose Ungroup Mask
(Windows). You can also press Shift+Command+G (macOS) or Shift+Ctrl+G
(Windows).

Note

Masked content is cropped like you see on the artboard when the asset is
exported. You’ll learn about exporting in Lesson 11.

7. Press Command+0 (macOS) or Ctrl+0 (Windows) to see everything.
8. Click in a blank area away from the artboards to deselect the masked content.

9. Choose File > Save (macOS) or click the menu icon (=) in the upper-left corner of the
application window and choose Save (Windows).

Masking with an image fill



Another method for masking is to drag and drop an image into an existing shape or path. The
image becomes the fill of the shape. This method of masking is great when adding design
content to a low-fidelity wireframe, for instance. Next, you’ll import a new image for a profile
picture and mask it with a shape.

1. Double-click the artboard icon ( [J) to the left of the artboard name “Journal” in the
Layers panel to fit the artboard in the document window.

Tip
If the circle doesn’t have a width and height of exactly 144, you could set the

Lock Aspect option (&) in the Property Inspector and change either Width or
Height to 144 to change both together.

2. Select the Ellipse tool () in the toolbar. Shift-drag on the Journal artboard to create a
circle. Release the mouse button and then the key when you see a width and height of
approximately 144 in the Property Inspector. As you drag, you’ll notice that the Width
and Height values change by 8 because the circle is snapping to the square grid.
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Note

If you were to deselect the Fill option in the Property Inspector with the shape
selected, the image would be hidden. Also, if you change the fill color for the
shape in the Property Inspector, the image will be removed from the shape.

3. Go to the Finder (macOS) or File Explorer (Windows), open the Lessons > Lesson04 >
images folder, and leave the folder open. Go back to XD. With XD and the folder
showing, find the image named meng.png in the folder, and drag the image on top of the
circle you drew in the Journal artboard. When the circle is highlighted in blue, release
the mouse button to drop the image into the frame.
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By dragging an image onto a shape, the image becomes the fill of the shape.

Editing an image fill mask

Dropping an image into a shape so that it becomes the fill of the shape means the image is
always centered in the shape. Next, you’ll explore the editing capabilities of this type of mask.

Note

Unlike with the Mask With Shape command you used in the previous section,
you cannot edit the anchor points of the shape in this type of mask.

1. With the Select tool (M) selected, double-click the image to enter Path Edit mode. The
image will be selected.

2. Drag a corner of the image to make it larger. Then, drag the image so that more of her
face is in the circle.

3. Press the Esc key to stop editing the image within the circle.
4. Deselect the Border option in the Property Inspector to turn it off.
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5. With the masked image still selected, Shift-drag a corner of the bounding box to make
the image smaller. When Width and Height are 80 in the Property Inspector, release the
mouse button and then the key.
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The image will remain centered in the shape and resizes proportionally to fill the shape.
Unlike images you place, the Lock Aspect option (&) is not selected for masked content
by default. That’s why you held the Shift key down when resizing it.

Note

The Width and Height values may change by different values in the Property
Inspector, depending on the zoom level of the document. If you are zoomed out
far enough, the width and height will change by 8.

Tip

If the circle doesn’t have a width and height of exactly 80, that’s okay. You
could set the Lock Aspect option (& ) in the Property Inspector and change
either Width or Height to 80 to change both together.




6. Drag the image into position, as you see i

n the figure.
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7. Choose File > Save (macOS) or click the menu icon (=) in the upper-left corner of the
application window and choose Save (Windows).

Working with text

When adding text to your design in Adobe XD, you have two main methods to choose from:
adding it at a point or in an area. Text at a point is a horizontal line of text that begins where you
click and expands as you enter characters. Each line of text is independent—the line expands or
shrinks as you edit it but doesn’t wrap to the next line unless you add a paragraph return or a soft
return. Entering text this way is useful for adding a headline or a few words to your artwork.

Text in an area uses the boundaries of an object to control the flow of characters. When text
reaches a boundary, it automatically wraps to fit inside the defined area. Entering text in this way
is useful when you want to create one or more paragraphs. In this section, you’ll explore the
different ways to create text and change the formatting of text.

Adding text at a point

With some design content on the Home artboard in place, next you’ll focus on adding text to it.
Since this new text will be a single line, creating text at a point is the best option, as you’ll soon
see.

Tip
If you move the pointer just off the single anchor point on text at a point, the
pointer will change (¥%). You can then rotate the text.

1. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.

2. Click in a blank area away from the artboards to deselect everything. Double-click the
artboard icon ([J) to the left of the Home artboard to zoom in to it and select the
artboard.



3. To temporarily turn off the square grid, in the Property Inspector, deselect the Square
grid option.

Note

The auto-correct functionality is a part of Spelling and Grammar, which is
turned on by default in Adobe XD. To learn more, see the sidebar “Spelling and
grammar in XD.”

Note

The figures in the lesson were taken on macOS, so you will see Helvetica Neue
being used. The default font for Adobe XD on Windows is Segoe UI.

4. Select the Text tool (1) in the toolbar. Click to the left of the Home artboard and type
field. If you see an auto-correct menu below the text that shows the text “Field,” click
the X to the right to keep the lowercase “field.”

5. Press Return or Enter, and type guide to create text at a point. Once again, to keep the
text lowercase, you may need to click the X to the right of the auto-correct menu that
appears beneath the text.

If you continue to type, the text will continue to the right until you either press
Return/Enter for a paragraph return or press Shift+Return (macOS) or Shift+Enter
(Windows) for a soft return.

6. Press Esc to select the text object.

A single point appears at the bottom of the bounding box around the text. This is one
way to tell that this is text at a point.

7. Drag the point at the bottom of the text object down and up to see the font size change.
Stop dragging when you see a font size of approximately 100 in the Property Inspector.



8. With the text object still selected, click the Fill color box in the Property Inspector.
Change the color to white in the Color Picker that appears.

9. Select the Select tool () and drag the text into the center of the Home artboard.

10. Choose File > Save (macOS) or click the menu icon (=) in the upper-left corner of the
application window and choose Save (Windows).
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Tip

To reshape the text as paths, you can convert text to outlines (shapes) by
selecting the text object and choosing Object > Path > Convert To Path
(macOS) or right-clicking and choosing Path > Convert To Path (Windows).

Tip
You can convert selected text objects between point text (= ) and area text (=)
by clicking the desired option in the Text section of the Property Inspector.

Creating a text area

To create text in an area, you drag with the Text tool (T ). Doing that creates an area to type text
into. After you draw the text area, the cursor appears, and you can type. Next, you’ll create a text
area for body copy that you’ll add to your design.



1. Press the spacebar to access the Hand tool (), and drag in the document window to see
the Hike Detail artboard to the right of the Home artboard. You can also drag on a
trackpad with two fingers to pan in the document window.

2. Select the Text tool (T') in the toolbar, and over the bottom half of the image, drag from
the left edge of the artboard to the right edge to create a text area that is as wide as the
artboard. Type Pine Meadow Lake Loop (without a period).

You may notice that your text doesn’t fit within the text area (but you see it all) since the
formatting is the same as the last text and is rather large. Also, the text is wrapping
within the bounds of the text object.

© Note
The text formatting you see may be different and that’s okay.

3. Select the Select tool () and notice the very small dot in the bottom-middle point of the
box around the text. That dot indicates that there is overset text, or the text doesn’t fit.

To make all of the text visible, you could drag the bottom-middle point down until it all
shows. Since the text is so large, in this case, you will simply change the font size.

4. Double-click the text to select it. You should now see all of the highlighted text.




5. Select the Font Size value in the Property Inspector and type 36. Press Return or Enter to
accept the change. Make sure the text color is white.

6. Press the Esc key to select the text object again and not the text within.

Importing text

Next, you’ll add more text to the design from a text file. This can be a great method for adding
text to your designs from an external source.

1. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.

2. Choose File > Import (macOS) or click the menu icon (=) in the upper-left corner of
the application window and choose Import (Windows). Navigate to the Lessons >
Lesson04 folder and select the file named Hiking.txt. Click Import to place the text in its
own type object on the same artboard.

Tip

You can easily include text in your design by simply dragging a plain text file
onto your artboard. This action creates an area text object with the contents of
the text file. You can also copy and paste text onto the artboard, creating an
area text object that you can easily move and edit in Adobe XD.

Note
If you remove all of the text from a text area, the text area itself will also be

removed.

3. Select the Select tool () and drag the text you just placed down toward the bottom of
the artboard.
You may need to zoom out a little to see the bottom part of the artboard or pan using the
Hand tool (spacebar). You can also drag on a trackpad with two fingers to pan in the
document window.



4. Press Command+3 (macOS) or Ctrl+3 (Windows) to zoom in to the text.

5. Drag the text area close to the left edge of the artboard (see the figure). As you drag, you
should feel it snapping to the square grid on the artboard. Drag until you see 16 for the X
value in the Property Inspector on the right.

6. Drag the middle-right point of the text area to the right to make it wider. Stop dragging
when it’s the same grid distance from the right edge of the artboard as it is from the left
edge.
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7. Click in a blank area of the document window away from content to deselect.

Styling text

In Adobe XD, the text-formatting options are found in the Property Inspector and include
formatting such as type (point or area text), font size, text alignment, and more. In this section,
you’ll get a feel for formatting text in Adobe XD by applying formatting to text.

1. Double-click the artboard icon ([J) to the left of the artboard name “Home” in the
Layers panel to fit the Home artboard in the document window.

2. With the Select tool () selected, click to select the text “field guide.”

Note
The figures in this lesson were taken on macOS, so you will see Helvetica Neue



being used.

» Note

The Font menu in Adobe XD shows all of your system fonts and any synced
Adobe fonts.

3. Make sure that Helvetica Neue (macOS) or Segoe UI (Windows) is selected for the font
in the Property Inspector. Click the arrow next to “Regular” to reveal the Font Weight
menu, and choose Bold.
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For both text at a point and area text, you can change the formatting for all of the text by
simply selecting the type object with the Select tool. If you want to apply different
formatting to different text within text at a point or a text area, you can select text with
the Text tool.

4. To adjust the space between the lines of text, change Line Spacing (=) to 96 in the
Property Inspector. Press Return or Enter.

[ i pesition whan siraling

Line spacing is the space between lines of text and is similar to leading in programs like
Adobe [llustrator.

5. Press the spacebar to access the Hand tool (¥0), and drag in the document window to see
the text on the Hike Detail artboard. You can also drag on a trackpad with two fingers to



pan in the document window.

» Tip
To change values in fields, you can select the value and press the up or down
arrow keys. If you press the Shift+up or down arrow keys, the value changes by
10.

6. With the Select tool () selected, click the text “Pine Meadow Lake Loop.” Make sure
Font Size is 36 and Font Weight is Bold in the Property Inspector. Change Line Spacing
to 40. Press Return or Enter after the last value entered.

= _3

figure.

8. Drag the bottom-middle bounding point up to just below the text.

This is meant to make the frames as small as they can be so that it will be easier to select
a lot of content in a small area.

9. Drag the text to the right so that the X value in the Property Inspector is 16.

¥

10. With the Select tool (M) selected, click in the gray pasteboard to deselect.
11. Select the Text tool ( T'), and click below the Pine Meadow Lake Loop text. Type



DISTANCE, press Return or Enter, and type 3.6 mi.

12. Press Command+A (macOS) or Ctrl+A (Windows) to select all of that text. In the
Property Inspector, change the font size to 10 and the line spacing to 16.

-

13. Double-click the text DISTANCE to select it. Change the character spacing to 100 and
press Return or Enter.

I zoomed in to the text to more easily see it.

14. Drag across the 3.6 mi text to select it. Change the font size to 16. Press Return or Enter.
Press the Esc key to select the text area.
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Duplicating text

One way to reuse text formatting is to copy a text object that has the formatting you want and
change the text. You can also click in text with formatting you want and then create a new text
object and use the formatting from the original text. In this final section, you’ll copy text and
change it.

1. With the Select tool () selected, drag the DISTANCE text object so its left edge aligns

with the Pine Meadow Lake Loop text above it. See the first part of the following figure
for the position.



2. Option-drag (macOS) or Alt-drag (Windows) the DISTANCE text object straight to the
right. When horizontal alignment guides appear, indicating the copy is aligned with the
original, release the mouse button and then the key.

3. Select the Text tool and double-click in the copied DISTANCE text to select it, and type
DURATION to replace the text. Double-click in the copied 3.6 mi text to select it, and
type 3:15 hr to replace the text.

4. Press Esc to select the text object. Select the Select tool (), and Option-drag (macOS)
or Alt-drag (Windows) the DURATION text object straight to the right. This time, you
may see a gap value and a pink bar appear between all three text objects when the gap is
the same value. Release the mouse button and then the key.

You may not see the gap values because the text is snapping to the square grid. If, when
dragging, you don’t see the gap values, you can either zoom in further or turn off the
square grid for the artboard and try dragging again. To turn off the square grid for the
artboard, press Command+’ (macOS) or Ctrl+’ (Windows). After dragging, you can then
turn the grid back on by pressing the same keyboard shortcut.

5. Change the text to ELEVATION 384 ft (see the flgure)

6. Repeat the last two steps to create another copy. Change the text to DIFFICULTY
HARD (see the figure).
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7. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the artboards.
8. Click in a blank area of the document window away from content to deselect.
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9. Choose File > Save (macOS) or click the menu icon (=) in the upper-left corner of the
application window and choose Save (Windows).

Note
If you started with the L.4_start.xd jumpstart file, then keep that file open.

10. If you plan on jumping to the next lesson, you can leave the Travel_Design.xd file open.
Otherwise, choose File > Close (macOS) or click the X in the upper-right corner
(Windows) for each open document.

Spelling and grammar in XD

In Adobe XD, by default, spelling check and grammar check are enabled. You can access
Spelling and Grammar by choosing it from the Edit menu (macOS) or by clicking the menu
icon (=) in the upper-left corner of the application window (Windows).

With Spelling and Grammar enabled, and the cursor in text or text selected, if a word is
miss-spelled, it will have the red underline. You can right-click the word and choose from
alternatives.

Pine Meadow Lake Loop
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With Spelling and Grammar enabled, XD will also auto-correct text you are typing. If you
mis-type a common word, the suggested correction may appear below the word (see the
first part of the following figure). You can click the correction to apply it. If you continue
typing another word or punctuation, for instance, the word will be auto-corrected (see the
second part of the following figure).
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Review questions

1 What are at least three asset types you can import into Adobe XD?

2 Briefly, how do you temporarily disable snapping when dragging an image?

3 How do you replace an image?

4 What are the two methods for masking?

5 What are at least two methods for bringing Photoshop content into Adobe XD?
6 What is the difference between text at a point and area text?

Review answers

1 The types of asset files you can import into Adobe XD are PSD, Al, Sketch, SVG, GIF,
JPEG, PNG, and TIFF.

2 When dragging an image, you can press the Command (macOS) or Ctrl (Windows) key
to temporarily disable snapping.

3 You can drag an image from your desktop onto an existing image to replace it.

4 In Adobe XD, you can easily hide portions of images or shapes (paths) using two
different methods: mask with shape or image fill. Masks are nondestructive, which means
that nothing that is hidden by the mask is deleted.

5 There are several ways to bring content from Photoshop into Adobe XD: copy and paste,
export from Photoshop and import into XD, import a Photoshop file (.PSD) (which
places the .PSD content into the XD file), open a Photoshop file (.PSD) directly in XD
(which opens the .PSD as a separate XD file), or place the content in a Creative Cloud
Library and drag it into your design from the Creative Cloud Library panel in XD.

6 Text at a point begins where you click and expands as you enter characters. Each line of
text is independent—the line expands or shrinks as you edit it but doesn’t wrap to the
next line unless you add a paragraph return or a soft return. Text in an area uses the
boundaries of an object to control the flow of characters. When text reaches a boundary,
it automatically wraps to fit inside the defined area.



5 Organizing Content

Lesson overview

In this lesson, you’ll learn how to do the following:

Arrange content.

Work with the Layers panel.
Create and edit groups.
Align content and artboards.
Position objects precisely.
Set a fixed position.

This lesson takes approximately 45 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the
lesson files and Web Edition.”

Your Account page is also where you’ll find any updates to the lessons or to the lesson
files. Look on the Lesson & Update Files tab to access the most current content.
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Using the Layers panel, you can organize your artboards and control how content is
exported, displayed, organized, selected, and edited. Within each artboard, you’ll use
arranging, grouping, positioning, and aligning to ensure that individual assets are organized
and easy to access.

Starting the lesson

In this lesson, you’ll learn ways to organize the design content in your app design. To start,
you’ll open a final lesson file to get an idea for what you will create in this lesson.

Note

If you have not already downloaded the project files for this lesson to your
computer from your Account page, make sure to do so now. See the “Getting

Started” section at the beginning of the book.

1. Start Adobe XD CC, if it’s not already open.

2. On macOS, choose File > Open From Your Computer. On Windows, click the menu
icon (=) in the upper-left corner of the application window and choose Open From
Your Computer.

For either macOS or Windows, if the Home screen is showing with no files open, click
Your Computer in the Home screen. Open the file named L5_end.xd, which is in the
Lessons > Lesson05 folder that you copied onto your hard disk.

Note
The screen shots for this lesson were taken on macOS. On Windows, the menus
can be accessed by clicking the hamburger menu.

3. If you see a message at the bottom of the application window about missing fonts, click
the X on the right side of the message to close it.

4. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the design content. This
file shows you what you will create by the end of the lesson.



5. Leave the file open for reference, or choose File > Close (macOS) or click the X in the
upper-right corner of the open window (Windows) to close the file.

Arranging objects

As you add content to artboards, each new object goes on top of the previous object. This
ordering of objects, called stacking order, determines how objects are displayed when they
overlap. You can change the stacking order of objects in your artwork at any time, using either
the Layers panel or arrange commands.

In the following figure, the red square was created first, the blue second, and the orange object
last. An arrange command has been applied to the orange object for each example. Arrange
commands (Send To Back, for instance) are found in the Object menu (macOS) or by right-
clicking the object to be arranged (macOS or Windows).

Original stacking order Send To Back Bring Forward Send Backward

The Send To Back command sends selected content behind all other artwork. The Bring To
Front command brings the selected content on top of all other artwork. The Bring Forward and
Send Backward commands bring the object forward one object and backward one object,
respectively. Next, you’ll work with the arrange commands to change the stacking order of
content.

Note

If you are starting from scratch using the jumpstart method described in the
section “Getting Started,” open L5_start.xd from the Lessons > Lesson05



folder.

. Choose File > Open From Your Computer (macOS) or click the menu icon (=) in the
upper-left corner of the application window and choose Open From Y our Computer

(Windows). Open the Travel_Design.xd document from the Lessons folder (or where
you saved it).

. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.

. Zoom in to the image at the top of the Hike Detail artboard using any zoom method,
including Option/Ctrl-scroll wheel, Option-swipe (Magic Mouse), or pinch (trackpad).

Note

As you draw the rectangle, if it’s not snapping to the square grid, you may be
zoomed in too far.

. Select the Rectangle tool ([7]), and in the lower half of the artboard, draw a rectangle that
spans the full width of the artboard. Make sure it has a height of approximately 224 in
the Property Inspector.

Why 2247? Because the rectangle is snapping to the square grid, which is set to a square
size of 8. That means drawn content will snap to the grid in increments of 8.

. Click the Fill color in the Property Inspector and, in the Color Picker that appears,
choose HSB from the color mode menu so you can enter values in Hue, Saturation, and
Brightness. Change the color values to H=180, S=54, B=33, and the A (Alpha or

transparency) to 90 to apply a green color to the rectangle. Press Return or Enter after
the last value is entered.



6. Select the Select tool () in the toolbar.

7. Choose Object > Arrange > Send Backward (macOS), or right-click directly on the
image and choose Send Backward (macOS) or Arrange > Send Backward (Windows).
Leave the rectangle selected.
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The rectangle is sent behind the previously last object created on that artboard, which is
some of the text. In Adobe XD, each artboard has its own stacking order. In the next
section, you’ll explore working with the Layers panel, which offers another way to
arrange and organize content. You’ll also finish arranging the green rectangle.

Working with the Layers panel

The Layers panel in Adobe XD is optimized for UX design. In Adobe XD, we don’t create layers
or sublayers—instead, objects (individual objects, groups, etc.) found on a specific artboard are
listed in the Layers panel. When you select content on an artboard, only the objects that are
associated with the artboard are shown, so your Layers panel stays clean and uncluttered. In
addition to organizing content, the Layers panel lists the artboards found in your document when
nothing is selected, and it offers an easy way to select, hide, and lock content, and much more.

Up to this point you’ve been navigating artboards using the Layers panel. In this section, you’ll
see how the Layers panel can be used for arranging, organization, naming, and selection.

Reordering artboards and layer content



At the beginning of this lesson, you explored stacking order and arranging content. In this
section, you’ll work with the Layers panel to change the ordering of content on artboards and the
ordering of the artboards. Changing the ordering of artboards may be useful for organizing your
designs, whereas changing the ordering of content within an artboard in the Layers panel has the
same effect as using arrange commands. Next, you’ll use the Layers panel to arrange the green
rectangle so it’s where it needs to be in your design.

Note
Your rectangle may have a different name, and that’s okay.

1. With the Select tool (J») selected and the green rectangle still selected, look in the
Layers panel.

] @ % Design
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In the Layers panel, you will see all of the objects that are on the artboard, including the
green rectangle, which is selected in the Layers panel. All of the text that is currently
beneath the green rectangle needs to be on top so you can read it.

Note

You may need to drag the green rectangle so that the text is within the bounds
of the box.

2. Inthe Layers panel, drag the selected rectangle (named Rectangle 60, or whatever yours
is named) down below the bottom text object. When a line appears, release the mouse
button.
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In the Layers panel, every object has an icon to the left of the name, indicating what type
of object it is. For instance, the “T” means text, the image icon (3 ) means image, a pen
icon (£») to the left of an object’s name indicates that it’s vector artwork, and so on.

3. In the document, click in the gray pasteboard to deselect the green rectangle.

Remember, with nothing selected, you can see a listing of all artboards in the Layers
panel.

Tip

There are two ways to select multiple artboards in the Layers panel. If the
artboards you want to select are next to each other in the Layers panel, hold
Shift and click the first and last artboards in the list. To select artboards from
various places in the list, hold Command (macOS) or Ctrl (Windows) while you
click each one.

4. Drag the “Journal ver2” artboard down in the Layers panel list, below the “iPad Pro
12.9in — 1” artboard. When a line appears, release the mouse button. Make sure the
order of the artboards you see matches the figure.
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If you look at the artboards in your design, nothing seems to have changed. As I
mentioned in a previous lesson, that’s because reordering artboards in the Layers panel
affects how the artboards are stacked, if they overlap in the design, but not their position
(X and Y coordinates). I tend to drag artboards into an order that makes sense to me. For



instance, in a design where I include both the app design and the web design, I like to
keep the artboards for the app together and the artboards for the web design together.

Selecting content using the Layers panel

There will be times when you have a lot of content in an area of your design and selection is
more difficult. In that case, you can also make selections using the Layers panel. Next, you’ll
select the text on the Hike Detail artboard in the Layers panel to group all of it together.

1. Double-click the artboard icon ([) to the left of the Hike Detail artboard name in the
Layers panel to center the artboard in the document window and show the content of the
artboard in the Layers panel.

2. Click the DIFFICULTY HARD text object in the Layers panel and Shift-click the Pine
Meadow Lake Loop text object to select all of the text objects on the artboard.
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With the text selected, you could change formatting options like font family, size, and
color.

3. To deselect the paragraph of text toward the bottom of the artboard, Command-click
(macOS) or Ctrl-click (Windows) the text object in the Layers panel whose name starts
with “The Pine Meadow Lake Loop....”
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Now you’ll group the selected text.

4. Right-click one of the selected objects in the Layers panel and choose Group to create a
group of the text.

@0 @ # Desgn Frotoiype

L £ Al Rems w
] Home Expihon
e ST K e L |
8] DERCIATY HARD Y '.""'h%
- ELEVATION 384 it E k‘ 5 4
oumancs  Copy HC
g ostancy  Paste ®v
= aste APpearance TRV
T ™t Duplicate #*D
) Frelied  Dglete &
o "
e T E 8
O, i howma 2 bicke “;
Add Color to Assets oRC
Add Character Style to Assots  OXT
Make Symbol K

Mark for Batch Export

Export Selected... *E

Anytime you group content using the group command or bring in content that is
grouped, the group icon ( pg) in the Layers panel, along with the object name, indicates
that it’s a group. In the section “Working with groups,” later in this lesson, you’ll learn
more about working with groups.

5. Press the Esc key to deselect the group.

With nothing selected, aside from all of the artboards in the document, you should also
see “Pasteboard” in the Layers panel. When you have design content that’s not on an
artboard (it’s on the gray pasteboard instead), “Pasteboard” appears in the Layers panel.

» Note



You can also select content in your document that’s not on an artboard (it’s on
the gray pasteboard) to show the pasteboard content in the Layers panel.

6. Double-click the name Pasteboard in the Layers panel to show the content.
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All of the content that is in the gray pasteboard is now listed in the Layers panel. The
ordering of the Pasteboard content in the Layers panel, by default, follows the order in

which you added that content to the pasteboard. The topmost object in the Layers panel
list is the last object added.

7. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.

Note

Your image may be named something different, and that’s okay. You can also

select the image on the pasteboard to highlight the name of the image in the
Layers panel.

8. Click the image named “scene_2” in the Layers panel to select that content. To cut the

content, so you can paste it on another artboard, press Command+X (macOS) or Ctrl+X
(Windows).
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Selecting content this way is sometimes easier when there is a lot of content in your
document.

9. Click the arrow to the left of the word PASTEBOARD at the top of the Layers panel to
go back and show the listing of artboards again.
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10. Right-click the Explore artboard name and choose Paste to paste the image onto the
artboard. You’ll resize and position the image in a later lesson.
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11. Press the Esc key to deselect the image and show the artboards in the Layers panel
again.

Locking and hiding content



From time to time you may need to lock and hide content to make selecting easier, hide versions,
and more. In this section, you’ll see how to lock and hide content in the document and in the
Layers panel.

1. With the Select tool (J») selected, click the image in the background of the Home
artboard.
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You’ll see the Home artboard content appear in the Layers panel and the home_2 image
selected in the list of layers.

Tip
You can also choose Object > Lock (macOS) or right-click the content and
choose Lock (macOS and Windows) to lock the content.

Tip
You can select a series of objects and lock them all at once using this method.

2. Press Command+L (macOS) or Ctrl+L (Windows) to lock the image.
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A small lock icon appears in the upper-left corner of the image, and its bounding box is
now gray. If you look in the Layers panel, a lock icon appears to the right of the object
name, also indicating that the object is locked. When an object is locked, it cannot be



moved, deleted, or edited. To unlock the image, you can press Command+L (macOS) or
Ctrl+L (Windows) or click the lock icon to the right of the object name in the Layers
panel or in the upper-left corner of the image on the artboard.

Next, you’ll lock and hide content from the Layers panel.
3. Click in a blank area of the document window, away from artboards and content, to
deselect everything.

4. Double-click the artboard icon ([7) to the left of the artboard name Memory in the
Layers panel to view the contents of the artboard.

5. Move the pointer over the Keyboard Alphabetic content in the Layers panel list, and
click the lock icon ( &) to lock the content. Click the Keyboard Alpha object in the
Layers panel to select it on the artboard and you’ll see the lock icon in the corner.
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You should now see a small lock icon in the upper-left corner of the content on the
artboard, and the bounding box is now gray. Next, you’ll hide content.

6. Press the Esc key to see the artboards listed in the Layers panel. Double-click the
artboard icon ([) to the left of the Explore artboard.

Tip
You can also press Command+; (macOS) or Ctrl+; (Windows), choose Object

> Hide (macOS), or click the eye icon (&) in the Layers panel to the right of
the object name to hide the content.

7. Right-click the image on the Explore artboard and choose Hide in the menu that appears.

——
s




When you right-click content, such as an image, you will see a lot of commands that
you’ve already worked with, like the lock and arrange commands. As with locking, you
can also hide content using a variety of methods. If you look in the Layers panel right
now, you will see that the image object name is dimmed and the eye icon (&) is on.

Tip
You can select a series of objects and hide (or show) them all at once using this
method.

8. Move the pointer over the eye icon (&) in the Layers panel and click several times to
show and then temporarily hide the image. Make sure it’s hidden. You will show it
again in a later lesson.
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9. Press the Esc key to see all of the artboards in the Layers panel.

Searching and filtering in the Layers panel

You can search the Layers panel to show only relevant layers and artboards containing the
keyword, or you can filter layers shown in the panel by text, shapes, and image categories. In this
section, you’ll briefly explore filtering and understand why it might be useful.

1. At the top of the Layers panel, click in the search field and type key. As you type, the
list of objects and artboards is filtered. You should see the Keyboard Alphabetic object
you locked in the previous section.

2. Click the lock icon ( &) in the Layers panel to unlock the keyboard.
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3. To clear the Layers panel filtering, click the X to the right of the field at the top of the
Layers panel.
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In addition to searching and filtering the Layers panel list, you can filter what appears
based on object type, such as text objects, images, and so on.

4. Click the arrow to the right of the search field and choose Text. All of the text objects in
the document appear in the Layers panel, grouped according to the artboard they are on.
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You may have noticed that what you typed (“key”) appeared at the bottom of the menu.
Recent search terms are temporarily saved in the filter menu for easy access.

Note



The recent search listing is reset when the file is closed.

5. Click the text object that starts with “The Pine Meadow Lake....” The text object with
the paragraph of text is selected on the Hike Detail artboard.
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6. Change the font size in the Property Inspector to 16 to make the text smaller.

7. Click the arrow to the right of the search field and choose All Items to see all of the
content on the Hike Detail artboard in the Layers panel.

8. Press the Esc key to deselect the text object and see the list of artboards in the Layers

panel.
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9. Choose File > Save (macOS) or click the menu icon (=) in the upper-left corner of the
application window and choose Save (Windows).

Working with groups

Objects in your design can be combined into a group so that those objects are treated as a single
unit. You can then move or transform a group without affecting the attributes of the individual
objects or positions relative to each other. Grouping content can also make selection of artwork
easier later and help you keep your content organized in the Layers panel. Grouping in XD is
similar to other Adobe applications like Illustrator or InDesign, with a few differences.



Creating a group
In this first part, you’ll explore a few ways to create a group of content.

1. Double-click the artboard icon ([) to the left of the Hike Detail name in the Layers
panel to fit the artboard in the document window.

Tip
You can also choose Object > Group (macOS), or right-click the selected
content and choose Group (macOS and Windows), to group the content.

2. With the Select tool () selected, drag across the green rectangle and the Pine Meadow
Lake Loop text group.
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In the Layers panel (where you could have also selected the content), you will see three
objects selected.

Note

Grouping content on different artboards is possible, but the grouped content
will be moved to the topmost or leftmost artboard.

3. Shift-click the image in the background of the same artboard to deselect it.

4. Press Command+G (macOS) or Ctrl+G (Windows) to group the selected content
together.

Note
You’ll learn about exporting assets in Lesson 11, “Exporting and Integration.”

5. Double-click the new group name in the Layers panel. Change the name to Pine



Meadow detail and press Return or Enter.
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You don’t have to rename a group, but doing so can make it easier to find content in the
Layers panel later. Also, when you export assets, the name of the content in the Layers
panel will become the name of the asset.

6. Click the group icon to the left of the Pine Meadow detail name to reveal content of the
group.
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Look in the Layers panel and you will see that the text objects are already grouped (you
can tell because of the group icon [ pa]). By grouping the text group and the green
rectangle, you created a nested group. Next, you’ll add content to an existing group
using the Layers panel.

Tip

If the content within the group is hidden in the Layers panel, the icon looks like
this: pa. If the content of the group is showing in the Layers panel, the group
icon looks like this: .

7. Press the Esc key to deselect the group and show all of the artboards in the Layers panel.
8. Double-click the artboard icon ([) to the left of the Journal name in the Layers panel to



fit the artboard in the window.

In the Layers panel, you should see a group named “Hike info copy,” or something
similar, and the image of Meng.

Tip
You can also group objects using the Layers panel. Select the objects, right-
click, and choose Group.

9. In the Layers panel, drag the Meng image object onto the Hike info copy group name.
When the Hike info copy group shows a highlight, release the mouse to add the image of
Meng to the group. Click the group icon () to collapse the group content, if necessary.
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10. Choose File > Save (macOS) or click the menu icon (=) in the upper-left corner of the
application window and choose Save (Windows).
Editing content within a group

To edit content within a group, you can ungroup the grouped content, select the individual
content by double-clicking the group, or select content within a group from the Layers panel.
Double-clicking a group can save you a lot of time when making edits. Next, you’ll make an edit
to one of the grouped objects.

1. Press the Esc key twice to deselect the Meng image and then the group.

If you are working in your design and want to edit content within a group, you can also
do that right in your design.

2. Double-click the image of Meng on the Journal artboard to select it.



The image should be selected, with a blue border showing around the group that the
image is in. The content for the entire group should be showing in the Layers panel.
3. Click away from the content, in the gray pasteboard, to deselect all.

4. Press Command (macOS) or Ctrl (Windows) and move the pointer over the content in
the group on the artboard.

As you move across the different objects in the group, each will highlight. Whichever
object is highlighted when you click will become selected.

5. With the key still held down, move the pointer over the 11/22/18 text. When you see a
blue highlight around it, click to select the text object.

Journal

That text is now selected, and you could edit the properties in the Property Inspector. By
Command-clicking or Ctrl-clicking, you are able to select any individual object in the

group—even if it’s a nested group. The blue border around the entire group means it is
the parent object of the image.



6. Double-click the 11/22/18 text to select it. Change the text to 11/22/19.

Tip
Pressing Esc once more with the group selected would deselect all.

7. Press the Esc key to stop editing the text and select the text object; then press the Esc
key again to select the entire group.

8. Choose File > Save (macOS) or click the menu icon (=) in the upper-left corner of the
application window and choose Save (Windows).

Aligning content

Adobe XD makes it easy to align or distribute multiple objects relative to each other or to the
artboard, as well as to align artboards to each other. In this section, you’ll explore the different
options for aligning objects.

Aligning objects to the artboard

Aligning objects to the artboard can be useful if, for instance, you need to center-align content.
Next, you’ll align some of the content to the center of an artboard.

1. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content in your
document.

2. Click the Memory artboard name above the artboard in your design, and press
Command+3 (macOS) or Ctrl+3 (Windows) to zoom in.

Note

The name may not be showing if you are zoomed out far enough. Instead, it
may show as three dots (...). If that’s the case, you can either zoom in or
double-click the artboard icon ([7) for the Memory artboard in the Layers panel
with nothing selected.

3. With the Select tool () selected, click the map icon group in the top half of the artboard
to select it. Click the Align Center (Horizontally) option ( £) at the top of the Property
Inspector.
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The group is horizontally aligned to the center of the artboard.

Click in a blank area away from the content to deselect.

Choose File > Save (macOS) or click the menu icon (=) in the upper-left corner of the
application window and choose Save (Windows).

Setting up the icons for alignment

You can also align objects to each other. This can be useful if you need to align a series of
profile images horizontally, for instance. In the next few sections, you’ll align some icons on the
Explore artboard to create a footer. But first, you’ll set up the icons by getting them onto the
correct artboard and finishing them.

1.

2.

Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content in your
document.

Right-click the orange-red rectangle on the Home artboard and choose Copy. Right-
click in the Explore artboard to the right and choose Paste. Drag the copied rectangle so

it snaps to the bottom of the Explore artboard.
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Content you copy and paste from one artboard to another is pasted in the same relative
position as the original artboard.

Press Command and + (macOS) or Ctrl and + (Windows) to zoom in a little.

Make sure you can see the Explore and Icons artboards.

Note

If your icons are larger or smaller than you see in the figure, that’s okay. You’ll
resize them shortly.



4. Drag the map icon, person icon, and double-circle onto the orange-red rectangle on the
Explore artboard. See the figure.
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With the icons roughly in place, next you’ll size them and add a circle behind the person
and map icons. Then you’ll align all of the icons to each other.

5. Zoom in to the icons at the bottom of the Explore artboard.

Now you’ll resize the icons to better fit within the bounds of the orange-red rectangle.

Note

If the height is snapping to larger increments, you can zoom in.

Tip
You can proportionally scale an object to a specific dimension using the
Property Inspector, but the Lock Aspect option (&) needs to be on.

6. Click the map icon. Shift-drag a corner until you see a height of approximately 20 in the
Property Inspector. Release the mouse button and then the key.
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7. Resize the person icon by Shift-dragging so it also has an approximate height of 20.
Select and then Shift-drag the double-circle icon so it has a height of approximately 48.

8. Select the Ellipse tool in the toolbar and draw a circle that has a width and height of
approximately 48.
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9. Deselect the Border option in the Property Inspector to turn off the border.
10. Click the Fill color box in the Property Inspector to open the Color Picker. Ensure that
the fill color is white, and change Alpha (transparency) to 15. Press Return or Enter, and
then press Esc to hide the Color Picker.



11. Select the Select tool () and make sure the circle is still selected. To make a copy of
the circle and paste it right on top of the original, press Command+D (macOS) or
Ctrl+D (Windows).

12. Drag the copy away from the original so you can see both circles.

Next you’ll align one of the circles with the person icon and the other circle with the
map icon.

Aligning objects to each other

When you select more than one object and apply an alignment method, the selected objects align
to each other, not to the artboard. Next, you’ll align the content for each icon and then align the
icons to each other.

1. With the Select tool (J») selected, drag the person icon onto one of the circles you just
created. Shift-click the circle to select both objects. Click the Align Middle (Vertically)
option (4#) and the Align Center (Horizontally) option (&) at the top of the Property

Inspector.
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Alignment in Adobe XD is like it is in most Adobe applications, where aligning to top
aligns all selected objects to the topmost object, aligning to bottom aligns all selected
objects to the bottommost object, and so on.

2. To group the circle and person icon together, press Command+G (macOS) or Ctrl+G



(Windows).

3. Drag the map icon onto the other circle you just created. Shift-click the circle to select

both objects. Click the Align Middle (Vertically) option (4#) and the Align Middle

(Horizontally) option (4£) at the top of the Property Inspector.
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4. To group the selected content together, press Command+G (macOS) or Ctrl+G

(Windows).

5. Drag each of the icons onto the orange-red rectangle as you see in the figure, if they

aren’t there already.
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Distributing the icons

Distributing objects enables you to select multiple objects and distribute the spacing between the
centers of those objects equally. Next, you’ll position and then distribute the icons you were just

working with.

1. Drag the map icon so that the left edge snaps to the square grid and you see an X value

of 24 in the Property Inspector.
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If you zoom in far enough and drag the icon, it will snap to the pixel grid.

2. Drag across the icons and the orange-red rectangle to select them all. Click the Align
Middle (Vertically) option (4#) at the top of the Property Inspector. The icons should
align to the orange-red rectangle.
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3. Click away from the selected artwork to deselect it all.

4. Shift-drag the person icon so that its right edge aligns with the third gridline from the
right. The person icon is now positioned the same distance from the right edge as the
map icon is from the left edge of the artboard.
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5. Drag across the icons and the orange-red rectangle to select them all. Shift-click the
orange-red rectangle to deselect it, leaving the three icons selected.

6. Click the Distribute Horizontally option ([1)) at the top of the Property Inspector.
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Distributing moves all the selected shapes so that the spacing between the centers of
each is equal.

7. Drag across the orange-red rectangle and the icons to select them all. Press

Command+G (macOS) or Ctrl+G (Windows) to group them together.
8. Press the Esc key to deselect the content.

9. Choose File > Save (macOS) or click the menu icon (=) in the upper-left corner of the
application window and choose Save (Windows).

Aligning and distributing artboards

As you work with your artboards, you may wind up dragging them around to better
organize your designs. For instance, you may want to create a user flow in an app with a
series of artboards.

In Adobe XD, you can easily align the artboards and distribute them just as you do objects.
This can be useful for keeping your artboards visually organized. It’s as easy as dragging
across artboards or selecting them in the Layers panel and applying an alignment or
distribution method at the top of the Property Inspector.

Positioning objects

Up to this point in the lessons, you’ve positioned objects without much precision. If precision is
required, Adobe XD has ways to get it done. That includes working with guides for spacing and
alignment, as well as position values in the Property Inspector.

Aligning with temporary guides

To start, you’ll copy and paste an icon from the Icons artboard onto the Home button and use
alignment guides to ensure that the content is aligned properly.

1. Double-click the artboard icon ([) to the left of the Icons artboard to zoom in to it.
2. On the Icons artboard, right-click the small white arrow and choose Copy.



3. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the artboards.

4. Click the orange-red rectangle on the Home artboard and press Command+3 (macOS) or
Ctrl+3 (Windows) to zoom in to it.

5. Right-click the orange-red rectangle and choose Paste.

=

6. Drag the arrow so that it’s centered vertically with the rectangle and on the right side
(see the following figure). A horizontal magenta guide will appear when it’s aligned.
Also, notice the distances to the right and left of the arrow as you drag, telling you how
far from the left and right edges of the artboard the icon is. The distances may be hard to
see because of the orange rectangle color.

7. Shift-click the orange-red rectangle and press Command+G (macOS) or Ctrl+G
(Windows) to group the two selected objects together.

8. Press the Esc key to deselect the group.

Setting gap distances

When you drag to align content, temporary guides appear between objects when the distance
between them is the same. This is referred to as the gap distance. This can be a quick visual way
to ensure that content spacing is even without having to distribute content. In this section, you’ll



position a few icons using temporary guides.

1. Double-click the artboard icon ([) to the left of the Icons artboard to zoom in to it.

2. On the Icons artboard, click the orange-red cloud icon to select it; then Shift-click the
orange-red pin icon to select it as well. Right-click one of them and choose Copy.

ony

3. Press the spacebar to access the Hand tool, and drag in the window so you can see the
Memory artboard. You can also drag on a trackpad with two fingers to pan in the
document window.

4. Click in the Memory artboard and press Command+V (macOS) or Ctrl+V (Windows) to
paste the icons. You may need to drag the icons so they are on the artboard.

5. To zoom in to them, press Command+3 (macOS) or Ctrl+3 (Windows).
6. Click in a blank area to deselect the icons; then click the cloud icon.

7. The icons may have been grouped when you pasted them. If they are a group, right-click
one of them and choose Ungroup.

8. Click away from the icons; then click the cloud icon.

9. In the Property Inspector, make sure the Lock Aspect option (&) is selected. Change
Height to 12. Press Return or Enter.
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10. Click the map pin icon. In the Property Inspector, make sure the Lock Aspect option (&)
is selected and then change Height to 18 in the Property Inspector. Press Return or

Enter.
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11. Drag the cloud icon to the left of the WEATHER text. Then drag the map pin icon to the
left of the LOCATION text. Leave the map pin icon selected.
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Notice that as you drag them into position, temporary alignment guides are not showing.
That’s because the LOCATION and WEATHER text is part of a larger group.

12. In the Layers panel, drag the selected Path object (the map pin icon) on top of the
Memory table group and release the mouse to add it to the group.

Do the same for the cloud icon in the Layers panel.
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13. Zoom in closely to the map pin icon and cloud icon.

Tip
Moving content with the arrow keys also displays alignment guides indicating
when things are aligned.

14. Now, drag the cloud icon on the artboard; when it’s aligned with the triangle icon below
it, a vertical cyan Smart Guide appears. If you then drag it up or down, you’ll eventually
see the magenta gap distance of 6.3.
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If you don’t see the gap distance, you may need to zoom in or out. The closer you zoom
in, the more granular the movement you have when dragging.

15. Zoom in to the map pin icon a little more, and drag the map pin icon so that it’s aligned
with the cloud icon and centered with the LOCATION text.



L

1Y \Al

Once again, you may or may not see the alignment guides indicating alignment with the
LOCATION text, depending on your zoom level.

Viewing distances with temporary guides

Another great feature of temporary guides is the ability to view the distance between selected
content and other objects or the edges of the artboard. This can be used to quickly ensure that
several individual objects are the same distance from some other object, for instance.

1. Press Command and — (macOS) or Ctrl and — (Windows) a few times to zoom out so
you can see more of the artwork around the map pin and cloud icons.

Note
You may need to double-click the LOCATION text to select the text object.

2. Click the LOCATION text to select it. Press the Option key (macOS) or Alt key
(Windows) and move the pointer to a blank area of the artboard.
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You will see four pink lines extending from the edges of the text object, and values that
represent the distance from the corresponding edge of the artboard. This is a quick way
to see how far away from any edge of the artboard the selected object is.

3. While still pressing the Option key (macOS) or Alt key (Windows), move the pointer



over content like the map pin icon.
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You can now see the distance between the LOCATION text and the object that the
pointer is over.

4. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content in your
document.

5. Click in a blank area of the gray pasteboard to deselect the content.

6. Choose File > Save (macOS) or click the menu icon (=) in the upper-left corner of the
application window and choose Save (Windows).

Fixed positioning

The footer you created with the double-circle, map, and person icons is intended to go at the
bottom of the app screen. If you create an artboard that is set up for vertical scrolling, the footer
you create will scroll (move) with the page content. You can set content like the footer to have a
fixed position when a user scrolls vertically in an artboard. Fixed positioned objects can be above
or below other design objects.

Next, you’ll put the footer into place and set it to a fixed position.

1. Zoom in to the Explore and Hike Detail artboards.

2. With the Select tool () selected, drag the footer group from the Explore artboard to the
bottom of the Hike Detail artboard. When it’s aligned with the bottom of the artboards
on either side and a horizontal aqua guide appears, release.
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3. To ensure that it’s aligned to the horizontal center of the artboard, click the Align Center
(Horizontally) option (£).
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You may need to move the Pine Meadow Lake Loop grouped content to better align it

with the footer, as you see in the preceding figure. Now you’ll see what happens when a
user scrolls through the artboard on a device.

4. Click Desktop Preview toward the upper-right corner of the application window.
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5. In the Preview window that opens, drag to scroll vertically.
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You can see that the footer is moving along with the rest of the content. To keep it stuck
at the bottom of the screen, you’ll fix its position.

6. With the footer group still selected, select Fix Position When Scrolling in the Property
Inspector.

Pine Meadow
Lake Loop
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= Note

On Windows, you may need to press Alt+Tab to show the Preview window
after clicking in the document window.

7. Press and drag in the Preview window again to see that the footer is now fixed to the



bottom of the screen and the rest of the content moves beneath it as you scroll.
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8. Click the red close button (macOS) or X (Windows) in the corner of the Preview
window to close it.

9. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content in your
document.

10. Click in a blank area of the gray pasteboard to deselect the content.

11. Choose File > Save (macOS) or click the menu icon (=) in the upper-left corner of the
application window and choose Save (Windows).

» Note
If you started with the L5_start.xd jumpstart file, then keep that file open.

12. If you plan on jumping to the next lesson, you can leave the Travel_Design.xd file open.
Otherwise, choose File > Close (macOS) or click the X in the upper-right corner
(Windows) for each open document.

Review questions

1 What is stacking order?

2 On what layer in the Layers panel do you find content on the pasteboard?
3 What effect does reordering artboards have on your document?

4 How can you edit content within a group without ungrouping?

5 Describe how to show distance measurements between objects when not dragging
content.

6 What is “fixed positioning”?



Review answers

1 Stacking order determines how objects display when they overlap. You can change the
stacking order of objects in your artwork at any time, using either the Layers panel or
arrange commands.

2 When you have design content that’s not on an artboard (that is, it’s on the gray
pasteboard instead), Pasteboard appears in the Layers panel.

3 Reordering artboards in the Layers panel affects how the artboards are stacked in the
design, not their position (X and Y coordinates). Changing the ordering of artboards may
be useful for organizing your designs, whereas changing the ordering of content within an
artboard in the Layers panel has the same effect as using arrange commands.

4 To edit content within a group without ungrouping, select content within the group by
double-clicking the group, select the content from the Layers panel, or Command-click
(macOS) or Ctrl-click (Windows) content within the group.

5 To show distance measurements between objects, with content selected, press the Option
key (macOS) or Alt key (Windows) and position the pointer on other content.

6 Fixed positioning is an option that can be applied to selected content on an artboard. It
allows for content, like a footer, to have a fixed position when a user scrolls vertically in
an artboard. Fixed positioned objects can be above or below other design objects.



6 Working with Assets and CC Libraries

Lesson overview
In this lesson, you’ll learn how to do the following:

e Understand the Assets panel.
Add colors to the Assets panel to reuse and edit.
Save and edit character styles.

Work with symbols.
Work with Creative Cloud Libraries.

This lesson takes approximately 45 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the
lesson files and Web Edition.”

Your Account page is also where you’ll find any updates to the lessons or to the lesson
files. Look on the Lesson & Update Files tab to access the most current content.
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In this lesson, you’ll explore a variety of useful concepts for working smarter and faster in
Adobe XD, including saving colors, character styles, and symbols in the Assets panel.
You’ll also explore the use of Creative Cloud Libraries to make design assets from other
Adobe applications available in Adobe XD.

Starting the lesson

In this lesson, you’ll work smarter by saving content in the Assets panel and working with CC
Libraries. To start, you’ll open a finished lesson file to get an idea of what you will create in this

lesson.

Note

If you have not already downloaded the project files for this lesson to your
computer from your Account page at peachpit.com, make sure to do so now.
See the “Getting Started” section at the beginning of the book.

1. Start Adobe XD CC, if it’s not already open.
2. On macOS, choose File > Open From Your Computer. On Windows, click the menu
icon (=) in the upper-left corner of the application window and choose Open From

Your Computer.
For either macOS or Windows, if the Home screen is showing with no files open, click

Your Computer in the Home screen. Open the file named L6_end.xd, which is in the
Lessons > Lesson06 folder that you copied onto your hard disk.

Note
The Home screen you see may look different. If you’ve opened files previously,
it will look a bit different.

3. If you see a message at the bottom of the application window about missing fonts, you
can click the X on the right side of the message to close it.

4. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the design content. This
file shows you what you will create by the end of the lesson.
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5. Leave the file open for reference, or choose File > Close (macOS) or click the X in the
upper-right corner of the open window (Windows) to close the file.

Managing assets with the Assets panel

You can use the Assets panel to save and manage project assets, including colors, character
styles, and symbols. Saving content in the Assets panel can save you a lot of time. For instance, a
color you save can be edited, and anywhere that color is applied in the document will
automatically update. Each project file has its own set of assets that, as of this writing, cannot be
shared between projects—although you can copy symbols (content like buttons and icons) from
one document to another and a link is created. A symbol is an object that can be reused multiple
times across artboards in a document. You’ll learn more about symbols and symbol linking later
in this lesson.

Note

If you are starting from scratch using the jumpstart method described in the
section “Getting Started,” open L3_start.xd from the Lessons > Lesson03
folder.

Note

A new feature was added as the book was going to press. If you open an XD
document and font(s) used in the document aren’t available on your system, the
missing fonts will appear in the Assets panel. If any of the missing fonts are
Adobe fonts in the Adobe Fonts Library, they are automatically activated and
available on your machine. You can right-click a font in the Assets panel list
and either choose to highlight where it is used or replace it.




1. Choose File > Open From Your Computer (macOS) or click the menu icon (=) in the
upper-left corner of the application window and choose Open From Y our Computer
(Windows). Open the Travel_Design.xd document in the Lessons folder (or wherever
you saved it).

2. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.

3. Click the Assets panel button ([Z]), in the lower-left corner of the application window, to
reveal the Assets panel.
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By default, the Assets panel is empty, but in previous lessons, you copied symbol
content from an iOS UI kit, so those symbols now appear in the Assets panel. If you see
a warning message about linked symbols, you can click OK.

You can add colors, character styles, and symbols to the Assets panel from any kind of
selection, special groups, or multiple selections, or from the entire document by selecting
all artboards. As you go through this section, you’ll learn about each of these types of
assets and see how you can use them to save yourself time and effort later.

Note

The Assets panel button may be blue with a small blue dot in the upper-right
corner. This indicates a modified or missing symbol that is linked to a source
document. You’ll learn more about this in the section “Fixing missing linked
symbols,” later in this lesson.

Tip



You can toggle the Assets panel open and closed by pressing
Command+Shift+Y (macOS) or Ctrl+Shift+Y (Windows).

Saving colors

To begin working with the Assets panel, you’ll save custom colors you’ve created. Saving colors
in the Assets panel is similar to saving colors as swatches in a document in other Adobe
applications, like Adobe Illustrator. Once you save a color in the Assets panel and apply it to
design content, if you edit the color later, any content that the color is applied to is updated.

Note
To save a color in the Assets panel, the color must be applied to content first.

1. With the Assets panel showing on the left side of the application window, press
Command+Y (macOS) or Ctrl+Y (Windows) to show the Layers panel.

2. Double-click the artboard icon ([7) to the left of the artboard name Icons in the Layers
panel to fit the artboard in the document window.

3. With the Select tool () selected, right-click the cloud icon on the Icons artboard and
choose Add Color To Assets from the context menu.
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This is one method for saving any color associated with content in the Assets panel.
Since this icon has a fill color and no border color, only the fill color will be saved as an
asset. If the icon were assigned a border color, that color would also be added to the
Assets panel.

Tip

You can double-click the name of a color when the Assets panel is in List View
(the default view) and change it. You’ll learn about changing views at the end
of this section.




4. Click the Assets panel button ([]), in the lower-left corner of the application window, to
reveal the Assets panel, if it isn’t already, and see the orange-red color saved in the
Colors section.
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Aside from saving an individual color, you can also select a series of objects and save all
of the colors at once.

5. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the design content.
6. Press Command+A (macOS) or Ctrl+A (Windows) to select all of the content in the file.

Note

The list of colors you see in the Assets panel may not match what you see in the
figure, and that’s okay.

7. Click the plus (+) in the Colors section of the Assets panel to save any colors applied to
the selected content.
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As you can see, this method captures any color from the selected content in your design,
including solid color fills, gradients, and fills or gradients with an alpha transparency
applied. Gradients saved are always ordered or sorted last in the list.

8. Press Command+Shift+A (macOS) or Ctrl+Shift+A (Windows) to deselect.

Note
The colors or ordering you see may not be exactly the same and that’s okay.



9. Click the Grid View button ( 22) at the top of the Assets panel, to view the colors in a
grid.

You can view the content in the Assets panel in a list view or grid view.

10. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Editing saved colors

Saving colors in the Assets panel can be useful for a few reasons, including maintaining color
accuracy and consistency and also for saving you time. Next, you’ll see how to edit a color you
saved as a swatch in the Assets panel and see the effect on the design content in your project.

1. Move the pointer over the green swatch with the tooltip #275454 (90%). When you find
that green swatch, click to select it; then right-click it and choose Highlight On Canvas
to see where it’s being used (the rectangle on the Hike Detail artboard).
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Note

To delete a swatch or multiple swatches in the Assets panel, select the swatches
you want to delete, right-click one of them, and choose Delete. Deleting a color
swatch in the Assets panel will not remove the color from the content in the
document.

2. Right-click the green color and choose Edit. Change Alpha (A) to 70%. Press the Esc
key to hide the color picker.
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3. Zoom in to the Journal artboard with the picture of Meng.

4. To select the image of Meng in the group, Command-click (macOS) or Ctrl-click
(Windows) the image.

3

To apply a color in the Assets panel to selected content, you can simply click the color
swatch. The color is applied as a fill by default. To apply a color to selected content, you
can right-click a color in the Assets panel and choose Apply As Border. That’s what
you’ll do next.

5. Right-click the green swatch with the tooltip #275454 (70%) in the Assets panel and
choose Apply As Border to apply the color to the border of the selected image.
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6. Change the border size in the Property Inspector to 3.
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7. Click in a blank area of the pasteboard, away from the image, to deselect and see the
subtle green border on the image.

Saving character styles

Saving text formatting is another way to work more efficiently. In the Assets panel, you can save
text formatting as character styles. Character styles allow you to format text consistently and are
helpful when text attributes need to be updated globally. Once a style is created, you only need to
edit the saved style, and then all text formatted with that style is updated. In this section, you’ll
save text formatting you applied in a previous lesson as a character style to see how they work.

1. Press Command+0 (macOS) or Ctrl+0 (Windows) to see everything.

2. Zoom in to the bottom half of the Hike Detail artboard.

3. Select the Text tool (‘T') and move the pointer above the paragraph of text, aligning it
with the left edge. When a vertical aqua guide appears, drag to make a text area. Type
Pine Meadow Lake Loop.
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4. Press the Esc key to select the text object.
5. Change the font size to 36 in the Property Inspector. Ensure that the font is Helvetica
Neue (macOS) or Segoe UI (Windows) (or similar) and that the font weight is Bold, and
change the Paragraph Spacing to 40.
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6.

Select the Select tool (») and drag a corner of the text box to show all of the text, if
necessary, and so that it wraps like you see in the figure. Then drag it into the position
you see in the figure. Make sure to keep the left edge aligned with the text below it.
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Note

If you are zoomed in far enough to a different part of the artboard, the text will
be pasted in the center of the document window.

7.

8.

Right-click the text object and choose Copy. Right-click anywhere in the Memory
artboard to the right, and choose Paste to paste a copy in the same relative position.
With the text object on the Memory artboard selected, click the orange-red color swatch
with the tooltip that shows #FF491E in the Colors section of the Assets panel to change
the color.
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Double-click the text to select it. Type What kinds of fauna do you see?

The same text formatting (including the color) needs to be applied to the original “Pine
Meadow Lake Loop” text on the Hike Detail artboard. To do so, you can save the
formatting from the text on the Memory artboard as a character style and apply it to the
text on the Hike Detail artboard.



Tip
You can also save formatting from text as a character style by selecting the text
object (not the text).

Note
Character styles don’t save alignment (left align, center, or right align).

Tip
You can double-click the name of a character style when the Assets panel is in
List View (the default view) and change it.

. With the cursor in the text “What kinds of fauna do you see?” or the text object selected,
click the plus (+) in the Character Styles section of the Assets panel.
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The text formatting is captured and saved as a style in the panel. Notice that the style
name shows as the font name. I chose Segoe UI (Windows) for the font, so the style I
see is named Segoe UI. If you chose a different font in the previous steps, your style
name will be different—that’s okay.

. With the Select tool (J») selected, press the Esc key to select the text object and drag a
corner so the text appears on two lines, if the text isn’t fitting.

Tip
Character styles are ordered alphabetically. If you have a lot of styles named
Helvetica Neue, for instance, they are sorted by font size—Ilargest at the top.




12.

13.

Click to select the “Pine Meadow Lake Loop” text in the bottom half of the Hike Detail
artboard. Click the character style named Helvetica Neue (macOS) or Segoe Ul

(Windows), or the character style name you see, to apply the formatting.
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With the Select tool (J») selected, drag a corner if the text isn’t fitting. Then drag it into
the position you see in the previous figure.

If you plan ahead, you can create a series of character styles before you begin your
design or create them from content later, maybe when you need to reuse text formatting.
The character styles, colors, and symbols (you’ll learn about symbols shortly) can also
be used as part of an overall design system or as a starting point for a similar project
later.

Editing character styles

With a character style created, next you’ll edit that style and see how all of the text with the
character style applied changes.

1.
2.
3.

Press Command+Shift+A (macOS) or Ctrl+Shift+A (Windows) to deselect all.
Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the content.

Right-click the character style in the Assets panel and choose Highlight On Canvas to
see where it’s being used.
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To edit a color or character style, you do not need to highlight the content on the canvas.
It’s just a useful way to see what will be affected when you edit the color or character
style.

Note



To delete a character style or multiple character styles, select the styles in the
Assets panel you want to delete, right-click one of them, and choose Delete.
Deleting a character style in the Assets panel will not remove the formatting
from the content in the document.

4. Right-click the style you saved in the Character Styles section of the Assets panel and
choose Edit from the menu that appears.

Tip
When typing a Hex color, you don’t need to add the “#” at the beginning or
type letters in caps.

5. Make sure Hex is chosen the Color Picker and change the color to 466D6D in the menu
that appears. Press Return or Enter to accept the value.

As you edit the character-style formatting, you should see the text in the document
changing. Unfortunately, when it comes to applying color to a character style, you can’t
select a saved color swatch from the Assets panel while editing the character style. You
could, however, select the Eyedropper tool in the editing menu and sample (click) a
color swatch to copy and apply that color to other text.

6. Click away from the menu to close it.
7. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Creating symbols

As you’ve seen, saving colors and character styles is a great time-saver. Being able to save
content, like a button you drew or a block of text you will need to reuse, can also be helpful.
Objects you save in the Assets panel can be saved as symbols. A symbol is an object that can be
reused multiple times across artboards in a document. All instances of a symbol used in your
project are linked, which means any update made to one of those instances is immediately
reflected in all other instances of that symbol. Next, you’ll save button artwork as a symbol.



1. Zoom in to the Home artboard.

2. Select the Text tool ('T") and click the orange-red rectangle to add some text. Type sign
up. Make sure it’s lowercase.

3. Press the Esc key to select the text object.

4. With the text object selected, click the white color swatch with the tool tip #FFFFFF in
the Colors section of the Assets panel to change the color.

O

£ o = B

5. Change the font size to 40 in the Property Inspector. Ensure that the font is Helvetica
Neue (macOS) or Segoe UI (Windows) (or similar) and that the font weight is Bold.
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» Tip

Because the text box may be taller than the text, it can be tricky to align the text
box with the orange-red rectangle.

6. Select the Select tool () and drag the text into the position you see in the figure. Make
sure to keep it visually vertically aligned with the orange-red rectangle shape.

» Tip



You can also save content as a symbol by right-clicking the selected content
and choosing Make Symbol from the menu.

7. Shift-click the orange-red button group to select both the text object and the button.

8. Click the plus (+) in the Symbols section of the Assets panel to save the selected content
as a symbol.
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Notice that after content is saved as a symbol, you’ll see the button content in the
Symbols section of the Assets panel, and the border around the symbol content on the
Home artboard in the document will be a subtle green. The button content on the Home
artboard is now an instance of the button symbol.

Editing symbols

You save content as symbols for several reasons. One is to be able to reuse content easily;
another is to easily update content. Next, you’ll reuse the button symbol on another artboard and
then you’ll edit the symbol to see the change.

Tip
When the Assets panel is displayed in list view, you can drag colors, character
styles, and symbols to reorder them within each section.

1. Click the List View button ( i=) toward the top of the Assets panel. If you scroll down in
the Assets panel, you can see the Symbols section. In list view, you can see the name of
the symbol.




2. Double-click the name of the new orange-red button symbol and type button. Press
Return or Enter to accept the name.

3. If you don’t see the Hike Detail artboard in the document window, you can press
Command and — (macOS) or Ctrl and — (Windows) to zoom out until you see it.

Next, you’ll drag a copy of the button symbol (called an instance) onto the Hike Detail
artboard. First, you’ll arrange some of the content to make room for it.

© Note
If you need to drag the image separately so it looks more like the figure, you
can click in a blank area to deselect and then drag the image.

4. Drag across the image and Pine Meadow Lake Loop text to select it. Make sure not to
select the footer. Drag all of it up a bit, matching the figure.
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» Tip
You can also copy and paste a symbol instance within an artboard or from one
artboard to another.

5. Drag the button symbol from the Symbols section of the Assets panel onto the Hike
Detail artboard.
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6. With the symbol selected, double-click anywhere in the symbol instance on the Hike
Detail artboard to enter symbol editing mode.

The symbol should have a thicker border around it that may be difficult to see.

» Note

Make sure the rectangle is selected; if you were to double-click the “sign up”
text in the previous step, the text would be selected.

7. Click to select the orange-red button rectangle if it’s not already selected. Drag the left
edge of the rectangle to the right to make it a little narrower.
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The other button symbol instance on the Home artboard should change as well. You can
make changes to the style, size, shadow, or position of objects in the symbol and see
these changes reflected in all linked instances.

8. Press the T key to select the Text tool (‘T"). Select the text “sign up” on the Hike Detail
artboard and type start hike.
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You can edit the text within a symbol instance, and the other symbol instances won’t
update. This can be useful if you have a series of buttons with the same appearance but
different text (as in this case).

9. Select the Select tool () and click in a blank area of the pasteboard to deselect; then
click the start hike symbol instance to select it.

» Note

If you do choose Push Overrides, you can press Command+Z (macOS) or
Ctrl+Z (Windows) to undo the command.

10. Right-click the button symbol instance with the “start hike” text and, in the menu that
appears, you’ll see the command Push Overrides. Don’t choose it!
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The Push Overrides option is useful if you want the text in all the button instances to
update.

11. Drag the “start hike” button so its right edge snaps to the right edge of the artboard and
is positioned as you see in the figure.
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12. With the “start hike” button selected, Shift-click the “sign up” button on the Home
artboard to select both. Click the Align Middle (Vertically) button ( §#) to align them to
each other.

13. Click in a blank area away from the artboards to deselect.
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14. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Breaking the link to a symbol

There may be times when you need to make an appearance change to a specific symbol instance.
For instance, with the button symbol you created, maybe you need one of the buttons to be
another color. If you change one of the instances, they all change. Next, you’ll learn how to
break the link to one of the instances so you can edit it without affecting the rest of them.

1. Press Command+Y (macOS) or Ctrl+Y (Windows) to show the Layers panel. Double-
click the artboard icon ([) to the left of the Home artboard to zoom in to it.

2. Command-click (macOS) or Ctrl-click (Windows) the white arrow on the button symbol
to select part of the arrow. Press the Esc key to select the whole arrow group.



3. To copy the arrow, press Command+C (macOS) or Ctrl+C (Windows).

» Note

Clicking in the artboard is important. The arrow group you copied is deselected.
If you don’t click in the artboard, the arrow you paste will be a part of the
original arrow group.

4. Move to the top of the Hike Detail artboard. Click in the Hike Detail artboard and press
Command+V (macOS) or Ctrl+V (Windows) to paste the arrow on the artboard.

5. To save the arrow as a symbol, press Command+K (macOS) or Crtl+K (Windows) and
drag it toward the top of the Hike Detail artboard, as you see in the figure.

Travel_Dosign — Edited ~

6. Copy the symbol instance by pressing Command+C (macOS) or Ctrl+C (Windows).
Press Command and — (macOS) or Ctrl and — (Windows) to zoom out a bit so you can
see the Hike Detail, Recording, and Memory artboards. You may want to press the
spacebar and drag to see them.

7. Click in the Recording artboard and press Command+V (macOS) or Ctrl+V (Windows)
to paste the arrow symbol instance in the same relative position on the artboard. Click in
the Memory artboard and press Command+V (macOS) or Ctrl+V (Windows) to paste
the arrow on that artboard as well.
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Note

You can double-click any of the symbol instances to edit all of them. I chose
the Recording artboard because the arrow is easier to see (white arrow on blue
background).

10.

. Double-click the symbol on the Recording artboard to edit the arrow content. Press

Command+A (macOS) or Ctrl+A (Windows) to select the entire arrow.

. Click the Flip Horizontally button (pi4) in the Property Inspector.
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The arrows on the Hike Detail and Memory artboards also flipped. Unfortunately, the
arrow on the Memory artboard needs to be the orange-red color you saved so you can
see it. If you change the color of the arrow, it will affect the other arrow symbol
instances. To make the arrow on the Memory artboard a different color, you can break
the link to the symbol so you can change anything and it won’t affect the other instances.

Click the symbol instance on the Memory artboard, right-click the button symbol
instance, and choose Ungroup Symbol.
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The content is no longer part of a symbol instance and is completely editable without

those edits affecting the button symbol instances.

11. Click the Assets panel button ([]) in the lower-left corner to see the assets, if it’s not
already open. In the Colors section of the Assets panel, right-click the orange-red color
and choose Apply As Border. The arrow on the Memory artboard now has an orange-red
border.
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12. To group the arrow content together (if it isn’t already), press Command+G (macOS) or

Ctrl+G (Windows).

Linked symbols

In Adobe XD, you can copy a symbol from one source document to other documents. If you
change the original symbol in the source document, symbols you pasted into other documents are
updated because they are linked. Linked symbols allow you to create and maintain a style guide
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or UI kit or simply use that content in other Adobe XD documents.

Tip

You can share a source document with linked symbols. You can invite
designers to edit or consume symbols from the source documents and receive

update notifications when those documents are updated.
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Note

If you move the linked symbol source and the target documents to a new
location, you need to ensure that the source and target documents are within the
same parent folder structure. Otherwise, the links will be broken.

When you modify a linked symbol in the source document, XD shows a notification telling you
that those symbols have been updated. In this section, you’ll see the notification. You can then
preview the changes in the original symbol and choose to accept or reject them.

In this lesson, you’ve been working with local symbols. Local symbols are symbols that reside
within a document. In the next few sections, you’ll explore linked symbols, or saved symbols
copied from a source document to a destination document.

Note

If you see a message at the bottom of the application window about missing
fonts, you can click the X on the right side of the message to close it.

1. Choose File > Open From Your Computer (macOS) or click the menu icon (=) in the
upper-left corner of the application window and choose Open From Y our Computer



(Windows). Click Your Computer in the dialog box that appears. Open the Icons.xd
document in the Lessons > Lesson06 folder.

2. With the Select tool () selected, click to select the text group in the top half of the
artboard. Shift-click the group in the bottom half of the artboard to select both.
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If you look in the Assets panel, you’ll see that both groups were saved as symbols.

Note

If you have multiple XD documents open, to see the Travel_Design.xd
document, choose Window > Travel_Design (macOS) or press Command-+~
(macOS) or Alt+Tab (Windows) to switch to the Travel_ Design.xd document.

Note
If you see a message, referring to linked symbols, you can click OK to close it.

3. With both instances selected, right-click either of them and choose Copy.

4. Choose File > Close (macOS) or click the X in the upper-right corner (Windows) to
close the Icons.xd document.

5. Back in the Travel_Design.xd document, press Command+0 (macOS) or Ctrl+0
(Windows) to see all of the design content; then zoom in to the Explore artboard (the
artboard to the right of Home).

6. Right-click in the artboard and choose Paste. Click in a blank area to deselect; then click
one of the symbol instances you pasted.
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With one of the symbol instances selected, you’ll see a green link icon in the upper-left
corner. This indicates that the symbol instance is linked to another document (the source
document). The green color also indicates that the symbol is up to date, meaning that it
already reflects the latest saved changes to the symbol in the source document.

7. In the Assets panel, scroll down to see the Symbols section, if you don’t already see it.
Make sure the List View option ( i=) is selected toward the top of the panel so you can
see the symbol names.

You should now see symbols named “carousel” and “hike specs” listed in the Assets
panel, along with a gray link icon to the right of each name.
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8. In the Assets panel, move the pointer over the link icon to the right of the “carousel”
symbol name.

In the tooltip that appears, you’ll see “Up-to-date” and the name of the document that the
symbol came from, which is Icons.xd. The link icon for a symbol in the Assets panel
indicates a saved symbol copied from the source document to the destination document.
You’ll learn more about working with linked symbols in the next section.

9. To save the file, press Command+S (macOS) or Ctrl+S (Windows).

Updating linked symbols

When you paste symbols from another document, a link between the original and the copy is
created. You can choose to maintain that link and only edit the original, break the link between



the source document and current document (making the symbol a local symbol), or maintain the
link and apply style overrides to the symbol.

In the next few sections, you’ll explore how to work with linked symbols.

1.

3.

In the Travel_Design document, press Command+0 (macOS) or Ctrl+0 (Windows) to
see all content. Zoom in to the Icons artboard.

Click the orange-red banner icon on the Icons artboard and press Command+C (macOS)
or Ctrl+C (Windows) to copy it.

You’ll add the banner to the hike specs symbol in the Icons.xd document to update it.

e

In the Assets panel, right-click the carousel symbol and choose Edit In Source
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In the menu that showed, there was also a command for deleting the symbol. If you
delete a symbol from the Assets panel, any instances in the document are still there; they
are just no longer linked to a symbol.

#

In the Icons.xd document that opens, double-click the gray box at the top of the carousel
symbol on the artboard to edit the content within. Zoom in to it.

Right-click the content and choose Paste to paste the orange-red banner icon. Drag it
into the position you see in the second part of the following figure. Make it smaller by
Shift-dragging a corner.
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Note

As with local symbols, you can edit text and images in a symbol in the source
document and the symbol will not update in the destination documents. To
force text and image updates from the source symbol to the destination
documents, you can right-click the source symbol and choose Push Overrides.

6. To save the file, press Command+S (macOS) or Ctrl+S (Windows). To close the
Icons.xd file, choose File > Close (macOS) or click the X in the upper-right corner
(Windows).

Back in the Travel_Design document, if you look at the carousel symbol in the Assets
panel, you should now see a blue circle and link icon notification indicating that it has
been modified in the source document and can now be updated in the Travel_Design
document. You may also see a message window appear and an Update button at the
bottom of the Assets panel, and the Assets panel icon in the lower-left corner of the
application windows is now highlighted. All of this indicates that the symbol has been
edited in the source document.

7. To see everything, press Command+0 (macOS) or Ctrl+0 (Windows).

8. Move the pointer over the blue link notification in the Assets panel to see a preview of
the update. Move the pointer away from the notification and the update preview will
stop.
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You may want to zoom in to the Explore artboard to more easily see the change.

Tip
To accept the symbol update, you can also click the blue update icon or right-

click a symbol or multiple selected symbols in the Assets panel list and select
Update from the context menu.

9. Click the Update All (1) button at the bottom of the Assets panel to accept the symbol
update and make the change to the carousel symbol.
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The link icon to the right of the name in the Assets panel is now gray and no longer blue,
indicating that the symbol has been updated.

Overriding linked symbols

While you can edit all of the appearance properties for linked symbols in the source document,
you can only modify the text and bitmap content for linked symbol instances in the destination
document. Next, you’ll edit the text in the carousel in the Travel_Design document.

e Double-click directly on the text “Pine Meadow Lake Loop” on the Explore artboard.
Change it to Shunemunk Sweet Clover Trail.
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The carousel symbol in the source document (Icons.xd) still has the “Pine Meadow Lake
Loop” text, and the destination symbol is still linked to the source symbol. Any
appearance changes you make to the source carousel symbol will still affect the carousel
symbol in the destination document, if you choose to update.

Breaking the link to a symbol



There may be times when you no longer want a symbol in the destination document to update
when that source symbol is changed and the document saved. For instance, the lines in the hike
specs symbol in the source document (Icons.xd) are white. All of the symbol instances in the
Travel_Design.xd document need to be green. The only way to edit the line color in the
Travel_Design document symbol is to convert the destination (linked) symbol to a local symbol.

1. Drag the hike specs symbol instance you pasted onto the Explore artboard to the
Recording artboard.

Since the text in the hike specs symbol instance is white on a white artboard, it may be
challenging to select. You can drag across the area above the carousel symbol instance to
select it.

2. On the Recording artboard, drag the white arrow symbol and the hike specs symbol into
the position you see in the figure. You may need to zoom in to the artboard to align
them.
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3. In the Assets panel, right-click the hike specs symbol. Choose Make Local Symbol from
the context menu that appears.
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The link icon disappears to the right of the hike specs name in the Assets panel and also
on the symbol instance(s) in the document. The symbol in the Travel_Design document
is now a local symbol and will not update if changes are made to the source symbol in
the Icons.xd document.

Fixing missing linked symbols

Now you’ll take the status bar content from the UI kit you copied into the document in Lesson 3
and add it to the top of all the other artboards. First, you’ll explore what happens when a link to a
symbol is broken. In this section, you’ll need to rename the
UlElements+DesignTemplates+Guides-iPhoneX.xd file you saved in the Lessons folder (or
wherever you saved it) at the end of Lesson 3.



1. Zoom in to the Memory artboard.

At the end of Lesson 3, you were asked to download the Apple iOS UI kit and copy the
black and white status bars and keyboard artwork into your Travel_Design document.
You were asked to save the UIElements+DesignTemp lates+Guides-iPhoneX.xd folder
into the Lessons folder.

Next, you’ll rename that folder.

2. Go to the Finder (macOS) or Windows Explorer (Windows) and open the Lessons
folder.

3. On macOS, rename the UIElements + DesignTemplates + Guides-iPhoneX. xd folder
you saved in the Lessons folder back in Lesson 3. The path should be Lessons > Ul
Elements + Design Templates + Guides. If you saved the folder elsewhere, you will
need to rename it in that location.
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4. On Windows, or if you are using the jumpstart file for this lesson (L6_start.xd), open the
Lessons > Lesson03 folder and rename the UI_kit_content XD file to
UIL_kit_content_missing.
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5. With the Select tool () selected, click the black status bar at the top of the Memory
artboard.
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You should now see a red circle with a link icon in the upper-left corner. If you do, this
indicates that a linked symbol is broken. In other words, the source document that the
symbol was copied from cannot be found. In the Symbols section of the Assets panel,
you will most likely see a series of symbols with the red broken link icon.

6. In the Symbols section of the Assets panel, click the top symbol with a red link icon and
Shift-click the last one to select them all. Right-click any of them and choose Make
Local Symbols.

The symbols are now local and are no longer linked to a source document that XD
cannot find. Another option in the menu you saw when you right-clicked was Relink. If
you had the original source document, you could relink to it. If you’d chosen that, the
selected symbols in the Assets panel would update if you made changes to the source
document symbols and saved the file.

7. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Replacing symbols

In Adobe XD, you can also replace symbols in your document, whether they are linked or not.

Tip
Since the symbol instance content is white on a white artboard, it may be tricky
to select. You can always go to the Layers panel (Command+Y [macOS] or

Ctrl+Y [Windows]) and select it there. Remember to show the Assets panel
again (Command+Shift+Y [macOS] or Ctrl+Shift+Y [Windows]).

1. Click the white status bar symbol instance on the Memory artboard and press Delete or
Backspace to remove it.
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Now you’ll select the black status bar and cut and paste that symbol onto several of the
artboards.

2. Click to select the black status bar symbol instance at the top of the Memory artboard.
Press Command+X (macOS) or Ctrl+X (Windows) to cut the symbol instance.

3. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all content.

4. Drag across the Home, Explore, Hike Detail, Countdown, Recording, Memory, and
Journal artboards to select the artboards (not the content on them).
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5. Press Command+V (macOS) or Ctrl+V (Windows) to paste the symbol instance in the
same relative position on all of the selected artboards.
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6. Click away from the content to deselect it all.
7. Zoom in to the Home artboard.

If you look in the Assets panel, you’ll see that there are two symbols named “Status
Bar.” One is the white status bar, the other is the black.

Tip



In the Assets panel, right-click one of the status bar symbols and choose
Highlight On Canvas. If the symbol is highlighted at the top of all of the
artboards, then it’s the black status bar. If not, it’s the white status bar.

8. Click the Grid View button (2z) toward the top of the Assets to see a thumbnail for each
symbol. That might make it easier to tell the difference between the black status bar
symbol and the white status bar symbol.

9. Move the pointer over the white status bar symbol in the Assets panel. A tooltip will
appear that shows the name (Status Bar) and that there are no copies being used in the
document.

a41

Tip
On macOS, you will see a green circle with a white arrow in it next to the
pointer when the pointer is over the symbol instance to be replaced.

10. Drag the white status bar on top of the black status bar on the Home artboard. When the
black status bar instance is highlighted, release the mouse button to replace all instances
of the black status bar with the white status bar.
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Unfortunately, all of the instances in the document are replaced. Currently, you cannot
replace selected instances with another symbol. In this case, a few of the white status
bars will need to be black.

11. Click the white status bar at the top of the Hike Detail artboard and press Delete or
Backspace to remove it. Do the same for the white status bar on the Memory artboard.

12. Drag the black status bar symbol onto the Hike Detail artboard.



13. Drag to align it to the horizontal center and to the same vertical position as the white
status bars on the other artboards.

start hike -

Pine Meadow
Lake Loop

14. To copy and paste the black status bar, so you can keep the same relative positioning,
press Command+C (macOS) or Ctrl+C (Windows) to copy the symbol instance. Right-
click in the Memory artboard and choose Paste.
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15. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Making the footer a symbol

The last symbol you’ll create in this design is to turn the footer group into a symbol and add it to
all of the artboards.

1. If you don’t see the Hike Detail artboard, press the spacebar and drag in the document
window or drag with two fingers on a trackpad.



2. With the Select tool () selected, click the footer group on the Hike Detail artboard (see

the figure).

3. Press Command+K (macOS) or Ctrl+K (Windows) to save it as a symbol.

S NS L

10.

When you convert the group to a symbol, the Fix Position When Scrolling option that
was set on the footer in Lesson 5 is turned off in the Property Inspector.

o

Select the Fix Position When Scrolling option in the Property Inspector.

To copy the new footer symbol, press Command+C (macOS) or Ctrl+C (Windows).
Deselect everything by clicking in a blank area of the gray pasteboard.

Press Command+0 (macOS) or Ctrl+0 (Windows) to see everything.

To show the Layers panel, press Command+Y (macOS) or Ctrl+Y (Windows).
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In the Layers panel, click the Explore artboard name to select it, and while pressing the
Command key (macOS) or Control key (Windows), click the Journal name in the Layers
panel list to select that artboard as well.

To paste the footer on both selected artboards in the same relative position, press
Command+V (macOS) or Ctrl+V (Windows).



Working with Creative Cloud Libraries

Creative Cloud Libraries are an easy way to create and share stored content such as images,
colors, character styles, Adobe Stock assets, and Creative Cloud Market assets between Adobe
applications like XD, Photoshop CC, Illustrator CC, InDesign CC, and certain Adobe mobile

apps.

Note

To use Creative Cloud Libraries, you will need to be signed in with your Adobe
ID and have an Internet connection.

Creative Cloud Libraries connect to your creative profile, putting the creative assets you care
about at your fingertips. When you create content in Illustrator CC or Photoshop CC (this does
not currently apply to content created in Adobe XD) and then save it to a Creative Cloud Library,
that asset is available to use in all of your XD project files. Those assets are automatically synced
and can be shared with anyone with a Creative Cloud account. As your creative team works
across Adobe desktop and mobile apps, your shared library assets are always updated and ready
to use anywhere. In this section, you’ll explore CC Libraries and use them in your project.

Adding Photoshop assets to CC Libraries

The first thing you’ll learn about is how to work with the Creative Cloud Libraries panel in
Adobe XD and use assets from a Creative Cloud Library. Currently you cannot add content to a
CC Library from within Adobe XD. This will most likely change in a future release of Adobe
XD. So for this section, you will open a file in Adobe Photoshop CC and add content to the
Libraries panel, which you can then use in Adobe XD.

Note

If you don’t have Photoshop CC installed on your machine or you don’t have
access to CC Libraries, you can skip to the section “Using CC Library character
styles.”

1. Choose File > Open CC Libraries (macOS), or click the menu icon (=) in the upper-left



corner of the application window and choose Open CC Libraries (Windows), to open the
Creative Cloud Libraries panel.

v a i

When you start working with CC Libraries in Adobe XD, you have one library to work
with, called My Library. You can create other libraries in Adobe applications such as
[lustrator or Photoshop that you can then access in XD; you just can’t currently create
them in XD.

. Open Adobe Photoshop CC.

Note

If you see a Missing Fonts dialog box indicating that you don’t have Helvetica
Neue on your system, you can choose a suggested font (like Segoe UI) and
click Resolve Fonts.

. In Adobe Photoshop, choose File > Open. In the Open dialog box, navigate to the
Lessons > Lesson06 folder, and select the PS_Libraries.psd file on your hard disk. Click
Open.

The file contains two artboards and design content on each.

. Choose Window > Workspace > Essentials (Default), if it’s not already chosen, and then
choose Window > Workspace > Reset Essentials.

. Choose View > Fit On Screen to see the two artboards in the document.

. Choose Window > Libraries to open the Libraries panel, if it isn’t open already.

The Libraries panel in Photoshop shows CC Libraries in the same way that the Creative
Cloud Libraries panel in XD shows them. Toward the top of the panel you’ll see a menu
for choosing a library, and you may see that the library named My Library is chosen.

You can choose a different library you’ve created from that menu. Don’t worry about
which library is chosen, since you’re about to make a new one.

. Click the New Library From Document button (E) at the bottom of the Libraries panel.
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Note

Deselecting Move Smart Objects To Library And Replace With Links ensures
that the Smart Objects are not linked to the graphics saved in the new library.

8. In the New Library From Document dialog box that appears, ensure that Character
Styles, Colors, and Smart Objects are selected. Deselect Move Smart Objects To Library
And Replace With Links, if it isn’t already deselected. Click Create New Library.

New Library from Document

{:@ Creative Cloud

Import Frequently Use

If you look in the Libraries panel, you’ll now see the content from the open file in a new



library named PS_Libraries or similar. The colors, text styles, graphics, and more from
the active document are added to that library in the Libraries panel. Make note of the
library name, since you’ll choose it in the Creative Cloud Libraries panel in Adobe XD.

Note

When you create a new library from a document by clicking the New Library
From Document button, raster images that aren’t Smart Objects aren’t added to
the Library.

Note

The order of graphics in the Libraries panel you see may be different from the
figure, and that’s okay.

10.

Close Photoshop and return to Adobe XD.

Back in Adobe XD, in the Creative Cloud Libraries panel, choose PS_Libraries, or
whatever your library was named in Photoshop, from the menu toward the top to see the
content from the library.
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Note

You may see the message “You Have [X] Unsupported Elements In This
Library.” Any saved objects that are not supported in libraries can’t be used in
Adobe XD.

Note



The character style names you see may be different, depending on your
operating system.

Note

If you see a color profile warning, you can ignore it for now and click Continue
or OK.

Adding Ilustrator assets to CC Libraries

Now you’ll open Illustrator CC and add vector artwork to the same library that you can then use
in XD.

1. Open Adobe Illustrator CC.

Note

If you see a Missing Fonts dialog box indicating that you don’t have Helvetica
Neue on your system, you can choose a suggested font and click Resolve Fonts.

2. In Adobe Illustrator, choose File > Open. In the Open dialog box, navigate to the
Lessons > Lesson06 folder, and select the AI_Libraries.ai file on your hard disk. Click
Open.

The file contains a few elements for the login screen of your app design in XD.

3. Choose Window > Workspace > Essentials, if it’s not already chosen, and then choose
Window > Workspace > Reset Essentials.

4. Choose View > Fit All In Window to see the two artboards in the document.

Note

If you see a color profile warning, you can ignore it for now and click Continue
or OK.

5. Choose Window > Libraries to open the Libraries panel, if it isn’t open already. Choose
PS_Libraries, or the library name you chose in Photoshop when you created it, from the
Library menu.

PS_Libraries is the library that was created in Photoshop. Next, you’ll drag the map
artwork from Illustrator into the library. You’ll already see a map in the library, but the



map from Illustrator has a few differences and will be the map you use in XD.

6. Select the Selection tool (J») in the toolbar on the left. Drag the large map into the
Libraries panel. When a plus sign (+) appears in the panel, release to add the artwork to
the library.

7. Drag each of the icons from the artboard, one at a time, into the Libraries panel to save
them.

8. Choose File > Close, without saving, and leave Illustrator open.
9. Return to Adobe XD.

Using CC Library character styles

You can now use the CC Library assets in your Adobe XD projects. In this section, you’ll apply
the character-style text formatting from the Creative Cloud Library you created in Photoshop.

1. Back in XD, zoom in to the Memory and Journal artboards.

2. Select the Text tool (‘T') and click in the top part of the Memory artboard. Type record
a memory; then press the Esc key to select the text object. The text you see may have
different formatting, and that’s okay.
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Note

If a font from a character style is not present on the local computer, a warning
icon is displayed to the right of the character style in the Creative Cloud
Libraries panel.

Note

If you didn’t have Photoshop CC installed on your machine or you don’t have
access to CC Libraries, you can select the type object and change the formatting
in the Property Inspector to Helvetica Neue (or similar), font size to 24, and
font weight to Bold. Then you may proceed with the following steps.

3. Click the style with the orange, Helvetica Neue (macOS) or Segoe UI (Windows)(or
other font), Bold (or other), 24pt font in the Creative Cloud Libraries panel to apply the
styling to the text.
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When you apply a character style from a CC Library, it’s not added to the Assets panel
as a style in the current document. Also, you cannot edit the style found in the Creative
Cloud Libraries panel in Adobe XD.

Note

In the next few sections, on Windows, you may need to press Alt+Tab to show
the Creative Cloud Libraries panel again.

4. Select the Select tool () and drag the text object into position as you see in the figure.
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5. Option-drag (macOS) or Alt-drag (Windows) the text object to the Journal artboard to
the right, below the Meng group of text. Release the mouse button and then the key.
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6. Press T to select the Text tool. Click in the copied “record a memory” text to select it.
Type my hikes. Press Esc to select the text object again.

7. Press the V key to select the Select tool (). Click the style with the white, Helvetica
Neue font (or other), Bold (or other), 24pt font in the Creative Cloud Libraries panel to
apply the styling to the text.
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Using graphics from a CC Library

Graphics stored in a CC Library can be dragged into an open XD document. Raster graphics
(images) and vector graphics are currently supported in CC Libraries in XD. Graphics you drag
into XD from a library are linked to the original source in the library. If you update the image in
Photoshop or vector graphic in Illustrator, for instance, it will be updated in your XD document.
Next, you’ll drag the image from the Creative Cloud Libraries panel into the document, replacing
the current image on the Journal artboard.

Note



In Adobe XD, you cannot drag a graphic from the Creative Cloud Libraries
panel onto a locked image to replace it.

. With the Select tool (J») selected, click the image at the top of the Journal artboard to
select it.

. Drag the image from the Graphics section of the Creative Cloud Libraries panel on top
of the image at the top of the Journal artboard to replace the image.

-

-l -

memery

by W Ta 1w
73* Cleudy
0
i3

Of

The image on the Journal artboard should now have a green border and show a link icon
in the upper- left corner. The image is linked to the image in the library. That means that
if you edit the image in another application, such as Photoshop, the image on the Journal
artboard will update. If you want, you can unlink the image, essentially embedding it in
the XD document, by clicking the green link icon at the upper-left corner of the asset.
You can also right-click the image and choose Unlink Graphic.

There are a few ways to embed a linked graphic from a library—clicking the link is one,
and another is embedding the graphic as you drag it in. Option-dragging (macOS) or Alt-
dragging (Windows) a graphic from the Creative Cloud Libraries panel will insert the
graphic as an unlinked (embedded) asset.

Note

It may take a little time for the graphics to appear on the artboard.




Tip

You can select multiple objects in the Creative Cloud Libraries panel with the
Shift key or Command key (macOS)/Ctrl key (Windows). You can then drag all
of the selected objects into XD at one time.

3. Drag the Record button icon, the stop button icon, and the map route trace artwork from
the Creative Cloud Libraries panel onto the Recording artboard and arrange them as you
see in the figure.
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4. Drag the map graphic, the one you saved from Illustrator, from the Graphics section of
the Creative Cloud Libraries panel into an empty area of the Hike Detail artboard.
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5. Right-click the map and choose Send To Back (macOS) or Arrange > Send To Back
(Windows). Position it, and the other content, as you see in the figure.

Pine Meadow
Lake Loop

Editing library items

You can edit vector artwork and raster images in a Creative Cloud Library from within XD. You
can also edit raster and vector graphics stored in Creative Cloud Libraries. Right-click a graphic
in the Creative Cloud Libraries or on the canvas and click Edit. Raster graphics open in
Photoshop and vector graphics open in Illustrator.

After you make changes to a graphic, save it. The graphic is updated in the Creative Cloud
Library, and the thumbnail in the Creative Cloud Libraries panel in XD is automatically
refreshed. The graphic on the canvas is also refreshed with your changes.

1. Click the stop button thumbnail in the Graphics section of the Creative Cloud Libraries
panel to select it, then right-click the same thumbnail and choose Edit.

2. When the asset opens in Illustrator, click the artwork to change the fill color.

3. Choose Window > Properties to open the Properties panel.

Creative Cloud Uibraries D =
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4. In the Properties panel on the right, click the Fill color, and in the menu that appears,
click the Swatches button (), and click a gray color to change the fill of the shape.



5. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

6. Close Illustrator by choosing Illustrator CC > Quit Illustrator (macOS) or File > Exit
(Windows).

7. Switch back to Adobe XD, and after the graphic has synced, you’ll see it has updated on
the Recording artboard.

8. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

» Note
If you started with the L6_start.xd jumpstart file, then keep that file open.

9. If you plan on jumping to the next lesson, you can leave the Travel_Design.xd file open.
Otherwise, choose File > Close (macOS) or click the X in the upper-right corner
(Windows) for each open document.
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Review questions

1 What types of assets can be saved in the Assets panel?
2 How do you edit a character style in the Assets panel?
3 How do you create a symbol?

4 What property changes made to a symbol instance will reflect in all instances of that
same symbol?

5 What is a Creative Cloud Library?
6 What types of assets can a Creative Cloud Library contain?

Review answers

1 You can use the Assets panel to save and manage colors, character styles, and symbols.

2 To edit a character style in the Assets panel, right-click the character style and choose
Edit. Make edits to the style in the panel that appears, and the text formatting will
automatically update wherever the style has been used.

3 To create a symbol, you will select content in a document and then perform one of the
following actions: click the plus (+) in the Symbols section of the Assets panel, right-
click the content and choose Make Symbol, or press Command+K (macOS) or Ctrl+K
(Windows).

4 You can change style, size, shadow, and/or position in a symbol instance and see those
changes reflected in all linked instances.

5 Creative Cloud Libraries are an easy way to create and share stored content such as
images, colors, text styles, and more between Adobe applications like XD, Photoshop
CC, Ilustrator CC, InDesign CC, and certain Adobe mobile apps.

6 A Creative Cloud Library can contain assets such as colors, text styles, graphics, text
frames, and more. Currently, in Adobe XD you can use colors, character styles, vector
artwork, and raster (image) graphics.



7 Using Effects, Repeat Grids, and Responsive Resize

Lesson overview
In this lesson, you’ll learn how to do the following:

e Understand effects.
Work with background and object blur.
Work with gradients and transparency.

Create and edit repeat grids.

Understand responsive resizing.

This lesson takes approximately 45 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the
lesson files and Web Edition.”

Your Account page is also where you’ll find any updates to the lessons or to the lesson
files. Look on the Lesson & Update Files tab to access the most current content.
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Adobe XD offers a variety of effects that can add both functionality and pop to your
designs, including drop shadows, transparency, and blurs. In this lesson, you’ll explore
those design features, learn about repeat grids—a feature that is sure to save you time when
designing, and explore responsive resize.

Starting the lesson

In this lesson, you’ll explore adding effects like drop shadows to your designs, you’ll apply
gradients, and you’ll work with repeat grids and responsive resize. To start, you’ll open a final
lesson file to get an idea of what you will create in this lesson.

Note

If you have not already downloaded the project files for this lesson to your
computer from your Account page, make sure to do so now. See the “Getting
Started” section at the beginning of the book.

1. Start Adobe XD CC, if it’s not already open.

2. On macOS, choose File > Open From Your Computer. On Windows, click the menu
icon (=) in the upper-left corner of the application window and choose Open From
Your Computer.

For either macOS or Windows, if the Home screen is showing with no files open, click
Your Computer in the Home screen. Open the file named L7_end.xd, which is in the
Lessons > Lesson07 folder that you copied onto your hard disk.

Note
The screen shots for this lesson were taken on macOS. On Windows, the menus
can be accessed by clicking the hamburger menu.

3. If you see a message at the bottom of the application window about missing fonts, you
can click the X on the right side of the message to close it.

4. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the design content. This
file shows you what you will create by the end of the lesson.



5. Leave the file open for reference, or choose File > Close (macOS) or click the X in the
upper-right corner of the open window (Windows) to close the file.

Applying and editing gradients

A gradient fill is a graduated blend of two or more colors, and it always includes a starting color
and an ending color. In Adobe XD, you can create a linear gradient (the beginning color blends
into the ending color along a straight line) or a radial gradient (the beginning color defines the
center point’s fill color, which radiates outward to the ending color).

Tip
You can import objects with gradients from other applications, such as Adobe
[lustrator. You can then edit the colors in the gradients within Adobe XD.
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In the Color Picker for the fill, you can choose the type of gradient you want from the menu at
the top of the Color Picker. The gradient editor (labeled B in the figure) appears. The leftmost
gradient stop (labeled A) marks the starting color; the rightmost gradient stop marks the ending
color (labeled C). A color stop is the point at which a gradient changes from one color to the
next. You can add more color stops by clicking below the gradient editor and changing the color



within the Color Picker.

Applying gradients

In this section, you’ll explore the options for creating gradients and apply a gradient to several
shapes in the design, starting with the Home artboard.

Note

If you are starting from scratch using the jumpstart method described in the
section “Getting Started,” open L7_start.xd from the Lessons > Lesson07
folder.

1. Choose File > Open From Your Computer (macOS) or click the menu icon (=) in the
upper-left corner of the application window and choose Open From Y our Computer
(Windows). Open the Travel_Design.xd document from the Lessons folder (or where
you saved it)

2. Zoom in to the Home artboard using any zoom method. Make sure you can see the
entire artboard.

3. Select the Rectangle tool ([J) in the toolbar. Starting in the upper-left corner of the
Home artboard, drag to the lower-right corner of the artboard to create a rectangle that
covers the artboard.

g

4. With the rectangle selected, click the Fill color box in the Property Inspector to show the
Color Picker. Click Solid Color at the top of the Color Picker and choose Linear
Gradient from the menu that appears.
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By default, a white-to-gray gradient is now applied to the fill of the shape. Notice the bar
that appears on the shape (an arrow is pointing to it in the following figure). This is
called the on-canvas gradient editor, and it helps you change the direction and duration

of the gradient.

» Note
You can tell when a color stop is selected because it has a thicker border, like

this: [=.

5. Click to select the leftmost color stop on the gradient editor (circled in the following
figure). Drag in the color spectrum bar to select any red. You’ll change this color later,
so it doesn’t have to be an exact match to what you see in the figure.
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6. Click to select the rightmost color stop on the gradient slider (circled in the following
figure). Make sure HSB is chosen from the color mode menu and change the HSB color
values to a blue: H=205, S=88, B=35, A=80. Press Return or Enter after the last value is

entered.
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7. Deselect the Border option in the Property Inspector to remove it.

8. To open the Layers panel if it isn’t open, press Command+Y (macOS) or Ctrl+Y
(Windows). In the Layers panel, drag the selected rectangle down so it’s on top of the
image but beneath everything else.
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Next, you’ll save the gradient color so that you can easily edit it across more than one
object.

9. Right-click the rectangle in the artboard and choose Add Color To Assets.

The gradient color is now saved in the Assets panel and can be used elsewhere.
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To see the gradient color in the Assets panel, if the panel is already open, you
can right-click an object and choose Reveal Color In Assets.

10.

11.

12.

13.

1.

To show the Assets panel, press Command+Shift+Y (macOS) or Ctrl+Shift+Y

(Windows). You may need to scroll in the Assets panel. The gradient color should be
highlighted in the panel.

With the rectangle still selected on the Home artboard, copy it by pressing Command+C
(macOS) or Ctrl+C (Windows), right-click in the Explore artboard to the right, and
choose Paste.

Right-click the rectangle copy on the Explore artboard and choose Send To Back
(macOS) or Arrange > Send To Back (Windows) so it’s behind all of the other content.
Leave the rectangle selected.

m

Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Editing gradient colors

Gradients can have more than the default two colors and can be adjusted directly on the artwork
to give you more control over their appearance. In this section, you’ll edit the linear gradient you
just created and saved in the Assets panel.

In the Assets panel, right-click the gradient you saved in the previous section and choose



Edit.

[ ] @ & Design

| 2 Al A
O
e |
i b |
""""" Highlick: on Canvas
&2 . Rename
T Apply
r 3 (7
m]
Q
eoe A

Linsar Gradient

3 b @—

. Homa
C J’-!-"_'-E.': I
© | o
7 | 55 '
P %
_§ E

|1 HEB + 180 54 33 90% I‘

"

Character Styles

o O =

2. Click to select the leftmost (red) color stop on the gradient slider (circled in the figure).
Make sure that HSB is chosen from the color mode menu and change the HSB color
values to this green: H=180, S=54, B=33, A=90. Press Return or Enter after the last
value is entered.

3. Move the pointer over the middle of the Gradient slider and click to add another color
stop. Change the new color to a red.
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4. Drag the new red color stop on the Gradient slider to the left and then to the right and
watch what happens to the gradient in the shape.

5. To remove the new red color, drag it away from the slider. There should be only two
colors in the gradient again.
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Dragging a color stop along the slider changes the duration of the gradient (the distance
it takes for one color to transition to another).

Tip
When editing on-canvas, to remove a color stop you can also click to select it
and press Delete or Backspace.

6. Click away from the color picker to hide it.

Adjusting the direction and length of a gradient

Not only can you adjust the colors in the Color Picker, but you can also adjust them on the art
using the on-canvas gradient editor, which is what you’ll do next. Note that edits to the gradient
made on the art affect only the selected object.

1. With the gradient-filled rectangle on the Explore artboard still selected, select the Select
tool (), and then Shift-click the rectangle on the Home artboard to select it as well.

Adjusting the direction and length of a gradient can only be done to selected objects.
You want the gradients on these artboards to look the same, which is why you selected
both.

2. Click the Fill color in the Property Inspector.

You should now see the on-canvas gradient editor on the rectangle on the Explore
artboard. When you select multiple shapes, the on-canvas gradient editor appears on the
first selected shape.

Note

The on-canvas gradient editor will not appear unless the Color Picker is
showing in the Property Inspector.




Tip

You can move the end of the on-canvas gradient editor segment by using the
arrow keys. You can move an inner color stop along the segment by using the
arrow keys as well.

3. Drag the bottom color stop of the on-canvas gradient editor up to make the gradient
shorter within the shape.
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You can change the direction and length of the gradient by dragging the color stops, so
try exploring a bit. If you do explore, your gradient may not look like you see in the
figures going forward, and that’s okay.

Tip
When editing on-canvas, you can also press Tab to select and change color
stops along the on-canvas gradient editor.

Tip
If you move the pointer over the Gradient slider on the art, a plus (+) will
appear next to the pointer, indicating that if you click, you will add a color stop.

4. Click the top color stop (circled in the following figure) and change the alpha (A) in the
Color Picker (to the right) to 80.
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5. Press the Escape key to hide the Color Picker; then press Command+S (macOS) or
Ctrl+S (Windows) to save.

Understanding effects

In Adobe XD there are several types of effects we can apply to content, including drop shadows,
transparency, and blur effects. Drop shadows can be used to show depth, transparency can be
used for design effect and overlays, and blur effects can be used to show focus for overlays, for
instance.

In this section, you’ll add a few of these effects to your design.

Working with background blur

Background blur uses an object as an overlay (the orange rectangle in the figure) to blur content
that is behind (the image of the surfer). Most of the time, the overlay object that is used to blur
content is a shape, and the color fill and border of the shape have no effect on the result.

Next, you’ll apply a background blur to existing content.

Note
You currently cannot apply a blur to a group.




1. Zoom in to the Hike Detail artboard using any method you’ve learned.

2. Select the Select tool (). Command-click (macOS) or Ctrl-click (Windows) the green
rectangle behind the Pine Meadow Lake Loop text to select it.
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Since the rectangle is part of a group, Command/Ctrl-clicking will select just that object
within the group.

3. Make sure the Border option is deselected to remove the border if there is one.

4. Select the Background Blur option in the Property Inspector, and change the following
options:
e Blur Amount ( 4): 7
e Brightness (-#:): —=30
e Effect Opacity ([7): 50
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Notice that the color of the overlay shape is reduced and any content that it overlays (the
image) is blurred. Feel free to adjust the background blur settings to get a better feel for
how it works.

5. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Working with object blur

Object blur is a method for blurring content such as a shape or an image. You can use object blur
to indicate things like a state for a button or a hero image on a web page with overlay text, or
maybe to move the focus to content above the blurred object, like a small pop-up form. Unlike
with background blur, you simply select the content to be blurred. Next, you’ll blur artwork on
the Recording artboard.

1. Press Command+0 (macOS) or Ctrl+0 (Windows) to fit all design content in the
document window.
2. Zoom in to the Recording artboard.

3. Click the icon you dragged from the Creative Cloud Library panel in Lesson 6,
“Working with Assets and CC Libraries.” See the figure for which to select.

The selected graphic has a green link icon in the upper-left corner because it’s linked to
the graphic in a Creative Cloud Library.

4. Click the link icon to unlink and embed the icon. You can now edit the individual
objects in the group.



5. Command-click (macOS) or Ctrl-click (Windows) the larger, light-colored orange circle
in the icon. See the figure for which part to select.

Tip

You can also change the opacity of selected content by simply selecting content
and typing numbers: 1=10%, 5=50%, and so on. Typing 0 sets the opacity to
100%.

6. Click the Background Blur option and choose Object Blur from the menu to turn it on.
Change Blur Amount ( 4) to 10.

7. Change Opacity to 60 in the Property Inspector by dragging the slider.
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Adjusting the opacity of objects is a great way to layer effects, make text readable on an
image, and much more.



8. Click away in a blank area to deselect all.
9. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Applying a drop shadow

Drop shadows are another effect that can add a nice design touch to content, give a sense of
depth, indicate the state of a button, and much more. In this section, you’ll see how to add a drop
shadow to an image. First, you’ll add more content to the Journal artboard.

1. Press Command+0 (macOS) or Ctrl+0 (Windows) to fit all design content in the
document window. Zoom in to the Journal ver2 artboard on the far right.

2. With the Select tool () selected, drag across the content on the Journal ver2 artboard
you see in the first part of the following figure—making sure not to select the orange
footer. Shift-click the “my hikes” text and the blue background shape to deselect them.

3. Press Command+C (macOS) or Ctrl+C (Windows) to copy the content. Right-click in
the Journal artboard and choose Paste.

4. Press Command+3 (macOS) or Ctrl+3 (Windows) to zoom in to the selected content.

5. Drag the content so it’s horizontally centered on the artboard and the search eyeglass
icon is aligned with the “my hikes” text.
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6. Right-click the content and choose Send To Back (macOS) or Arrange > Send To Back



(Windows) so that it’s behind the footer symbol.
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For the next step, you’ll most likely need to zoom out or pan in the window.

7. Click in the gray pasteboard area to deselect, and then Command-click (macOS) or Ctrl-

click (Windows) the image of Meng in the group toward the top of the same Journal
artboard.
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8. Select the Shadow option in the Property Inspector and change the following options:
e X (Distance along the X axis [horizontal]): 0

e Y (Distance along the Y axis [vertical]): 0
e B (Blur of the shadow): 10
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9. Click the Shadow color box, and with black selected, change the alpha (A) to 70. Press
Return or Enter to accept the new value, if you typed it in.
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10. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Using repeat grids

When designing for mobile apps or websites, you may create repeating elements or lists, such as
a series of employee profiles or a list of entrées available at a restaurant. The repeating elements
share a common design and general elements, but the images and text may be different. It can be
cumbersome to create a grid of elements, especially when you need to easily adjust the spacing
between them or rearrange common elements.
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An example of a repeat grid

In Adobe XD, you can select an object or group of objects and apply a repeat grid to easily
repeat the content. With a repeat grid applied to content, you can simply pull a handle at the
bottom or right side of the content, and the content repeats in the direction you pull. When you
modify any style of an element, the change is replicated in all elements of the grid. For example,
if you round the corners of an image in one of the elements, the corners of all images in the grid
are affected.

If you have a text element in the grid, only the style of the text element is replicated and not the



content. So you can style text elements quickly while keeping the content different in the grid
elements. You can replace placeholder text in a repeat grid by dragging a text file onto the grid.
The repeat grid in Adobe XD has to be my favorite feature.

Adding content for a repeat grid

Next, you’ll add some content and set up your document so that you can create a repeat grid.

1. Press Command+0 (macOS) or Ctrl+0 (Windows) to zoom out.

2. With the Explore artboard showing, drag the symbol instance that contains the text
“Shunemunk Sweet Clover Trail” below the Home artboard.

This content is a description for a local hike.
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3. Click in the gray pasteboard to deselect, and then zoom in to the hike description content
you dragged below the Home artboard.
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Note

If you don’t see Unlink Symbol and see Ungroup Symbol instead, choose
Ungroup Symbol. Choosing either will cause the symbol to no longer be a
symbol.

4. Right-click the selected content and choose Unlink Symbol. Leave the hike description
content selected.

You can make a repeat grid from a symbol, but when the hike description content is
repeated, the gray rectangle in each will need to be a different image. As a symbol, it



will be the same image. Unlinking the symbol from the original means it’s no longer a
symbol and it’s now just a group of content.

5. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Creating a repeat grid

Now that you have some content ready, you’ll create a repeat grid from it. The Hike Detail
artboard will show a series of hikes. Instead of copying and pasting, you will take the group of
content from the previous section and apply a repeat grid to it.

Tip
You can also press Command+R (macOS) or Ctrl+R (Windows) to make a
repeat grid.

Note
Any locked content that is selected when you create a repeat grid will not be
included in it.

Tip
You can nest repeat grids within each other. In other words, you can make a
repeat grid from a repeat grid and other selected content, for instance.

1. With the entire hike description content selected, click the Repeat Grid button in the
Property Inspector to convert the selected content into a repeat grid.
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A couple of things to notice when you convert content to a repeat grid:



e First, there is now a dotted green border around the content, indicating it’s a
repeat grid.

e Second, there are now two handles: one on the bottom and one on the right side.
You drag the handles to create copies of the original content vertically (the
bottom handle) or horizontally (the handle on the right side). The original content
and the copies become cells in the repeat grid. You can then edit the cell and
adjust the gap between rows and/or columns.

For the next step, you may want to zoom out a bit or scroll down to see below the
artboard.

2. Drag the bottom green handle down until you see two copies of the content.
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The content is repeated vertically, and the entire repeat grid acts like a group of the
repeating elements. Later in this lesson, you’ll learn how to adjust the gap between the
repeated elements. To make it so you can scroll the content vertically in your prototype,
you’ll make the artboard taller.

Tip

Pressing the Option (macOS) or Alt (Windows) key while dragging a grid
handle resizes the repeat grid on the opposite side as well, from the center.
Pressing the Shift key while dragging a grid handle resizes both handles
proportionally, from the center.

3. Drag the handle on the right side of the repeat grid to the right until you see a total of
three hike descriptions.
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This reveals a repeat of the column, to the right.

4. Drag the bottom green handle back up until you see only one row of hike descriptions.
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The content is repeated horizontally, and the entire repeat grid acts like a group of the
repeating elements. When finished, you’ll add this repeat grid content to the Hike Detail
artboard. To create room for it, next you’ll resize the Hike Detail artboard and arrange
some of the content.

5. If there’s an image below the Hike Detail artboard, move it out of the way so you can
make the Hike Detail artboard longer.

For the next few steps, you may need to pan or zoom out.



6. Click the Hike Detail artboard name (above the artboard) to select it. Drag the bottom-
middle handle down until you see an approximate height of 2300 in the Property
Inspector to the right.

13

Editing content in a repeat grid

One of the benefits of a repeat grid, aside from being an easy way to duplicate content, is the
ability to change the content in the grid. If there are repeating images in the grid, you can replace
as many images as you like. You can also edit text independently, but styling remains applied to
all copies of the object in the grid. Next, you’ll change some of the content in the repeat grid you
created.

1. Click any content in the repeat grid to select the entire repeat grid. Double-click the first
large gray rectangle on the left to select it.
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When you double-click an object within a repeat grid, you enter into the repeat grid’s
edit mode. The dashed green border around the repeat grid turns into a thicker solid-
green border to indicate that you are in edit mode and can edit content within.

Note

You may need to double-click more than once to select the text.

2. Double-click the middle Shunemunk Sweet Clover Trail text to select it, and type Pine

Meadow Lake Loop to replace the text.

Notice that the other text objects did not change. You can edit the content of each of the
copies in a repeat grid separately.

3. Double-click the Shunemunk Sweet Clover Trail text in the hike description on the right
to select it, and type Seven Hills & Reeves Brook Trail Loop to replace the text.
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4. Click in a blank area away from the repeat grid to deselect it. You may need to click a

few times.



5.

6.

Click the image below the repeat grid and press Command+C (macOS) or Ctrl+C
(Windows) to copy it.

Command-click (macOS) or Ctrl-click (Windows) any of the large gray rectangles in the
repeat grid to select it. Right-click the same gray rectangle and choose Paste
Appearance.

The image is pasted into all of the gray rectangles as a fill. In a repeat grid, if you change
the appearance of any of the content, the rest of the copies in the repeat grid reflect that

change.

Tip

Images are placed in the cells in alphanumeric order. You’ll notice I added a
“_1,”“_2,” and so on, to the names of the images. That helped me control the
ordering of the images as they were placed in the repeat grid.

Note

The data is imported and not linked, so any changes you make to the source file
won’t affect the data you’ve already placed in your XD file.

7. Go to the Finder (macOS) or File Explorer (Windows), open the Lessons > Lesson07 >

repeat_grid folder, and leave the folder open in a Finder window (macOS) or File
Explorer (Windows). With XD and the folder showing, click the image named
hike_1.jpg and Shift-click the image named hike_4.jpg. Drag any of the selected images
on top of any of the repeating images in the repeat grid. When it shows a blue highlight,
release the mouse button to replace the images.
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You can easily change the content of a repeat grid, either by changing an individual
object or by dragging in images or a plain text file. Order in a repeat grid is defined in
left-to-right reading order (left to right, then top to bottom). In this case, the repeat grid
only shows the first three images since only three of the gray rectangles are showing. If
you were to select the entire repeat grid and drag the right handle to show a few more of

the hike descriptions, you’d see the fourth image, and when it came to the fifth
description, the first image would appear again.
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You can also drag a text file into a repeat grid to replace text in a repeating pattern. See

the sidebar toward the end of this section for specifics on how to set up a text file for
import.

Note

It may be difficult to drag the text file onto one of the text blocks if you are
zoomed out in XD.

8. With XD and the repeat_grid folder both still showing, click the text file named

distance_text.txt. Drag it on top of any of the “3.6 mi” text blocks in the repeat grid.
When it shows a blue highlight, release the mouse button to replace the text.
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The first occurrence of the 3.6 mi text (on the left in the repeat grid) is replaced with the
first paragraph in the text file, and so on.
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9. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Setting up a text file for a repeat grid

Text files you drag into a repeat grid must have the extension .txt. You can create this using
TextEdit in macOS (choose Format > Make Plain Text), Notepad in Windows (save as .txt),
or any text editor you prefer.

Within the text file, make each piece of data a separate paragraph. In the example in the
previous section, you dragged the bottom of the repeat grid to reveal a total of three
repeated elements. If the text file had four paragraphs (with returns between each), the first
four repeated text elements would be replaced and then the pattern would start again.

Editing content appearance in a repeat grid

With content in the repeat grid, next you’ll adjust the distance between the rows, as well as some
of the formatting within.

Tip
You can drag to change the distance between rows or columns in the repeat

grid. You can even drag so that rows or columns overlap. This will show as a
negative value in the row or column indicator.

1. Click away from the repeat grid to deselect it. Click any content within the repeat grid to



select the entire repeat grid.

2. Move the pointer between the first two hike descriptions. When the pink column
indicator shows, drag right and then left to see the distance between the columns change.
A small distance value will appear above each pink column indicator. Drag until you see
a value of approximately 30.
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3. If the right side of the right-most hike description content is being covered, drag the
handle on the right side of the repeat grid to the right.
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If you drag far enough, a repeat of the column will be revealed to the right. If you don’t
drag far enough, the content in the third description may be cut off.

4. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Adding content to a repeat grid

After you create a repeat grid, you can always add content to or remove content from it later
using a variety of methods. Next, you’ll add content to the repeat grid.
1. Zoom out or pan over so you can see the Icons artboard, if necessary.

2. With the Select tool () selected, right-click the orange-red map pin icon and choose
Cut.




3. Click back on the repeat grid below the Home artboard, and to zoom in, press
Command+3 (macOS) or Ctrl+3 (Windows).

4. With the repeat grid selected, double-click one of the images in the repeat grid. This
enters repeat grid edit context mode.

5. Press Command+V (macOS) or Ctrl+V (Windows) to paste the icon into the center of
the cell.
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Now you’ll adjust some of the content to position the map pin icon.

6. Click the text Shunemunk Sweet Clover Trail to select the type object.
7. Change the font size to 20 in the Property Inspector to make it smaller.
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8. Drag the right edge of the type object to the left to make it narrower.
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9. Drag the type object to the right to make room for the icon. See the first part of the
following figure.

10. Drag the map pin icon to the left of the Shunemunk Sweet Clover Trail text.

Tip



To move the icon in 1-pixel increments, you can press an arrow key.

11. Shift-drag a corner of the map pin to make it smaller so it fits. Drag it just to the left of
the Shunemunk Sweet Clover Trail text.

You can draw any element or add text to a repeat grid, even after you’ve created it. Since
a repeat grid automatically repeats every element, this allows us the flexibility to play
with design in a new way.

12. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Ungrouping a repeat grid

If you need to edit the different cells in a repeat grid separately, you can always ungroup a
repeat grid. This breaks apart the repeat grid so that each cell is independent from the
others.

With the repeat grid selected, click the Ungroup Grid button in the Property Inspector. You
can also choose Object > Ungroup Grid (macOS) or press Command+Shift+G (macOS) or
Ctrl+Shift+G (Windows).

Finishing the repeat grid

In this last section on repeat grids, you’ll drag copies of the repeat grid into place on the Hike
Detail and Explore artboards. You’ll also add a few finishing touches to those same artboards.

Note
You may need to click in the gray pasteboard more than once to deselect it.




1. Click in the gray pasteboard area to deselect. Drag the repeat grid into the middle of the
Explore artboard.
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You may find that the content of the repeat grid isn’t centered on the artboard even
though the repeat grid is. That’s because there may be space off the right edge of the
rightmost object. You can either drag the right handle of the repeat grid to the edge of

the content or press the arrow keys right or left to align it visually. Now you’ll drag a
copy of it to the Hike Detail artboard.

2. Option-drag (macOS) or Alt-drag (Windows) the repeat grid to the bottom of the Hike
Detail artboard. You may need to pan in the document window or zoom out.

-

Now you’ll add a rectangle behind the repeat grid on the Hike Detail artboard.

3. Select the Rectangle tool and drag to create a rectangle that covers the bottom part of the
Hike Detail artboard.
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4. Open the Assets panel by clicking the Assets panel button ([Z]) in the lower-left corner
of the application window, if you don’t already see it. Click the green color with the
name #265353 to apply it to the fill of the rectangle.

5. Right-click in the green rectangle on the Hike Detail artboard and choose Send To Back
(macOS) or Arrange > Send To Back (Windows).

Paste znv
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Now you’ll add some of the final content to the Explore artboard so users can navigate
when you add interactivity.

6. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the artboards.

Note

If you select any other content when you drag across, Shift-click the content
you don’t want selected.

7. Zoom in to the Journal artboard, making sure you can see the whole artboard.

8. On the Journal artboard, select the Select tool () and drag across the “my hikes” text
and the search icon to the right of it. To make it a symbol, press Command+K (macQOS)
or Ctrl+K (Windows). As a symbol, it’ll be easier to make edits across the copies.



9. Copy the symbol by pressing Command+C (macOS) or Ctrl+C (Windows).

10. Click in the Explore artboard and press Command+V (macOS) or Ctrl+V (Windows) to
paste it in the same relative position.

11. Shift-drag the symbol instance up toward the top of the artboard.

12. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Responsive resize

When designing a website in Adobe XD, it’s important to consider how content acts across the
wide variety of screen sizes available across mobile and tablet devices, as well as for desktops.
Designers have long created multiple artboards at different sizes for each page in a web design,
for instance. That meant copying and resizing an artboard, and then resizing all of the content on
the new artboard manually. To solve this problem, Adobe XD has a feature called responsive
resize. With responsive resize, XD automatically predicts which constraints you are likely to
apply and then automatically applies those constraints as objects are resized. In this section,
you’ll explore responsive resize to begin creating a tablet design from a phone design.

Getting started with responsive resize

To start this section you’ll open a document. You’ll then explore how to turn on responsive
resize and see how it affects the different artboards.

1. Choose File > Open From Your Computer (macOS) or click the menu icon (=) in the
upper-left corner of the application window and choose Open From Y our Computer



(Windows). Open the Responsive_resize.xd document in the Lessons > Lesson 07
folder.

2. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the artboards.

In the document, there are two sizes for a single page in a website—a mobile design and
a desktop design. You’ll make a copy of the mobile-sized artboard, turn on responsive
resize and then resize the artboard to be a tablet-sized version of the design.

3. With the Select tool () selected, click the Journal - phone artboard name to select the
artboard.

4. To duplicate the artboard, press Command+D (macOS) or Ctrl+D (Windows). The new
artboard, named “Journal - phone - 1,” is selected.

5. Double-click the new artboard name and change it to Journal - tablet.

6. Press Command+3 (macOS) or Ctrl+3 (Windows) to zoom in to the artboard.

7. Drag the right-middle point of the selected Journal — tablet artboard to the right to make
it wider. When you see a width of approximately 850 in the Property Inspector, stop
dragging.

Joarngl - tablet




The content on the artboard doesn’t resize or move by default. By default, the responsive
resize option is turned off for artboards, but you can turn it on for selected artboards.
Turning it on for an artboard will allow the content on that artboard to resize. Next,
you’ll undo the artboard resizing and try again with the responsive resize option turned
on.

Note

You could just drag the right-middle point of the artboard to the left to make it
narrower, but using the undo command puts it back to the same size every time
more easily.

8. Press Command+Z (macOS) or Ctrl+Z (Windows) to undo the artboard resizing.

9. With the artboard still selected, in the Property Inspector click the Responsive Resize
toggle to turn it on.
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Journal - tablet

The content on the artboard is now set to resize as the artboard is resized.

Note

Responsive resize currently does not support symbols. As a workaround,
ungroup symbols and resize the group.




Tip

For a scaled resize, use the Shift key to temporarily override the responsive
behavior. You can pull from one of the corner selection handles to lock the
aspect ratio of your group as you resize.

10.

11.

Drag the right-middle point of the Journal — tablet artboard to the right until you see a
width of approximately 800 in the Property Inspector.

You can see that the header image resizes, the button content is separated, the repeat grid
adds columns, and more. Notice that the HIKES, DISTANCE, and MEMORIES text,
along with the numbers below them, is not staying together.

With responsive resize turned on for the artboard, Adobe XD analyzes the objects on the
artboard, their grouping structure, their proximity to the edges of the parent group (such
as the artboard), and the layout information when resizing. When resizing either objects
on the artboard or the artboard itself, pink crosshairs appear on the content that is being
resized. These crosshairs indicate what constraint rules are applied to a group. Constraint
rules are used to determine how objects behave when you resize them. You’ll explore
constraint rules in the next section.

Press Command+Z (macOS) or Ctrl+Z (Windows) to undo the artboard resizing.

Grouping content

When you resize an artboard with the responsive resize option enabled, Adobe XD does its best
to re-create the placement of your elements on a larger or smaller artboard. Before resizing
content, you can group similar objects to establish relationships between them. When resized,
grouped objects stay together by default and allow you to establish a hierarchy in your projects.

Next, you’ll group content to keep it together when it’s resized and also set manual constraint
rules. This will make more sense when you see them in action.

1.

Zoom in to the top half of the Journal - tablet artboard.

2. With the Select tool () selected, drag across the text “MEMORIES, 172” and the short

vertical line just to the left of the text and number to select it all.
To group them together, press Command+G (macOS) or Ctrl+G (Windows).

Drag across the text “DISTANCE, 98 mi” and the short vertical line just to the left of
the text and number to select it all.

To group them together, press Command+G (macOS) or Ctrl+G (Windows).



Meng Nov 22, 2018 . Meng Nov 22, 2018

98 mi

~ NOVEMBIR 18, 2018
%

6. Click the Journal — tablet artboard name to select it. Drag the right-middle point of the
artboard to the right. You can see grouped content now stays together.

7. Press Command+Z (macOS) or Ctrl+Z (Windows) to undo the artboard resizing.

Next, you’ll group the content for the orange start hike button so it stays together when
the artboard is resized.

8. Click the orange start hike button at the top of the artboard.

You can see that it’s a symbol instance. That means that the orange button shape will not
resize when the artboard is resized.

9. With the symbol instance content selected, Shift-click the white double-circle on the
button and the menu text. To group them together, press Command+G (macOS) or
Ctrl+G (Windows).
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10. Click the Journal — tablet artboard name to select it. Drag the right-middle point of the
artboard to the right. You can see that all of the content in the orange button group now
stays together.

11. Press Command+Z (macOS) or Ctrl+Z (Windows) to undo the artboard resizing.



Setting manual constraints

If you’re not happy with the content resizing when you resize an artboard, you can also edit
constraint rules manually, which enables you to determine how objects behave when you resize
the symbol, artboard, or group those layers are in. Manual constraints you apply will always
override automatic constraints placed by XD.

1. Click the orange start hike button group at the top of the artboard.

Journal - tablet
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In the Responsive Resize section of the Property Inspector, there are two buttons: Auto
and Manual. By default, the content in an artboard with responsive resize turned on is set
to Automatic. For selected content, you can set the constraints manually by clicking the
Manual button and setting which edges of the artboard we want it to stick to and whether
we want to keep its height or width fixed.

2. Click the Manual button to set constraints for the button group manually.
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With Manual selected, you can now see position and size options. The position options
are used to fix the position relative to the parent. In this case, the parent of the button
group is the artboard. The Fix Width and Fix Height options can be used to ensure that
the content does not resize horizontally, vertically, or both.

By default, the position of the button is set to be fixed to the top and right edges of the



artboard. In this case, the button needs to stay in the same relative position it is currently.
To do that, you can set the position to Fix Left and Fix Top.

Tip
If content within a group has the Fix Width content turned off, you can choose
Fix Left and Fix Right for that group.

3. Click Fix Left (}=).

With Fix Left selected, Fix Right is disabled. The button group will now stay the same
distance from the left edge of the artboard no matter how wide the artboard becomes.

Tip
Undoing by pressing Command+Z (macOS) or Ctrl+Z (Windows) can be used
to undo constraint options you set.

4. Deselect Fix Width.

The width of the button group will now resize horizontally. That doesn’t mean each
object will get wider. It means that the content within the button will spread out to match
a changing button width.

5. Click the Journal — tablet artboard name to select it. Drag the right- middle point of the
artboard to the right a little. As you drag, you should see a faint pink line from the left
edge of the orange button group to the left edge of the artboard. This is the constraint
rule applied to the group—fixed left.



You can see that the left edge of the button stays the same relative distance from the left
edge of the artboard. It is now fixed to the left side of the artboard. Also, the white
double-circle moves separately because it’s not a part of the orange button symbol.

6. Press Command+Z (macOS) or Ctrl+Z (Windows) to undo the artboard resizing.

7. Double-click the orange button shape to select the symbol within the group.

Journal = tablet

You can tell the symbol instance is selected because it has a green border, and you can
see it selected in the Layers panel. It won’t resize because it’s a symbol instance.

8. Right-click the symbol instance and choose Ungroup Symbol so that it can resize.
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By ungrouping the symbol, the text and orange button shape are no longer grouped as a
single object. That means they will move independent of each other, just like the double-
circle on the orange button shape will. To keep the button parts together and allow them



to resize, you will group them all.

9. Press the Esc key to select the group that the selected content are in.

10. With the Manual option still selected in the Property Inspector, and the Fix Width option
not selected, make sure that Fix Right (=) is selected, and deselect Fix Left (=) and Fix
Height ( 1 ), if necessary.
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Both Fix Left and Fix Right can be selected, in this case, because some of the content in
the group has Fix Width turned off, so it can resize.

11. Click the Journal — tablet artboard name to select it. Drag the right-middle point of the
artboard to the right. You can see that the orange button shape resizes.
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12. Press Command+Z (macOS) or Ctrl+Z (Windows) to undo the artboard resizing.

The button would look better if it didn’t resize and it was on the right side of the artboard
at the larger artboard size.

13. Click in a blank area of the gray pasteboard to deselect, and then click the orange button
group to select it. Select the Fix Width option in the Property Inspector. Ensure that Fix
Right (=f) and Fix Height ( | ) are selected.



B3 Ropest Grid

w 240 % 138 c o
48 24 e X

O Fix position when scroling

Auta

T K - Fl Width
L -l

| * | T

Setting the Fix Width option on the group overrides the orange button shape, which has
the Fix Width option turned off. In other words, if the group can’t resize (it has a fixed
width), the content within can’t either.

14. Click the Journal — tablet artboard name to select it. Drag the right-middle point of the
artboard to the right. You can see that the orange button shape no longer resizes.
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Finishing the design

When it comes to resizing artboards, responsive resize will only get you most of the way there,
but it may not always get it right. To finish the design, you’ll set the artboard to a specific width
and resize/move some of the content.

1. With the artboard still selected, change the Width value in the Property Inspector to 834.
Press Return or Enter.
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The content should resize like it did at the end of the previous section.

2. Click the repeat grid object. Move the pointer between the columns, and when the pink

column indicator shows, drag to the right until you see a distance value above the pink
column indicator of approximately 80.

Note

If you don’t see an alignment guide, you can also just drag it so it’s visually
aligned on the artboard.




4. Drag the grid into the horizontal center of the artboard.
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5. Click in a blank area of the pasteboard to deselect.
6. To see everything, press Command+0 (macOS) or Ctrl+0 (Windows).
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7. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

8. Choose File > Close (macOS) or click the X in the upper-right corner of the open
window (Windows) to close the Responsive_resize file.

Note
If you started with the L.7_start.xd jumpstart file, then keep that file open.




9. If you plan on jumping to the next lesson, you can leave the Travel_Design.xd file open.
Otherwise, choose File > Close (macOS) or click the X in the upper-right corner
(Windows) for each open document.

Review questions

1 What is the difference between object blur and background blur?
2 How do you apply a gradient to content?

3 What is a repeat grid?

4 How do you replace a series of images in a repeat grid?

5 What are two ways to add content to a repeat grid?

Review answers

1 Background blur uses an object as an overlay to blur content that is behind it. Most of the
time, the overlay object that is used to blur content is a shape, and the color fill and
border of the shape have no effect on the result. Object blur is a method for blurring
selected content such as a shape or an image.

2 You apply a gradient to the fill of content by clicking the Fill color in the Property
Inspector and choosing Linear Gradient or Radial Gradient from the menu at the top of
the Color Picker.

3 In Adobe XD, you can select an object or group of objects and apply a repeat grid to
easily repeat the content. With a repeat grid applied to content, you can simply pull a
handle at the bottom or right side of the content and the content repeats in the direction
you pull. When you modify any style of an element, the change is replicated in all the
elements of the grid. For example, if you round the corners of an image in one of the
elements, the corners of all images in the grid are affected.

4 To replace images in a repeat grid, go to the Finder (macOS) or Windows Explorer
(Windows) and open a folder. With XD and the folder showing, drag the image(s) on top
of any image in the repeat grid. When a blue highlight appears, release the mouse button
to replace the image(s).

5 Enter into edit content mode by double-clicking content within a repeat grid or by
Command-clicking (macOS) or Ctrl-clicking (Windows) content within a repeat grid.
Then you can either create content within the repeat grid or paste content into it.



8 Creating a Prototype

Lesson overview

In this lesson, you’ll learn how to do the following:

Understand prototypes.

Explore Design mode versus Prototype mode.
Set the home screen.

Link and unlink content.

Integrate auto-animation.

Work with a drag trigger.

Preserve scroll position.

Add timed transitions.

Create overlays.

Use voice triggers and speech.

This lesson takes approximately 60 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the
lesson files and Web Edition.”

Your Account page is also where you’ll find any updates to the lessons or to the lesson
files. Look on the Lesson & Update Files tab to access the most current content.
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A prototype lets you visualize the navigation between artboards (screens). It’s useful for
gathering feedback on the feasibility and usability of designs, which saves time on
development. In this lesson, you’ll create a working prototype from your design and
preview it locally in Adobe XD.

Starting the lesson

In this lesson, you’ll create a working prototype from your app design and test it locally in XD.
To start, you’ll open a final lesson file to get an idea for what you will create in this lesson.

Note

If you have not already downloaded the project files for this lesson to your
computer from your Account page, make sure to do so now. See the “Getting
Started” section at the beginning of the book.

1. Start Adobe XD CC, if it’s not already open.

2. On macOS, choose File > Open From Your Computer. On Windows, click the menu
icon (=) in the upper-left corner of the application window and choose Open From
Your Computer.

For either macOS or Windows, if the Home screen is showing with no files open, click



Your Computer in the Home screen. Open the file named L8_end.xd, which is in the
Lessons > Lesson08 folder that you copied onto your hard disk.

3. If you see a message at the bottom of the application window about missing fonts, you
can click the X on the right side of the message to close it.

Note

The figures in the lesson were taken on Windows. On macOS, certain parts of
the XD interface will be a little different.

4. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the design content. This
file shows you what you will create by the end of the lesson.

5. Leave the file open for reference, or choose File > Close (macOS) or click the X in the
upper-right corner of the open window (Windows) to close the file.

Starting with prototypes

It’s often useful to create an interactive prototype of your design to test the user experience it
offers. You can create the prototype at any point in the design process. A prototype helps you
visualize the navigation between screens or wireframes. It is useful for gathering feedback on the
feasibility and usability of designs, which can save time on development. For instance, if you
wanted to test the checkout (purchasing) process for an app design, you could generate a
prototype that allows users to tap or click a button and proceed to the next screen. This would
allow everyone to experience how the final app might work.

Note
Going forward, the terms “link” and “connection” will be used interchangeably,



as well as “artboards” and “screens.”

@ Note

The figures on this page are just examples of connections in an interactive
prototype.

In Adobe XD, we link interactive elements to create connections between screens. That means
we create links (also called connections) between artboards or objects and other artboards using
several methods, as you’ll soon see.

In the following figure, the blue area covering the Create Account button represents a hotspot, or
interactive area. An arrow is pointing to it in the figure. The blue connector (also called a wire)
coming from the right edge of the blue area indicates the connection (link) between the hotspot
and the resulting screen (artboard).
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While testing a prototype, if you tap or click the Create Account button, a transition, such as a



dissolve or slide, will occur to show the next artboard.

Design mode vs. Prototype mode

When you open a file in Adobe XD, the program starts out in Design mode. In Design mode, you
have access to all of the design tools and panels necessary to create and edit. When you’re ready
to begin prototyping, you need to switch to Prototype mode and create any necessary interactive
connections.

In this short section, you’ll explore switching between the two modes.

Note

If you are starting from scratch using the jumpstart method described in the
section “Getting Started,” open L8_start.xd from the Lessons > Lesson08
folder.

1. Choose File > Open From Your Computer (macOS) or click the menu icon (=) in the
upper-left corner of the application window and choose Open From Y our Computer
(Windows). Open the Travel_Design.xd document in the Lessons folder (or where you
saved it).

2. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the design content.

Notice the two modes, Design and Prototype, listed toward the upper-left corner of the
application window. By default, Design mode is selected. You can tell you are in Design
mode because the toolbar and Property Inspector are showing.

3. Click Prototype, to the right of Design, to switch to Prototype mode.
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Notice that the toolbar shows only the Select and Zoom tools now, and the Property
Inspector is hidden. While in Prototype mode, you can still import or paste content into
your design, copy and paste content or artboards, access the Assets and Layers panels,
and even drag symbols into the design from the Assets panel. Other design changes,
such as creating content or making text formatting changes, are not allowed. To do so,
you would need to switch back to Design mode.



Note

If the artboards in your document are blank (empty) when you enter Prototype
mode, you’ll see a message that tells you the artboards need content. Also, if
there is only one artboard in the document, when you enter Prototype mode
you’ll see a message that tells you to add more artboards to the document.

4. Press Control+Tab (macOS) or Ctrl+Tab (Windows) to switch back to Design mode.
Press Control+Tab (macOS) or Ctrl+Tab (Windows) once more to switch back to
Prototype mode. Make sure that Prototype mode is showing before proceeding.

Note

Don’t confuse the home screen with the artboard named Home in the
Travel_Design.xd file.

Setting the home screen

One of the first things you’ll do in Prototype mode is set the home screen. The home screen is
the first screen that users encounter when they view your prototype, and you can set any artboard
as the home screen. If you don’t set a home screen, by default, the home screen is the topmost,
leftmost artboard (in that order). Suppose you want to send a prototype to a colleague for
feedback on a specific part of the design, such as the checkout (purchasing) process of an app.
Instead of having your colleague start at the default home screen (the Home artboard in the
Travel_Design file), you can set the artboard where the checkout process begins as the home
screen. That way, the first artboard users will see when they open the prototype is the start of the
checkout process.

In this section, you’ll ensure that the home screen is set to the artboard named Home—which
will be the first screen users see.

1. In Prototype mode, with the Select tool (») selected, click the name “Home” above the
artboard to select the entire artboard.




Note

If you don’t see the white house icon in the small gray shape off the upper-left
corner of the artboard, you most likely need to zoom in further.

2. Press Command+3 (macOS) or Ctrl+3 (Windows) to zoom in to the artboard.

With the artboard selected, you should see a small gray shape with a little white house in
it, called the home screen indicator, off the upper-left corner of the artboard. If a selected
artboard is the home screen, the home screen indicator will be blue with a little white
house icon in it.

3. Click the home icon in the little gray box to set the artboard named Home as the home
screen.
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The artboard named Home will be the home screen by default anyway, because it’s the
topmost, leftmost artboard. In this case, you are explicitly setting the Home artboard as
the home screen in case you add another artboard later that becomes the topmost,
leftmost artboard.

4. Click away from the artboards in a blank area of the pasteboard to deselect all.

Linking artboards

Now you’ll test the user experience of your design by creating an interactive prototype. That
way, you, as well as others, can interact with the prototype by testing the links between screens.
A designer could use it as a way to visually describe an interaction between screens to a

developer, and much more. In this section, you’ll explore how to create links (connections) and,
later, test those links.

1. Press Command and — (macOS) or Ctrl and — (Windows) a few times to zoom out of the
Home artboard.



Make sure you can see a few of the artboards to the right of the Home artboard. You
may want to press the spacebar and drag in the document window, or two-finger drag so
you can see more artboards.

2. Click either the name “Home” above the Home artboard or “Home” in the Layers panel
(if it’s showing) to select the artboard.

In Prototype mode, when you select an artboard, you’ll see a small white arrow in a blue
shape () on the right side of the artboard. It’s circled in the previous figure. This is
called the connecting handle and is what you use to make a connection.

3. Drag the connecting handle away from the artboard and you’ll see a connector (blue
line). Drag the connector within the bounds of the Explore artboard. When a subtle blue
highlight appears around the Explore artboard, release the mouse button to connect the
Home artboard to the Explore artboard.
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When you test the prototype, either in the Desktop preview in XD or in the Adobe XD
mobile app on your device, tapping anywhere on the home screen will transition to the
Explore screen.

Tip
You can set the duration for a connection to 2 or 3 seconds and test the

prototype to really see the difference between a push and a slide transition.
You’ll see how to test the prototype shortly.

4. In the pop-up that appears after creating a connection, change the following:



e Trigger: Tap (the default setting) (Trigger is an interaction you set that triggers
or causes the transition from one screen to the next.)

e Action: Transition (the default setting) (The action is what happens when a
connection or link is triggered.)

e Destination: Explore (The destination is the screen [artboard] that will appear
when a user taps or clicks an artboard or object with a connection.)

e Animation: Slide Left (Animations occur when one screen [artboard] replaces
another.)

e FEasing: Ease Out (the default setting) (Easing makes transitions feel more
natural. Ease Out, for instance, means the transition starts quickly and
decelerates toward the end.)

e Duration: 0.3s (the default setting) (Duration is the length of time it takes to
transition from one screen [artboard] to the next.)

e Preserve Scroll Position: unselected (For maintaining the vertical scroll position
when you transition to another artboard.)

Tip
You can also press the Esc key.

5. Click in a blank area of pasteboard to hide the menu and deselect the artboard.

Notice that the connector line is now hidden. To see connectors in Prototype mode, you
need to select content and/or artboards.



6. Click the name of either the Home or Explore artboard (above each artboard) to see the
connector you created.

On the right end of the blue connector line (on the left edge of the Explore screen),
you’ll see an arrow in the connecting handle (€1). The arrow indicates the direction and
end of the connection.

7. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Previewing links locally

As you begin to add connections and create your prototype, you’ll want to preview and test those
connections. You can do this using several methods, including a desktop preview and the Adobe
XD mobile app. In this section, you’ll be introduced to the Preview window for testing. In
Lesson 9, “Previewing a Prototype,” you’ll learn more about the different methods for
previewing.

Tip
You can also press Command+Return (macOS) or Ctrl+Enter (Windows) to
open the Preview window.

1. Click Desktop Preview (p) in the upper-right corner of the application window.

sign up




The Preview window is opened at the size of the artboard currently in focus. You can
edit the design and interactions in your prototype while previewing in the Preview
window. The changes are instantaneously available for preview.

2. Drag the Preview window by the bar at the top so that you can see most of the artboards,
if necessary.

Note

In the next few sections, on Windows, you may need to press Alt+Tab to show
the Preview window after clicking in the document window.

Tip
You can preview design changes you make to content on your artboards in real
time in the Preview window, without having to save.

3. Click any content in the Home artboard to select it, and then click to select content in the
Explore artboard. Whichever artboard is the focus (the one you are working on) will
show in the Preview window. Make sure the Home artboard is showing in the Preview
window before moving on.
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4. Move the pointer over the Home screen in the Preview window. The pointer changes to
a hand (), indicating that there is a connection (link) in that area. Click anywhere in
the screen and the Explore screen appears after a sliding transition.
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Note

The Preview window must be in focus (selected) to use the arrows for
navigating.

5. Press the left arrow key to return to the previous (Home) screen in the Preview window.
You can easily navigate between screens in the Preview window by pressing the left or
right arrow keys.

6. Close the Preview window.

Editing links

At times, you will want to remove connections, re-route connections, or change the connection
options. Next, you’ll edit the options for the connection you created in the previous section.
You’ll then remove that connection and, instead, create a connection from an object on the Home
artboard to an artboard you copy and paste from another document.

1. Click the name of either the Home or Explore artboard (above each artboard) to see the
connector you created. Click the connecting handle on either end of the connector to
show the menu again. Choose Push Left from the Animation menu that appears.



When you preview a prototype, you’ll see the difference between a slide transition and a
push transition. A slide transition slides the artboard you’re linking over the top of the
current artboard. A push transition pushes the current artboard out of the way as the new
artboard slides (animates) in.

. Click in a blank area to hide the menu, and then click the name of either the Home or
Explore artboard to see the connector again. Move the pointer over either end of the
connector and drag away from the artboard into a blank area of the pasteboard. Release
the mouse button to remove the connection.
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Now you’ll add a sign-up form to the design so that you can create a connection from the
Sign Up button on the Home screen to the form you add on a new artboard.

. Choose File > Open From Your Computer (macOS) or click the menu icon (=) in the
upper-left corner of the application window and choose Open From Y our Computer
(Windows). Open the Sign_up.xd document in the Lessons > Lesson08 folder.

. With the Select tool selected, click the artboard name “Sign up” to select the artboard.
To copy it, press Command+C (macOS) or Ctrl+C (Windows).



5.

6.

continue
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To close the Sign_up.xd file, choose File > Close (macOS) or click the X in the upper-
right corner with the Sign_up.xd document showing (Windows).

Back in the Travel_Design file, click the Home artboard name above the artboard to
select it. Paste the Sign up artboard by pressing Command+V (macOS) or Ctrl+V
(Windows).

The Sign up artboard should appear beneath the Home artboard or to the right of the
Journal ver2 artboard. If the artboard is pasted to the right of the Journal ver2 artboard,
zoom out and drag the Sign up artboard by the artboard name to below the Home
artboard.

If the large image that was below the Home artboard is added to the Sign up artboard
you pasted, you can select the image and press Backspace or Delete to remove it.
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Selecting an artboard before pasting an artboard will usually paste the artboard directly
beneath the artboard you copied. I say “usually” because the zoom level and what
artboard is selected has an effect on where the artboard is pasted.

Now you’ll add the status bar and back arrow symbols from the Recording artboard to
the Sign up artboard. You’ll copy and paste the symbol instances from an existing
artboard so you can paste them in the same location on the Sign up artboard.

Click the white status bar at the top of the Recording artboard. You’ll probably have to
pan or zoom in the document to see the Recording artboard. Shift-click the white arrow
symbol beneath it. To copy the content, press Command+C (macOS) or Ctrl+C
(Windows).



10.

11.

continue

Now that the Sign up artboard has everything it needs, you’ll create a connection from
the sign up button on the Home artboard to the Sign up artboard.

Click the sign up button on the Home artboard.

When you select content on an artboard in Prototype mode, it will have a blue highlight
and you’ll see a connecting handle with an arrow on the right side of the content, similar
to selecting an artboard in Prototype mode. You can drag the connecting handle to
another artboard, but not to another object.

Drag the connecting handle to the Sign up artboard beneath it. When the Sign up




Tip
You can also click either connecting handle to open the pop-up, and select
Target > None to unlink the artboard.

Tip
You can also drag a connecting handle directly to another artboard to change
the link.

Note

On Windows, you may need to pan in the document window to see the whole
settings pop-up for the connection.

12. In the pop-up that appears after creating the connection, ensure that the following are
set:

ﬂ'ﬁi sign up
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e Trigger: Tap (the default setting)

e Action: Transition (the default setting)

e Destination: Sign up

e Animation: Dissolve

e FEasing: Ease Out (the default setting)

e Duration: 0.5 (You will need to type in the value, since 0.5 does not appear in the



menu, and press Enter or Return to accept the change.)
e Preserve Scroll Position: unselected

You’ll test this interaction in the next section.

13. Click in a blank area of the pasteboard to close the pop-up.

Copying and pasting connections

In Preview mode (not in Design mode), when you copy artboards or make a copy of content that
has a connection associated with it, the connection is preserved in the copy. You can also copy
and paste an interaction, and not the content, from one object or artboard to another object or
artboard. This is a real time-saver when you have content that has the same connections, such as
footers, across multiple artboards. Next, you’ll copy an interaction from one object to another.

1. Press Control+Tab (macOS) or Ctrl+Tab (Windows) to switch back to Design mode.

2. Zoom in to the top half of the Hike Detail artboard and double-click the small white
arrow symbol instance at the top of the artboard to edit it.

Next, you’ll add a connection from the left-pointing arrow at the top of the Hike Detail
artboard. The problem is that the area that users will tap or click will be very small—the
size of the arrow. You can add a transparent rectangle (or other shape) to use as a hotspot
(larger area to click or tap).

Note

My first instinct was to simply turn off the fill and border of the rectangle.
Unfortunately, this would make it difficult to select in Prototype mode.

3. Select the Rectangle tool ([J) in the toolbar and draw a rectangle on top of the arrow
icon. Change Opacity to 0 in the Property Inspector.
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4. Press Control+Tab (macOS) or Ctrl+Tab (Windows) to switch back to Prototype mode.

5. Press the Esc key to select the entire symbol instance (the arrow and the rectangle you
just drew). Click (don’t drag) the connecting handle (the small arrow on the right edge).
In the pop-up menu change the following:

e Action: Previous Artboard (This creates a connection from the Hike Detail
artboard to whichever artboard was last viewed.)

With Previous Artboard selected, the connecting handle now shows on the left side of
the artwork as a curved arrow (€)) with no line connecting to another artboard.

6. Click in a blank area of the pasteboard to hide the pop-up, and then click the arrow
symbol instance to select it again. Right-click it and choose Copy.

7. Move the pointer onto the white arrow symbol on the Recording artboard. When you see
a blue highlight in the shape of the rectangle, right-click and choose Paste Interaction.
You may need to pan in the document window or zoom out.
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The interaction is pasted from one symbol instance to another. Next, you’ll paste the
interaction on the white arrow symbol on the Sign up artboard.

Note

Currently, connections you apply to symbol instances are not applied to any
other symbol instances in the document.

8. Move the pointer onto the white arrow symbol on the Sign up artboard. When you see a
blue highlight in the shape of the rectangle, right-click and choose Paste Interaction.

9. Click in the Explore artboard so that artboard shows in the Preview window when you
open it. Click Desktop Preview (») in the upper-right corner of the application window.

10. In the Preview window that opens, press the right arrow several times to go to the
Recording artboard. On the Recording artboard, click the white arrow to return to the
previous artboard.

11. Close the Preview window.
12. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Taking prototypes further

Prototypes allow us to visualize our designs and test our ideas. As you dig into creating
prototypes in Adobe XD, the more you realize just how many options there are. You can set



connections to animate content between artboards, trigger connections with speech, use a drag
gesture to simulate user experiences like dragging between images in a slideshow, and much
more. In this section, you’ll explore these options and see how some of them can be used in
combination to bring your design vision to life.

Auto-animating content

When you create connections between artboards, the default action for a connection is set to
Transition. Currently, there are a total of five actions you can set for a connection. The first
you’ll explore is called auto-animate, which allows you to create prototypes where the content
between the connected artboards will animate from one to the next. You can duplicate an
artboard, modify some properties for the content, such as size and position, and then apply the
Auto-Animate action to the connection to create an animated transition when the prototype
transitions from one artboard to the next.

In this section you’ll create a slideshow that animates—starting with copying the Explore
artboard and making a change on the copied artboard.

Note

If you are starting this section from scratch using the jumpstart method
described in the section “Getting Started,” open L8_prototyping_start.xd from
the Lessons > Lesson08 folder.

1. With the Travel_Design.xd document showing, press Command+0 (macOS) or Ctrl+0
(Windows) to see all of the design content.

2. With the Select tool () selected, Option-drag (macOS) or Ctrl-drag (Windows) the
Explore artboard by its name to make a copy beneath the original. When the copy is in
place, release the mouse button and then the key.

Couredown




To use auto-animate, make sure that the objects you are looking to animate have the
same name in the Layers panel between each of the artboards. By duplicating the
artboard, you’re assured that the names of the content between the artboards is the same.

3. Zoom in to the Explore artboard and the new copy beneath it so you can see both.

4. On the original Explore artboard, drag the repeat grid to the right so the first hike
description is showing. See the figure. Leave the repeat grid selected.

The idea is to make a content or appearance change on either artboard. This could be
changing the position of content, opacity, font size, rotation, and a lot more. For a listing
of supported properties for auto-animate in XD artboard transitions, visit
https://helpx.adobe.com/xd/kb/supported-auto-animate-features-in-xd.html.

5. While in Prototype mode, and with the repeat grid on the original Explore artboard
selected, drag the connecting handle to the Explore — 1 artboard beneath it. When the
Explore — 1 artboard has a blue border, release the mouse.

Racoathig |

6. In the pop-up window that appears after creating the connection, ensure that the
following are set:

Trigger: Tap (the default setting)
Action: Auto-Animate

Destination: Explore — 1
Easing: Ease In-Out
Duration: 0.3


https://helpx.adobe.com/xd/kb/supported-auto-animate-features-in-xd.html
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7. Click Desktop Preview (») in the upper-right corner of the application window.

8. In the Preview window that opens, move the pointer over the repeat grid and click to see
the animation from the Explore artboard to the Explore — 1 artboard.
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» Note

If you add content to both artboards, make sure that the names of the objects in

the Layers panel are the same between artboards. Also, if you add something to
one artboard, it will either fade out or fade in, depending on which artboard you
added it to.

There are so many things you can try with auto-animate. Try moving other content on the
Explore — 1 artboard or introducing another object. You could even copy the Explore — 1



artboard, drag the repeat grid on the new artboard to show the last hike description, and make
a connection with the Auto-Animate action from the repeat grid on Explore — 1 to the Explore
— 2 artboard. You can then preview the connection in the Preview window. Know that if you
explore, your design content may look different than what you see going forward.

9. Close the Preview window.
10. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Note

In order to save on Windows, you may need to click back in the Travel_Design
application window before saving.

Auto-animate examples Hia

To see more examples of auto-animate in Adobe XD, check out the video “Auto-animate
examples,” which is a part of the Web Edition of this book. For more information, see the “Web
Edition” section of “Getting Started” at the beginning of the book.

Adding a drag trigger

When you create a connection, you can set the trigger to Drag to simulate user actions like
dragging to change images in an image slideshow. When you select Drag from the list of
triggers, XD automatically switches the Action to Auto-Animate. Next, you’ll apply a drag to the
connection between the Explore and Explore — 1 artboards. That way, instead of clicking to see
the animation, you can drag. You can then control the animation speed by how fast you drag.

1. Click the repeat grid on the original Explore artboard to see the connection, if it isn’t
already selected.

2. Click the start or end of the connection to show the options pop-up window (both are
circled in the following figure).

3. Choose Drag from the Trigger menu and ensure that None is chosen for Easing.




When you select Drag, the Duration option is no longer visible in the pop-up window.
That’s because the user controls the duration by how fast they drag.

. Click Desktop Preview (») in the upper-right corner of the application window.

Tip
To try the animation again, you can click in the Explore artboard so that it
shows in the Preview window.

Note

To transition from the Explore artboard to the Explore — 1 artboard you don’t
have to drag the entire way. If you drag more than halfway from one artboard to
the next, the animation will be completed for you.

5.

In the Preview window that opens, move the pointer over the repeat grid and drag to the
left to see the animation happen.
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After dragging, your first instinct may be to drag to the right so you see the first hike
description again. To accomplish that, you would need to set up another connection from
the repeat grid on the Explore — 1 artboard to the Explore artboard.

Click the repeat grid on the Explore — 1 artboard to select it.

Drag the connecting handle from the repeat grid to the Explore artboard above it. When
the Explore artboard has a blue border, release the mouse.

In the pop-up window that appears after creating the connection, the settings should be
the same as for the last connection, except for the Destination. Ensure that the following



are set:
e Trigger: Drag
e Action: Auto-Animate
e Destination: Explore

e Easing: None

9. Click Desktop Preview (») in the upper-right corner of the application window. With
the Explore — 1 artboard showing in the Preview window, drag to the right to see the
Explore artboard. Drag to the left to see the Explore — 1 artboard.

10. Close the Preview window.

Setting up content for preserving scroll position

By default, if you scroll through a screen vertically and click an object, like a button, with a
connection set to another artboard, the top of the next artboard appears, instead of maintaining
your scroll position on the previous screen. When creating connections, you can choose to
preserve scroll position, which allows the prototype to transition to the next screen while
maintaining the vertical scroll position from the previous screen. In this section, you’ll set up the
design content to be able to create a connection for preserving scroll position.

1. Drag across the Home, Sign up, Explore, Explore — 1, and Hike Detail artboards to
select them.



2.

U B .

Drag the selected artboards by any of the artboard names to the left. There needs to be
room to add a copy of the Hike Detail artboard to the right of it.

Press Control+Tab (macOS) or Ctrl+Tab (Windows) to switch back to Design mode.
Click the repeat grid at the bottom of the Hike Detail artboard to select it.
Press Command+3 (macOS) or Ctrl+3 (Windows) to zoom in to it.

Move the pointer between the columns, and when the pink column indicator shows, drag
to the right until you see a distance value above the pink column indicator of
approximately 100.
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» Note

You won’t see any helpful alignment guides indicating it’s centered when
dragging the content because it’s part of a repeat grid.

7. Shift-drag one of the descriptions in the repeat grid to the right to show the first hike
description. Release the mouse button and then the Shift key when it’s visually centered
horizontally in the artboard.

Lo

Shunemunk Sweaet Pine Meadow Laké
Clowver Trail Laop

EISTANCE  DURATION  ILEVATION DISTAMCE  DURATION  ELEVA
10Zmi 31Shr  JB4W 4.2mi 3i6hr 384

8. Click away from the artboards in the gray pasteboard area to deselect them all.
9. Press Command+0 (macOS) or Ctrl+0 (Windows) to see everything.

10. Click the Hike Detail artboard name and press Command+D (macOS) or Ctrl+D
(Windows) to duplicate the artboard.

As with the repeat grid you animated on the Explore and Explore — 1 artboards, you’ll do
something similar to the repeat grid at the bottom of the Hike Detail artboard and the

copy.
11. Shift-drag the repeat grid on the new Hike Detail — 1 artboard to the left to show the

second hike description. Release the mouse button and then the Shift key when it’s in
place.



12. Press Control+Tab (macOS) or Ctrl+Tab (Windows) to switch back to Prototype mode.

Preserving scroll position

Now that you have the content set up, you can create a connection between artboards and learn
about preserving scroll position.

1. Click the repeat grid at the bottom of the original Hike Detail artboard. Drag the
connecting handle on the right edge of the selected repeat grid to the Hike Detail — 1
artboard. When the Hike Detail — 1 artboard has a blue border, release the mouse.
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2. In the pop-up window that appears after creating the connection, the settings should be
the same as the last connection, except for the Destination. For this connection, you
want the user to tap the repeat grid content to dissolve from one artboard to the next. Set
the following to achieve that:




e Trigger: Tap

e Action: Transition

e Destination: Hike Detail — 1

e Animation: Dissolve

e Easing: Ease In-Out

e Duration: 0.3 (the default setting)

e Preserve Scroll Position: unselected (the default setting)
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Note

You may see that some of the content scrolls over the top of the orange footer
bar that is set to fixed positioning. If that is the case, you can right-click the
orange footer symbol on the Hike Detail artboard and choose Bring To Front
(macOS) or Arrange > Bring To Front (Windows). You can do the same for the
Hike Detail — 1 artboard.

3. Click Desktop Preview () in the upper-right corner of the application window. With
the Hike Detail artboard showing in the Preview window, drag up to scroll in the
window so you can see the repeat grid at the bottom of the artboard. Click the repeat
grid to go to the Hike Detail — 1 artboard.

Notice that the Hike Detail — 1 artboard showed, but it showed the top of the artboard.
When using the Tap trigger and Transition action, you can set Preserve Scroll Position
so the next artboard that appears will be scrolled to the same position as the artboard you
are coming from. Setting a Drag trigger or Auto-Animate action automatically scrolls to
the same position between artboards.

4. Back in the Travel_Design document, click the start or end of the repeat grid connection



on the original Hike Detail artboard to show the options pop-up window. Select Preserve
Scroll Position.
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5. Click in the Hike Detail artboard to show it in the Preview window, if you don’t see it
already. Back in the Preview window, scroll down to see the repeat grid.

6. Click the repeat grid to see the next hike description on the Hike Detail — 1 artboard.
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Note

You may notice that the positions of the repeat grid content appear to “jump”
because they aren’t in exactly the same horizontal position. To fix that, you can
make a copy of the repeat grid off the artboards. You can then ungroup the
repeat grid on both artboards (or before you duplicated the Hike Detail
artboard) and center the individual hike description content on each artboard.
You can also click one of the repeat grids and use the arrow keys to move it
into the same position as the other. You can check the position in the Preview
window by clicking in the Hike Detail artboard and scrolling down to see the
repeat grid content. You can then click in the Hike Detail — 1 artboard to show
it in the Preview window so you can see the position difference between the
two artboards.




7. Close the Preview window.

Setting up timed transition content

Another trigger you can use is called Time. A time trigger can only (currently) be applied to
connections between artboards, not for connections from an object to an artboard. Artboards with
a connection and a time trigger will transition between the artboards based on a specific delay.
This can be great for prototyping on-boarding or learning content, timers, and more.

In this section, you’ll create a timer for recording a hike using the Countdown artboard to start.
This will require adding a bit of text to the Countdown artboard and making a few copies of it,
along with changes, on the copied artboards.

1. Press Control+Tab (macOS) or Ctrl+Tab (Windows) to switch back to Design mode.

2. Zoom in to the Countdown artboard (the artboard with the orange background).

3. Select the Text tool ('T") and click in the Countdown artboard to add text. Type 3 and
press the Esc key to select the text object.

It may be difficult to see since it’s so small. You’ll change the font size next.

Note

If a border is applied to the text object, deselect the Border option in the
Property Inspector.

4. Change the following formatting options in the Property Inspector:

e Font Family: Helvetica Neue (macOS) or Segoe UI (Windows)

e Font Style: Bold

e Font Size: 1000

e Color: White (Change the fill color using the Assets panel.)
5. With the Select tool () selected, drag the number into position as you see in the figure.
6. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the artboards.



7. To make two copies of the Countdown artboard, Option-drag (macOS) or Alt-drag
(Windows) the Countdown artboard by its name, down below the original. Release the
mouse button and then the key.

8. Repeat this with the Countdown — 1 artboard to create a total of three identical
artboards.

9. Double-click the number 3 on the Countdown — 1 (middle) artboard and type 2. Finally,
double-click the number 3 on the Countdown — 2 (bottom) artboard and type 1.



Setting timed transitions

With artboards and content in place, now you can set up the timed transitions to create a timer.

Note

In the real world, you would copy this interaction and paste it on the start hike
button on the Hike Detail — 1 artboard. If the user drags the repeat grid at the
bottom to show the Hike Detail — 1 artboard, and then scrolls up, they will need
to have the option to tap the start hike button on that artboard.

1. Press Control+Tab (macOS) or Ctrl+Tab (Windows) to switch back to Prototype mode.

2. Zoom in a bit to the Hike Detail and Countdown artboards.

3. Click the start hike button on the Hike Detail artboard, and drag the connector to the
Countdown artboard. In the pop-up, change the following:

e Trigger: Tap (Notice that you only see Tap, Drag, and Voice for triggers—not
Time. That’s because you have to select an entire artboard to be able to set the
Time trigger.)

e Action: Transition

e Destination: Countdown

e Animation: Dissolve

e Easing: Ease In-Out

e Duration: 0.3

e Preserve Scroll Position: unselected



» Note

You could select the Countdown artboard, copy it, and paste the interaction to
the other artboards, but you still have to change the destinations for each
connection.

4. Click the artboard name Countdown to select the artboard. Click the connector on the
right edge of the artboard and set the following in the pop-up:
e Trigger: Time
e Delay: 0.4s
e Action: Transition
e Destination: Countdown — 1
e Animation: Dissolve
e FEasing: Ease In-Out
e Duration: 0.3
e Preserve Scroll Position: unselected
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5. Click the artboard name Countdown — 1 to select the artboard. Click the connector on
the right edge of the artboard and change the following in the pop-up:

|

e Destination: Countdown — 2

Dds

Countdonwn - 2

Drasobve b -

Lase in-Ont =

aks

O Fresen Seeol Positon

6. Click the artboard name Countdown — 2 to select the artboard. Click the connector on
the right edge of the artboard and change the following in the pop-up:

e Destination: Recording
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@ Note
The figure only shows a few screens. You should wind up with the Recording
artboard in the Preview window when all of the timers have run.

7. Click in the Hike Detail artboard, and then click Desktop Preview (p) in the upper-right
corner of the application window. In the Preview window, click the start hike button to
see the timer in action. When finished previewing, you can close the Preview window.
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8. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Setting up content for overlays



Overlays are an exciting type of action in Adobe XD that you can use to create sliding menus,
modal overlays, form overlays, and a lot more. In this section, on the Memory artboard, you’ll
add a field for users to type into. When a user taps (or clicks) in the field, the keyboard will slide
in so they can begin typing. The keyboard, as the overlay, needs to be on a separate artboard.

1.
2.

Press Control+Tab (macOS) or Ctrl+Tab (Windows) to switch back to Design mode.

Zoom out or pan in the Document window so you can see the Memory and Icons
artboards.

Select the Rectangle tool ([]) in the toolbar. Draw a rectangle above the keyboard and
below the “What kinds of fauna do you see?” text.
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Note

To see the names in the Assets panel, click the List View button (=) toward the
top of the panel. If the Grid View button (z2) is selected, you can move the
pointer over a color to see a tooltip with the color name.

5.

Press Command+Shift+Y (macOS) or Ctrl+Shift+Y (Windows) to show the Assets
panel, if it isn’t already showing. Right-click the orange-red color with the name
#FF491E, and choose Apply As Border to make the rectangle have an orange-red
border.
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6. To make room for a new artboard below the Memory artboard, drag the Icons artboard
by its name to below the Journal artboard.

7. With the Select tool () selected, Option-drag (macOS) or Alt-drag (Windows) the
Memory artboard by its name to make a copy beneath the original, named Memory — 1.
Release the mouse button and then the key.
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8. Drag across all of the content on the new artboard (Memory — 1), except for the

keyboard, to select it. To remove it, press Delete or Backspace. Drag the keyboard to the
top of the artboard.
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Now you’ll resize the artboard to match the size of the keyboard. You could leave the
Memory — 1 artboard the same size as the original Memory artboard, but you wouldn’t
be able to position the keyboard on the Memory artboard. Also, you would need to
remove the fill color for the Memory — 1 artboard; otherwise, when the keyboard slides
onto the Memory artboard, the Memory — 1 artboard would cover the Memory content
since it “overlays,” or is on top of, the content.

Note

The artboard will not snap to the keyboard content. You may want to click the
keyboard artwork to get the Height value in the Property Inspector. Then select
the artboard again and change the Height value in the Property Inspector to
match.

9. Click the Memory — 1 artboard name to select the artboard. Drag the bottom-middle
point of the artboard up to match the height of the keyboard as best you can.

10. Click the keyboard on the Memory artboard and press Delete or Backspace.

Creating overlays
Now that you have content in place, you’ll create the keyboard overlay.

1. Press Control+Tab (macOS) or Ctrl+Tab (Windows) to switch back to Prototype mode.

2. Click the rectangle with the orange-red border on the Memory artboard, and drag the
connector to the Memory — 1 artboard beneath it.



fauna do you see?

3. In the pop-up, change the following:
e Trigger: Tap
e Action: Overlay
e Destination: Memory — 1
e Animation: Slide Up
e Easing: Ease In-Out
e Duration: 0.3

After setting the Action to Overlay, you should see a green box with an X in the middle
of it on the Memory artboard. This indicates the size and position of the overlay. After
selecting Slide Up for the Animation, the green box is positioned at the bottom of the
Memory artboard since it will be positioned off the bottom edge of the Memory artboard
to start, and then slide up onto the artboard.

4. Press and hold in the middle of the green box on the Memory artboard to see a preview



of the keyboard on the artboard. Make sure the green overlay box is at the bottom of the
Memory artboard. If it isn’t, you can drag the keyboard overlay to position it in the
Memory artboard by dragging the green circle in the center of the overlay.
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5. Click Desktop Preview (») in the upper-right corner of the application window. Click
the rectangle in the Preview window to see the keyboard slide onto the Memory artboard
from the bottom. When finished previewing, you can close the Preview window.

6. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

Note

To save on Windows, you may need to click back in the Travel_Design
application window before saving.

Adding a voice trigger

The final type of prototype interaction you’ll explore is setting a voice trigger. When you select
Voice for the connection trigger, you can type in a phrase. When you preview your prototype,
you trigger the action by saying that phrase. When using a voice command or a time trigger, you
can also select Speech Playback as an action for your interaction. You can have your prototype
speak back to you during preview when triggered. In this section, you’ll start by adding a voice
interaction to the Recording artboard.

Note

Voice command and speech playback capabilities are available in English,
German, Japanese, Korean, Chinese, and French. Note that these capabilities
are based on the Language and Region settings on your computer. Speech
detection has been optimized for accents, and speech playback offers a wide
variety of voices with accents based on your region.

1. Option-drag (macOS) or Alt-drag (Windows) the Recording artboard by its name to



make a copy beneath the original, named Recording — 1. Release the mouse button and
then the key.
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Now, you’ll change the appearance of the orange-red and white circle artwork (a record
button) on the new artboard.

Note

Some of the content found on the Recording artboard was dragged onto the
artboard from the Creative Cloud Libraries panel. It was linked to the content in
the panel, so in order to edit it, you needed to break the link.

2. Press Control+Tab (macOS) or Ctrl+Tab (Windows) to switch to Design mode.

3. Click the orange-red and white circle toward the bottom of the new Recording — 1
artboard. Click the green link icon in the upper-left corner to break the link to the library
asset and embed the artwork in the document.
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4. Command-click (macOS) or Ctrl-click (Windows) the orange-red center of the selected



content to select just that part.

Tip
If the Assets panel isn’t yet open, you can open it by pressing
Command+Shift+Y (macOS) or Ctrl+Shift+Y (Windows).

5. In the Assets panel, click the black color to apply it to the fill.

F

6. Press Control+Tab (macOS) or Ctrl+Tab (Windows) to switch to Prototype mode.

Note
You may need to click more than once to select the button.

7. Click the orange and white record button toward the bottom of the original Recording
artboard.

8. Drag the connecting handle from the button, down to the Recording — 1 artboard beneath
it. When the Recording — 1 artboard has a blue border, release the mouse. In the pop-up,
change the following:

e Trigger: Voice

e Command: (type) Start recording
e Action: Auto-Animate

e Destination: Recording — 1

e FEasing: Ease In-Out

e Duration: 0.3
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10.

11.

12.
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Click the recording button on the Recording artboard to hide the pop-up.

Press Command+Return (macOS) or Ctrl+Enter (Windows) to open the Preview
window. Click in the Recording artboard in the document to show it in the Preview
window.

When the Recording artboard shows in the Preview window, you might see a message at
the bottom of the application window telling you to press the spacebar, say the phrase,
and then release.

5

Make sure that the Preview window is in focus (click in it). Press and hold the spacebar
and say the phrase “Start recording.” Release the spacebar.

Hold down the SPACERAR while speaking to use voice commands.

After a short time, the Recording — 1 artboard should appear and the record button
should have a black center in the Preview window.

Close the Preview window and press Command+S (macOS) or Ctrl+S (Windows) to
save the file.

Animating the record button Hi«

To see how to animate the record button, check out the video “Animating the record button,”

which is a part of the Web Edition of this book. For more information, see the “Web Edition’

b

section of “Getting Started” at the beginning of the book.

Adding speech playback

Another type of triggered action you can perform is Speech Playback. You can have a phrase
read aloud when an artboard appears in the prototype. In the case of the Travel_Design app,



you’ll make it so that after the user is finished recording, they will be taken to the Memory
artboard. The phrase “What kinds of fauna do you see?” will be read aloud, along with simple
instructions.
1. Click the record button at the bottom of the Recording — 1 artboard.
2. Drag the connecting handle from the button to the Memory artboard. When the Memory
artboard has a blue border, release the mouse. In the pop-up, change the following:
e Trigger: Tap (The user will tap the button to go to the Memory artboard.)
e Action: Transition
e Destination: Memory
¢ Animation: Dissolve
e Easing: Ease In-Out
e Duration: 0.3
e Preserve Scroll Position: unselected
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3. Click the Memory artboard name above the artboard to select it.
4. Click the connector on the right edge of the artboard.
5. In the pop-up window that appears after creating the connection, ensure that the
following options are set:
e Trigger: Time (That way, after a period of time, the voice will speak the phrase
you enter.)
e Delay: 0.2s
e Action: Speech Playback
e Voice: Kendra

e Speech: (type) What kinds of fauna do you see? Click the field to enter your
answer.



Woa
Wt kinds of
Tauna do you see?

6. Click in the Recording — 1 artboard so it will show in the Preview window to start. Press
Command+Return (macOS) or Ctrl+Enter (Windows) to open the Preview window.

7. In the Preview window, click the black record button to go to the Memory artboard.

After a short pause, you should hear “What kinds of fauna do you see? Click the field to
enter your answer” being read aloud. Make sure the speakers on your device are turned

up!
8. Close the Preview window.
9. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

10. If you plan on jumping to the next lesson, you can leave the Travel_Design.xd file open.
Otherwise, choose File > Close (macOS) or click the X in the upper-right corner
(Windows) for each open document.

Note

If you started with either the L.8_start.xd file or the L.8_prototyping_start.xd
jumpstart file, then keep that file open.

Review questions

1 What is meant by the “home screen”?

2 What are the two types of connections you can make in your prototype?
3 How do you edit a connection in Prototype mode?

4 What is a trigger in a prototype?

5 For Auto-Animate to work properly between artboards, what must you ensure when it
comes to the content that changes between the artboards?

6 What can you apply a time trigger to?



Review answers

1 The home screen is the first screen that users will encounter when they view your app or
website prototype. By default, the home screen is the topmost, leftmost artboard (in that
order).

2 The two types of connections you can make in your Adobe XD prototype are a
connection between content and an artboard or a connection between an artboard and an
artboard.

3 To edit a connection (link) in Prototype mode, you select either the content or artboard
that is linked or all of the content. You can then drag a connector away from the linked
content and release to remove it or drag a connector away from linked content to another
artboard.

4 Tn a prototype, a trigger is an interaction you set that triggers or causes the transition from
one screen to the next.

5 For Auto-Animate to work, the content that is meant to animate between artboards needs
to have the same name in the Layers panel.

6 To use a time trigger, you need to have an artboard selected.



9 Previewing a Prototype

Lesson overview
In this lesson, you’ll learn how to do the following:

e Record prototype interactions.
e Preview on device via USB.
e Preview a cloud document on device.

This lesson takes approximately 30 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the
lesson files and Web Edition.”

Your Account page is also where you’ll find any updates to the lessons or to the lesson
files. Look on the Lesson & Update Files tab to access the most current content.



http://peachpit.com

In this lesson, you’ll preview a working prototype in Adobe XD, record prototype
interactions that you can share with others as a video file, and preview your prototypes via
USB and cloud document, using the Adobe XD mobile app on a device.

Starting the lesson

In this lesson, you’ll create a working prototype from your app design and test it locally as well
as on a handheld device. To start, you’ll open a final lesson file to get an idea for what you will
create in this lesson.

Note

If you have not already downloaded the project files for this lesson to your
computer from your Account page, make sure to do so now. See the “Getting
Started” section at the beginning of the book.

1. Start Adobe XD CC, if it’s not already open.



2. On macOS, choose File > Open From Your Computer. On Windows, click the menu
icon (=) in the upper-left corner of the application window and choose Open From
Your Computer.

For either macOS or Windows, if the Home screen is showing with no files open, click
Your Computer in the Home screen. Open the file named L9_end.xd, which is in the
Lessons > Lesson09 folder that you copied onto your hard disk.

Note

The screen shots for this lesson were taken on macOS. On Windows, the menus
can be accessed by clicking the hamburger menu.

3. If you see a message at the bottom of the application window about missing fonts, you
can click the X on the right side of the message to close it.

4. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the design content. This
file shows you what you will create by the end of the lesson.

o

5. Leave the file open for reference, or choose File > Close (macOS) or click the X in the
upper-right corner of the open window (Windows) to close the file.

Recording a prototype

In Lesson 8, “Creating a Prototype,” you were introduced to previewing a prototype within
Adobe XD using the Preview window. At some point in the design process, you may also want
to share your prototype with others. One way to share a prototype is to record prototype
interactions and create a video in the MP4 format. In this section, you’ll record a video of the
prototype interactions in your Travel_Design file.

There are separate instructions for recording on macOS and Windows, so you only need to pay
attention to the instructions that pertain to the operating system you are using.



Note

If you are starting from scratch using the jumpstart method described in the
section “Getting Started,” open L9_start.xd from the Lessons > Lesson09
folder.

1. Choose File > Open From Your Computer (macOS) or click the menu icon (=) in the
upper-left corner of the application window and choose Open From Y our Computer
(Windows). Open the Travel_Design.xd document in the Lessons folder (or where you
saved it).

2. Click in the gray pasteboard to make sure everything is deselected. When you open the
Preview window in the next section, with nothing selected, the Home artboard will show
in the window.

Recording on macOS

To start, macOS users will explore how to create a prototype recording. Windows users can jump
to the next section, “Recording on Windows.”

Shane Decument
Share for Review
Sharg for Developmant

MSNBgD Links.

Tip
You can also open the Preview window by clicking Desktop Preview (») in the
upper-right corner of the application window. Then click the record option (the

timecode or the circle to the left) in the upper-right corner of the Preview
window to start recording.

1. Click the Share button in the upper-right corner of the application window and choose
Record Video. The Preview window opens and recording begins immediately.

2. Move the pointer into the Preview window and click the sign up button to transition to
the Sign up screen.
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When in the Preview window, while recording, the pointer shows as a circle, which
makes it easier to see and follow along with in the video. Notice that the timer in the
upper-right corner of the Preview window is changing, indicating that it’s recording.

John Doe

Audio can be recorded along with the video. On macOS (only), if you want to record
without audio, you can click the arrow to the right of the time code in the Preview
window and deselect Enable Microphone, and then record again.

Note
On macOS, recording also stops when you switch away from the application.

3. Press Esc to stop recording. In the dialog that appears, make sure the name is
Travel_Design, navigate to the Lessons > Lesson09 folder, and click Save.
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Recording prototype interactivity is easy using this method, which can make this a great
way to share that interactivity with someone else. Once the video file is saved, you can
share it via email and many other available options.

4. Close the Preview window.

macOS users can skip to the section “Previewing on a device.”

Recording on Windows

Recording prototypes is not directly supported in Adobe XD on Windows. However, there’s a
workaround using the native recorder to record what you do in the Preview window.

Note

To complete this section on Windows, you’ll need to have the Game Bar app
installed, which is available via the Microsoft Store.

1. Click the Share button in the upper right of the application window and choose Record
Video. The Preview window opens.

A message appears in the Preview window, telling you to press Win+G to begin
recording. The Windows Game Bar app, installed by default, will be used.

2. Press Win+G (Windows) to begin recording.



- Tip
You can also enable or disable the microphone in the Game Bar if you want to
record the audio.

3. In the Game Bar that opens, click the Record From Now button (the black circle) to
begin recording. The display should disappear, and a small toolbar with a timer and Stop
button appear in the operating system. You can control the recording from there.

10:00 AM
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4. Move the pointer into the XD Preview window and click the sign up button to transition
to the Sign up screen.

> Note

On Windows, recording doesn’t automatically stop when you switch away from
the application or when the Preview window does not have focus anymore.

5. Click Stop in the small floating toolbar to stop recording (an arrow is pointing to the
toolbar in the following figure). You can also press Win+G and click the Stop button in
the Game Bar that opens.



6. If you want to access the video that was created, you can press Win+G to show the
Game Bar, if it isn’t showing. You can then click the My Captures folder to show your
video captures.
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7. In the My Captures folder, open the video that was recorded by double-clicking to play
it.
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Previewing on a device

Previewing locally in Adobe XD using the Preview window can be an effective way to test links
and get an idea of what your design will look like. To truly experience your prototype, you
should test on a device such as an iPhone. The free Adobe XD CC mobile app lets you preview
designs you create in Adobe XD on iOS and Android devices.

Note

To learn more about system requirements for Adobe XD on mobile devices,
check out this page: helpx.adobe.com/xd/system-requirements.html.

There are two methods for testing on devices using the mobile app:

¢ Real-time preview via USB: You can connect multiple devices via USB to a computer
that is running Adobe XD, make changes to your designs and prototypes on the desktop,
and preview them in real time on all connected mobile devices.

¢ Loading cloud documents from Creative Cloud (available for documents created in
Adobe XD on macOS or Windows 10): If you save your XD documents as cloud
documents, you can load them onto your devices using Adobe XD on mobile.

Setting up

In this section, you’ll set up the Adobe XD mobile app on your device. There are a few things
you will need in order to proceed:
¢ Internet access to download and sign in to the Adobe XD mobile app

o A free or paid Creative Cloud account (preferably the same Creative Cloud account you
are using in Adobe XD)


http://helpx.adobe.com/xd/system-requirements.html

e The free Adobe XD app from the App Store for iOS (iPhones and iPads) or Google Play
store (Android phones and tablets)

Note
Visit www.adobe.com/products/xd.html#mobile to learn more.

1. With the Adobe XD mobile app installed on your device, launch the app.
2. Use one of these methods to sign in to the Adobe XD app:
¢ If you have a free or paid Creative Cloud account, click Sign In and log in with
your usual Adobe ID.

¢ If you don’t have a Creative Cloud account, either click Sign in with Facebook or
Google (to use an account you already have with one of those services) or click
Sign Up to create a free Adobe ID.

Note

If you create a new Adobe ID or choose to sign in with Facebook or Google,
the sign-in process will involve more steps.

After signing in, you will see the app home screen. By default, on the home screen, you’ll see
all of your cloud documents saved to Creative Cloud. If you haven’t saved any cloud
documents, the screen will resemble the figure to the right. You’ll learn more about saving a
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document as a cloud document in Lesson 10, “Sharing Documents, Prototypes, and Design
Specs.”

At the bottom of the screen (circled in the figure) you’ll see options for My Documents (which
is selected by default), Live Preview, and Settings. The Live Preview option is for previewing
a file that’s open in Adobe XD desktop on your device, and the Settings option is where you
can log out, check storage usage, and more.

Previewing via USB

Previewing via USB, or Live Preview, is available on macOS and Windows (currently, if your
device is running Adobe XD on Windows 10, real-time preview through USB is not supported
on Android). In this section, you’ll test the Travel_Design.xd prototype that is open in Adobe
XD on your device.

Note

The device needs to be unlocked. On macOS, depending on the device and
operating system of the device connected via USB to your computer, iTunes
may open.

1. Connect your mobile device to the USB port of the computer running Adobe XD on the
desktop.



Make sure the copy of Adobe XD on your desktop machine is up to date by checking the
Creative Cloud desktop app.

Note

Ensure that you use USB cables that transfer data. Some USB cables can be
used only to charge your devices and cannot transfer data.

Note

On Windows, if you are previewing on an iOS device, such as an iPhone, you
will need to have the latest version of iTunes installed.

2. Tap the Live Preview option at the bottom of the screen.

The Live Preview screen opens, and instructions may appear in the center of the screen
telling you to connect the device to your desktop and/or open an XD document in XD on
desktop.

3. Ensure that Adobe XD is showing on your desktop computer and that the
Travel_Design.xd file is also showing. The home screen (or currently selected screen)
should appear in the mobile app on your device.
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Note

In the figures in this section, the design prototype has black borders when
previewing in the mobile app on a device. That’s because the artboard size in
the design file is set to iPhone X/XS and I’m previewing the prototype on an
iPhone 8 Plus.

An example of an iPhone connected to my laptop via a USB cable




Note

In Adobe XD on the desktop, you may see a notification explaining that fonts
will be sent to your device(s) when you preview on mobile. If you see this
message, click OK. Please be aware that certain font vendors do not allow for
the transfer, display, and distribution of their fonts. You are responsible for
ensuring that you respect the font license agreement you have with the font
vendor.

If the open document in XD on the desktop doesn’t appear on your device, you can disconnect
and reconnect to the USB port on your machine. You can also close and then launch the Adobe
XD app on your mobile device.

Note

If you are testing on an Android device with macOS, make sure it is set to
transfer data through the USB port, not just transfer power (charging mode).
Visit this page to learn more: https://helpx.adobe.com/xd/help/adobe-xd-on-
mobile-fag.html#Android.

4. In Adobe XD on the desktop, you can close the Preview window if it’s still open. Click
Device Preview ([J) in the upper-right corner of the application window to see a list of
connected devices.
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If there are multiple devices connected via USB to your desktop machine, and they’re set
up to transfer data, they will all appear in the Preview On Device window.

Note

While viewing a prototype on mobile, if the required font is not present on your
device, you get an alert message. The fonts are substituted with available fonts.
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Tip

You can easily turn off the blue hotspot hints you saw in the previous section
by tapping with three fingers to show options, and then tapping the Hotspot
Hints toggle.

Note
If you rotate your device, the screens will scale to fit with letterboxing (black
bars) around them, if necessary.

5. With the Home screen of your prototype showing on your device, tap an area of the
screen where there are no links to see blue hotspot hints appear. You may need to tap a
few times at first to clear a message about tapping with three fingers to show the menu.
An arrow is pointing to the hotspot hint in the following figure.

By default, blue hotspot hints appear where you created connections in your prototype in
Adobe XD. You can turn off hotspot hints in the mobile app settings.

Note

If you haven’t created interactions (wires) on your prototype mode, you can
swipe right and left to navigate through your artboards on the mobile device. As
soon as you create an interaction (a wire), you won’t be able to navigate using
swipes. The reason behind that is that the interaction defined by you is
preserved, instead of letting the user, who is probably testing your prototype,
navigate to a specific artboard with a swipe gesture by mistake.

6. Tap the sign up button on the Home screen to go to the form.

7. Tap in the sign up screen (the screen with the form) to see the hotspot hint(s). Tap the
white back arrow at the top of the screen to return to the prototype Home screen.
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8. In your Travel_Design file in Adobe XD on the desktop, zoom in to the Home artboard
a bit. With the Select tool () selected, drag the sign up button on the Home artboard
down a little, to see the mobile app preview change in real time.
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9. Press Command+Z (macOS) or Ctrl+Z (Windows) to undo moving the object.
10. Save the document by pressing Command+S (macOS) or Ctrl+S (Windows).




Tip

After tapping with three fingers, you will see the Browse Artboards option in
the menu that appears at the bottom of the screen. You can quickly jump
between artboards by tapping an artboard thumbnail.

11. Back on your device in the Adobe XD mobile app, tap with three fingers on the device
screen to open the Adobe XD menu. Tap the arrow in the upper-left part of the screen, to
the left of the Travel_Design name, to return to the mobile app home screen, where you
will see the viewing options at the bottom of the screen.

sign up

12. Disconnect the USB cable from the device. Leave the mobile app open on your device
for the next section.

Since you will load a cloud file in the next section, you won’t need to have the cable
connected. If you want to return to a live preview of an open XD document, you will
need to reconnect the USB cable.

You can unplug the USB cable and continue viewing and testing a cached version of the
prototype. Without a connection, however, there will no longer be real-time updating if changes
are made in Adobe XD on the desktop. If you reconnect the cable while in the same session and
with the design file still open in Adobe XD, the app screen will refresh on your device.

Delete downloaded XD files from your device

To control the storage space on your mobile device, you can delete downloaded files by
tapping Settings > Preferences (from the app home screen after signing in).

Here you can view the amount of local space used, and then tap Remove Offline Documents



to delete XD documents downloaded to your device.

—From Adobe XD Help
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Previewing cloud documents

In the Adobe XD mobile app, you can also view a cloud document stored on Creative Cloud. To
open a cloud document in the mobile app, that cloud document needs to be shared with you, or
you need to save a document as a cloud document in Adobe XD on the desktop, which is what
you’ll do next.

In previous versions on Adobe XD, the XD mobile app allowed you to view Creative Cloud
files. The mobile app will no longer display documents saved as Creative Cloud files. In other
words, simply saving an Adobe XD document (.xd) into the Creative Cloud Files folder on your
hard drive or in Creative Cloud will not work. Files you wish to view in the XD mobile app can
be opened in Adobe XD and saved as a cloud document.

Note

To perform this step, you will need access to the storage that comes with your
Creative Cloud membership.

1. In Adobe XD on the desktop, with the Travel_Design file open, choose File > Save As
(macOS) or click the menu icon (=) in the upper-left corner of the application window
and choose Save As (Windows). In the menu of options that appears, change the name
to Travel_Design_cloud.

Note

You may see “Saving...” to the right of the filename in the title bar above the
document. When a document has finished saving to Creative Cloud (which may
take some time), “Saving” will disappear and show as “Saved.” The file won’t
show in the XD mobile app until it has finished saving in Adobe XD on the



desktop.

2. Click Cloud Documents in the Save To section, and then click Save.

Ak Travel Design_clowd — Saved ~

In the title bar above the document, a cloud icon (4) appears to the left of the name
above the document, indicating that it’s a cloud document.

By saving an XD document as a cloud document, you are saving it to a destination called
Cloud Documents, which is hosted on Creative Cloud. To view a cloud design file saved
in Creative Cloud, you do not need to have your mobile device connected to the USB
port of the computer running Adobe XD on the desktop. All you need is an active
Internet connection on the device.

Note
Saving the document as a cloud document may take some time, depending on
your Internet speed.

3. In the Adobe XD mobile app on your device, with the main app screen showing, tap My
Documents at the bottom of the screen (highlighted in the first part of the following

figure).
Files saved as cloud documents cannot be viewed if there is no Internet connection on
the device.

Note
The list of files you see will be different from those in the figure.

Tip

To refresh the list of XD cloud documents synced with Creative Cloud or to
update documents already in the list that you’ve edited and saved in Adobe XD,
pull the XD Documents screen down and release.



4. In the file list that appears, tap Travel_Design_cloud to load the document.
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Note

You may see a message telling you that you can tap with three fingers to see a
menu. You can tap the screen with one finger to dismiss it, if necessary.

Tip

After tapping with three fingers, you will see the Browse Artboards option in
the menu that appears at the bottom of the screen. If you were to tap Browse
Artboards, the artboards in the document would show as thumbnails. You can
quickly jump between artboards by tapping an artboard thumbnail.

5. Tap with three fingers on your device screen to open the Adobe XD menu. Tap the
arrow in the upper-left part of the screen, to the left of the Travel_Design_cloud name,
to return to the mobile app home screen, where you will see the list of cloud documents
again.

Now you’ll explore what happens when you update the XD file in Adobe XD.

6. In your Travel_Design_cloud file in Adobe XD on the desktop, with the Select tool ()
selected, make a simple change to the Home artboard. Maybe move the sign up button



on the Home artboard, as you did previously.
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After making the change, you’ll see “Edited” to the right of the name in the title bar
above the document, indicating that you made a change. If you make a change to the
design file in Adobe XD on the desktop, cloud documents are auto-saved. After some
time, you should see “Saved” to the right of the document name in the title bar. The file
will update in the app, assuming you have an Internet connection and aren’t currently
viewing it. If you want, you can make a cloud document available offline. That means it
will download in its current state and you can view it whether or not you have an active
Internet connection.

Note

The list of cloud documents will update automatically without you having to
pull to refresh the screen, but that may take some time, depending on your
internet connection.

7. Back on your device, in the XD app, with the cloud document list showing, drag the
screen down to refresh the list. This is a faster way to get the list to update with the latest
version of the file.



As stated earlier in this section, you will need to be connected to the Internet to view the
cloud documents and update them. What happens if you need to view a cloud document
and you know you won’t have an active Internet connection when you need to view it?
You can set cloud documents in the app to download to the device for offline viewing
later.

. Tap the ellipsis (...) to the right of the Travel_Design_cloud name in the app.

. Tap Available Offline to turn the option on. The document is downloaded in the current
state and will be available for offline viewing. Tap in a blank area of the screen to hide
the menu at the bottom of the screen.
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The Travel_Design_cloud document is downloaded to the device, and a blue circle with
a white arrow now appears on the filename in the app. When Available Offline is set for
a cloud document, any further changes made to the document in Adobe XD will be
applied as long as there is an Internet connection. Once the Internet connection is no
longer available, the document is left in the last saved state before losing Internet. As
soon as an Internet connection is available, the cloud document can be updated, even
though it’s still set to Available Offline.

Note

If you are viewing the cloud document in the XD mobile app and the document
has been updated in Adobe XD on the desktop, a message may appear when
you have an Internet connection, asking if you would like to update the file on
your device.

Note
Using the Adobe XD mobile app, you can also view files shared with you.

10. Close the app on your device and return to Adobe XD on your desktop.

11. Choose File > Close (macOS) or click the X in the upper-right corner (Windows) for
each open document.



Review questions

1 How do you record interactivity in your prototype in Adobe XD on the desktop?
2 What file format does Adobe XD create when recording interactivity in your prototype?
3 What are the two ways you can preview an XD document in the Adobe XD mobile app?

4 Which method of previewing in the mobile app, via USB or viewing a Creative Cloud
file, allows for real-time updates?

5 What is a cloud document?

Review answers

1 To record interactivity in Adobe XD on desktop, click the Share button in the upper-right
corner of the application and choose Record Video. On macOS, recording begins
immediately. After having tested the prototype, press Esc to stop recording. In the dialog
that appears, name the video file and click Save. On Windows, after the Preview window
is open, press Win+G to begin recording. You can start recording in the Game Bar that
appears. After you are finished recording, press Win+G again and click Stop.

2 When recording prototypes, the video file format is MP4.

3 When previewing an XD document in the XD mobile app, either you can view
documents saved as cloud documents or you can view an open document in Adobe XD
on the desktop using Live Preview.

4 Only previewing via USB in the mobile app allows for real-time updates.

5 A cloud document is an XD document that is saved in Creative Cloud from the Adobe
XD desktop app.



10 Sharing Documents, Prototypes, and Design Specs

Lesson overview
In this lesson, you’ll learn how to do the following:

e Understand the different methods of sharing.
e Share your cloud documents.

e Share your prototype for review.

e Update a shared prototype.

e Comment on a shared prototype.

e Share design specs.

e Update design specs.

e Manage shared links.

This lesson takes approximately 60 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the
lesson files and Web Edition.”

Your Account page is also where you’ll find any updates to the lessons or to the lesson
files. Look on the Lesson & Update Files tab to access the most current content.
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Sharing your projects with others is an important part of the design cycle because it allows
for collaborative editing, gathering feedback in the form of comments, sharing design
specifications, and more. In this lesson, you’ll learn how to share your documents in
different ways, depending on your needs.

Starting the lesson

In this lesson, you’ll learn about different methods for sharing your prototype, learn how to work
with comments, and manage your shared prototypes.

Note

If you have not already downloaded the project files for this lesson to your
computer from your Account page, make sure to do so now. See the “Getting
Started” section at the beginning of the book.

1. Start Adobe XD CC, if it’s not already open.

2. Choose File > Open From Your Computer (macOS) or click the menu icon (=) in the
upper-left corner of the application window and choose Open From Y our Computer
(Windows). Open the non-cloud document Travel_Design.xd in the Lessons folder (or
where you saved it).



3. If you see a message at the bottom of the application window about missing fonts, you
can click the X on the right side of the message to close it.

Note

If you are starting from scratch using the jumpstart method described in the
section “Getting Started,” open L10_start.xd from the Lessons > Lesson10
folder.

Note

The screen shots for this lesson were taken on macOS. On Windows, the menus
can be accessed by clicking the hamburger menu.

4. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the design content. Leave
the file open.

Methods of sharing

If you need to share designs and prototypes with others—to invite collaborators to edit a cloud
document, gather feedback on the design or prototype, or share design specifications with a
developer—you can use the Share feature from within the desktop version of Adobe XD. You
may choose to share at any point during the design process, from an in-progress design with no
interactivity to a fully interactive prototype.

Adobe XD allows you to share in the following ways:

e You can use the Share Document command to share a cloud document with others. All
invited collaborators can edit your document and save changes to the original file.

¢ You can share for review, which is saved to your Adobe Creative Cloud account, to the



web. You’re given a link to share with others for viewing and commenting in their
browser. Prototype sharing is meant to facilitate review and feedback.

¢ Share for development with others. Developers can inspect designs for measurements,
colors, and character styles, and copy them to be used when developing the app or
website in another application. They can also download any assets marked for batch
export.

When sharing a prototype or design specs, you can also allow for commenting. Commenting
takes place in the browser, and comments are stored along with the shared prototype in Creative
Cloud. Projects you share are associated with the Adobe ID you use to sign in to Adobe XD.

In this lesson, you’ll learn how to share a cloud document, share and update prototypes, share for
development, give and receive feedback, and manage your shared links.

Sharing a cloud document

In Lesson 2, “Setting Up a Project,” and Lesson 9, “Previewing a Prototype,” you learned what
cloud documents are and saved an XD document as a cloud document, respectively. In this
section, you’ll save another document as a cloud document and share it with another user. In
order to follow along in this section, you will need to have another XD user that you can send the
file to. That way, they can make edits and you will see how it works. If you don’t, you can
simply read along.

Cloud documents are XD’s cloud-native document type, providing users with a fast and
convenient method to manage, share, and retain up-to-date documents. You can save your XD
designs as cloud documents to ensure that they are up to date and accessible even when you’re
offline. You can then share them with other Creative Cloud users and invite those users to
collaborate. To share the Travel_Design document with someone else so that they can make
edits, the document must first be saved as a cloud document.

Note

To access the Share window, it doesn’t matter which mode is showing, Design
or Prototype. Design mode appears in the figures.

1. Click the Share button in the upper-right corner of the application window.
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In the Share window that appears, there are several sharing commands: Share Document,
Share For Review, and Share For Development. You’ll focus on Share For Review in
the next section. You can publish a prototype to the web using this method, which you



can then access via a link that you can share with others for viewing and commenting in
the browser.

2. Choose Share Document from the menu.

In the Share window, after choosing Share Document, you will most likely see a
message that tells you that the document needs to be saved to the cloud first.

3. Click Save As in the Share window.

Note

On Windows, the Save options window will appear in the center of the
document window.

4. In the Save options window that opens, change the name to Travel_Design_share. With
the Cloud Documents option selected, click Save.

Travel_Design ~

After the document is saved to Creative Cloud, you can share it with others. In the Share
window, after the document has been saved, you will see a place where you can add
people to share it with. Type an email address for each person you would like to share
the document with. Add a comma (,) between each email address if you want to send it
to more than one person.

5. Enter an email address in the field.



If you enter an email address that you’ve previously entered, you may see it appear
below the field. You may not see it now since it may be the first time you are sharing a
document.

6. Add a message in the Message field. I typed “Can you make the changes we discussed?”
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The message is optional, and the user will see the message in an email that he or she
receives.

7. Click Invite.

Collaboration Imvitation

Once you share a document, collaborators receive a notification from the Creative Cloud
desktop application as well as via email. The figure at right shows the recipient receiving
the notification.



After XD sends the invite, you (the initiator) will see a message indicating that it has
finished.

8. Click the Share button again and then choose Share Document. In the Share window,

you’ll now see a listing of users you’ve shared the cloud document with, including the
owner (most likely you).
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Note
When you remove a user from sharing, that user will no longer be able to edit
the file.

This is one place where you can track who has access to the document. You can also remove
invited collaborators from the shared cloud document. To do so, you would move the pointer

over an email address in the list (not the owner) and click Remove. You would then need to
click Save to remove them.
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9. Press the Esc key to hide the Share Document window.

All invited collaborators can edit your document and save changes to the original file. If
more than one collaborator has simultaneously opened the document, the changes made
by the first collaborator are updated to the cloud document, and the second collaborator
is given an option to save as a separate document.

NOTIFICATIONS a

@ Brian Wood invited you to edit Travel_Design_share

Can yous rake the changes we disoussed?

@ Get started with Adobe XD. Go from ideas to sxpeniends
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If an invited collaborator opens the Creative Cloud desktop app, that user will see a
notification and can click to open the file. That collaborator can also click Open in the
email he or she will receive. If a collaborator then makes a change to the shared
document and the file is saved, the owner will receive a message indicating that there’s a
newer version of the document available.

The changes can be accepted to reload the document with the new changes.
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Sharing a prototype for review

In this section, you’ll share the Travel_Design_share prototype to gather feedback about the
design and user experience. You can share a document that is either a cloud document or saved

locally.



Note

To share prototypes using the Adobe XD Share feature, you must be signed in

with an Adobe account to the Adobe Creative Cloud app or any other Adobe
application.

With the Travel_Design_share document open, click the Share button in the upper-right
corner of the application window to open the Share window.
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2. Choose Share For Review in the Share window.
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3. The first time you share for review, you will most likely see a screen that has a View
Example link and a Continue button. If you want to click View Example to explore, feel

free. The default browser on your machine will open. After you are finished, return to
Adobe XD and click Continue in the Share screen.
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4. In the Share For Review window that appears, set the following options:

Ensure that Anyone With The Link Can View is chosen from the menu at the top
of the window. You can make the shared prototype accessible by anyone who
has a browser and Internet connection, or you can choose Only Invited People
Can View from the same menu to send an email invite to certain people.

Title: Travel design app (The title appears when viewing the shared prototype
in a browser as well as when managing your shared links. Naming can be a
useful way to distinguish between versions of a shared project, for instance.)

Allow Comments: unselected (If this were selected, users could comment on the
prototype in the browser. Users can be either signed in with a Creative Cloud ID
or comment as a guest. For this example, we don’t need users to comment on the

prototype.)
Open In Full Screen: unselected (The default setting. Select this option if you
want the prototype to open in full screen when a user clicks the link.)

Show Hotspot Hints: selected (The default setting. This option allows users to
see hotspot hints in the prototype. If a user taps or clicks in an area that is not
interactive, the interactive areas are highlighted, showing where you can tap or
click.)

Require Password: unselected (You can restrict access to your prototypes and
design specs by adding password protection. You can password-protect new
prototypes or design specs only.)

Note

The prototype might take a little while to publish, depending on your Internet

speed.

5. Click Create Link to create a shared project.
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Once the prototype is created and saved to Creative Cloud, you will see more commands
in the Share For Review window. To view the prototype in the default browser on your
system, you can click the Open In Browser icon ([%). To share a link to the prototype
with others, you can click the Copy Link icon (£?). With the link copied, you can paste it
into an email, for instance, to share with others. To understand the Copy Embed Code
command ( ¢/3), see the sidebar “Embed a shared prototype in a web page.”

. Click the Open In Browser icon ([%) toward the top of the Share For Review window to
open the prototype in the default browser on your machine.

rryone with the Bri can view
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Cpen in Full Screen

The prototype opens in the default browser on your machine. The prototype home screen
will be centered in the browser window and will be the size of the artboard named
“Home” in Adobe XD (in this case). Above the prototype, you’ll see the title of the
prototype you set when sharing, and the date and time it was generated. For a list of
supported browsers, visit: https://helpx.adobe.com/xd/system-requirements.html.


https://helpx.adobe.com/xd/system-requirements.html
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Tip

You can also link to specific artboards in your design. With the prototype open
in the browser, navigate to a specific artboard. Copy the URL for that artboard.
You can then share that URL with others. The first screen they will see is the
artboard you saw in the browser when you copied the URL.

In the upper-right corner of the web page, you’ll see a place to sign in (or sign out if you’re
already signed in) and a way to make the preview fullscreen (,”). Below the home screen,
you’ll see left and right arrows for navigating between the artboards, a home icon (¢ ) to
return to the home screen, and an artboard counter, which currently shows 2. If your design
includes connections, only those artboards connected directly or indirectly (through other
artboards) to the home artboard are uploaded and shared.

Note
Fullscreen hides all UI elements in the browser window. To exit fullscreen
mode, press the Esc key.

To view a shared project, you don’t need to be signed in with an Adobe ID. Anyone with
access to the link can view the prototype in a desktop browser or in a browser on their device.

7. Interact with the prototype by clicking in the home screen to see the hotspot hints
available. Click the Sign Up button on the home screen to navigate to the next artboard.
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8. Click the home icon ( #%) below the artboard to return to the prototype Home screen.

9. Close the browser window and return to Adobe XD.

Embed a shared prototype in a web page

Prototypes you share in Adobe XD can be embedded in any web page that supports inline
frames (iframes). This can be useful if you want to showcase work you’ve done in Adobe
XD in a web portfolio, for instance.

Here’s how you copy embed code for a previously shared prototype from an open Adobe
XD file:
1. In Adobe XD, click the Share button in the upper right of the application window.
2. Choose Share For Review from the menu that appears.

3. In the Share For Review window that opens, click the Copy Embed Code option (</>).
When the code for embedding is copied to the clipboard, a message, “Code Copied,”
appears below the icon.
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With the code copied, you can paste it in the code of a web page or send it to someone else.
Below is an example of embed code:

<iframe width="375" height="812" src="https://xd.adobe.com/embed/8a9c6c62-4e51-
4424-5877-2605fc324238-fcad/”frameborder="0"allowfullscreen></iframe>

Updating a shared prototype

After sharing a prototype, you may decide that you want to make changes to the content or
maybe changing the home screen to share only a certain portion of the prototype. After making
changes to your project, you can share the project again. You will then be able to either create a
new shared prototype or update the existing prototype. Creating a new shared prototype can be a
great way to create versions of your prototypes.

Next, you’ll update the Travel_Design_share prototype by adding a few more connections.

1. Back in Adobe XD, click Prototype in the upper-left corner of the application window to
be able to edit the artboard connections.

2. On the Sign up artboard (below the Home artboard), click the Continue button. Drag its
connecting handle to within the bounds of the Explore artboard. When a subtle blue




3. In the pop-up that appears after creating the connection, ensure that the following are
set:

e Trigger: Tap (the default setting)
e Action: Transition (the default setting)
e Destination: Explore
e Animation: Slide Left
e FEasing: Ease Out (the default setting)
e Duration: 0.3 (the default setting)
e Preserve Scroll Position: unselected

4. Click in a blank area of the gray pasteboard to hide the pop-up.

Now you’ll connect the Explore — 1 artboard with the Hike Detail artboard.

5. On the Explore — 1 artboard (to the right of the Sign up artboard), double- click the
middle image in the repeat grid (the one that is horizontally centered in the artboard).




6. Drag the connecting handle from the right edge of the selected content to within the
bounds of the Hike Detail artboard. When a subtle blue highlight appears around the
artboard, release the mouse button.

7. In the pop-up that appears after creating the connection, ensure that the following are
set:

e Trigger: Tap (the default setting)

e Action: Transition (the default setting)

e Destination: Hike Detail

e Animation: Slide Left (the default setting)
e FEasing: Ease Out (the default setting)

e Duration: 0.3 (the default setting)

e Preserve Scroll Position: unselected

Now that changes have been made, you’ll update the link to the prototype.

8. Click the Share button in the upper-right corner of the application window to open the
Share window. Choose Share For Review in the Share window.



Note

The prototype might take a little while to publish, depending on your Internet

speed.

9. When the Share For Review window appears, ensure that the title is Travel Design app
and leave the rest of the settings at default. Click the Update button.

10.
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The shared prototype has now been updated to reflect the changes. Users you already
shared the link with can simply refresh the prototype in the browser. Clicking New Link
would have created a new prototype link with a different title (in this case) that you
could also share with others. Changing the title is useful for being able to later
differentiate between new links you create from the same project, maybe for creating and
keeping track of versions.

After the shared link is updated, click the Open In Browser icon ([4) in the Share For
Review window to view the prototype in your default browser.
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When the prototype opens in the browser, the first screen you’ll see is the Home
artboard. You should also now see that there are 13 artboards. Any artboards that have
direct or indirect connections to that artboard are a part of the shared prototype and can



be viewed in the browser.

11. Close the browser window and return to Adobe XD.

Sharing a prototype link with others

Projects you share in Adobe XD can be shared with others by copying the link to the
prototype and sending it to others. This can be useful if you want feedback on a public
prototype from stakeholders or team members, for example.

Here’s how you share a link to a previously shared prototype, from an open Adobe XD file:
1. In Adobe XD, click the Share button in the upper right of the application window.
2. Choose Share For Review from the menu that appears.
3. In the Share For Review window that opens, click the Copy Link icon (£).

With the code copied, you can paste it into an email, for instance.

Commenting on a shared prototype

When you share a project in Adobe XD, by default the shared prototype is set to allow for
commenting. Commenting is done in-browser when the shared prototype is viewed, and guest
commenting is allowed, which means anyone can comment because they don’t need to be signed
in with an Adobe ID. After you receive comments, you can go back to Adobe XD and update
your prototype, based on those comments. After making changes to the prototype, you can share
it again by updating the existing prototype or creating a new version.

In this section, you’ll share the project again, this time focusing on working with commenting.

1. In Adobe XD, with the Travel_Design_share cloud document open and Prototype mode
showing, click in the artboard named Home to select it.

At this point, we need to gather feedback on the app design. Previously, when you
published the Travel Design app prototype, you turned comments off. Next, you’ll share
a prototype and turn comments on.

2. Click the Share button in the upper-right corner of the application window to open the
Share window. Choose Share For Review.

3. Change the title to Travel Design app_v2, select Allow Comments, and click New Link
so the previous prototype you shared isn’t overwritten.
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Note
Depending on the speed of your Internet connection, this may take a little

while.

4. After the file is shared, click the Open In Browser icon ([4) in the Share For Review
window to view the shared prototype in your default browser.
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In the browser you should now see a comment icon (#) in the upper-right corner of the
browser window (circled in the previous figure).




Note

If you are not signed in when the page opens, click Sign In and sign in with
your Adobe ID. To learn more about guest commenting, see the “Guest
commenting” sidebar.

5. If the Comments panel isn’t already showing, click the comment icon ( ) on the right to
open the Comments panel.
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Note

Any users who are currently viewing the prototype will see the comments
added without having to refresh the page. If you find that new comments from
other users are not showing, you can refresh the web page and show the
Comments panel again.

6. Click in the field that shows the text “Make a comment,” and type Need to add an
option to log in and either click the Submit button or press Return or Enter to add the
comment. Leave the prototype open in the browser for the next section.
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The comment will appear in the Comments panel. If you are signed in with your Adobe
ID and you initiated the review, you will see “Owner” next to your name. As the owner,
you can add, reply to, delete, and resolve your comments or guest comments.



Guest commenting

When viewing a shared prototype in a browser, with the comments showing, reviewers can
either sign in using their Adobe ID or sign in as a guest when commenting on a shared
project.

To sign in as a guest, reviewers click Comment As A Guest at the bottom of the Comments
panel. They supply a name and select I’'m Not A Robot for the Captcha. They can then click
Submit.

If, after commenting as a guest, a user ends the session by closing or refreshing the browser,
he or she will have no control over the previous guest comments they made. On the other
hand, if reviewers sign in using their Adobe ID, they can edit their previous comments.
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Pinning comments

Pinning comments is a great way to visually associate a comment with a specific area of an
artboard. When you pin a comment, Adobe XD assigns a number to that comment. The
comments in the Comments panel show these numbers, so you can easily identify which
comment is associated with which number on the artboard. Generic comments, like the first
comment you added, are not pinned and do not show a number. Next, you’ll add another
comment and pin it to an artboard.

1. With the shared prototype still showing in the browser, click the Sign Up button on the
prototype Home screen to show the next screen.

The comments from the previous artboard are still showing in the Comments panel



because the All Screen Comments option in the Comments panel is selected. The
comments are organized by screen, and you can see the name of the screen in the
Comments panel list. If you only wanted to see the unique comments for a specific
artboard, you could deselect All Screen Comments—but do not do so right now.

Tip
If you click a screen name, such as Home, that screen will show in the browser.

2. Click in the field that shows the text “Make a comment,” and type add keyboard here
when tapping a field.

Tip
While pinning a comment, you can press the Esc key to cancel pinning.

3. Click the Pin icon ( #) that appears below the comment.
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4. Move the pointer over the Sign up screen, and click at the bottom to set a comment pin.
You can drag the number where you want it on the screen.

continue

5. Click Submit in the Comments panel to accept the comment.
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The number associated with the comment is a visual way to locate the comment in the
Comments panel and in the shared project.
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continue Sign up
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Reply 21 seconds ago

6. Click the Pin icon ( #) in the Comments panel, move the pointer onto the screen, and
click just above the “John Doe” text to set the comment pin.
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7. Add another comment in the Comments panel by typing Make text larger. Click
Submit in the Comments panel.

8. Move the pointer over the first comment marker (1) at the bottom of the screen to subtly
highlight the associated comment in the Comments panel.
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When there are a number of pinned comments, this can help you find the comment
associated with a comment pin in the Comments panel.

9. Leave the prototype open in the browser.

Working with comments

With comments added to the artboards in your shared prototype, in this section you’ll explore
replying to comments, deleting comments, and more, in that same prototype.

Tip
To view the prototype in the browser without comment pins on the artboards,
hide the Comments panel by clicking the comment icon ().

1. With the prototype still open in the browser and the Comments panel showing, move the
pointer over the comment marked “2” in the comments list on the right. The
corresponding pin is highlighted in the prototype.
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Comments in your shared prototype can be edited, deleted, replied to, and marked as
resolved.

2. Click the pin icon ( #) under the comment. Move the pointer out into the screen and
click to the right of the “Already have an account?” text.

This is an easy way to edit the location of a comment pin.
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- Tip
If you want to delete a comment, you can click the trash can icon () and
verify you want to delete the comment.

3. For the same comment, click the Edit icon ( #) below the comment to change it.
Change the comment from “Make text larger” to “Make text larger and bold.” Click
Save Changes.
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Not only can you edit comments, but you and others can reply to comments. Next, you’ll
add a reply to the same comment, marked “2.”

4. Move the pointer over the comment marked “2” in the comments list. Click Reply to
add a reply to the original comment. Type How about changing the text color instead?
and press Return or Enter to add the reply.
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5. Click the small arrow to the left of the “1 Reply” text to collapse the comment reply.

Replies to comments appear under initial comments. Comment replies will be collapsed
when viewed by other commentators and will need to be expanded to be viewable.

Need to add an option ta log in

35 minutes ago
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Note
You can’t edit other reviewers’ comments. The owner can delete guest
comments, but guest commentators cannot delete or edit comments by others.

6. Move the pointer over the comment labeled “2” and click Resolve.
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Marking a comment as resolved removes it from the list of comments. This method can
be used as a way to mark comments as “done,” for example. Resolved comments can
still be viewed by filtering the comments list, which is what you’ll do next.

Tip

When viewing resolved comments, you can also unresolve a resolved comment
by moving the pointer over the comment and clicking the Move To Unresolved
button in the Comments panel.

7. Click the Filter icon ('y) toward the bottom of the Comments panel to see a window
with filtering options. Click Resolved in the Status section of the window to see any
comments that have been marked as resolved.

D) All Screen Comments @

There are several useful filtering options in the window that is showing, including
filtering by reviewer and time. Notice that the filter icon (4*) now has an indicator that




one or more filters have been applied.

8. Click in a blank area of the browser to close the filter window. Move the pointer over
the comment in the Comments panel and click Move To Unresolved when it appears.
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The comment should now be back in the main comments list. To see those comments,
you’ll clear the Resolved filter.

Tip
You may also see Clear Filter in the Comments panel without having to click
the Filter icon.

Note
In the figure the Clear option was already clicked.

9. Click the Filter icon (y*) to see the window with filtering options. In the same window,
click Clear to remove the filtering and return to the main comments list.

D) All Screen Comments. T

Comments added by users are stored with the shared prototype. To see comments from a
previous version of a shared project, you would need to manage your shared links, which

you’ll do next.

10. Close the browser window and return to Adobe XD.



The comments made in the browser for a prototype do not show in Adobe XD when the
associated project file is open.

Creative Cloud comment notification

If you’re the initiator of a shared prototype and someone you’ve shared the prototype with
adds comments, when viewing the prototype in the browser a notification will appear (the
first part of the following figure). You can click the notification icon to see the comments
they’ve made.

Also, in the Creative Cloud desktop app, you can click the notification icon to view the
comments (the second part of the following figure).
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As for the users that you, as the initiator, shared the prototype with, if they are logged in
with an Adobe ID or as a guest, they will only see a number on the comment icon in the
browser, and will not receive the same notifications.

Note: Currently, the initiator will also receive email notifications when comments are made.
You can set the email communication preferences by visiting
https://accounts.adobe.com/communication. You will need to sign in with the same Adobe
ID that you use for Adobe XD.

Sharing design specs

As you near the end of the design process and get ready to move to development outside of
Adobe XD, you can publish design specs. This creates a public URL, similar to sharing a
prototype, which you can share with others. These specs can improve communication by
allowing developers to view the sequence and flow of artboards, as well as detailed specs for
each artboard, complete with measurements, colors, character styles, relative spacing between
elements, and more.

In this section, you’ll share design specs and explore the design specs in your default browser. A
part of sharing design specs with others is to allow assets to be downloaded when they are
viewing the design specs in the browser. To allow them to download assets, you need to mark
assets for export in the Layers panel, which is what you’ll do first. You do not need to mark
assets for export to share design specs.

1. Click Design in the upper-left corner of the application window to show Design mode, if
it isn’t already.

2. Open the Layers panel by pressing Command+Y (macOS) or Ctrl+Y (Windows), if it
isn’t already showing.


https://accounts.adobe.com/communication

3. With the Select tool selected, on the Home artboard, click the gradient-filled rectangle
behind the “field guide” text. You should now see the edges of the image behind it.
Click the image area outside of the artboard or click the image in the Layers panel list.

4. In the Layers panel, move the pointer over the selected image in the list of layers. Click
the Mark For Export icon ([7) to make the image available for download to anyone who

views the design specs.
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Now that you’ve marked an asset for export, you’ll share the design specs.

Tip

As with shared prototypes, whichever artboard is set as the home screen will be
the first artboard users see in the design specs. Any artboard with a direct or
indirect connection to that home screen artboard will be published.

5. Click the Share button in the upper-right corner of the application window to open the
Share window. Choose Share For Development.

When sharing, you can have either Design mode or Prototype mode showing.
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Note

To share prototypes or design specs using the Adobe XD Share feature, you

must be signed in with an Adobe ID to either the Adobe Creative Cloud app or
any other Adobe application.

In the window that opens, if you see a message that shows a link to an example, you can
simply click Continue.

Share Your Design Specs with Developers
Start having dincunsions o your deign by
sharing it with your developers.

Witw Example

=

7. In the Share For Development window, change the following:



e Choose Only Invited People Can View from the menu at the top of the window.
As with sharing prototypes, when sharing design specs you can make the shared
prototype accessible by anyone who has a browser and Internet connection, or
you can choose from the same menu to send an email invite to certain people.

e Title: Travel Design dev (The title appears when viewing the shared prototype
in a browser as well as when managing your shared links.)

e Export For: iOS (the default setting) (The units for the shared prototype are
based on the artboard size of the home screen. The home screen in this file was
set to the iPhone X/XS preset size. Adobe XD recognizes the default artboard for
the home screen as being sized for an iPhone (i0S) and sets the units
accordingly. The units are important when viewing the design specs in the
browser because you can copy and paste the number value along with the unit of
measurement—px, dp, or pt—that you need.)

¢ Include Assets for Download: selected (This setting is available because one
asset was marked for export. If there were no assets marked for export, this
option would be dimmed.)

Note

The default unit for iOS is pt, the default unit for the web is px, the default unit
for Android is dp, and the default unit for custom-sized artboards is px. These
default units are not editable.

Understanding the Export For option when sharing design
specs



Based on the platform you create the design for, each platform has a separate set of
resolution settings. Web: Assets are exported at 1x and 2x resolutions. iOS: Assets are
exported at 1x, 2x, and 3x resolutions. Android: Assets are optimized and exported for the
following Android screen densities:

e ldpi - Low density (75%)

e mdpi - Medium density (100%)

e hdpi - High density (150%)

e xhdpi - Extra high density (200%)

e xxhdpi - Extra extra high density (300%)

e xxxhdpi - Extra extra extra high density (400%)

—From Adobe XD Help

8. Click Create Link.

Because you chose Only Invited People Can View from the menu at the top of the Share
For Development window, the next screen you see will be to invite users to access the
design specs.

9. With the Invite option automatically selected in the window, enter an email address or
multiple email addresses separated by commas. You can add a message that users will
see. Click Invite.
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The design specs are published and saved in Creative Cloud.

Note

Unlinked artboards are not published in the design specs. The position of the
artboards in the browser when viewing the design specs is identical to the
position of the artboards in the design file.

Note
Mobile browsers are not supported or recommended for viewing design specs.

10. Click the Open In Browser icon ([%) toward the top of the Share For Development
window. You may need to click the Share button and then choose Share For
Development to see the Share For Development window.



In the upper-left corner of the page in your browser, you’ll see information about the
design specs, such as the name and number of artboards. In the upper right you’ll see the
Invite button for inviting others to view the design specs, a search field, a view
percentage, and a place to sign in (or sign out if you’re signed in). Next, you’ll begin to
inspect the design specs.

Inspecting design specs

Browser-based design specs allow everyone involved on a project to view the sequence and flow
of artboards in what’s called the UX flow view. This view of all the artboards (screens) in the
design specs shows the number of artboards that need to be developed (useful for planning the
scope of development work), the sequence and flow in the design specs (useful for understanding
the end-user workflow), the date when the design specs were last updated, and more.

In order to view design specs, whomever you share the design specs link with will need the
following:

e A link to the design specs (In the previous section, you saw the Copy Link option to copy
the link to the design specs from the Publish Design Specs window in Adobe XD. You
can paste that link in an email or other method of communication.)

e A supported desktop browser and Internet connection

Note

For a list of supported browsers, visit helpx.adobe.com/xd/system-
requirements.html.

Next, you’ll explore the design specs currently open in the browser.


http://helpx.adobe.com/xd/system-requirements.html

Note

If you see a message across the bottom of the web page, you can click the X on
its right side to dismiss it.

Tip

You can zoom and pan to view specific details. To pan, use the trackpad or
press the spacebar to activate the Hand tool. To zoom in or out, use the Zoom
menu in the upper-right corner of the page, pinch in or out on your trackpad, or
press Command and +/- (macOS) or Ctrl and +/- (Windows.

1. With the design specs open in your browser, move the mouse over individual artboards
to see how they are connected to each other.
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In the UX flow view, you can zoom or pan, search for a specific artboard by name in the
upper-right corner of the web page, and more.

2. Click the Home artboard to see a detailed view of it.
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To the right of the artboard in the browser window, you can see all the unique screen
details, colors, character styles, and interactions used on that artboard. The colors and
character styles you see when viewing an individual artboard in the browser may differ
from those found in the Assets panel when the original project file is open in Adobe XD.
The design specs show all formatting applied to the content, whether it’s been saved in
the Assets panel or not.

. Move the pointer over the white color in the Colors section on the right. Objects that
have the white fill or border color are highlighted on the artboard.
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Tip

You can change the color format by clicking Hex above the color swatches and
choosing another format, such as HSLA. You can also change the unit that
appears in the character styles by clicking the menu to the far right of
“Character Styles” (the figure shows “pt”; you may see something different)
and choosing another unit, such as px or dp. This change is persistent across the



entire session—the same color formats and measurement units are used when
you view other screens.

4. Click the orange color in the Colors section on the right side of the page.

Clicking a color or a character style will copy the formatting to the clipboard. For
instance, copying a color will copy the Hex value of #FF491E (in this case). If you click
to copy a character style, only the name of the font is copied. You can then paste the
value into your code or into an email, for example.

Now you’ll navigate to the next artboard.

5. Scroll down in the area on the right to see the Interactions section, if you don’t already
see it.

Interactions for a screen are the connections created in Prototype mode. You can see the
options set for the connection, and if you click it, the connected artboard will appear in
the browser window.

6. Move the pointer over the interaction to see the Sign Up button highlight. You may need
to scroll in the browser window to see the bottom of the screen. Click the interaction you
see to go to the Sign up artboard.

sign up « varsass

Triggee Tag
A Trasitn
[

Selecting objects that have a connection set in Prototype mode shows a thumbnail of the
target screen (artboard) on the right in the browser. In most cases, you could click the
target screen to navigate to it. For some connections, like those set to previous artboard,
the target for the selected content won’t work if you click it.



Note

As of this writing, while viewing the design specs in the browser, if you select a
grouped object, you won’t see the target you set while prototyping in Adobe
XD. Selecting objects while viewing the design specs in a browser selects only
individual objects.

. On the Sign up artboard, click the John Doe text on the artboard.

s
Johin Lrg n Faigfna Mo, Fagular
Nt

joehncoedmail.com =0

LTI

After you select an element on the artboard, you can view its height and width
coordinates, as well as the properties of the selected content, on the right side of the
page. You can also copy the character styles, color values, and content from the design
specs.

Adobe XD focuses on the relationships between elements. So, for example, if you design
an iPhone X/XS artboard at 375x812 units and it uses type with a 10-unit font size, that
relationship remains the same, no matter what physical size your design is scaled to.

However, in the design specs in the browser, height and width measurements and X and
Y coordinates are displayed in px, pt, or dp. When viewing design specs in the browser,
the unit of measurements can be changed from one unit to another, depending on the
need. This feature allows you to copy and paste the number value along with the unit of
measurement (pX, pt, or dp) that you need.
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Tip
With text formatting showing, you can click certain properties like the font
name (Helvetica Neue, on macOS) to copy it to the clipboard.




8. Click the Next arrow (>) below the artboard to navigate to the Explore — 1 artboard.
9. Click the text “Pine Meadow Lake Loop.” You may need to scroll to see it.

o g

10. In the Content section on the right side of the page, click the text in the Content area to
copy it.
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The text is copied to the clipboard and can now be pasted wherever you need it. This is
great for developers who need the content, such as text, to develop the app.

11. Click the image in the middle of the screen, then move the pointer over the image to the
right to see the relative distance between the objects.

my hikes my hikes

) Pine Meadow Lake ™ Pine Meadow Lake

If you’re a developer, this can be very useful information as you build the app elsewhere.

12. Click All Screens in the upper-left corner to return to the UX flow view.
13. Close the browser window and return to Adobe XD.
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Updating design specs

After sharing design specs, you may want to make changes to the project. When that happens,
you first edit your project in Adobe XD and then share the newly updated design specs by
overwriting the original design specs or creating a copy.

Next, you’ll make a simple design change and update the design specs.

1. Back in Adobe XD, make sure that Design mode is showing with the
Travel_Design_share.xd file open. Click Design in the upper-left corner of the
application window, if necessary.

2. Zoom in to the Home artboard.

Note

You don’t need to save the file in order to update the design specs. Also, since
this is a cloud document, auto- save should save it automatically.

4. Press Command+S (macOS) or Ctrl+S (Windows) to save the file.

5. Click the Share button in the upper-right corner of the application window to open the
Share window. Choose Share For Development.
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6. In the Share For Development window, click the Settings tab and then change the Title
to Travel Design dev v2. Click New Link to create new design specs to share.

Changing the title is useful for being able to differentiate between new links you create
from the same design specs. You will need to share the new link you just created with
anyone who has the link to the original design specs in order for them to see the updates.
The old link to the design specs will continue to work, but it will not be updated when
you make changes to the original project file in XD.

In the Share For Development window, clicking the Open In Browser option ([%) would
allow you to view the newer version of the design specs in your default browser.

7. After the design specs are finished uploading, click away from the Share For
Development window to hide it.

Managing shared links

Every time you share a cloud document, prototype, or design specs, it’s saved in Creative Cloud
and is tied to the Adobe ID used to sign in to Adobe XD. Next, you’ll see how to manage cloud
documents, prototypes, and design specs you’ve shared.

Tip

You can also choose File > Manage Links (macOS) or click the menu icon (=)
in the upper-left corner of the application window and choose Manage Links
(Windows).

1. Click the Share button, and in the Share window, choose Manage Links.
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A website opens in your default browser, where you can manage your published

prototypes and design specs. If you aren’t already signed in with your Adobe ID, you
will need to do so in order to see your shared projects.

Beneath the name of each link, you’ll see a label for “Prototype” or “Design Specs” to
tell you what type of shared link it is. If you click a thumbnail, you will open the
prototype or design specs. This is a way to revisit a previously shared prototype and
even share it again by copying the URL in the browser window and sharing it.

Move the pointer over the design specs you shared in the previous section. Click the

ellipsis (...) to show a menu. From that menu you can copy a link to the design specs or
delete it.
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The Manage Links command in the Share window is meant to show you your shared
prototypes and design specs, but you can also access your cloud documents.

3. Click Files on the left side of the page in the browser to show files stored in Creative
Cloud, including cloud documents.

4. Click Cloud Documents at the top to show your cloud documents.
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You should now see the cloud documents you’ve saved. From here, you can view a



cloud document by clicking its thumbnail, or you can delete it.

5. Close the browser window and return to Adobe XD.

6. To close the Travel_Design_share.xd file, choose File > Close (macOS) or clicking the
X in the upper-right corner (Windows), saving it if prompted.

Review questions

1 What does the Share Document feature allow you to do?
2 When you share a prototype, where are the files stored?
3 How do you embed a shared prototype in a web page?

4 Who can comment on a shared prototype?

5 What is a pinned comment?

6 What is a resolved comment?

Review answers

1 You can use the Share Document option to share a cloud document with others. All
invited collaborators can edit your document and save changes to the original file.

2 Shared prototypes are associated with the Adobe ID associated with Adobe XD, and the
prototype is stored in the Creative Cloud account associated with the Adobe ID.

3 To embed a shared prototype in a web page, with an Adobe XD file open, click the Share
button. In the Share window that opens, choose Share For Review. With the prototype
already shared, you will see a series of options at the top of the Share For Review
window. Click the Copy Embed Code option ( </3) and either paste the code into any web
page that supports it or share it with others so that they may embed the shared prototype
in their web page.

4 Commenting is done in a browser by users signed in with an Adobe ID as well as by
guests (users without an Adobe ID).

5 When viewing a shared prototype in your default browser, you can pin a comment to a
location in an artboard. When a comment is pinned, it is assigned a number. The
comments in the Comments panel show these numbers, allowing you to easily identify
the context of the pinned comment. Comments that aren’t pinned do not show a number.

6 When viewing a shared prototype in your default browser, marking a comment as
resolved removes it from the list of comments and can be used as a way to mark
comments as “done,” for example. Resolved comments can be viewed by clicking the
Filter icon (y') toward the bottom of the Comments panel to see a window with filtering
options. Click Resolved in the Status section of the window to see any comments that
have been marked as resolved.



11 Exporting and Integration

Lesson overview
In this lesson, you’ll learn how to do the following:

e Export assets.
e Use XD plugins.

This lesson takes approximately 30 minutes to complete. Please log in to your account on
peachpit.com to download the lesson files for this lesson, or go to the “Getting Started”
section at the beginning of this book and follow the instructions under “Accessing the
lesson files and Web Edition.”

Your Account page is also where you’ll find any updates to the lessons or to the lesson
files. Look on the Lesson & Update Files tab to access the most current content.
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After you’ve shared a working prototype, gathered feedback, and implemented the
suggested changes, you can create production-ready assets for development. In this lesson,


http://peachpit.com

you’ll export assets in a variety of formats and expand what is possible with XD using
plugins.
Starting the lesson

In this lesson, you’ll learn how to share design assets by exporting and also how to enhance your
design workflow with third-party plugins.

Note

If you have not already downloaded the project files for this lesson to your
computer from your Account page, make sure to do so now. See the “Getting
Started” section at the beginning of the book.

1. Start Adobe XD CC, if it’s not already open.

2. Choose File > Open From Your Computer (macOS) or click the menu icon (=) in the
upper-left corner of the application window and choose Open From Y our Computer
(Windows). Open the non-cloud document—Travel_Design.xd document in the Lessons
folder (or where you saved it).

3. If you see a message at the bottom of the application window about missing fonts, you
can click the X on the right side of the message to close it.

Note

If you are starting from scratch using the jumpstart method described in the
section “Getting Started,” open L11_start.xd from the Lessons > Lesson11
folder.

Note

The screen shots for this lesson were taken on macOS. On Windows, the menus
can be accessed by clicking the hamburger menu.

4. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the design content. Leave
the file open.



Exporting assets

At any point in the design process, you can create production-ready assets. With Adobe XD, you
can export assets for developers and others involved in the project. Assets can be exported in the
following formats: PNG, SVG, PDF, and JPG.

e PNG (Portable Network Graphic): A raster graphics format best used for raster images
such as banners.

e SVG (Scalable Vector Graphic): A vector image format that is best used for icons, logos,
and page elements.

e PDF (Portable Document Format): A format for exchange that retains all vector, image,
and text content. This is best for sharing your project designs.

e JPG or JPEG (Joint Photographic Experts Group): A raster graphics format best used for
photographs and other images.

If your XD project was created as a proof of concept, you may want to export artboards to PDF
(single PDF or multiple PDFs) or as images. To provide production-ready assets, you can export
individual assets from your project in the previously mentioned formats. Given the need for
responsive websites and apps, you will likely need to provide raster assets at multiple sizes to
enable use on devices with different screen sizes and pixel densities.

When exporting assets, any selected content or artboard in your project is exported. If nothing is
selected, all artboards are exported. Exported assets are named according to the name of the asset
or artboard in the Layers panel. In the next few sections, you’ll export artboards and design
content in different formats.

Exporting as PDF

Exporting as PDF allows you to export what you see on the screen (artboards or selected
content). Saving as PDF is a great way to share your content for review so the end user doesn’t
need Adobe XD to view the design. In this section, you’ll export all of the artboards as PDF and
explore the export options.

1. With the Travel_Design.xd file open, make sure that Design mode is showing. Click



Design in the upper-left corner if it’s not showing.
You can export content in either Design mode or Prototype mode.

2. With the Select tool () selected, click in a blank area away from the artboards to
deselect anything that is selected.

3. Choose File > Export > All Artboards (macOS), or click the menu icon (=) in the
upper-left corner of the application window and choose Export > All Artboards
(Windows).

With nothing selected, you will only see two export options: All Artboards and Batch. If
you select a series of artboards before exporting, you will see the same All Artboards
command as well as the command File > Export > Selected to export only the selected
artboards. If you choose File > Export > All Artboards, all artboards are exported,
regardless of whether individual artboards are selected.

Note

Content on the pasteboard that is not associated with an artboard will not be
included in the PDF.

4. In the export dialog box, navigate to the Lessons > Lesson11 folder (macOS), or click
Choose Destination (or Change) and navigate to the Lessons > Lesson11 folder
(Windows), and change the following options:

¢ Format: PDF

e Save Selected Assets As: Single PDF File (the default setting) (If you choose
Multiple PDF Files with PDF chosen, each artboard will be saved as a separate

PDF.)
5. Click Export All Artboards.
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The export dialog box on macOS
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A PDF named Travel_Design.pdf will be generated from all of the artboards and placed
in the Lesson11 folder. That can be a useful way to share your design with others, and
they only need to have a PDF reader to view the PDF.

Exporting as SVG

If your project contains vector graphics, it’s best to export them in SVG format. As with all
vector graphics, graphics in SVG format are infinitely scalable, so there’s no need to export the
same graphic at multiple resolutions. As an SVG graphic scales to accommodate various devices
with a range of screen sizes, it remains crisp and clean. Icons, logos, and other drawn (rather than
painted) page elements are perfect candidates for the SVG format. In this section, you’ll export
the map artwork as SVG and explore the export options.

1. Make sure the Layers panel is showing by pressing Command+Y (macOS) or Ctrl+Y
(Windows), if necessary.

2. With nothing selected in the document, double-click the Sign up artboard icon ([) in
the Layers panel to zoom in to it.
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Note

Selecting a series of objects in your document will result in an SVG file being
generated for each.

3. Double-click the person icon to the left of the John Doe text on the artboard, to select



the icon group.

Sigh up Explons - 1

Looking in the Layers panel, you can see that the asset name is icon (or something
similar). When you export assets on macOS, you can change the name of the asset in the
export dialog box. On Windows, the asset name is the same as the name of the content in
the Layers panel and can’t be changed in the export dialog box.

Note

As a best practice when naming assets for use on web or app, avoid spaces in
names. You can use hyphens (-) or underscores (_) in the names instead.

Tip
The assets you export are named according to the name found in the Layers

panel. Naming content according to a final asset naming convention in the
Layers panel can make it faster to export assets.

4. Double-click the name “Icon” in the Layers panel (or whatever it is you see), change it
to icon-person, and press Return or Enter to accept the change.

@ XD File Edit Object Plugins View Window Help
@B ® % Desigh Protolym

If there was text in the selected content, you might consider converting the text to
outlines before saving as SVG. SVG files require the font to be present when viewing
the file in browser or an application like Adobe Illustrator. You can convert text to
outlines (shapes) by selecting the text object and choosing Object > Path > Convert To



Path (macOS) or by right-clicking the text object and choosing Path > Convert To Path
(Windows).

5. Choose File > Export > Selected (macOS), or click the menu icon ( =) in the upper-left
corner of the application window and choose Export > Selected (Windows).

6. In the export dialog box, navigate to the Lessons > Lesson11 folder (macOS), or click
Choose Destination (or Change) and navigate to the Lessons > Lesson11 folder
(Windows). Change the following options:

Save As (macOS): icon-person (This should already be the name because it uses
the name in the Layers panel. As a best practice, we remove spaces in asset
names.)

Format: SVG

Styling: Presentation Attributes (the default setting) (With presentation
attributes chosen, any formatting, like width and height, will be written inline in
the SVG code.)

Save Images: Embed (the default setting) (This option saves any selected raster
content directly within the SVG file. If you select Link, selected raster content
will be exported as a separate image file that is linked to the SVG file. This
results in multiple assets being exported. Linking can be useful if you need to
make frequent updates to the raster content and not the SVG content.) We
usually embed raster content in SVG to minimize broken links.

Optimize File Size (Minify) (macOS) or Optimized (Minified) (Windows):
selected (Minifying SVG will potentially make the file smaller.)

Note

When exporting SVG to hand off to a developer, for instance, you can ask the
developer to see whether optimizing the SVG is suggested.

-------
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7. Click Export.

Exporting as PNG

PNG files are raster files, which means they are composed of pixels and won’t scale well when
resized. When exporting for websites, best practice is to save multiple versions of each image
file: one at the original size in the XD design, and one at twice the size of the original to
accommodate different screen sizes and pixel densities. When exporting a PNG asset for iOS
apps, you will export three sizes of PNG files. When exporting for Android apps as PNG, you
will also need a variety of sizes.

In this section, you’ll export content as PNG and explore the export options.

1. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the design content.
2. Click the map artwork on the Hike Detail artboard.

Note

This keyboard shortcut performs the same command as choosing File > Export
> Selected (macOS), or clicking the menu icon (=) in the upper-left corner of
the application window and choosing Export > Selected (Windows).

3. Press Command+E (macOS) or Ctrl+E (Windows) to export selected content.



4. In the export dialog box, for macOS, navigate to the Lessons > Lesson11 folder. On
Windows, click Choose Destination (or Change) in the Export To section and navigate
to the Lessons > Lesson11 folder.

Change the following options:

e Save As (macOS only): Map (XD will automatically add a suffix to each saved
asset, depending on the chosen format.)

e Format: PNG

After choosing PNG, you will see four Export For options: Design, Web, iOS, and
Android. Which option you select will depend on where you will use these images.

Design: This is the default option. Only one image is created, at the original size of the
selected content. It is meant to match exactly what is seen on the screen. Design is a
great option for sharing individual images and screen designs.

Web creates two sizes for each exported asset: one that is 1x (non-Retina or HiDPI) and
another that is 2x, or double the size (Retina or HiDPI).

iOS creates three sizes for each exported asset: one at 1x, a second that is 2x (twice the
size of the original), and a third that is 3x (three times the size of the original).

Android creates six sizes for each exported asset: 1dpi, mdpi, hdpi, xhdpi, xxhdpi, and
xxxhdpi.

e Export For: i0S (since this is an app for iOS)
e Designed At: 1x (the default setting)

With Web, iOS, or Android selected, before exporting, it’s important to set the size to
the size you’ve designed at. With the iOS option, you have three choices: 1x (non-Retina
or non-HiDPI), 2x, or 3x. By default, artboard sizes (such as iPhone X/XS) and the
assets in them are sized at 1x (non-Retina). If you did not change the artboard sizes (the
width, we mean, because the height can mean a scrolling screen), then you would leave
the Designed At option set at 1x.

For another example, if you choose Web from the Export For option, you are given two
choices for the Designed At option: 1x or 2x. You could either create your artboards at
twice the default size (2x) and scale down to the smaller size (1x) when exporting, or
you could design at smaller, default artboard sizes (1x) and then scale up (2x) when
exporting.



5. Click Export.
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There are three PNG files generated in this case. The images that are 2x and 3x are
named with “@2x” and “@3x,” respectively.
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To understand how this sizing works for an iOS app, see the sidebar “Export PNG for
i0S.”




Note

To see a larger version of this infographic, visit
helpx.adobe.com/xd/help/export-design-assets.html.

Export PNG for Android

Use the following infographic to understand how your design assets are exported for
Android when you design at different resolutions: 1dpi - Low density (75%), mdpi -
Medium density (100%), hdpi - High density (150%), xhdpi - Extra high density (200%),
xxhdpi - Extra extra high density (300%), xxxhdpi - Extra extra extra high density (400%).
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—From Adobe XD Help

Note

If you’d like to see a larger version of this infographic, visit
helpx.adobe.com/xd/help/export-design-assets.html.
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Export PNG for iOS

Use the following infographic to understand how your design assets are exported for iOS
when you design at 1x and 2x.
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Exporting as JPG

The final format we’ll discuss is JPG (or JPEG). When you export assets (such as photos) as
JPG, you can set the quality level of the exported file according to your needs. You can export as
JPG when saving images for a website, when someone asks for a JPG file, and more.

1. Click the image at the top of the Hike Detail artboard.

2. Press Command+E (macOS) or Ctrl+E (Windows) to export it.

3. In the export dialog box, for macOS, navigate to the Lessons > Lesson11 folder, or, on
Windows, click Choose Destination (or Change) in the Export To section and navigate



to the Lessons > Lessonl1 folder.

Change the following options:

Save As (macOS only): HikeDetail-header

Format: JPG

Quality: 80%. (The Quality setting determines the file size of theq generated
asset and the quality. The lower the Quality setting, the smaller the file size, but
you sacrifice more and more quality the lower you go.)

Export For: Design (the default setting) (The Design option will export a single
JPG at the original size, whereas the Web option will export two sizes: 1x and
2x. When exporting your own assets, you will need to make a determination as to
whether you need one asset or two.)

4. Click Export.
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5. Press Command+S (macOS) or Ctrl+S (Windows) to save the file, if necessary.




Export to After Effects

If you want to use After Effects to turn your XD designs into custom animations or micro-
interactions, do the following:

1. In XD, select the layer or artboard you want to animate in After Effects.

2. Select File > Export > After Effects (macOS) or click the menu icon (=) in the upper-
left corner of the application window and choose Export > After Effects (Windows). If
After Effects is not installed on your machine, this option is dimmed. You can also use
the Command+Option+F (macOS) or Ctrl+Alt+F (Windows) keyboard shortcut. After
Effects launches (if closed) or moves to the foreground (if running in the background).

The selected layers or artboards are transferred as native shapes, texts, assets, and nested
compositions in your After Effects project. You can perform multiple asset transfers to the
same After Effects project and create animations in stages or from multiple XD files. For a
list of supported features, visit https://helpx.adobe.com/xd/kb/open-after-effects-files-in-
xd.html.

—From Adobe XD Help

Using plugins

In Adobe XD, you can use plugins and app-integrations from Adobe and third-party developers
to enhance your design workflow by automating complex and repeat tasks and enabling deep
integrations with external tools and services. In this section, you’ll discover where to find plugins
in Adobe XD and use one of them to add a series of user images to artboards.

Tip
To see a sampling of the plugins available for XD, visit
www.adobe.com/products/xd/resources.html.

Note

You need XD version 13.0+ to view, manage, and build plugins. Plugin
development and management are supported on both Windows and MacOS.

Note

XD also supports external integrations such as JIRA and in-app extensions to
provide a complete solution for designers and stakeholders.
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Installing a plugin
In Adobe XD, you can view and manage plugins available in the Plugin Manager. In this first

section, you’ll explore the Plugin Manager and install a plugin.

1. Choose Plugins > Discover Plugins (macOS), or click the menu icon (=) in the upper-
left corner of the application window and choose Plugins > Discover Plugins
(Windows).

In order to use plugins, you will install them. After you have installed at least one plugin,
you can manage them by choosing Plugins > Manage Plugins.

Tip
XD plugins are saved in the XDX format. If you’ve downloaded a plugin.xdx
file, you can also double-click to install it.

Tip
To access add-ons, such as UI Kits, plugins, and app integrations, press

Command+N (macOS) or Ctrl+N (Windows) to open the Home screen. In the
Home screen, click Add-ons on the left side of the dialog box.

2. In the Plugin Manager window that opens, make sure that All Plugins is selected on the
left side to see the plugins available. Since new plugins are constantly added, the list of
plugins you see will probably be different.
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3. In the Search field at the top of the window, type UI faces. The UI Faces plugin should



appear. If you don’t see it, you can clear the search field and try working with another.
4. To learn more about the plugin, click See Details. You should see a description of the

plugin.
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5. To install the plugin, click Install.
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After a plugin is installed, a success message appears. You can now begin using it.

6. Click Installed Plugins on the left side of the dialog box to see any plugins you’ve

installed.
[ ]
All Pluging Installed Plugins

o LATEST RELEASE +
.:: M Faces Dctober 12, 2018 e
LT Adichanabr Thde & Epa gelads *

Disable
Unirstall

If you move the pointer over a plugin in the list, you’ll see an ellipsis (...). If you click
the ellipsis, you can either disable the plugin or uninstall it.

7. Close the Plugin Manager by clicking the red circle in the upper-left corner (macOS) or
the X in the upper-right corner (Windows).

Creating plugins



To get started with creating your own plugins, choose Plugins > Development > Create a
Plugin (macOS) or click the menu icon (=) in the upper-left corner of the application
window and choose Plugins > Development > Create a Plugin (Windows). The Adobe I/0
developer console (https://console.adobe.io/plugins) will open in your default browser,
where you can learn what it takes to make your own plugin.

You can also visit https://adobexdplatform.com for more information on the XD platform,
as well as samples, community access, and much more.

—From Adobe XD Help

Using a plugin

After installing a plugin, you can start to use it. In the Travel_Design document you’ll insert a
series of user images (avatars) with the UI Faces plugin.

1.

5.

With the Travel_Design.xd file open, make sure that Design mode is showing. Click
Design in the upper-left corner if not.

Zoom in to the bottom half of the Hike Detail and Hike Detail — 1 artboards.
Select the Ellipse tool (()) in the toolbar on the left.

Shift-drag to create a circle in a blank area of the Hike Detail artboard. When the circle
has a height and width of 64 in the Property Inspector, release the mouse button and then
the key.

Select the Select tool (J») and drag the circle so its left edge is aligned with the left edge
of the text box above it. Alignment guides will appear when the edges are aligned.

Now you’ll make some copies using the repeat grid.

6. With the circle selected, click the Repeat Grid button in the Property Inspector. A repeat

grid handle now shows on the right edge of the circle; drag it to the right to make a total


https://console.adobe.io/plugins
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of seven circles.

7. Move the pointer between two of the circles, and when the pink column indicator shows,
drag left to overlap the circles. Stop dragging when the circles appear to fit width-wise

within the bounds of the artboard.
’u : 1 TIRE COUR TaRe Coopr |

8. So that you can edit each circle now—which the plugin requires—click the Ungroup
Grid button in the Property Inspector.

9. With the circles selected, choose Plugins > UI Faces (macOS), or click the menu icon (
=) in the upper-left corner of the application window and choose Plugins > UI Faces
(Windows). Any plugins you install will be listed in the Plugins menu. In the UI Faces
dialog box that appears, you can select specific sources to pull the images from, an age
range, gender, and more. Select Yes for the Randomize option, so it’s a random
selection of images, and click Apply Faces.



Travel_Design — Edited
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After the faces are added, you will see a success message that you can close. If any of
the images fail, you can select the circles that don’t have images and apply UI Faces
again (choose Plugins > UI Faces) (macOS), or click the menu icon (=) in the upper-
left corner of the application window and choose Plugins > UI Faces (Windows).

10. With all of the circles still selected, group them by pressing Command+G (macOS) or
Ctrl+G (Windows).

11. Drag them into position as you see in the figure.

Pine Meadow
Lake Loop

Finishing the design

Next, you’ll add some text to finalize the design and then copy the new content to the Hike
Detail — 1 artboard.

1. Option-drag (macOS) or Alt-drag (Windows) the green Pine Meadow Lake Loop text
down above the avatars. Release the mouse button and then the key.



Pine Moadm:\-\' Pine Meadow
Lake |.oop Lake Loop

Pine Meadow

P
‘\ .l'f
Pine Meadow Pine Meadow
Lake Loop Lake Loop

3. With the Select tool () selected, press the Esc key to select the text object and then
drag it into position, as in the figure.

A
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With the avatar content finished, now you’ll group it all and copy it to the Hike Detail —
1 artboard.

4. Drag across the Hikers text and avatar images to select it all. You may find that the text
box above the content is overlapping it. If that is the case, click away from the content to
deselect and then click the text box above. Drag the bottom handle up to make it shorter.




5. Drag across the Hikers text and avatar images to select it all again. Group them together
by pressmg Command+G (macOS) or Ctrl+G (Windows).

Pine Meadow Pine Meadow
Lake Loop

6. With the new group selected, copy it by pressing Command+C (macOS) or Ctrl+C
(Windows).

7. Right-click in the Hiker Detail — 1 artboard and choose Paste to paste the group in the
same relative position.
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8. Press Command+0 (macOS) or Ctrl+0 (Windows) to see all of the design content.
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9. Choose File > Close (macOS) or click the X in the upper-right corner (Windows) to
close all open files.

You did it! I hope you learned a whole bunch from this book and will continue to learn and



explore different ways to work with Adobe XD. The future is very bright for Adobe XD!

Third-party integration
You can bring your designs into other applications that integrate with XD: Zeplin, Avocode,

Sympli (only on macOS), Kite Compositor, and ProtoPie.

The section below provides a high-level overview of the workflow using the example of XD
running on macOS with Zeplin installed. The procedure works the same way on XD
running on Windows.

1. Select an artboard or layer in your XD file, and click File > Export > Zeplin. Zeplin
needs to be installed.

2. In the dialog box that opens, click Import. To replace existing screens in Zeplin with the
same name, select Replace screens with the same name. Zeplin adds it as a new version
of that same screen, without losing your notes.

The artboards are imported into Zeplin.

Note: This procedure varies slightly depending on the application you are using. For more
information, refer to your application’s documentation:

—From Adobe XD Help

Review questions

1 In which file formats can you export content from Adobe XD?

2 When exporting PNG, what purpose does the Designed At option serve?

3 Before exporting assets, where can you change the name of the assets to be exported?
4 When exporting as JPG, what does the Quality setting effect?

5 What is a plugin?

Review answers

1 Currently, you can export assets in the following formats: PNG, SVG, PDF, and JPG.

2 When exporting as PNG for Web, iOS, or Android, Adobe XD makes multiple sizes for
each asset it exports as PNG. In order to do that, it has to know what size you designed at
(what size the artboards are). In the case of an app you’re designing for iOS, you can
choose from 1x, 2x, or 3x. If you left the artboard size at the default sizing when setting
up a document (for instance, iPhone X/XS at 375 x 812), then you designed at 1x. If you
changed the size of your artboards when you started, to 750 x 1624, for example, then
you designed at 2x.

3 In the Layers panel in XD, you can change the name of the asset. The asset name given in
the Layers panel is the asset name when it is exported.

4 The Quality setting determines the file size of the generated asset and the quality. The
lower the Quality setting, the smaller the file size, but you sacrifice more and more



quality the lower you go.

5 In Adobe XD, you can use plugins and app-integrations from Adobe and third-party
developers to enhance your design workflow by automating complex and repeat tasks and
enabling deep integrations with external tools and services.
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A

action setting, 239

Adobe After Effects, 333

Adobe Authorized Training Centers, 5
Adobe Create Magazine, 5

Adobe forums, 5

Adobe ID, 187, 275, 309

Adobe XD
described, 8, 31
image formats, 96
installing, 2
mobile app, 275-276
plugins, 334-340
resources, 5, 30
starting work in, 11
system requirements, 2
third-party integration, 340
unit-less nature of, 49
workspace, 12-13

Adobe XD Learn & Support page, 5, 30
Adobe XD product home page, 5

After Effects projects, 333

Align Center button, 110

aligning
artboards, 46, 150
content to pixel grid, 77-78
guides used for, 62, 82, 151
objects to artboard, 144
objects to each other, 147-148
setting up icons for, 144-147



anchor points
creating, 82
editing, 72, 75
paths and, 83

Android
exporting PNG files for, 330
measurement units for, 310
resolution settings for, 311

animation
auto-animating content, 247-249
connection setting for, 239
of record button, 265

appearance changes
artboard, 4445
repeat grid, 217
shape, 64-65

application modes, 12, 13
area text, 118, 119-120, 127

arranging
artboards, 42—43
objects, 131-132

Artboard tool, 38-41, 57

artboards, 12, 13
aligning, 46, 150
appearance changes, 44-45
arranging, 4243
browsing on devices, 279
changing multiple, 45
creating, 38—41
deleting, 39
distributing, 150
dragging, 43
duplicating, 43-44
editing, 41-44
grids added to, 47-53, 57
linking, 238-239
managing with Layers panel, 53-56



navigating, 25-27

orientation options, 41
renaming, 27, 40

reordering, 133, 134, 159
resizing, 42, 57

responsive resize for, 46, 223
Retina (HiDPI) sizing for, 36
review questions/answers on, 57
screens represented as, 35
selecting, 42, 44, 45

artwork
adding from Illustrator, 79-80
aligning to pixel grid, 77-78
copying and pasting, 89
editing with Pen tool, 88-89
masking images or, 111-117
symbols created from, 170-171
zooming in/out of, 20, 21-24, 31

assets
CC Library, 187-194
exporting, 323-333
importing, 97-101
managing, 163-186
naming/renaming, 326, 341

Assets panel, 12, 13, 163-186
character styles in, 166—169
custom colors in, 163—-166
gradient colors viewed in, 201
opening and closing, 17, 163
symbols in, 170-186
types of assets in, 163, 195
audio recording, 272
auto-animating content, 247-249, 267
auto-correct feature, 118, 126
Autosave feature, 36
Available Offline option, 284



backgrounds
blur effect for, 205-206, 231
color for artboard, 44, 45

bitmap images, 61

blur effects
background blur, 205-206
object blur, 206-207

Boolean operations, 74

borders
options for, 68—69
shape, 64-65

Bring Forward command, 131
Bring to Front command, 131

Browse Artboards option, 279, 282

C

character styles, 166—169
CC Library, 190-191
deleting, 169
editing, 169, 195
saving, 166—168

circles
creating, 63, 68, 74
duplicating, 70
image fills in, 115-117

Classroom in a Book training series, 1
closed paths, 83

cloud documents
described, 36, 285
previewing on devices, 281-284
saving XD documents as, 281
sharing, 289-292
video on working with, 37

code, embed, 297
Color Picker, 45, 64, 65, 66, 199



color stops, 199, 200, 203

color swatches
deleting, 65, 165
editing, 165166

colors
background, 44, 45
border, 65
fill, 64
gradient, 202-203
saving, 163—165

Column Width values, 52
combining shapes, 74-76, 93
comment icon, 301, 305

comments, 300-308, 319
adding, 300-302
guest, 302
notification of, 308
pinning, 303-304
working with, 305-308

Comments panel, 301, 302, 303, 304, 305

connections
copying and pasting, 244-246
editing, 241-244, 267
previewing, 240-241
types of, 267
See also links

content
aligning, 77-78, 144-150
auto-animating, 247-249
grouping, 141-144, 224-225
hiding, 139
Illustrator, 79-80
locking, 137-138
masking, 111-117
ordering/reordering, 133-134
Photoshop, 106-110
saving as a symbol, 170-171



selecting, 135-137
Sketch, 110

Convert to Path command, 77
Copy Embed Code command, 294, 297
Copy Link icon, 294, 300

copying and pasting
connections, 244246
embed code, 297
Photoshop files, 106-107
replacement images, 102
selected artwork, 89
shared prototype links, 300
symbol instances, 174
from UI kits, 91-92

corner points, 75, 84, 93
corner widgets, 70, 71, 103

Creative Cloud
cloud documents stored in, 36
previewing documents loaded from, 275, 281-284
saving XD documents to, 281
shared prototypes stored in, 319
working with documents from, 37

Creative Cloud Libraries, 187-194, 195
character styles used from, 190-191
editing items in, 193-194
graphics used from, 191-193
Illustrator assets added to, 189—190
Photoshop assets added to, 187-189
selecting multiple objects in, 192

curves, drawing, 83—85, 93

Custom Size icon, 35

D

Dash values, 67
dashed lines, 66-67



deleting
artboards, 39
character styles, 169
color swatches, 65, 165
comments, 306
downloaded XD files, 280
See also removing

Design mode, 14-18
panels, 1618
Property Inspector, 15
toggling Prototype mode and, 19, 236
tools used in, 14

design specs, 308-317
inspecting, 312-316
sharing, 308—312
updating, 317
viewing, 312, 315

designs
finishing, 338-340
previewing, 28-29
sharing, 29, 31
workflow for UX, 9-10
Desktop Preview, 28, 240
destination setting, 239
development, sharing for, 289, 310-312, 317

Device Preview option, 277

device previews, 275-284
cloud documents for, 281-284
deleting files from, 280
mobile app setup for, 275-276
USB connection for, 276-280, 285

direction handles, 83

direction lines
creating, 83-84
splitting, 86

direction points, 83



distances
setting between gaps, 152—154
viewing with temporary guides, 155

distributing
artboards, 150
objects, 148-150

documents
cloud, 36
creating, 35-37
panning, 24-25
saving, 37
switching between, 30
zooming in/out of, 20, 21-24, 31

downloading
lesson files, 3
UI kits, 90-91

drag triggers, 249250
dragging

artboards, 43
images, 100-101, 110

drawing
curves, 83-85, 93
grid used for, 83
straight lines, 81-82, 93

drop shadow effect, 208-209

duplicating
artboards, 4344
lines, 77
shapes, 70
text, 124-126

duration setting, 239, 244, 250

E

easing transitions, 239

editing
artboards, 41-44



artwork, 88—89

CC Library items, 193-194
character styles, 169, 195
color swatches, 165-166
comments, 306
connections, 241-244
gradient colors, 202-203
group content, 143-144
masks, 112—-114, 116-117
repeat grids, 213-217
shapes, 72-74, 76-77, 88-89
symbols, 171-173

educator resources, 5

effects, 205-209
background blur, 205-206
drop shadow, 208-209
object blur, 206-207

Ellipse tool, 63, 68, 74, 115
embedding shared prototypes, 297, 319
Export For option, 310, 311, 328, 332

exporting assets, 323-333, 341
to After Effects, 333
batch export for, 333
file formats for, 323, 341
as JPG files, 332—-333
as PDF files, 324-325
as PNG files, 327-331, 341
as SVF files, 80, 325-327

eye icon, 139
Eyedropper tool, 64, 169

F

file formats
for exporting assets, 323, 341
supported for images, 96, 127

fills



artboard, 44
gradient, 199-204
image, 115-117
shape, 64

filtering options
Comments panel, 307
Layers panel, 139-141

Fix Height option, 225
Fix Width option, 225, 226, 227
fixed positioning, 156-158, 159

flipping
lines, 77-78
shapes, 73

folder icon, 108
Font menu, 122

fonts
formatting, 122, 123-124
missing, 11, 60, 163, 187, 189
mobile previews and, 277, 278
used in lesson files, 4

footer symbols, 186
formatting text, 122—-124, 166-169
forums, Adobe, 5

frames
resizing images within, 104-105
support for inline, 297

fullscreen mode, 295

G
Game Bar app, 272, 273-274

gaps
changing in dashed lines, 67
setting between objects, 152—-154

gradient editor, 199, 200



gradient slider, 200, 202, 203, 204

gradients, 199-204
applying, 199-202, 231
description of, 199
direction and length adjustments, 203-204
editing colors of, 202-203
linear and radial, 199

grammar check, 126

graphics
types in Adobe XD, 61
using from CC Libraries, 191-193
See also raster images; vector graphics

Grid View button, 165, 184
grids, 47-53, 57
drawing with, 83
layout, 47, 51-53
pixel, 77-78
square, 47, 48-51
See also repeat grids
groups, 141-144
creating, 141-142, 224-225
editing content within, 143—144, 159

guest commenting, 302

guides
alignment, 62, 82, 151
temporary, 151, 155

Gutter Width values, 52

H

Hand tool, 24-25, 83, 119, 313
Helvetica Neue font, 4, 118, 122, 168, 187

Hex values, 44, 45, 169, 314
hiding/showing
content on artboards, 139
group content, 142



square grids, 63, 68
HiDPI (Retina) sizing, 36, 328
Highlight On Canvas command, 184
Home screen, 11, 35, 237, 267
hotspot hints, 278
HSB color values, 45, 132, 200, 202

I

[lustrator
adding assets to CC Libraries from, 189—190
bringing in content from, 79-80
exporting artwork from, 80

image icon, 109, 134

images, 96-117
adding from Photoshop, 106-110
copying and pasting, 102, 106-107
dragging and dropping, 100-101, 110
filling shapes with, 115-117
formats supported for, 96, 127
importing, 97-101
masking, 111-117
opening from Sketch, 110
ordering in repeat grids, 215
positioning, 103
replacing, 101-102, 127, 215
rotating, 103-104
sizing/resizing, 97, 98, 103, 104—-105
transforming, 102-104
using from CC Libraries, 191-192

importing
drag and drop for, 100-101
images into Adobe XD, 97-101
multiple assets, 99-100
objects with gradients, 199
text, 121

inspecting design specs, 312-316



installing
Adobe XD, 2
plugins, 334-335

instances, symbol, 171, 174, 195

interactivity
example of prototyping, 10
previewing prototypes with, 278
recording in prototypes, 271-274, 285
i0S
exporting PNG files for, 331
measurement units for, 310
resolution settings for, 311

J

JPG (JPEG) format
described, 323
exporting files as, 332-333, 341
importing images in, 97

jumpstart method, 4

L
language options, 262

Layers panel, 12, 13, 133-141
grouping objects using, 142
icons indicating object type in, 134
locking and hiding content from, 138-139
managing artboards with, 53-56, 57, 134
opening and working in, 16—17, 26-27
reordering content in, 133-134
searching and filtering in, 139-141
selecting content using, 135-137
toggling the visibility of, 53

layout grids
applying, 51-53
explained, 47
outline style, 53



Learn & Support page, 5, 30

lessons in book
downloading files for, 3
jumpstart method for, 4

libraries. See Creative Cloud Libraries
Libraries panel (Photoshop CC), 188
Line Spacing option, 122

Line tool, 66, 69, 77

linear gradients, 199

lines

creating, 66—67, 69
curved, 83-85
dashes added to, 67
drawing, 81-85, 93
duplicating, 77
flipping, 77-78
straight, 81-82, 93

linked symbols, 176-183
breaking links to, 173—-175, 181
creating, 176-178
explained, 176
fixing missing, 182—183
overriding, 180
updating, 178-180

links
editing, 241-244
managing, 318
previewing, 240-241
sharing prototype, 300
See also connections

List View button, 171

Live Preview option, 276, 285

local symbols, 176, 183

Lock Aspect option, 41, 98, 103, 115, 117, 146
locking content, 137—-138



low-fidelity wireframes, 10, 31

M

macOS
native zooming, 20
prototype recording, 271-272
system requirements, 2
workspace, 12

Manage Links command, 318
margin settings, 52, 53

Mark for Export icon, 309

Mask with Shape command, 112

masks, 111-117, 127
editing, 112-114, 116-117
image fill, 115-117
removing from content, 114
shape or path, 111-112

Maximize application option, 11
measurement units, 49, 310

menu bar, 12

mobile app for Adobe XD, 275-276

mobile device previews, 275-284
cloud documents for, 281-284
deleting files from, 280
mobile app setup for, 275-276
USB connection for, 276-280, 285

modes
Design mode, 14-18, 236
Prototype mode, 18-20, 236

MP4 file format, 271, 285

N

naming/renaming
artboards, 27, 40



assets, 326, 341
groups, 142

navigating artboards, 25-27
New Library from Document dialog box, 188

notifications, comment, 308

O
object blur effect, 206-207, 231

objects
aligning to artboard, 144
aligning to each other, 147-148
arranging, 131-132
distributing, 148-150
grouping, 141-144
locking, 137-138
positioning, 151-158
saving as symbols, 170-171
setup to align, 144-147

offline documents, 283-284

on-canvas gradient editor, 200, 203, 204
Open in Browser icon, 294, 295

open paths, 83

ordering/reordering
artboards, 133, 134, 159
images in repeat grids, 215
layer content, 133134

organizing content, 128—159
aligning objects and, 144-148
arranging objects and, 131-132
distributing objects and, 148-150
groups created for, 141-144
Layers panel for, 133-141
positioning objects and, 151-158
review questions/answers on, 159

orientation, artboard, 41



Outer Stroke button, 68
outline style, 53

overlays, 259-262
creating, 261-262
setting up content for, 259-260
video examples of, 262

overriding linked symbols, 180

P

panels
overview of main, 16-17
tip on displaying, 18
See also Assets panel; Layers panel

panning documents, 20, 24-25, 313
Paste Appearance option, 110
pasteboard, 12, 13, 136, 159

pasting. See copying and pasting

Path Edit mode, 72, 75, 88-89, 93, 113

paths
components of, 83
curved, 83-85
direction changes, 86—87
masking with, 111-112
reshaping text as, 119
straight, 81-82

PDF format
described, 323
exporting as, 324-325

Pen tool, 81-89, 93
curves drawn with, 83-85
editing artwork with, 88-89
lines drawn with, 81-82
path direction changes and, 86-87

Photoshop
adding assets to CC Libraries from, 187-189



bringing in content from, 106-110, 127
copying and pasting from, 106-107
opening files from, 108-110

Pin icon, 303, 304, 305
pinned comments, 303-304, 319
pixel grid, 77-78
pixels, virtual, 47
Plugin Manager, 334
plugins, 334-340
creating, 336
explained, 334, 341

installing, 334—-335
using, 336-338

PNG format
described, 323
exporting as, 327-331, 341

point text, 118-119, 127

positioning objects, 151-158
aligning with temporary guides, 151
fixed positioning for, 156-158, 159
setting gap distances and, 152-154
viewing distances and, 155

Preview window, 28-29, 240-241

previewing
connections, 240-241
designs, 28-29, 31
prototypes, 275284, 285

Property Inspector, 12, 13, 15
Prototype mode, 18-20, 236

prototypes, 232—-285
auto-animating content in, 247-249
copying/pasting connections in, 244-246
drag triggers added to, 249-250
editing connections in, 241-244
home screen setup for, 237



interactivity in, 10, 238

linking artboards in, 238-239

mode for creating, 18-20, 236
overlays used in, 259262

preserving scroll position in, 251-254
previewing on a device, 275-284, 285
purpose of using, 10, 31, 235
recording, 271-274, 285

review questions/answers on, 267, 285
sharing for review, 293-308

speech playback added to, 265-266
testing connections in, 240-241

timed transitions in, 255-258

voice triggers added to, 262-264

Push Overrides command, 172, 179

Q

Quality setting, 332, 341

R
radial gradients, 199

radius, corner, 70, 71

raster images
sizing for Adobe XD, 97
using from CC Libraries, 191
vector graphics vs., 61
See also images

record button, 264, 265

recording prototypes, 271-274, 285
on macOS, 271-272
on Windows, 272-274

Rectangle tool, 62, 70, 72, 111, 131

rectangles
creating, 62, 72
masking with, 111-112
rounding corners of, 6971



removing
masks from content, 114
text from text area, 121
See also deleting

renaming. See naming/renaming
reordering. See ordering/reordering

repeat grids, 210-221
adding content to, 217-219, 231
creating, 211-213
description of, 210, 231
editing content in, 213-216
finishing touches for, 219-221
modifying appearance of, 217
ordering images in, 215
replacing images in, 215, 231
selecting content for, 210-211
setting up text files for, 216
sizing/resizing, 212
ungrouping, 219

replacing
images, 101-102, 127, 215
symbols, 183185

replying to comments, 306

resizing. See responsive resize; sizing/resizing
resolution settings, 311

resolved comments, 307, 319

resources for Adobe XD, 5, 30

responsive resize, 222-230
artboards and, 46, 223
description of, 222
finishing designs after, 229-230
getting started with, 222-223
grouping content for, 224-225
manual constraints for, 225-228

Retina (HiDPI) sizing, 36, 328
review, sharing for, 289, 293-295, 297, 299, 300, 301



rotating
devices, 278
images, 103—-104
shapes, 73
text, 118

Round Cap button, 67, 69, 78

rounded-corner rectangles, 69-71

S

San Francisco fonts, 4, 90-91

saving
character styles, 166—168
colors, 163-165
documents, 37
symbols, 170-171

scaling images, 98, 103

screens
device size options for, 35
See also artboards

scroll position preservation, 239, 251-254
content setup for, 251-252
steps in process of, 251-254

searching
in Layers panel, 139-141
in Plugin Manager, 334

Select tool, 14, 38, 42, 44, 45, 48

selecting
artboards using Select tool, 42, 44, 45
content using Layers panel, 135-137
multiple objects in CC Libraries, 192

Send Backward command, 131, 132
shadows, drop, 208—-209

shapes, 61-78
borders for, 64—65
combining, 74-76, 93



creating, 62—63, 72
duplicating, 70

editing, 72-74, 76-77, 88—-89
fills for, 64, 115-117
flipping, 73

masking with, 111-112
rotating, 73

Share Document option, 289, 290, 291, 319
Share for Development window, 310-312, 317
Share For Review window, 293-295, 297, 299, 300, 301

shared prototypes, 293-308
commenting on, 300-302, 319
copying links to, 300
embedding in web pages, 297
file storage for, 319
pinning comments in, 303-304
steps for creating, 293-296
updating, 297-300

sharing, 19, 286-319
cloud documents, 289-292
design specs, 308-312
managing links for, 318
overview on methods of, 289
prototypes for review, 293-308
review questions/answers on, 319
sizing/resizing
artboards, 42, 57, 223
images, 97, 98, 103, 104-105
repeat grids, 212
See also responsive resize

Sketch, adding assets from, 110
Smart Objects, 188

smooth points, 84, 87, 93
snapping, disabling, 103, 127
speech detection, 262

speech playback, 262, 265-266



spelling check, 126

square grids
drawing with, 83
explained, 47
hiding/showing, 63, 68
shape creation and, 72
working with, 48-51

stacking order, 131, 159

straight lines, 81-82, 93

styles, text/character, 122124, 166-169
Subtract option, 75-76

SVG format
described, 323
exporting as, 325-327

swatches. See color swatches
Swatches button, 194

symbols, 170-186
breaking links to, 173—-175, 181
copying instances of, 174
creating, 170-171, 195
defined, 163, 170
editing, 171-173
footer groups as, 186
linked, 176-183
local, 176, 183
replacing, 183—-185
responsive resize and, 223, 226-227
system requirements, 2

T
tap triggers, 239, 244, 248

temporary guides
aligning with, 151
viewing distances with, 155

text, 118-126



area, 118, 119-120, 127
converting, 119

duplicating, 124-126
importing, 121

point, 118-119, 127
removing, 121

rotating, 118
spelling/grammar check, 126
styling, 122124, 166-169

Text tool, 118, 119, 120, 167, 172
third-party integration, 340
time triggers, 255-258, 267

timed transitions, 255-258
content setup, 255-256
steps in setting, 256—258

toolbar, 12, 13

tools
Design mode, 14
Prototype mode, 19

transforming images, 102—-104
transitions, 239, 255-258

triggers, 239, 267
drag, 249-250
tap, 239, 244, 248
time, 255-258
voice, 262-264

U

UI Faces plugin, 334, 336, 337

UI kits, 90-92, 93
copying/pasting from, 91-92
downloading, 90-91
opening files in, 91

undo command, 82, 172, 226

Ungroup Grid button, 219



Ungroup Mask option, 114
units of measurement, 49, 310

updating
cloud documents, 284
design specs, 317
linked symbols, 178180
shared prototypes, 297-300

USB-connected previews, 275, 276-280, 285

user experience (UX) design workflow, 9-10

A"

vector graphics
adding from Illustrator, 79-80
raster images vs., 61
using from CC Libraries, 191, 192-193
working with shapes as, 61-78

video recording prototypes, 271-274

video tutorials/examples
animating the record button, 265
auto-animating content, 249
batch exporting assets, 333
cloud documents, 37
exporting artwork from Illustrator, 80
overlays, 262

view commands, 21-22
viewing
design specs, 312, 315
distances, 155

virtual pixels, 47

voice triggers, 262-264

\%Y%
Web Edition of book, 3

web pages
embedding shared prototypes in, 297, 319



measurement units for, 310
resolution settings for, 311

widgets, corner, 70, 71, 103

Windows
native zooming, 20
prototype recording, 272-274
system requirements, 2
workspace, 13

wireframes, low-fidelity, 10, 31
workflow, UX design, 9-10

workspaces
macOS, 12
Windows, 13

X

XD program. See Adobe XD
XDX file format, 334

Z

Zoom tool, 22-24, 67, 77
zooming in/out, 20, 21-24, 31, 66, 313
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Classroom in a Book®, the best-selling series of hands-on software training books, helps you
learn the features of Adobe software quickly and easily.

The Classroom in a Book series offers what no other book or training program does—an
official training series from Adobe Systems, developed with the support of Adobe product
experts.

To see a complete list of our Classroom in a Book titles covering the 2019 release of Adobe
Creative Cloud go to: www.adobepress.com/cc2019
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Adobe InDesign CC Classroom in a Book (2019 release)
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Adobe Dreamweaver CC Classroom in a Book (2019 release)
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